Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Videos not playing - Shared plex server

sim667sim667 Posts: 113Members, Plex Pass Plex Pass
I set my freind up so he could share my server the other day. However whenever we try and play a video on his macbook he gets a video cannot be played error.

We're on different networks, he can see my shared content, just not watch it.

Any pointers on sorting this?

Comments

  • sim667sim667 Posts: 113Members, Plex Pass Plex Pass
    Should add it works fine on my iOS applications, when im signed into myplex...... I've just tested it across 3g.

    So i would think it unlikely to be a port issue on my network.
  • I am oddly having the same issue. Strange thing is. She can access the music from my share, yet every time she tries to start a movie (Yes, she can see all my movies and everything) she receives the "Error:Error While Opening File" message. She is in Colorado, and I am in New Hampshire. But I didn't think that should make a difference. Ports are all forwarded correctly (on my side at least), and I can access the movies from another laptop on the same network using a different account. Any help would be much appreciated.

    Things I have tried:
    - Rebooting Server
    - Rebooting both PCs
    - Updating Both Clients and the Server
    - Logging onto a separate account, on a separate computer, but on same network (All works).
    - Different video formats
    - Music Stream (Music streams work fine for her)

    Thanks again,
    Mike
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    I think this issue is going to take some logs to investigate. This is going to need logs from both the server and the remote client.

    1. Restart both the Plex Media Server and the remote client so we have fresh logs

    2. Try to play the content in the client

    3. On the client, zip up the "Plex.log" file

    4. On the server, zip up the "Plex Media Server.log" file

    5. Attach both files to the reply here

    (See link in signature for info on logs.)
  • Here are the two log files you have requested.

    My "Plex Media Server" log, and her "Plex Client" log.

    Hope this can help us. Thanks for the speedy reply Ninja.
  • Anyone out there? ::pokes::
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Nothing definitive yet, mike. Things seem to be correct on the server side based on the log. Have you tried (or, well, has she tried) fully rebooting the computer before trying to stream rather than just restarting the client application? The client log shows a line related to a DLL, but I don't know if it's actually related to what's being experienced or not.
  • mikestancato@gmail.commikestancato@gmail.com Posts: 5Members
    edited January 2012
    Yes. She did try restarting her PC. I also restarted the server multiple times. =/

    And the issue isn't her streaming. The Server is on my computer. She only has the client installed. I have shared my content with her. She can play music albums from my share, but she cannot watch my videos. She just continuously receives, "Error: Error opening file" on a few movies, and on the others, "Please Wait" would be displayed, but the movie doesn't start.
  • sim667sim667 Posts: 113Members, Plex Pass Plex Pass
    I can get the logs, but it might take a while as the other computer is at my friends house.
  • So there is no fix to this issue it seems, is there?
  • seriousplayseriousplay Posts: 1Members
    Trying to keep this thread alive...

    I am also having the same problem:
    1. Streaming movie from local server works. Remote stream to iPhone and Android device works.
    2. Streaming from remote server doesn't work.

    Thanks for the help in advance!
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Re-reading the thread, it occurs to me there's something I neglected to ask...

    On the remote desktop client, what is the quality setting under "Preferences > System > myPlex"? The default is "Direct Play", which will quite possibly not work at all depending on your bandwidth situation at each end (and the source quality of the video being requested). I'd recommend starting with a low setting such as 720kbps or maybe 1.5mbps, depending on what the upload bandwidth is like for the PMS end.
  • sim667sim667 Posts: 113Members, Plex Pass Plex Pass
    Chris C wrote:

    Re-reading the thread, it occurs to me there's something I neglected to ask...

    On the remote desktop client, what is the quality setting under "Preferences > System > myPlex"? The default is "Direct Play", which will quite possibly not work at all depending on your bandwidth situation at each end (and the source quality of the video being requested). I'd recommend starting with a low setting such as 720kbps or maybe 1.5mbps, depending on what the upload bandwidth is like for the PMS end.


    I will get my friend to try this later and report back.
Sign In or Register to comment.