Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Publish Server to myPlex

Tarek.MMDTarek.MMD Posts: 2Members
Instructions not working
I have created my myPlex account and signed into it on the Plex Media Manager from Preferences -> MyPlex

My login is ok.
I have clicked Publish Server to MyPlex
There is a green light that says Server is Mapped to Port 32400 (ip.ip.ip.ip)
Then there is a red light that says myPlex was unable to connect to your server.

I've checked the box below that says manually specify port. (if I don't, the green light won't come on)

What am I doing wrong that is not allowing the server to be mapped?

I am using Comcast.

Thanks

Comments

  • Tarek.MMDTarek.MMD Posts: 2Members
    Any thoughts?


    Tarek.MMD wrote:

    I have created my myPlex account and signed into it on the Plex Media Manager from Preferences -> MyPlex

    My login is ok.
    I have clicked Publish Server to MyPlex
    There is a green light that says Server is Mapped to Port 32400 (ip.ip.ip.ip)
    Then there is a red light that says myPlex was unable to connect to your server.

    I've checked the box below that says manually specify port. (if I don't, the green light won't come on)

    What am I doing wrong that is not allowing the server to be mapped?

    I am using Comcast.

    Thanks
  • MattyKMattyK Posts: 72Members, Plex Pass
    edited April 2012
    Chances are you need to further configure your router or gateway, depending on how they have been set up and how old they are. From the excellent Plex wiki section on MyPlex:

    Troubleshooting Auto-Configuration Failures
    If publishing the Plex Media Server fails, you should try the following:
    Find your router's user manual or on-line documentation
    Check whether your router supports UPnP or NAT-PMP
    If they do, you may need to switch the feature on in the router's software
    If the services are enabled, try toggling them off, and then back on again and try to publish the server once more
    If your computer has a firewall, proxy, or anti-virus software installed, try temporarily disabling them and then attempt to publish the server again
    Sometimes, older routers offer UPnP support that may not work with new applications. If you cannot get the router to automatically configure the port-forward, you can seek help from the manufacturer or other forums. There may be upgraded firmware that fixes the issue. If disabling the firewall allows successful publishing, you need to add the Plex Media Server to the firewall's allowed list - consult the firewall's user manual. If you exhaust all possibilities, it's a simple matter of setting up a manual port-forward.
    [edit]Manually Configure the Router
    If the Plex Media Server cannot configure the router automatically, it may simply be that the router doesn't support auto-configuration, or the support is flawed. In this case, a manual port-forward can be configured. This is not an inferior configuration, and is not hard to do. To configure the manual port-forward:
    On the computer hosting the Plex Media Server, set up the computer so that it uses a manual local IP address, or an IP reservation in the router's DHCP server (so that the computer will always have the same local IP)
    Choose an appropriate port number
    Port 32400 is the default, but you can choose one not being used by a service in your network above 1024
    Generally, ports in the 20,000 to 50,000 range work well
    Consult your router's manual for instructions on how to forward a port
    Map the chosen external port number so that it is forwarded to internal port 32400 for the local IP address of the computer running your Plex Media Server


    Important:
    While you can choose any valid external port number you desire, the internal port the mapping forwards to must always be 32400.


    Information:
    When NAT auto-configuration fails, it is only necessary to configure a port-forward. The myPlex service discovers and tracks the external IP address, so it is not necessary to setup a dynamic DNS tracker.


    Hope this helps -
  • ebob64ebob64 Posts: 2Members, Plex Pass

    Incredible how performing a media server update has completely caused plex to be unusable, cant log in, all family members linked to my server outside my home network cannot gain access, cant log into publish my server after clean reinstall...lifetime plexpass member for two years. Nothing works...same router, same computer. One update, all is gone...have no clue

Sign In or Register to comment.