Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Setting up Plex with AT&T Uverse

filmfx66filmfx66 Posts: 4Members, Plex Pass Plex Pass
Problems with connecting
OK, here is the deal. I have been running my plex server without issue for a while. I have ROKus on my TVs in the house as well as the Plex app on my Android devices... All has been fine and dandy. Well, about a week ago I switched from Time Warner cable to ATT Uverse and that is where the problems began. I have since been able to go to the AT&T modem and open the correct port. I am able to see my Plex server in my house, it shows up on the Plex website as a valid server and sees my static IP address.

However, my other devices like the Androids can no longer connect to the server. Is there a secondary port I am missing that needs to be opened on the Uverse modems?

Any help would be grand.

Thanks!

Billy

PS, I tried working on this myself for a couple of weeks to avoid bothering the forums with it but alas I am now stumped.
«1

Comments

  • ahbillyahbilly Posts: 17Members, Plex Pass Plex Pass
    Well, let me first welcome you to the pain that is ATT Uverse. I recently did the exact same thing hoping to save some $ and not only did it end up being barely cheaper, the upload speeds for my media server sucked and the TV service would cut out almost every 45 min. Back to Time-Warner!

    Alas, my whining will not help your immediate problems.

    First you need to setup a port forward for your router to port 32400 on your Plex Machine. I'm not sure which modem you have, but it should be under the firewall settings in applications or pinholes.

    Then once you have that setup go to the preferences in plea server app, and get over to the myPlex tab. Click "Publish Server to myPlex", and "manually specify port". Also, make sure the port is 32400. Restart the Plex Media Server.

    Voila!

    Should be good to go!
  • filmfx66filmfx66 Posts: 4Members, Plex Pass Plex Pass
    Ok, good news, I finally figured this thing out


    The main problem is the fact that I have my uverse router going to my airport and I was using the airport to serve ip address to the house. So this is what I did.

    On my computer I instead connected wirelessly directly to the uverse wireless network.
    I have a cat-5 ethernet cable connected to the network in the house that goes to the airport.

    On the uverse side in the firewall panel I created two custom applications:

    1. Plex UDP, select UDP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    2. Plex TCP, select TCP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    Now, after you have created the two apps, type in the ip address supplied by your uverse wireless connection. By default it is a 192.168.1.x number. Put that number into the box that says "Enter IP Address". This is in the firewall/Applications, Pinholes and DMZ tab

    Once you select that IP scroll down and select the user-defined list, you should see Plex udp and Plex TCP, select them both and then add. Save your changes.

    Go back to your plex server and turn off Publish Server and turn it back on again. You should now see that the server is mapped and no error message.


    I hope that helps everyone with Uverse!
  • Talls79Talls79 Posts: 1Members
    Works really well - thanks! But part of your instructions weren't perfectly clear for noobs like me.

    The range should be 32400 to 32400 for both for ports, don't leave one box blank.
    Instead of putting a custom number in for IP, just select the IP for whatever computer you have connected to your U-Verse that is running Plex Sever. Mine was wired to the U-verse router, so it was easy to figure out. Once you select that one THEN choose the 2 Apps you created (don't select until you have the right IP address).
  • filmfx66filmfx66 Posts: 4Members, Plex Pass Plex Pass
    Talls79 wrote:

    Works really well - thanks! But part of your instructions weren't perfectly clear for noobs like me.

    The range should be 32400 to 32400 for both for ports, don't leave one box blank.
    Instead of putting a custom number in for IP, just select the IP for whatever computer you have connected to your U-Verse that is running Plex Sever. Mine was wired to the U-verse router, so it was easy to figure out. Once you select that one THEN choose the 2 Apps you created (don't select until you have the right IP address).



    Thanks for making that more clear. :)
  • alexwickalexwick Posts: 55Members, Plex Pass
    it just dont seam to work... any other advise!?? frustrating..!
    i setup both with the predefined port nr... but just doesnt work on the plex server site... says couldnt share to myplex... or so..
  • rdeanmrdeanm Posts: 1Members Plex Pass
    Thanks, filmfx66, it worked for me!
  • bigmtnskierbigmtnskier Posts: 2Members
    filmfx66 wrote on July 19 2012, 6:35 AM: »

    Ok, good news, I finally figured this thing out


    The main problem is the fact that I have my uverse router going to my airport and I was using the airport to serve ip address to the house. So this is what I did.

    On my computer I instead connected wirelessly directly to the uverse wireless network.
    I have a cat-5 ethernet cable connected to the network in the house that goes to the airport.

    On the uverse side in the firewall panel I created two custom applications:

    1. Plex UDP, select UDP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    2. Plex TCP, select TCP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    Now, after you have created the two apps, type in the ip address supplied by your uverse wireless connection. By default it is a 192.168.1.x number. Put that number into the box that says "Enter IP Address". This is in the firewall/Applications, Pinholes and DMZ tab

    Once you select that IP scroll down and select the user-defined list, you should see Plex udp and Plex TCP, select them both and then add. Save your changes.

    Go back to your plex server and turn off Publish Server and turn it back on again. You should now see that the server is mapped and no error message.


    I hope that helps everyone with Uverse!

    I have UVerse as well, but only use the RG 2 Wire as a modem.  I followed both of your instructions above clearly. I created a TCP and UDP user defined port forward, I also did the same on my Asus NT56U router and I still can't get connected with Plex Media Server. I have spent almost 12 hours on this, so any sound advice would be HIGHLY APPRECIATED  :D

    Below are links to screenshots for both my UVerse RG/Modem & my Asus Router:

     http://www.webpagescreenshot.info/img/51b4f819a26d45-02829139

    http://www.webpagescreenshot.info/img/51b4f87d5ba551-43305517

  • murray129murray129 Posts: 7Members

    Same problem here.  Mine use to work by using the instructions above and recently they worked on my service.  So I was going back in to set these up and I get "ERRORS, invalid port range."

  • KkattarKkattar Posts: 1Members

    For those who are using the 2Wire router directly (no airport or additional router), I had the same issue. I resolved it by eliminating the "Application Type" I had selected with I added the Protocol. See screenshot below. It works just fine now. Cheers![attachment=21145:2013-10-31_01-08-15.jpg]

  • kieronch3kieronch3 Posts: 10Members ✭✭

    like the last poster i did it without an application type also like him you dont need two seperate apps (plex tcp and plex udp) you can add both permissions to the list and just call it plex...my .02 for something that already been answered...lol

  • BazhawBazhaw Posts: 13Members

    UGH!  New PLEX user...have tried everything suggested to get the AT&T Uverse router (2Wire 3800HGV) to connect to the Plex server.  Connecting wirelessly - with nothing between Windows PC (Win 7 Ultimate) and router.  I have created a new user-defined app (TCP and UDP) on static IP address of PC with 32400 incoming & outgoing ports, added the user-defined app to the machine's IP address, manually specified the port and still am failing to connect.  I have even checked the router-behind-router detection.  All to no avail!  When I test to see if the port is open - I get a timeout error, which means the port is closed (??) so there is no way that Plex would be able to see it.  Now, I don't know how to get the port open or even how to proceed from here...any help would be greatly appreciated!

  • dachtmandachtman Posts: 1Members, Plex Pass

    I just found that ATT Internet Security Suite was blocking the port that I was trying to use on my machine. I had to go into it and edit the ports and system services to allow Plex to connect. Once I got that working my connection was all set.

  • tydakingtydaking Posts: 1Members, Plex Pass
    I had the same issue when I switched to Uverse, I also had to remove my linksys router that was behind the AT&T modem to get Plex to map properly. Has any one had issues streaming content remotely since switching to Uverse? I notice content buffers all the time now. Never had this issue before..
  • jwbohlmanjwbohlman Posts: 5Members, Plex Pass Plex Pass

    I know this topic is old but just started using Plex and wanted to let you know how I resolved the issue with getting myPlex to work when going through AT&T uverse to a Time Capsule.

    Everything FilmFX66 said works except for the IP address you select to forward the application through needs to be the IP of the Time Capsule.  So for example mine is 192.168.0.1.  

    That should work just fine.

  • LuisTexasLuisTexas Posts: 1Members, Plex Pass

    This works for me for my new Uverse. Here the procedure:

    a) Go to the web browser and type the IP address given in the router device (http://192.168.1.x number)

    b) Create two custom app in the firewell Setting-Firewall-Applications as was described above:

    1. Plex UDP, select UDP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    2. Plex TCP, select TCP as the setting and the port number to 32400 (assuming you are using the manual port setup)

    c) Select the computer were the plex-server is from the list and add the two apps. You should see Plex udp and Plex TCP, select them both and then add. Save your changes.

    d) Go back to your plex server and turn off Publish Server and turn it back on again. You should now see that the server is mapped and no error message.

    That works great for me. Thanks for the guiding.

  • tcrooks0904tcrooks0904 Posts: 1Members, Plex Pass Plex Pass

    LuisTexas & filmfx66, that worked for me!  Thanks!

  • matrixbudmatrixbud Posts: 8Members ✭✭
    ahbilly wrote on May 22 2012, 12:59 AM: »

    Well, let me first welcome you to the pain that is ATT Uverse. I recently did the exact same thing hoping to save some $ and not only did it end up being barely cheaper, the upload speeds for my media server sucked and the TV service would cut out almost every 45 min. Back to Time-Warner!

    Alas, my whining will not help your immediate problems.

    First you need to setup a port forward for your router to port 32400 on your Plex Machine. I'm not sure which modem you have, but it should be under the firewall settings in applications or pinholes.

    Then once you have that setup go to the preferences in plea server app, and get over to the myPlex tab. Click "Publish Server to myPlex", and "manually specify port". Also, make sure the port is 32400. Restart the Plex Media Server.

    Voila!

    Should be good to go!

    I don't follow this last step. I have done everything else. I suspect I don't understand all the terminology, but I can't find a myPlex tab or "Publish Server" anywhere. When you say to go to the plex server app, if that means to go to my Roku box, it has a Plex channel but no myplex tab. If by app, you mean Plex Media Server on my computer, the web page has 4 tabs (Web, Server, Users, Devices) with lots of subtabs, but no myPlex tab or subtab, and I can't find "Publish Server" anywhere.

    Where should I be looking?

  • matrixbudmatrixbud Posts: 8Members ✭✭

    flimfx66, thank you for your good instructions. I finally got Plex to work today after trying on and off for a couple of years. Until now I couldn't even get Plex to work on my TV off my home network let alonge externally to my iPads.

    I have the Plex media server on a Mac. Turns out my trouble was McAfee Internet Suite. It has a firewall that I wasn't aware of, and today no matter how I configured it to allow Plex, I simply couldn't get Plex to work on my TV. So I finally disabled McAfee's network protection and suddenly both my home network and external networks all came to life.

  • AftaMidNiteAftaMidNite Posts: 1Members, Plex Pass Plex Pass

    Thanx matrixbud

    I have an older MacBook and had just about given up trying to stream from my laptop to the Roku on my Tv. But read your post and disabled the McAfee firewall and voi·là. It's up and working.

  • zskelleyzskelley Posts: 10Members, Plex Pass Plex Pass

    Any way of changing settings so the firewall can stay on a still have remote access

«1
Sign In or Register to comment.