Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

MyPlex Shared servers on apple TV

abrock111@gmail.comabrock111@gmail.com Posts: 15Members, Plex Pass Plex Pass
Hi there I am having a problem with MyPlex and apple tv. My brother and mother both have an apple tv who I share my PMS with via Myplex. Now for a while things worked perfectly they could not view a few tv shows or movies but I researched that and it is a known bug being worked on. Now all of the sudden the can not access any thing. My server is up and green when they sign into the website and they can see the server on the apple tv but when the go to any channels, TV for instance no files or shows, show up. They click on the channel and it sits there thinking for a bit then goes to a screen with the plex logo in the upper right hand portion of the screen but nothing else. I can however access everything on my Iphone and Ipad with no problems so it seems to be strictly a problem with the apple tv. I am some what tech savvy but could not figure it out, hence me turning here. I am not sure if setting up a port forwarding would help or even how to do that. I have the newest version of the mac mini as well as the newest time capsule and running all my media from a external HD. My personal apple TV works but I believe that is because it is on the same network my PMS runs on. I could be wrong though. I would appreciate any help as I convinced my mom to cut the cord on cable with this and is now kind of backfiring in my face.

If there is any other info you would need let me know. As I said the problem is with my families gear so I am not sure if I could get a log file or something but I could try. Thank you again for any help!


  • Chris CChris C Posts: 11,700Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    You mention that you can "access everything on my Iphone and Ipad with no problems". Is that when you're on your own wifi at home or is that via 3G or otherwise "remote" and from another network. If you're at home then it really doesn't mean anything. If that's when you're remote then it indicates that the myPlex connection is working.

    My recommendation:

    - Completely close/quit your Plex Media Server (PMS) and then reopen it. Verify in the PMS preferences that you are publishing to myPlex.

    - Log into the my.plexapp.com website, go to the Servers tab, and verify that your server is listed there and that the name is in green. If the name isn't green, then there's a problem.

    - Have your brother/mother restart their AppleTV. Once restarted, go back into the Plex client and then sign out of myPlex and sign back in.

    See how things work at that point.
  • abrock111@gmail.comabrock111@gmail.com Posts: 15Members, Plex Pass Plex Pass
    Yes I can access it remotley via 3g or on another WiFi network such as my work. I have logged into my myplex account and my server is listed and is green as is my brother and mother's accounts. When they log into their myplex accounts it shows availble and green. I did turn off the apple tv and reboot it I also restarted my PMS. I am kind of SOL at the moment as my hard drive with all my media just took a dump and I lost it all so at the moment it is moot but I would like this to work again once I get another hard drive. Again thanks for any help and the speedy responces.
  • abrock111@gmail.comabrock111@gmail.com Posts: 15Members, Plex Pass Plex Pass
    OK so I got another external hard drive up and running now so I can now see if Plex on the apple TVs is working and after doing everything it is still not happening. When I go into plex (on their appple tv) I see all the channels but when I go into it there is nothing listed just the plex symbol in the upper right of the screen. I have been reading about bridging my router. I am not sure if that will help but I have the newest 2tb time capsule and a Motorola SB6120 SURFboard DOCSIS 3.0 eXtreme Broadband Cable Modem. Thanks again for any help.
  • abrock111@gmail.comabrock111@gmail.com Posts: 15Members, Plex Pass Plex Pass
    Another update. after restarting my moms apple tv hers is up and running but my brothers is still down. we have tried to updated the plex "app" on his apple tv. I stopped sharing my server wit him via MyPlex and then invited him again. My server is green on the MyPlex website for both him and I. He signs into MyPlex on his apple tv but sometimes will get my server and sometimes he doesn't. When he does and clicks on it all he gets is the plex emblem on the upper right of the screen. I appreciate any help.

    Thank you
  • Chris CChris C Posts: 11,700Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Since this appears to be an issue more related to the AppleTV / AppleTV Plex client, I'm going to move this thread over to that forum. It seems pretty clear that the myPlex sharing in general is working and that your Plex Media Server is working.
  • -SKYNET--SKYNET- Posts: 9Members, Plex Pass Plex Pass
    Hi Abrock. Just had the same issue with my ATV.
    I just reinstalled it from scratch by click on Restore in iTunes and when it's done jailbreaked it with Seas0npass.
    Installed Plex and it's up and running after that. I can now see all shared content through MyPlex.

    Hope it works for you too.

  • This happened to me as well. uninstall/reinstall through ssh did not help. Got it back working uninstalling plex client and going to a previous version (which I prefer to jailbraking again)

    Anyways, I guess you can choose your poison now :)
  • Ethan1972Ethan1972 Posts: 6Members, Plex Pass
    Hi, same Problem her.

    But there's one diff. I got two share's. One from my brother and one from a friend.

    - The shared-content from my friend works fine one the atv2.
    - The shared-content from my brother doesn't work one the atv2 but on other devices no problem (ipad, iphone, with web-browser).
    But on the atv2: all I gets is the plex emblem on the upper right of the screen...

    Any help ???
  • Ethan1972Ethan1972 Posts: 6Members, Plex Pass
    O.K. i solved it!

    cold-restart of my atv2 and now is everything fine :)
  • Ethan1972Ethan1972 Posts: 6Members, Plex Pass
    :angry: next cold-restart and the problem is back... confusion...
  • iijaymaciiiijaymacii Posts: 1Members

    I see that this thread seems to have died off.  I am currently having the same issue on my aTV... I can see the server, choose a media type (i.e. Movies, Music, TV Shows) but then there is a hang for an extended period and it displays only the plex logo in the upper right quadrant of the screen.  

    Is this issue a bug within the Plex Client for aTV, an iOS version issue, or other?  Seems to have only occurred since updating my aTV OS.  If so and the restore seems to fix it as suggested above, I would assume I need to restore to a previous iOS version.  Any idea which one?

    If it was found to be a Plex Client issue has there been a fix or other remedy that would not include restoring the aTV?

    I am fairly command line savvy and enjoy the troubleshooting process as opposed to a "nuclear" E & I approach.  Thanks.

  • Wdog118Wdog118 Posts: 169Members, Plex Pass Plex Pass

    I have 2 buddies that are also having this same problem with the aTV. It can do local servers fine. The shared servers show up but when you select any of them the content is not there.

    We've tried. installing/reinstalling, restarts of both atv and pms's with no luck.

    Did I miss a solution for this?

  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass
    Have you tried removing any shares in MyPlex then adding back either a section or all sections and seeing if the content appears (try both)?
Sign In or Register to comment.