Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Update 0.10.0.0-b0b2ed28

thomashwthomashw Posts: 140Members, Plex Pass Plex Pass
Released Sept. 1, 2012
Here's the latest build!

It's going to be a bit different of an install process than running a simple apt-get upgrade because the build hasn't been put on the Plex server yet, but it is fairly simple to do. It should eventually be put on the Plex servers so you can upgrade using apt-get if you prefer at a later time.

Change Log
  • Fix crash with clang 3.1
  • Upgrade project settings within Xcode
  • Add an advanced setting regarding how dates are shown
  • In channels, really show the date and fix height on items without a date
  • Make sure myPlex shows up the first time
  • Don't transcode images from myPlex
  • Auto find the server
  • New icon
  • Fix exception in 5.x.x
  • Fix grid view in 5.x.x
  • Fix bookcase view in 5.x.x


Screenshots
Just a few quick photos I took with my iPhone.

http://imgur.com/a/aI1Fm#0

Installation
This build works with both OS 4.x.x and 5.x.x, but if there's nothing stopping you I would suggest upgrading to the latest OS. I'm running it and Plex runs great for me.

1. ssh into your Apple TV
ssh root@apple-tv.local

2. Run the following command in the ssh
wget --no-check-certificate https://github.com/downloads/thomashw/thomashw.github.com/plex_atv_plugin-0.10.0.0-b0b2ed28.deb

3. Run the following command in the ssh session to install Plex on your Apple TV.
dpkg -i plex_atv_plugin-0.10.0.0-b0b2ed28.deb

4. Restart Apple TV
killall AppleTV


If you get dependency issues, run the following commands and then go back to step 3.
apt-get update
apt-get install beigelist org.tomcool.smframework


Once your Apple TV restarts, go into Plex -> Settings and make sure it reads 0.10.0-b0b2ed28. If so, it installed correctly!

If you have trouble, please post in this thread and someone will help you.

Bugs
Post to Lighthouse! The link is in a sticky'ed thread on this forum.


Have fun! I hope everything works for you!
«13456

Comments

  • meltmanmeltman Posts: 180Members, Plex Pass Plex Pass
    Nice work. Updating from 4.4.4 now.


    Thank you for this.
  • ChrispyChrispy Posts: 45Members, Plex Pass Plex Pass
    Thanks guys. Just finished the install on my ATV running 5.01, will check it out later this evening and report back.
  • peteFpeteF Posts: 31Members, Plex Pass Plex Pass
    Working great on 5.01- grids working, auto server connect working, thank you so much!!!
  • 5stringdeath5stringdeath Ninja Posts: 1,398Members, Plex Pass, Plex Ninja Plex Ninja
    Works great on 5.0.2(4250)

    Thanks! Great work.
  • meltmanmeltman Posts: 180Members, Plex Pass Plex Pass
    edited September 2012
    Coming from a fresh jailbreak I get the following errors:
    dpkg: dependency problems prevent configuration of com.plex.client-plugin:
    com.plex.client-plugin depends on beigelist; however:
    Package beigelist is not installed.
    com.plex.client-plugin depends on org.tomcool.smframework (>= 0.7.7-2); however:
    Package org.tomcool.smframework is not installed.

    Not sure which source to add to install the two missing dependencies.

    Edit:
    Just needed to do the following:

    apt-get update
    apt-get -f install
  • 5stringdeath5stringdeath Ninja Posts: 1,398Members, Plex Pass, Plex Ninja Plex Ninja
    meltman wrote:

    Coming from a fresh jailbreak I get the following errors:
    dpkg: dependency problems prevent configuration of com.plex.client-plugin:
    com.plex.client-plugin depends on beigelist; however:
    Package beigelist is not installed.
    com.plex.client-plugin depends on org.tomcool.smframework (>= 0.7.7-2); however:
    Package org.tomcool.smframework is not installed.

    Not sure which source to add to install the two missing dependencies.


    Just install NitoTV and it will handle all of that
  • meltmanmeltman Posts: 180Members, Plex Pass Plex Pass

    Just install NitoTV and it will handle all of that


    Just needed to do the following:

    apt-get update
    apt-get -f install

    picked up the missing dependencies.
  • 5stringdeath5stringdeath Ninja Posts: 1,398Members, Plex Pass, Plex Ninja Plex Ninja
    edited September 2012
    meltman wrote:

    Just needed to do the following:

    apt-get update
    apt-get -f install

    picked up the missing dependencies.


    Yep same outcome, Nito is just easier for some :D And its a handy util to have installed
  • meltmanmeltman Posts: 180Members, Plex Pass Plex Pass

    Yep same outcome, Nito is just easier for some :D And its a handy util to have installed


    If you dont have ATV flash black, installing nito is going to be a command line affair just the same.

    Best to have the full instructions without installing auxiliary apps to perform the same functions in my opinion.
  • 5stringdeath5stringdeath Ninja Posts: 1,398Members, Plex Pass, Plex Ninja Plex Ninja
    meltman wrote:

    If you dont have ATV flash black, installing nito is going to be a command line affair just the same.

    Best to have the full instructions without installing auxiliary apps to perform the same functions in my opinion.


    I don't disagree. But options are options.
  • robot2xlrobot2xl Posts: 462Members, Plex Pass Plex Pass
    Thank you Thomas! :D
  • JordanJordan Posts: 79Members, Plex Pass Plex Pass
    YAY! Looking forward to trying this out!
  • MobilePlexerMobilePlexer Posts: 15Members
    edited September 2012
    meltman wrote:

    If you dont have ATV flash black, installing nito is going to be a command line affair just the same.

    Best to have the full instructions without installing auxiliary apps to perform the same functions in my opinion.


    Ok, maybe I'm too stupid but I don't get it :huh:

    Configuration:
    • aTV Flash (black) 1.7
    • Plex Client 0.10.0.101-6 (works fine except of the grid/cover view)


    The aTV Flash(black) maintenance system shows the installed version as the most current one. Additionally I installed nitoTV 0.8.3 now but plex isn't shown in the list.
    So, I did it manually and it worked fine :rolleyes:
    But to get the automatically supported update process .. what would I have to to?
  • hybrid-thyhybrid-thy Posts: 1Members, Plex Pass
    Great Work !! Work like a charm on both my ATV's (5.0.2 and 4.4.4). Worth waiting ! ;) Keep up the good work !
  • robot2xlrobot2xl Posts: 462Members, Plex Pass Plex Pass
    In the grid view can not sort movies by collection, year, etc.

    In a large collection visualization becomes difficult if not select lists.

    Any fix?

    :(
  • webjoewebjoe Posts: 35Members, Plex Pass Plex Pass
    Thank You, Thomas.... It´s nice to see some development again for the Apple TV...
    We are using the app everyday an the only reason for having an Apple TV is because of this app....
  • thedustroomthedustroom Posts: 7Members, Plex Pass
    webjoe wrote:

    Thank You, Thomas.... It´s nice to see some development again for the Apple TV...
    We are using the app everyday an the only reason for having an Apple TV is because of this app....

    +1 - we don't use it for anything but Plex either, it's about time Apple opened up this platform so we could get more/better software on it!
  • thomashwthomashw Posts: 140Members, Plex Pass Plex Pass
    meltman wrote:

    Coming from a fresh jailbreak I get the following errors:
    dpkg: dependency problems prevent configuration of com.plex.client-plugin:
    com.plex.client-plugin depends on beigelist; however:
    Package beigelist is not installed.
    com.plex.client-plugin depends on org.tomcool.smframework (>= 0.7.7-2); however:
    Package org.tomcool.smframework is not installed.

    Not sure which source to add to install the two missing dependencies.

    Edit:
    Just needed to do the following:

    apt-get update
    apt-get -f install


    Woops - sorry about that. Forgot to consider people installing on a new jailbreak. :P


    Ok, maybe I'm too stupid but I don't get it :huh:

    Configuration:
    • aTV Flash (black) 1.7
    • Plex Client 0.10.0.101-6 (works fine except of the grid/cover view)


    The aTV Flash(black) maintenance system shows the installed version as the most current one. Additionally I installed nitoTV 0.8.3 now but plex isn't shown in the list.
    So, I did it manually and it worked fine :rolleyes:
    But to get the automatically supported update process .. what would I have to to?

    This version of Plex has to be installed using the steps I gave - my first paragraph in the post explains it a bit. What they're saying is NitoTV will handle the dependencies if they're missing (if you're installing Plex on a new jailbreak, for example).

    robot2xl wrote:

    In the grid view can not sort movies by collection, year, etc.

    In a large collection visualization becomes difficult if not select lists.

    Any fix?

    :(

    Post in Lighthouse, please! Please give as much detail as possible, including steps so I can reproduce the issue.
  • J.TylerJ.Tyler Posts: 120Members
    Fantastic, works like a dream - thanks guys!
  • nickehnickeh Posts: 1Members
    This is awesome to see work being done on the AT2, i use the plexapp on it everyday! Thanks!
«13456
Sign In or Register to comment.