If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex & Sony BDP-S580

steve__osteve__o Posts: 1Members
worked at first, now it doesn't?
Using Plex in a default installation, after much frustration (with little success) in trying to get Windows Media Center to work.

Want to stream to three different devices. One is a Sony BDP-S580 Blu Ray player, second is a Roku 2 XD, third is a Pioneer VSX-822 receiver. The first two are wireless to a TP-Link 1043 wireless router, with excellent signal strength and no lag. The Pioneer receiver is connected via a powerline ethernet connection. I have Plex installed on my Windows Vista Ultimate PC, sharing out a number of items - mp3's & flac's in a couple folders, and video (mostly avi & mpegs) in another folder.

On the Roku 2 XD, I've been able to get it to play the MP3's, which tells me that the configuration on the server is working. Haven't tried any video yet though. This was the last device I attempted to connect to the media server.

On the Sony BDP-S580, I am able to see the Plex Media Server, which corresponds to the MAC address of that PC. When I installed it initially, this was the first device I tested. And surprisingly, it worked. I was able to browse some of the folders I had added & was able to play some of the MP3's in those folders. However, after I exited the music player on the BDP-S580, all subsequent attempts to reconnect & play anything at all are met with the message, "Couldn't communicate with Server. Please try again later." I'm able to confirm that the connection is still good, as I am able to stream both Pandora & Netflix. In the setup, the Plex Media Server still shows up & has a status of "Shown". Also, it still shows up as Plex Media on each of the menus (photo, music, video). I've removed it & had it search for it successfully, but it will not play anything.

The other device is the Pioneer VSX-822, which is supposed to work with DLNA. It sees the Plex Media server, and I am able to go through some "standard" folders (remote, shared, music, etc), but when I attempt to go into just the music (or any other) folder, that device will appear to connect (the remote stops accepting input), but it never sees any of the folder structure that I know is part of those folders. FWIW, the folder menu is very similar to the menu on the Roku.

Is there any "fix" for the BDP-S580? I've seen some configuration files in this forum, but am not sure what version of it is the correct one.

I'm on the current version of Plex (9.6.9, I think). The firmware on the Blu Ray is M07.R.0624.

Any help, ideas or suggestions would be appreciated.

Sign In or Register to comment.