Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex on Kindle Fire HD

Anything I watch randomly crashes back to main menu
Hello,
I have a Kindle Fire HD and I installed Plex. Everything seems to be fine but when I go to watch a tv show or movie off my Plex server it will randomly crash back to the Plex main menu. Sometimes it does this within 10 seconds, other times you can watch half of a movie before it does this. But I've never been able to watch anything completely - tv show or movie. It always does this. The Plex server has 10Mbps up bandwidth, and where I am watching the shows I measure about 7Mbps down. I have the Plex client set to 3Mbps. I've tried different advanced settings, I've tried different bandwidths...Nothing fixes this problem.

Anyone know how to fix this?

Thank you,
Aaron.
«1

Comments

  • elanelan Sheriff of Plexville MauiPosts: 8,853Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Interesting, we don't have one of those devices in-house. Any way you can enable network logging in advanced settings, sign into myPlex, and then make it crash? (Alternatively, you could use "logcat" and send us a log)
  • elan wrote:

    Interesting, we don't have one of those devices in-house. Any way you can enable network logging in advanced settings, sign into myPlex, and then make it crash? (Alternatively, you could use "logcat" and send us a log)


    Hi Elan,
    Thank you for your response. I can add to this...I have another family member that I setup with a tablet (Acer Iconia A200 running ICS). I have Plex setup on it. She is saying that she too has not been able to watch a tv show. She said at some point it always 'freezes' and never comes back.

    Regarding the logs I will try to get them for you. Give me until the weekend at least (I have to go to these people's houses and do this).

    Where do you want the logs?

    Also, I tried to find documentation on what exactly the advanced settings on the client do. I searched the plex site but could not find them. Do you have a document? I would like to know which settings I should use.

    Thanks,
    Aaron.
  • darrindarrin Plex Dev Team Posts: 2,044Members
    There is no explicit documentation on Advanced Settings bc we generally don't want people messing around in there unless they have a specific issue. If you have a non-Windows PMS go to Settings / Advanced Settings and turn on Network Logging (you'll have to be signed into myPlex first). Then let us know that you've done that... or better come to Plex Chat to let us know so we can work with you in real time. If you have a Windows PMS follow my instructions below for getting us a logcat and PMS log... send the logs to android@plexapp.com.
  • aamjohns@yahoo.comaamjohns@yahoo.com Posts: 9Members
    edited October 2012
    darrin wrote:

    There is no explicit documentation on Advanced Settings bc we generally don't want people messing around in there unless they have a specific issue. If you have a non-Windows PMS go to Settings / Advanced Settings and turn on Network Logging (you'll have to be signed into myPlex first). Then let us know that you've done that... or better come to Plex Chat to let us know so we can work with you in real time. If you have a Windows PMS follow my instructions below for getting us a logcat and PMS log... send the logs to android@plexapp.com.


    ...Thanks. Will enable logging.

    Thanks,
    Aaron.
  • darrindarrin Plex Dev Team Posts: 2,044Members
    Aaron - don't forget to come to Plex Chat and mention my name so I can look up the logs you generate... there's a sliding window - I'd hate to miss them.
  • RadimusRadimus Posts: 50Validating, Plex Pass Plex Pass
    I have 2 Kindle Fire HD in my home running factory OS... no changes or hacks and all run Plex fine.

    My mother-in-law uses hers for hours at a time with no hiccups.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Am having similar issue, can usually start a video fine, can start and stop for a few times, then it reaches a point where video won't continue. Havejust enabled log and forced same error.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Ok. Uninstalled and Reinstalled Plex on the KFHD, all seemed to be working fine. Started running a video this morning. Paused (video at 19:08) to make a phone call (paused about 8mins based on my phone) - went back to movie (device went to sleep, so woke it up). Now app won't restart video, either from point I was at or at beginning, Nor will it play another movie. Just starts, player initializes, then returns to library.

    Made a log and have just emailed it in to android@plexapp.com. Using Log2File Send2Email; only decent log file capture on Amazon Appstore from what I could find. Let me know if it works.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Also just went though and turned fine grain network logging. Myplex name: rsayah. Tried pulling a couple more logs because first didn't seem to have enough info. Will send those along as well.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Here's a link to the app I used to grab the logs. Hope it's useful to others. This was the only free app in the Amazon Store.
    http://amzn.com/B008OIOQYQ
  • darrindarrin Plex Dev Team Posts: 2,044Members
    Kelarr - thanks so much for the logs. Here's what we see in the logs:


    I/avc_utils( 105): found AVC codec config (720 x 368, Baseline-profile level 3.0)
    I/ESQueue ( 105): found AAC codec config (48000 Hz, 2 channels)
    E/OMXNodeInstance( 105): OMX_GetExtensionIndex failed
    W/ACodec ( 105): OMX.TI.DUCATI1.VIDEO.DECODER requires the use of OMX_AllocateBuffer instead of the preferred OMX_UseBuffer. Vendor must fix this.


    This is a low level media player error. It's lower level than Plex unfortunately - so there's nothing we can do about it at this time. I'm afraid Amazon will need to fix this in a future patch.

    That said - maybe there's a way we can work around it. If you stop the app entirely and restart it - are you then able to get it working after this happens? If so it might suggest a complete reinitialization of the video subsystem might help here.
  • RadimusRadimus Posts: 50Validating, Plex Pass Plex Pass
    I have a Kindle Fire HD setup in my livingroom as a HTPC, connected via wifi to PMS, connected to TV via Micro HDMI.

    Settings are:
    Local 2mbps

    Advanced:
    secondary openGL player
    Transcode: HTTP Streaming
    Direct Play : enabled
    Device uses HLS: checked
    Direct Streaming: Checked
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Darrin,

    Glad to know it's a real issue at least. I'll give customer service a shout. Can't hurt, but don't expect them to jump through hoops for what is a bit of a competitor. I see you have Amazon Instant Video channel, does that give you a good contact for App development?

    I'll also do my own playing around. The Amazon Video process sits resident in memory, so maybe there's something there that prevents the video subsystem from fully reinitializing after a crash.

    Last thought, if reinstalling app seems to get Plex working again, (at least until the error creeps back); is there a way to "repair" the installation (just like recopying all the DLLs for a windows program) without removing the app? Not that it's a big deal to reinstall, just a pain to have to go and restore settings.

    Thanks for your help.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Radimus,

    I'm running with all the same settings. My issue came up when the device would fall asleep, paused, in the middle of playback (i.e. taking a phone call). Any experience with such cases? It's worked fine, until it just doesn't, then I reinstall.

    What file types are you streaming from the server? just to compare notes. Not that Plex cares, but maybe Kindle does. My Rips are all using handbrake "universal" default, although I do have MCEbuddy converting broadcast TV from a Windows Media Center on another PC. Problems occur in both file types.

    Radimus wrote:

    I have a Kindle Fire HD setup in my livingroom as a HTPC, connected via wifi to PMS, connected to TV via Micro HDMI.

    Settings are:
    Local 2mbps

    Advanced:
    secondary openGL player
    Transcode: HTTP Streaming
    Direct Play : enabled
    Device uses HLS: checked
    Direct Streaming: Checked
  • RadimusRadimus Posts: 50Validating, Plex Pass Plex Pass
    Most videos are an assortment of AVI, MP4, MKV that are either rendered via Direct Play or HLS Transcode Quality 6

    Pausing works if it is short time
    Fast Forward really doesn't work reliably and just ends the stream, but reselecting it and resume works ok.

    No failures that break it sufficiently that Clearing Data/Cache is necessary

    My biggest issue with Plex is the performance of the transcode on my Old PC that is my PMS server (P4@3.4ghz, 4gb ram, a 5 year old Dell XPS ver 3)... The latest server upgrade seems to be less processor intensive and works much better.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Ok, have a little more news. what ever is going wrong affects ALL video playback. Just to recap. Uninstalled/Reinstalled Plex. Started up a video, watched for a few minutes. Paused and let the KFHD fall asleep (5 min setting). Started it back up, and video failed, back to library. Unable to start anything else.

    Force Stop Plex, and try again, nothing.
    Force Stop Amazon Video, nothing.
    Try playing a video in Amazon, got an error.
    Try playing a video in Netflix, get sound, no video.

    So it's definitely low level issue, and at least it's system wide so hopefully they'll feel inclined to address it. Would appreciate if someone else on the forum here can replicate the issue. It happens like clockwork for me.
  • RadimusRadimus Posts: 50Validating, Plex Pass Plex Pass
    just for giggles try this:

    make this batch file on the plex server: http://forums.plexapp.com/index.php/topic/51714-command-line-to-shutdown-media-server/

    then start the plex server again and try to watch your videos.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    I have logged the issue with Amazon. They offered a refund for the App, which I refused (You guys have already earned the $$$). And instead they offered me a Amazon Credit, worth more than the app, for all my trouble. So good for them.

    I pushed to see if they'd let slip when the next software update might be arriving, but no such luck. I have to figure with all the Kindle Fire 8.7s going out as Christmas Presents we'll likely see a major update in January.
  • rsayahrsayah Posts: 9Members, Plex Pass Plex Pass
    Just an update here. Amazon pushed an update last night. No change in my issue, not that I'd have expected it, this one must have been in the pipeline already.
  • shortguy91shortguy91 Posts: 34Members, Plex Pass Plex Pass
    Kelarr wrote:

    Ok. Uninstalled and Reinstalled Plex on the KFHD, all seemed to be working fine. Started running a video this morning. Paused (video at 19:08) to make a phone call (paused about 8mins based on my phone) - went back to movie (device went to sleep, so woke it up). Now app won't restart video, either from point I was at or at beginning, Nor will it play another movie. Just starts, player initializes, then returns to library.

    Made a log and have just emailed it in to android@plexapp.com. Using Log2File Send2Email; only decent log file capture on Amazon Appstore from what I could find. Let me know if it works.
«1
Sign In or Register to comment.