Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

YouTUBE on ROKU

rc.vempatirc.vempati Posts: 86Members ✭✭
edited November 2012 in Plex Classic for Roku
I have noticed an issue yesterday playing YouTUBE videos on ROKU using Plex. I am able to play the videos using Plex Center windows client. But when it comes to ROKU, the progress bar shows complete but does not display the video.

Is YOUTUBE restricting playing videos from ROKU? I know they are implementing so many policies not to play on ROKU.

BTW, I can play the videos using Transcoding. But not DIRECT Play.

Is there any way in ROKU to send fake http headers so that YouTUBE does not know the hits are coming from ROKU. I think in ROKU we can define the HTTP headers. Just a thought on how to address the issue.

I am sure, they are restricting ROKU.

Comments

  • rc.vempatirc.vempati Posts: 86Members ✭✭
    I tested by getting the final url of the youtube video. I was able to play using direct play on Roku. Some thing else stopped playing youtube on Roku using Direct Play.
  • @joewatchestv@joewatchestv Posts: 1Members
    I've had the same issue for the last couple days. What other client can I use to stream YouTube to Roku?
  • trekkeriiitrekkeriii Posts: 16Members, Plex Pass Plex Pass
    Another channel that streams YouTube:

    https://owner.roku.com/add/VideoBuzz
  • stevydstevyd Posts: 35Validating, Plex Pass Plex Pass
    I've also been experiencing an issue with the YouTube channel on roku. After lots of playing around i've come to the conclusion that (my issue at least) is due to the "Automatic" transcoding setting not using the right mode. So basically when set to auto it will try and transcode the youtube video which then subsequently fails. However if you force it to "Direct Play /w Fallback" The video Direct plays absolutely fine on the roku and the PMS logs show that it is indeed direct playing.

    I would really like a feature so you can force particular channels to use a particular transcoding setting as I have another channel - CBS iirc that will only work if "Direct Stream" is selected.

    So to everyone having issues try selecting the Direct Play setting in your roku client and see if that solves your issue. It's a shame Auto doesn't work as I have to keep changing this setting for different channels.
  • rc.vempatirc.vempati Posts: 86Members ✭✭
    Finally, I was able to solve the issue by updating the URL service by removing the options for FLVs. Now ROKU picks one of the MP4 which can played using "direct play" with out transcoding.

    ACTUAL CODE:

    YOUTUBE_VIDEO_FORMATS =
    YOUTUBE_FMT = [ 34, 18, 35, 22, 37]
    YOUTUBE_CONTAINERS =
    YOUTUBE_VIDEORES =
    YOUTUBE_VIDEOCODEC =
    YOUTUBE_AUDIOCODEC =

    CHANGED TO:

    YOUTUBE_VIDEO_FORMATS =
    YOUTUBE_FMT = [ 18, 22, 37]
    YOUTUBE_CONTAINERS =
    YOUTUBE_VIDEORES =
    YOUTUBE_VIDEOCODEC =
    YOUTUBE_AUDIOCODEC =
  • stevydstevyd Posts: 35Validating, Plex Pass Plex Pass
    The above fix certainly made "Automatic" work however it's transcoding all youtube videos. By setting to a Direct Play setting it can direct play absolutely fine. So it seems like there is still an issue with the client/server knowing when transcoding is necessary
Sign In or Register to comment.