Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Undertexter visas ej

absolutandersenabsolutandersen Posts: 15Members
Hej!

Har ett problem med undertexterna i plex. Jag har testat alla möjliga inställningar i media Manager, lagt till .en i filnamnet, omintallerat hela plex app utan resultat. Varför fungerar inte textningen? I en del filer (mp4) har jag lagt in texten själv (med iSubtitle) och då fungerar det, men inte när det gäller en extern .srt-fil.
På iPhone och iPad står det "Ingen text(fil)" eller liknande.

Hur ska jag få tillbaka min text?

Kör senaste plex på OS X 10.8. Ipad med iOS 6.0.1.
«1

Comments

  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2012

    Hej!

    Har ett problem med undertexterna i plex. Jag har testat alla möjliga inställningar i media Manager, lagt till .en i filnamnet, omintallerat hela plex app utan resultat. Varför fungerar inte textningen? I en del filer (mp4) har jag lagt in texten själv (med iSubtitle) och då fungerar det, men inte när det gäller en extern .srt-fil.
    På iPhone och iPad står det "Ingen text(fil)" eller liknande.

    Hur ska jag få tillbaka min text?

    Kör senaste plex på OS X 10.8. Ipad med iOS 6.0.1.

    Om filmen redan var inscannad i biblioteket innan du la till undertexten så måste du föra en total omscanning av filmen. Hämta metadata på nytt så att säga. (detta gäller för alla klienter förutom klienten som körs på en Mac (och kanske de andra datorklienterna också)). Så gå in i http://127.0.0.1:32400/web (om du sitter på din PMS-maskin) och leta reda på filmen, gå in i den, håll nere alt och klicka på den runda pilen. Då kommer du se längst ner att metadata hämtas på nytt.
  • absolutandersenabsolutandersen Posts: 15Members
    Tack för ditt svar! Textfilen har legat tillsammans med filmfilen sedan innan första inläsningen. Jag har även testat att ladda om metadatan på det sättet du skriver.
    Men det fungerar ändå inte. Det HAR funkat förr (läs: månader sedan).
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Tack för ditt svar! Textfilen har legat tillsammans med filmfilen sedan innan första inläsningen. Jag har även testat att ladda om metadatan på det sättet du skriver.
    Men det fungerar ändå inte. Det HAR funkat förr (läs: månader sedan).

    Om du är säker att du gjort rätt så måste vi ta det till nästa steg helt enkelt :)
    Gör en refresh metadata igen och sedan laddar du upp din Plex Media Server.log direkt hit och berätta vilken exakt tid som du satte igång refreshen. Då kan jag försöka hitta anledningen.
  • absolutandersenabsolutandersen Posts: 15Members
    edited December 2012
    atrus wrote:

    Om du är säker att du gjort rätt så måste vi ta det till nästa steg helt enkelt :)
    Gör en refresh metadata igen och sedan laddar du upp din Plex Media Server.log direkt hit och berätta vilken exakt tid som du satte igång refreshen. Då kan jag försöka hitta anledningen.


    Här kommer den! Tack för din hjälp! Den här gjorde jag 15.30.
  • PokePoke Posts: 19Members, Plex Pass Plex Pass
    Har samma problem med vissa .srt filer. Brukar hjälpa att öppna dom i nått edit prog typ Jubler (mac) å sen spara om. Vet inte varför men det funkar i 9 fall av 10.
  • absolutandersenabsolutandersen Posts: 15Members
    Poke: Det verkar omständligt! :) får hoppas att det finns någon annan lösning för oss. Jag har gjort allt så automatiserat som möjligt så jag vill inte hålla på att fippla med sånt där i onödan.

    Atrus: har du hunnit kika på .log-filen än?
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2012

    Poke: Det verkar omständligt! :) får hoppas att det finns någon annan lösning för oss. Jag har gjort allt så automatiserat som möjligt så jag vill inte hålla på att fippla med sånt där i onödan.

    Atrus: har du hunnit kika på .log-filen än?

    Var tyvärr väldigt svårt att utläsa, och detta p.g.a. att jag inte var tydlig nog med dig.
    Låt oss göra det igen:
    1. Stäng av PMS.
    2. Starta upp PMS.
    3. Gå till en serie som visar detta problem och som har så få säsonger och så få avsnitt som möjligt. Kör sedan en refresh metadata på bara den serien.
    4. Ladda sedan direkt upp PMS-loggen hit.
    5. Berätta vilken tid, vilken serie och vilket avsnitt (säsong och avsnitt) som du ser detta problem med.

    Om du följer de där instruktionerna så kommer loggen vara betydligt prydligare och lättare att söka igenom.

    Risken är att Poke har rätt. Om srt-filerna inte är i rätt format (som jag sett ibland på s4u bland annat) så är det inte så mycket att göra åt förutoma att följa Pokes råd. Men låt oss först lista ut om det är det som är problemet.

    Se även till att du har senaste versionen av PMS. Det var en bugg i en av de tidigare versionerna som skapade ett väldigt liknande problem för vissa mobila enheter.
  • absolutandersenabsolutandersen Posts: 15Members
    atrus wrote:

    Var tyvärr väldigt svårt att utläsa, och detta p.g.a. att jag inte var tydlig nog med dig.
    Låt oss göra det igen:
    1. Stäng av PMS.
    2. Starta upp PMS.
    3. Gå till en serie som visar detta problem och som har så få säsonger och så få avsnitt som möjligt. Kör sedan en refresh metadata på bara den serien.
    4. Ladda sedan direkt upp PMS-loggen hit.
    5. Berätta vilken tid, vilken serie och vilket avsnitt (säsong och avsnitt) som du ser detta problem med.

    Om du följer de där instruktionerna så kommer loggen vara betydligt prydligare och lättare att söka igenom.

    Risken är att Poke har rätt. Om srt-filerna inte är i rätt format (som jag sett ibland på s4u bland annat) så är det inte så mycket att göra åt förutoma att följa Pokes råd. Men låt oss först lista ut om det är det som är problemet.

    Se även till att du har senaste versionen av PMS. Det var en bugg i en av de tidigare versionerna som skapade ett väldigt liknande problem för vissa mobila enheter.


    Ja, då kör vi! :)
    Tiden är 14:37. Dexter, avsnitt 1. (fast det gäller alla.)

    Tack igen!
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Ja, då kör vi! :)
    Tiden är 14:37. Dexter, avsnitt 1. (fast det gäller alla.)

    Tack igen!

    Ok, så där ser jag tydligt att du gör en refresh metadata helt korrekt. Vad jag inte ser är då undertextfilen hittas. Kolla om du har kvar /Users/atrus/Library/Logs/PMS Plugin Logs/com.plexapp.agents.localmedia.log från samma tidpunkt som då du körde sist (kl 14:37), annars måste du köra samma sak igen.
    Om du inte har kvar filen, skicka upp den nya PMS.log och localmedia.log OCH vilken tid det gjordes, OCH vad filen heter på hårddisken (både videofilen och undertextfilen). Snart har vi löst denna gåta tror jag!

    Förresten, funkar undertexten på en datorklient? Alltså, är det bara på mobila enheter som det ej fungerar?
  • absolutandersenabsolutandersen Posts: 15Members
    Hej igen!

    Jag kör bara Media Server-delen och har ingen annan klient än iPhone/ipad nu. Det har dock fungerar med tidigare versioner, då till AppleTV.

    Jag sitter på jobbet nu, fixar en logg antingen ikväll eller imorgon!

    Tack för hjälpen!
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Hej igen!

    Jag kör bara Media Server-delen och har ingen annan klient än iPhone/ipad nu. Det har dock fungerar med tidigare versioner, då till AppleTV.

    Jag sitter på jobbet nu, fixar en logg antingen ikväll eller imorgon!

    Tack för hjälpen!

    Jag förstår. Men det skulle hjälpa om du installerade PMC på din Mac för att se om undertexterna syns då. Bara för att testa.
  • absolutandersenabsolutandersen Posts: 15Members
    atrus wrote:

    Jag förstår. Men det skulle hjälpa om du installerade PMC på din Mac för att se om undertexterna syns då. Bara för att testa.

    Hej!

    Jag installerade PMC, det enda jag får fram när jag togglar undertexter är "Invalid".

    Jag skickar med loggen du bad om. Jag hade flera såna loggar, denna hette .log.1 på slutet. Jag har också loggar som heter Plex Media Server.old.log under Library/logs. Om det är av intresse.

    Och jag hade fel på en minut igår; 14:36 stod klockan på.
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2012

    Hej!

    Jag installerade PMC, det enda jag får fram när jag togglar undertexter är "Invalid".

    Jag skickar med loggen du bad om. Jag hade flera såna loggar, denna hette .log.1 på slutet. Jag har också loggar som heter Plex Media Server.old.log under Library/logs. Om det är av intresse.

    Och jag hade fel på en minut igår; 14:36 stod klockan på.

    Ah, äntligen hittade vi något vettigt. Du får ett exception då undertexten till avsnitt Dexter s07e10 försöker läsas. Jag ska våga mig på en gissning här. Den undertextfilen har en så kallad BOM markup. Det står för Byte Order Mark, och det är en Unicode char som ligger först i en undertext.

    Oavsett om program som Plex ska hantera undertextfiler med BOM eller inte så fungerar det undermåligt idag. Så dyker du på detta så måste du byta ut undertexten till en fungerande fil, eller öppna upp undertexten i t.ex. Jubler och spara om den (då försvinner BOM). Sen kan du köra en refresh metadata igen på serien och det ska nu funka. Funkar det fortfarande inte så kanske du har fler BOM-undertexter som måste fixas. Så kolla i din localmedia.log och se efter vilken fil den bombade på.

    Teta göra detta för att se om min (och Pokes) misstanke är korrekt. Om det inte är det så får vi försöka hitta en annan förklaring.

    Om det är det som är felet så ska jag försöka övertala utvecklarna att ta en titt på BOM-problematiken.
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2012
    Sådär, utvecklarna har fixat buggen för externa SRT-filer. Om externa undertextfilern har en BOM (Byte Order Mark) så ska de visas ändå.
    Fixen går ut till Plexpass-medlemmarna nu (ska testas någon vecka gissar jag). Vet ej hur länge det tar innan icke-Plexpass-medlemmar får den versionen. Så för några få dollar så finns det nog en lösning för dig :)
  • absolutandersenabsolutandersen Posts: 15Members
    Där ser man! Testade att spara om i Jubler, men det funkade inte ändå. Sen verkade det vara så många, så efter att jag tagit bort ett tiotal så la jag ner det!

    Ska kolla upp plexpass! Tack för infon!
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Där ser man! Testade att spara om i Jubler, men det funkade inte ändå. Sen verkade det vara så många, så efter att jag tagit bort ett tiotal så la jag ner det!

    Ska kolla upp plexpass! Tack för infon!

    Om det inte var BOM-problematiken så är det inte säkert att nya PMS:en hjälper dig dock.
  • absolutandersenabsolutandersen Posts: 15Members
    Vad skulle det kunna vara om inte BOM-problem då?
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Vad skulle det kunna vara om inte BOM-problem då?

    Ingen jäkla aning tyvärr. Jag tror att nästa steg i undersökningen måste bli att du laddar upp undertextfilen hit så ska jag ta mig en titt. Döp om undertext-filen till .txt på slutet så kommer forumet tillåta dig att ladda upp den. Berätta vad den hette innan du döpte om så jag vet vad jag ska döpa tillbaka den till. Se till att filen inte fungerar för dig först, så jag inte testar en fungerande :)
  • FredrikSandbergFredrikSandberg Posts: 1Members
    atrus wrote:

    Ingen jäkla aning tyvärr. Jag tror att nästa steg i undersökningen måste bli att du laddar upp undertextfilen hit så ska jag ta mig en titt. Döp om undertext-filen till .txt på slutet så kommer forumet tillåta dig att ladda upp den. Berätta vad den hette innan du döpte om så jag vet vad jag ska döpa tillbaka den till. Se till att filen inte fungerar för dig först, så jag inte testar en fungerande :)



    Jag har också problem med undertexterna till plex, Jag har ställt in så den ska synka automatiskt in texter. Svenska som första val och englska som andra. Men när jag startar upp tv serien så startar inte filmen alls. Sen när jag klickar i att det inte ska vara någon undertext så startar den. Hade gärna uppskattat lite hjälp. Tack på förhand! :)
  • atrusatrus Posts: 11,168Members, Plex Pass, Plex Ninja Plex Ninja

    Jag har också problem med undertexterna till plex, Jag har ställt in så den ska synka automatiskt in texter. Svenska som första val och englska som andra. Men när jag startar upp tv serien så startar inte filmen alls. Sen när jag klickar i att det inte ska vara någon undertext så startar den. Hade gärna uppskattat lite hjälp. Tack på förhand! :)

    Saknar lite info för att ha en chans att hjälpa dig :)
    Typ, vilken klient har du? Vilken version av PMS har du? Har du alltid haft detta problemet? Om inte, när började det? Gjorde du något speciellt runt den tidpunkten såsom till exempel uppdatering av något? Har du upplevt detta problem med någon tidigare version av PMS/klienten? Vilket operativsystem är det på datorn som har PMS installerat på sig?
    Kommer även behöva att du skickar upp din Plex Media Server.log hit så jag kan ta en titt i den. Berätta exakt vilken tid som du senast såg detta fenomen. Om du inte minns, återskapa felet och håll koll på klockan :)
«1
Sign In or Register to comment.