If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

SECURE ACCESS TO PLEX CONSOLE

mvlucchimvlucchi Posts: 9Members
Hi, guys,
I installed via apt-get Plex Server in Ubuntu Server.

If I access the URL "http://192.168.1.100:32400/web/index.html # / dashboard" from other PC in subnet, I see the dashboard without authentication required.
Is there any way to force login and password for access to the dashboard?

Many thanks

Comments

  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
    mvlucchi wrote:

    Hi, guys,
    I installed via apt-get Plex Server in Ubuntu Server.

    If I access the URL "http://192.168.1.100:32400/web/index.html # / dashboard" from other PC in subnet, I see the dashboard without authentication required.
    Is there any way to force login and password for access to the dashboard?

    Many thanks

    Settings -> myPlex -> Show Advanced -> Require authentication on local networks.
    Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
    Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
    Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
    Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
    Airplay & PlexConnect Targets: 4 x ATV3
  • mvlucchimvlucchi Posts: 9Members
    Trudge wrote:

    Settings -> myPlex -> Show Advanced -> Require authentication on local networks.



    Thanks for your fast reply.

    I went to the url:
    http://192.168.1.100:32400/web/index.html #! / settings
    but I can not find "require authentication on local network"

    I see only user text box for username and text box for password
    and two buttons.

    Greetings
  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
    mvlucchi wrote:

    Thanks for your fast reply.

    I went to the url:
    http://192.168.1.100:32400/web/index.html #! / settings
    but I can not find "require authentication on local network"

    I see only user text box for username and text box for password
    and two buttons.

    Greetings

    click on show advanced settings.
    Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
    Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
    Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
    Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
    Airplay & PlexConnect Targets: 4 x ATV3
  • mvlucchimvlucchi Posts: 9Members
    Hi,
    I click on "show advanced settings" but I see a new item in menu ( network ).
    If I se new network menu, I can not find "require authentication on local network"

    I upload a png images.
    Many thanks.
  • tobiashietatobiashieta Plex Dev Team Posts: 5,524Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    mvlucchi wrote:

    Hi,
    I click on "show advanced settings" but I see a new item in menu ( network ).
    If I se new network menu, I can not find "require authentication on local network"

    I upload a png images.
    Many thanks.


    Upgrade.

    Follow me on twitter @tobiashieta or G+

  • mvlucchimvlucchi Posts: 9Members

    Upgrade.


    Hi,
    I upgrade to latest version with following command:

    sudo nano /etc/apt/sources.list
    then I add "deb http://www.plexapp.com/repo lucid main" to the file
    sudo apt-get update
    sudo apt-get install plexmediaserver

    ubuntu install the latest version ( see second image attached ), but I have not solved the problem ( see first image attached ).

    Do you have other ideas ?
  • mvlucchimvlucchi Posts: 9Members
    I add third Image after upgrade below.
    Is there any way to force login/password from command line ?

    Many thanks
  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
    mvlucchi wrote:

    Hi,
    I click on "show advanced settings" but I see a new item in menu ( network ).
    If I se new network menu, I can not find "require authentication on local network"

    I upload a png images.
    Many thanks.

    you need to actually log into myPlex, you wont get far using it to provide security without logging in.
    Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
    Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
    Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
    Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
    Airplay & PlexConnect Targets: 4 x ATV3
  • mvlucchimvlucchi Posts: 9Members
    Trudge wrote:

    you need to actually log into myPlex, you wont get far using it to provide security without logging in.



    Thank you,
    now I understand.
    I did not think to secure access to the dashboard from the same subnet the server had to publish to myplex.

    Many thanks.
Sign In or Register to comment.