Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

myPlex could not connect to your server

shahrukhmshahrukhm Posts: 1Members
Ever since i installed plex media server it has been working fine locally, i never could get my plex running. I have a Netgear WNDR3700 router, ive toggled UPnP several times, forwarded the port computers port to 32400 several times but i never could get it to work. It repeats the error. My router shows a list of devices trying to connect through UPnP and the ip address of my laptop and the 32400 port number shows but it never works.
«1

Comments

  • ubeermenchubeermench Posts: 1Members, Plex Pass Plex Pass
    I have the same problem. same router also
  • grandpacarpgrandpacarp Posts: 62Members, Plex Pass Plex Pass
    ubeermench wrote:

    I have the same problem. same router also


    Same router. Same issue.
  • grandpacarpgrandpacarp Posts: 62Members, Plex Pass Plex Pass
    Just to add to this... my logs were showing the connection attempts as a DOS attack. Turning that off, I was able to get a clean log entry:

    [LAN access from remote] from 54.241.71.49:63633 to X.X.X.X:32500 Sunday, Feb 10,2013 06:21:46 (I put the X's). So now it looks like I have good forwarding happening. I was running with my firewall turned off... still get the same "could not connect to server" error.
  • grandpacarpgrandpacarp Posts: 62Members, Plex Pass Plex Pass
    edited February 2013
    SUCCESS!!! After scrounging I put the last of the puzzle together. Netgear 3700's: Disable Port Scan & DOS protection. The next trick was figuring out that no matter what port you manually specify, the internal port is always 32400 (you're only altering the EXTERNAL port number with that plex setting). I think that between these two pieces of information, you should be able to configure things w/o trouble. Good Luck!
  • andysassoandysasso Posts: 3Members, Plex Pass Plex Pass
    grandpacarp wrote on February 10 2013, 3:26 PM: »

    SUCCESS!!! After scrounging I put the last of the puzzle together. Netgear 3700's: Disable Port Scan & DOS protection. The next trick was figuring out that no matter what port you manually specify, the internal port is always 32400 (you're only altering the EXTERNAL port number with that plex setting). I think that between these two pieces of information, you should be able to configure things w/o trouble. Good Luck!

    Finally this works!!!!!!!!

  • jamiespotterjamiespotter Posts: 1Members, Plex Pass Plex Pass

    I don't really understand? What did you actually do? I have the same router and same problem.

  • grandpacarpgrandpacarp Posts: 62Members, Plex Pass Plex Pass
    jamiespotter wrote on March 27 2013, 12:11 PM: »

    I don't really understand? What did you actually do? I have the same router and same problem.

    1. Disable "Port Scan and DOS Protection"

    2.  Under Port Forwarding.  You need to specify port forwarding to internal port 32400 on your mplex server.    An example would be in the Settings of mplex: Settings/mplex/"Manually specify port".  Lets say you set this to 32700.  Then port forwarding should be from 32700 to your server's IP @ port 32400.
     

  • casperinmdcasperinmd Posts: 2Members, Plex Pass Plex Pass
    grandpacarp wrote on March 27 2013, 9:35 PM: »

    1. Disable "Port Scan and DOS Protection"

    2.  Under Port Forwarding.  You need to specify port forwarding to internal port 32400 on your mplex server.    An example would be in the Settings of mplex: Settings/mplex/"Manually specify port".  Lets say you set this to 32700.  Then port forwarding should be from 32700 to your server's IP @ port 32400.
     

    Perfect, I have a Cisco router..but my issue is I was forwarding 32401 to 32401...when I should have left the internal port to 32400.

    Thanks!

  • NikonSixNikonSix Posts: 33Members, Plex Pass

    None of this advice is helping. Thank you though.

    Why is this happening anyway? I didnt have this problem before the update.

    I can't get myPlex to work over LTE on my iPhone either anymore...

  • bearddbeardd Posts: 1Members

    I'm getting the myPlex could not reach your server error and am using the WNDR3700. I have disabled the DOS protection and forwarded 32400. What else am I missing?

  • chaudichaudi Posts: 89Members, Plex Pass Plex Pass

    I gtot he same router. I've tried to disable DOS & Port scan protection but that didn't help.

    I can't connect to my server if I go via my.plexapp.com/servers/..... and it shows in red as in disconnected(?).

    but if I connect to xxx.xxx.xxx.xxx:32400/web/index.html I can reach the server. So all ports and such is working.

    How to fix this?

  • eezeeeze Posts: 16Members

    From what I dug up during my initial setup is this.


    Plex (internally) only works on port 32400.  So even port forwarding, say port 5100 for example won't work, you'll have to set up some sort of static Port Address Translation (PAT)

    I had more luck with enabling uPNP and making sure I didn't have any double-NAT anywhere in the path rather than port  forwarding. This was on my Linksys.


    I just tested earlier with a Cisco router (Ie Not Linkysys) but rather a Cisco 1841  where I can do a manual PAT/NAT from outside 5100 to 32400 internally and it had no problem.

  • eezeeeze Posts: 16Members

    FYI, pretty dangerous to do a manual port forward of port 32400 because any attacker could randomly scan for port 32400 since all PLEX devices run on the same port.

    Would much rather have the setting for "Port" actually mean that Plex would respond on that port. 

  • brookj1986brookj1986 Posts: 1Members

    I found a solution to my problem. Turns out it was Double -NAT issue. I too have the WNDRMAC. I also have Arris Interactive, L.L.C. TG862G modem from Comcast (and it has a built in router). Despite never using the Wireless interface with this combo modem that Comcast gave, it was creating this double-NAT issue since the day it was installed. If I was on my home network, I had no issues accessing my PlexApp. The moment I was on 4G or non- home Wifi, I couldn't access anything.

    After following the above suggestions about port forwarding, which I really appreciated everyone's input on, I realized this wasn't working for my particular situation.

    All I did was call Comcast Customer care and asked them to turn on bridge mode on my router which they can do remotely. Once done, I power cycled my modem and WNDRMAC once, and everything was back up and running as it was prior to getting this new 'upgraded' modem. Able to access MyPlex from everywhere again!

    Anyway, I would recommend calling Comcast (if this is your ISP) and asking them to put your modem into bridge mode not during peak hours -- I called at 10:20PM and had no wait at all. Anyway, hopefully this helps someone resolve their issues as for me it turns out it wasn't a port issue at all.

  • dwk001dwk001 Posts: 21Members, Plex Pass Plex Pass

    If you want to log into your modem/router combo usually the default 192.168.100.1

    Username is usually admin
    password is either: admin, or password

    From inside the modem/router youll look for LAN Settings.
     

    Inside of it, there is an option for Bridged, Routed, Routed with Nat, or Routed without Nat.
     

    If your router is going to be the only device hooked directly into the modem, then use "Bridged" That will allow all IP routing to be done through the router

     

  • jparis215jparis215 Posts: 1Members, Plex Pass

    I have the same problem and I have been trying to fix it with no luck. I can only use plex on my devices when they are on my home network. I can sign into myplex fine, but it says: "myPlex could not reach your server". I'm running win 7 so I have the use the Web UI. Since it can't reach my server I assume it also can't publish the server.

    I have tried disabling uPNP and forwarding the ports on my router and that doesn't work either, myPlex still can't reach my server.

    Suggestions would be highly appreciated.    

  • k.runge@live.comk.runge@live.com Posts: 147Members

    Add me to the list of people having connection problems to MyPlex with this router. Strange thing is, everything was working fine up until a week ago when I had to replace the HDD of my server. Now I have the same problem. So nothing in my router has changed. I'm sure I set port forwarding way back. Maybe a firewall issue with the server with the new HDD?

  • k.runge@live.comk.runge@live.com Posts: 147Members

    Okay, here's what worked for me. I remembered that I used to have my server set to static IP. I changed that back and under port forwarding, active forwarding rules, I have Plex, 32400, 32400, both, and the static IP address. MyPlex instantly connected.

  • dl7481dl7481 Posts: 19Members ✭✭
    andysasso wrote on February 27 2013, 7:17 AM: »

    Finally this works!!!!!!!!

    Okay so I have the same Wndr3700v2 router behind a standard Arris Modem. Could you please help me port forward my plex? I got it to work on my old Wndr1000v3 router with the same Arris modem. What am I doing wrong?!!

  • dl7481dl7481 Posts: 19Members ✭✭
    beardd wrote on May 24 2013, 2:53 AM: »

    I'm getting the myPlex could not reach your server error and am using the WNDR3700. I have disabled the DOS protection and forwarded 32400. What else am I missing?

    Did you get your problem resolvced? Can you please help me? I have the same router 

«1
Sign In or Register to comment.