Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

No subtitles

Hi,

I am new here, this is my first post. I just bought Roku 3 about a week ago. And I am exploring Plex. 

 

There is some shows I like to watch that is not found on Hulu Plus on my ipad or Roku, these shows is "Web Only," meaning I can only watch it on my PC. (bleech)

 

To try it, I selected 'Auction Hunters' from Spiketv.com and saw it is subtitled on my PC. So I saved that to my Plex queue.

 

I started Roku, and saw the show is in my queue, and started playing it. Well, guess what? No subtitles. I enabled EVERYTHING (Plexapp.com, Roku, TV... anything that will enable captioning). I am sooo disappointed. I had high hopes!

 

I am deaf and I really rely on captioning. Is there a way I can fix this? Can Plex fix this? 

 

I will give Plex five stars if they could just enable the captioning to the online streaming videos. Pretty please?

«1

Comments

  • smitty870smitty870 Posts: 2Members, Plex Pass

    I have the same issue, I log into the plex channel and select subtitles and force play from the PC using subtitles with no such lulck

  • BerkeboBerkebo Posts: 1Members, Plex Pass Plex Pass
    Got the same issue with my Roku 3.
  • techmattrtechmattr Posts: 215Members, Plex Pass Plex Pass

    I've just started researching subtitles today but from http://roku.yt1300.com/1080p.html it says "embedded subtitles are not supported and you need to use a srt file". So I'm guessing the titles you're trying to play are embedded?

  • crankocranko Posts: 4Members, Plex Pass

    Same here, on Roku 3, downloaded .srt, dumped into the same movie folder and rename it as the same as the .mkv filename.

    Re-synced the movie folder, the "unknown subs" appear on Roku 3's PLEX app subs roll-down but the sub is not appear in the movie.

  • TorjacTorjac Posts: 4Members, Plex Pass Plex Pass

    The same thing happens when I use the iPhone/iPad App. I can choose the movie, and even the subtitle I want from the MKV file through the Plex server. I still do not get the subtitles on the screen. The only place I can actually see subtitles is on my iMac using Plex.

  • dzirkelbdzirkelb Posts: 25Members, Plex Pass
    itznfb wrote on April 8 2013, 7:05 PM: »

    I've just started researching subtitles today but from http://roku.yt1300.com/1080p.html it says "embedded subtitles are not supported and you need to use a srt file". So I'm guessing the titles you're trying to play are embedded?

    Ouch, does this mean the "forced" subtitles I place in my mkv container will never play on a plex machine?  Even a windows plex client?  If so, ouch ouch ouch

  • techmattrtechmattr Posts: 215Members, Plex Pass Plex Pass
    dzirkelb wrote on May 3 2013, 9:41 PM: »

    Ouch, does this mean the "forced" subtitles I place in my mkv container will never play on a plex machine?  Even a windows plex client?  If so, ouch ouch ouch

    That's for the Roku Plex client. I believe it's a Roku limitation. Apparently support is growing for that as well though.

  • otsepotsep Posts: 5Members, Plex Pass Plex Pass

    My subtitles work fine on the Roku 3. Try changing to the Stable transcoder. 

  • schuylerschuyler Plex Dev Team Posts: 3,787Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    The Roku doesn't support embedded subtitles, but the Plex Media Server knows that and will burn them into the video for you. If you want files to direct play and have subtitles then you're only option is external SRT subtitles. But otherwise just leave everything at default settings (Experimental transcoder, Automatic, latest Plex Media Server version) and it'll work.

  • reaper888reaper888 Posts: 43Members, Plex Pass Plex Pass
    Extracting the srt worked great for me so far
  • Cleopatra2525Cleopatra2525 Posts: 7Members
    schuyler wrote on May 7 2013, 12:01 AM: »

    The Roku doesn't support embedded subtitles, but the Plex Media Server knows that and will burn them into the video for you. If you want files to direct play and have subtitles then you're only option is external SRT subtitles. But otherwise just leave everything at default settings (Experimental transcoder, Automatic, latest Plex Media Server version) and it'll work.

    The above simply does not work on the Roku 2 XD with Coursera videos and SRT's.  Direct Stream or Transcoder, whether experimental or automatic, simply refuses to work or freezes the app. :(  How do I get the subtitles to display?

  • schuylerschuyler Plex Dev Team Posts: 3,787Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    MachineGhost wrote on June 6 2013, 7:44 AM: »

    The above simply does not work on the Roku 2 XD with Coursera videos and SRT's.  Direct Stream or Transcoder, whether experimental or automatic, simply refuses to work or freezes the app. :(  How do I get the subtitles to display?

    That's a use case near and dear to my heart, I have a Coursera section too, but I haven't tried their subtitle files. I'll see if I can take a look based on one of the classes I'm in now, but if you want to share one of the files that isn't behaving that'd be helpful too.

    What exactly freezes the app? That shouldn't be possible.

  • Cleopatra2525Cleopatra2525 Posts: 7Members
    edited June 2013
    schuyler wrote on June 6 2013, 6:38 PM: »

    That's a use case near and dear to my heart, I have a Coursera section too, but I haven't tried their subtitle files. I'll see if I can take a look based on one of the classes I'm in now, but if you want to share one of the files that isn't behaving that'd be helpful too.

    What exactly freezes the app? That shouldn't be possible.

    Playing as Transcoder doesn't do anything and trying to play the file again will lock up the app.
     

    So what is the working solution to get the SRT files to play without using transcoding?

  • schuylerschuyler Plex Dev Team Posts: 3,787Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I'm still not clear on what is locking up the app. That shouldn't be possible, and I don't know of any way to do it. If you can provide a sample file that causes the problem, steps to reproduce the problem, or logs, then I'd love to get to the bottom of it.

    Based on my testing with a particular Coursera class (don't know how well the extrapolation holds), the issue is with newlines at the beginning and end of the file. The next version of Plex Media Server will try to take care of this automatically, but in the meantime you can try editing the .srt file and making sure there's no blank line at the top and add a blank line at the end of the file.

  • Cleopatra2525Cleopatra2525 Posts: 7Members

    Found a new issue with Coursera.  Seems to be when the start time is less than 0.  I've attached a SRT with the issue.

    There's also an issue with more lines than one in-between sections than just at the beginning and the end. 

    I haven't found that CR/LF (Windows) or LF (Unix) makes any difference; it is the spacing (or start time).

  • schuylerschuyler Plex Dev Team Posts: 3,787Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    That first line seems pretty bogus, I'm not sure I blame the Roku. You may want to complain to Coursera, they should be providing valid SRT files.

  • Cleopatra2525Cleopatra2525 Posts: 7Members

    Is there anything you can do offer an option to turn on a black background behind the subtitles as with TV closed captions?  I don't know what genius decided on yellow letters as an industry standard for subtitles, but it is frustratingly difficult to impossible to read on certain bright or patterned background scenes, and especially when overlayed over black sentences or pictures on white backgrounds featured on Coursera slides.  I'm close to pulling my hair out!

    I e-mailed Roku to offer such an option system-wide and to forward it to the appropriate department, but who knows if they'll take my suggestion seriously.  Is there any access in the Roku API to offer such functions in Plex?

  • schuylerschuyler Plex Dev Team Posts: 3,787Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    MachineGhost wrote on August 1 2013, 5:32 PM: »

    Is there anything you can do offer an option to turn on a black background behind the subtitles as with TV closed captions?  I don't know what genius decided on yellow letters as an industry standard for subtitles, but it is frustratingly difficult to impossible to read on certain bright or patterned background scenes, and especially when overlayed over black sentences or pictures on white backgrounds featured on Coursera slides.  I'm close to pulling my hair out!

    I e-mailed Roku to offer such an option system-wide and to forward it to the appropriate department, but who knows if they'll take my suggestion seriously.  Is there any access in the Roku API to offer such functions in Plex?

    Sadly, people have been complaining to Roku about this for a while. There's no way for us to change anything about the subtitles except for the color (which is only possible on recent Roku versions). So you could switch to white or black instead of yellow, but I don't think that's better personally.

    The only other option is to disable soft subtitles, which will result in transcoding the video and burning in the subtitles. When you do that, it's our transcoder that renders the subtitles, and it should use a black outline. That setting is inside our channel on the Roku, Preferences -> Subtitles -> Subtitles (Burned in vs. Soft).

  • Garrett G.Garrett G. Posts: 2Members

    I just got my Roku box the other day so bear with me, but I believe I have a working solution. 

    I have a Roku 2 XS with the newest firmware. I've been working with an MKV I downloaded of A Good Day To Die Hard. There is a Russian sequence in the first 2 minutes of the movie. I used Handbrake to convert the movie to MP4. I imported the SRT file into Handbrake when I converted and, although Plex shows it in the Playback Options menu for the individual movie, selecting it does not display subtitles no matter what. 

    However, I edited the SRT with Notepad and found that it had a blank line at the top and two at the bottom. I removed the blank line from the top and left only one blank line at the bottom. I named the file the same as the movie and left it in the same folder with the MP4. 

    In the Playback Options menu, I selected Unknown (SRT) for the subtitles. (The one I imported into the MP4 was still listed as English ()

    When I selected "Soft" in the Plex options under Subtitles, The subtitles are displayed as small yellow lettering. 

    When I select "Burned in" the subtitles are white with a black edge and slightly larger than the yellow ones. 

    I have enabled on the Sever Settings > Agents > Movies > Personal Media > Local Media Assets (Movies) 

    The subtitles display consistently in the Direct Play and Automatic playback modes. 

    What I have not yet done is re-converted the MKV to MP4 with Handbrake using the new, edited SRT file. I'll update in the next few days. 

    Other notes:

    I've been trying multiple movie formats the last few days to find the right balance between quality and reliability. I've used the settings from Rokode for a 720p file in an MP4 container with AC3 Passthru for audio.  Maybe it's my network but 1080p movies seem to have trouble with buffering. I have a 60in LED TV and I can't tell a real difference between 1080p and 720p on streaming video anyway. 

    I have a DTS receiver, but I chose AC3 so I could use the MP4 container for broader compatibility. Roku/Plex only does DTS passthru with MKV

  • Cleopatra2525Cleopatra2525 Posts: 7Members

    Great idea!  But I want to point that out burned in (hard) subtitles do not work because the transcoders do not work on my Roku XD.  Experimental reports an invalid video file or some such and stable does not display the captions.

    schuyler wrote on August 5 2013, 6:33 PM: »

    Sadly, people have been complaining to Roku about this for a while. There's no way for us to change anything about the subtitles except for the color (which is only possible on recent Roku versions). So you could switch to white or black instead of yellow, but I don't think that's better personally.

    The only other option is to disable soft subtitles, which will result in transcoding the video and burning in the subtitles. When you do that, it's our transcoder that renders the subtitles, and it should use a black outline. That setting is inside our channel on the Roku, Preferences -> Subtitles -> Subtitles (Burned in vs. Soft).

«1
Sign In or Register to comment.