If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

.wtv files on Surface RT (won't stream)

dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

I've recently signed up and installed Plex, specifically for watching .wtv files on the Surface RT tablet I just purchased.  I've been using media streaming servers like Remote Potato, AirVideo and Qloud to stream our recorded files to different devices I've owned for ages, but Plex is the only one I can find for Windows 8.


All the files I've tried seem to stream ok to my Windows Phone 8 and the Plex desktop program on my laptop (running Win 8 Pro).  So the server seems to be working ok.  But only a small number of files will stream to Windows 8 plex (whether on my SurfaceRT, or on the same Win 8 laptop).


I have tried .wtv, .mpg and .avi files. None of the .mpg or .avi files I've tried have worked. The loading dots just cycle forever, and up the top it says "HTTP Live Streaming - Opening". I've managed to get a couple of .wtv files to play, but almost all load forever, and never play. This is all just over local network for now (remote connection should work once local does).


It's a very clean, attractive app! And would make my awesome Surface RT experience that much more complete, so would be great to sort it out.


Thanks for your help!



  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Hmm, that's odd.

    It sounds like you're having some issues with HTTP Live Streaming transcodes on your Plex/Win8 clients.  If you could post a Plex Media Server.log file from the server after a failed play, and/or upload sample media, it would provide us with more data to diagnose the issue.

    If the issue is only with transcodes, that's one thing.  But if it's also with Direct Play files, then the problem might be something impeding the network connection between your clients and the server.  With Direct Play, we pretty much hand off the URL to the underlying Media Foundation player and get out of the way.

    A few notes:

    1) MPEG files will probably never Direct Play on Windows RT.  But on your laptop, you can install the WMC pack and enable the MPEG setting in the Plex app, and you'll get Direct Play for MPEG files.

    2) AVI files should Direct Play, but it depends on the codecs.  You can use the Media Info button on the video's pre-play page to see what the app's going to do with the media.

    3) WTV files won't Direct Play because MSFT doesn't ship a Media Foundation splitter for them.  (Amazingly enough, given it's their format...)

    Anyway, I hope this helps in terms of providing next steps on diagnostics.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass
    edited April 2013

    Thanks for your quick reply!

    So, I don't have that many avi files.  One I do have (Bourne Ultimatum) streams fine if I access the file directly (across the network) and play it in the Xbox Video player.  From within Plex (on my Surface), Media info says it will be transcoded as "The media has no container". If I do try and play it, it attempts to load forever, and eventually goes back to the movie's pre-play page. The situation is the same for most of the other files I have (wtv and mpg). They all say "The media has no container". The few that do provide info when I look at "Media Info" tend to play fine (wtv and mpeg-2 files transcoding).  I should add, the video I record is pretty much all h.264 files I think, in wtv wrapper.

    I'm attaching a log from this morning (in 2 parts).  I tried to play 3 files:
    - "Judge Judy" (wtv file that kind of did load...the progress bar appeared at the bottom and progressed for a little while. But it was just a black screen, and then it exited back to the episode's pre-play page)
    - "August Rush" (wtv file that just loaded for ages)
    - "Bourne Ultimatum" (wtv file that just loaded for ages)

    I wasn't 100% sure what was important, so I didn't delete much. But I got rid of everything logged before I started playing with it today.

    As for uploading sample media...they're all pretty massive files. Do you mean, maybe record a minute or two of TV, and then upload it? SD video is about 20Mb/min, HD about 70.

    Thanks again!

  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Oh, yeah, interesting.

    The basic problem you're running into is on the server:  there's no media info.  We should probably find a more elegant way to fail somewhere in the playback / transcode pipeline when this happens.  (That said, something would need to go fairly wrong during scanning and media analysis for this to happen.)

    To confirm the issue and give me some testing fodder for later, please navigate to http://yourserver:32400/library/metadata/23 and post the XML from that, or copy XML via the Media Info button inside the app.

    Your fix, btw, is probably going to be to re-analyze the media in your library section via the PMS web client.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass
    edited April 2013

    Cool, yeah I thought the media info seemed like it'd probably be the problem. This is the xml for 3 files, none of which play (they looked tidier on the website):

    <?xml version="1.0" encoding="UTF-8"?>
    -<MediaContainer size="1" identifier="com.plexapp.plugins.library" mediaTagVersion="1363083824" mediaTagPrefix="/system/bundle/media/flags/" allowSync="1" librarySectionUUID="5e3486d2-3133-40b7-8647-5664b4e4bbac" librarySectionID="1">-<Video title="Bourne Ultimatum" type="movie" updatedAt="1363992180" key="/library/metadata/23" summary="" thumb="/library/metadata/23/thumb/1363992180" addedAt="1363990916" ratingKey="23" guid="local://23">-<Media mediaAnalysisVersion="0" id="23" container=""><Part size="731348992" key="/library/parts/24/file.avi" id="24" file="D:\Videos\Movies\Bourne Ultimatum\The Bourne Ultimatum.avi"/></Media></Video></MediaContainer>

    <?xml version="1.0" encoding="UTF-8"?>
    -<MediaContainer size="1" identifier="com.plexapp.plugins.library" mediaTagVersion="1363083824" mediaTagPrefix="/system/bundle/media/flags/" allowSync="1" librarySectionUUID="5e3486d2-3133-40b7-8647-5664b4e4bbac" librarySectionID="1">-<Video title="August Rush" type="movie" updatedAt="1364448369" key="/library/metadata/10" summary="August Rush is a 2007 drama film directed by Kirsten Sheridan and written by Paul Castro, Nick Castle, and James V. Hart, and produced by Richard Barton Lewis. Deciding to run away to New York City, musical prodigy Evan Taylor begins to unravel the mystery of who he is. All the while Evan Taylor's mother is searching for him whilst his father is searching for her." art="/library/metadata/10/art/1364448369" thumb="/library/metadata/10/thumb/1364448369" addedAt="1363990912" ratingKey="10" originallyAvailableAt="2007-10-06" duration="6840000" tagline="An incredible journey moving at the speed of sound" year="2007" rating="8.6999998092651403" studio="Warner Bros. Entertainment" contentRating="PG" guid="com.plexapp.agents.imdb://tt0426931?lang=en">-<Media mediaAnalysisVersion="0" id="10" container=""><Part size="4405067776" key="/library/parts/11/file.wtv" id="11" file="D:\Videos\Movies\August Rush\August Rush.wtv"/></Media><Genre id="74" tag="Romance Film"/><Genre id="1601" tag="Musical Drama"/><Genre id="1602" tag="Romantic fantasy"/><Genre id="1603" tag="Music"/><Genre id="26" tag="Drama"/><Genre id="1250" tag="Childhood Drama"/><Writer id="1585" tag="Nick Castle"/><Writer id="1586" tag="James V. Hart"/><Director id="1584" tag="Kirsten Sheridan"/><Producer id="1604" tag="Richard Barton Lewis"/><Country id="120" tag="USA"/><Role role="Lyla Novacek" id="1587" tag="Keri Russell"/><Role role="Louis Connelly" id="1588" tag="Jonathan Rhys Meyers"/><Role role="Evan Taylor" id="1589" tag="Freddie Highmore"/><Role role="Thomas Novacek" id="1590" tag="William Sadler"/><Role role="Richard Jeffries" id="1591" tag="Terrence Howard"/><Role role="Maxwell 'Wizard' Wallace" id="1592" tag="Robin Williams"/><Role role="Marshall Connelly" id="1593" tag="Alex O'Loughlin"/><Role role="The Dean" id="855" tag="Marian Seldes"/><Role role="Hope" id="1594" tag="Jamia Simone Nash"/><Role role="Arthur" id="1595" tag="Leon G. Thomas III"/><Role role="Lizzy" id="1596" tag="Bonnie McKee"/><Role role="Nick" id="1597" tag="Aaron Staton"/><Role role="Professor" id="1598" tag="Ronald Guttman"/><Role role="Mannix" id="1599" tag="Michael Drayer"/><Role role="Reverend James" id="1600" tag="Mykelti Williamson"/></Video></MediaContainer>

    <?xml version="1.0" encoding="UTF-8"?>
    -<MediaContainer size="1" identifier="com.plexapp.plugins.library" mediaTagVersion="1363083824" mediaTagPrefix="/system/bundle/media/flags/" allowSync="1" librarySectionUUID="15bf1310-fc1c-4abd-9fbe-2f4f0b2fbc70" librarySectionID="6">-<Video title="Judge Judy Vibe 2013 03 11 10 18 00" type="movie" key="/library/metadata/180" summary="" addedAt="1364447195" viewOffset="9733" ratingKey="180" viewCount="1">-<Media mediaAnalysisVersion="0" id="180" container=""><Part size="637272064" key="/library/parts/181/file.wtv" id="181" file="D:\Recorded TV\Judge Judy_Vibe_2013_03_11_10_18_00.wtv"/></Media></Video></MediaContainer>

    As for re-analysing the media, is that by going into the "Movies" folder and selecting "More" and then choosing the analyse option? I think I did that before, but I've selected it again.

  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Yeah, mediaAnalysisVersion="0" and no streams means analysis didn't succeed.

    And yes, More -> Analyze Media.

    If analysis fails to improve things, a Plex Media Scanner.log and a file sample would help (just a few seconds is fine, assuming it reproduces the issue).

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

    Here's the media scanner log, and a few video files (.wtv files renamed as .txt for upload). The "Cash in the Attic" one seems to have analysed correctly, but the others haven't been (though, in this case, perhaps because it's so short, I get an error message "The video failed to play." and up the top it says "MF_MEDIA__ENGGINE_ERR_SRC_NOT_SUPPORTED : HRESULT - 0xC00D36C4")
    I've told it to analyse again. So far I haven't noticed any change...not sure how long it'll take as there's quite a number of files.

    Also, I'm not sure if it'll matter, but I set up my "Recorded TV" folder using the "Movies" template, as that showed all the recently recorded videos without them needing to have been organised into folders and renamed etc.


  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I downloaded the "Judge Judy Vibe" video into a movie section and refreshed the section.  Seems to be working fine:

    <MediaContainer mediaTagVersion="1361247793" mediaTagPrefix="/system/bundle/media/flags/" librarySectionUUID="0392d7ec-417a-4e6f-9f3b-2eb68b82bc0a" librarySectionID="9" identifier="com.plexapp.plugins.library" allowSync="1" size="1">

    <Video title="Judge Judy Vibe 2013 04 02 17 23 41 Txt" updatedAt="1364924114" addedAt="1364924106" originallyAvailableAt="2013-04-02" duration="4000" art="/library/metadata/27107/art/1364924114" thumb="/library/metadata/27107/thumb/1364924114" year="2013" summary="" type="movie" guid="com.plexapp.agents.none://4f3387372db3d2261f9cd67def243e1e9f3eb09d?lang=xn" key="/library/metadata/27107" ratingKey="27107">

    <Media duration="4000" videoFrameRate="PAL" container="wtv" videoResolution="576" videoCodec="mpeg2video" audioCodec="mp2" audioChannels="2" aspectRatio="1.78" height="576" width="720" bitrate="3616" id="24282">

    <Part size="2097152" duration="4000" key="/library/parts/24286/file.wtv" container="wtv" id="24286" file="D:\Operations\Incoming\Temp\Plex\Simple\Judge Judy_Vibe_2013_04_02_17_23_41.txt.wtv">

    <Stream language="English" bitrate="256" id="25958" languageCode="eng" channels="2" index="0" codec="mp2" selected="1" streamType="2"/>

    <Stream height="576" width="720" bitrate="3616" id="25959" index="1" codec="mpeg2video" streamType="1" scanType="interlaced" pixelAspectRatio="64:45" frameRate="25.000" anamorphic="1"/>






    I played it inside the Win8 app and it played fine via HLS transcode.

    So... I can't repro, unfortunately.  Next step for your troubleshooting might be to run "plex media scanner.exe --analyze --item X" where X is the ratingKey attribute from the item's XML.  See what that says and check out the scanner log.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass
    edited April 2013

    Thanks again for getting back to me!

    So, in light of that, I've done some more testing.  I deleted all of my media folders (in plex) and started again with an empty one.  I can throw as many Judy Judy recordings in there as I like - they all scan and analyse quickly and correctly, and play fine transcoding.  I also put the avi movie in the folder, and it scanned correctly. But as soon as I have a larger HD wtv file, things stop.

    I made a bunch of HD recordings. The ones that were ~1.5Mb in size (~1s) analysed fine. Anything bigger (~3mb +) analyse and analyse, and never get anywhere (~4mb, that I used command prompt to force analysis, processed for half an hour before I cancelled it).

    When I first set it all up, I added big directories of files. I think, in each directory, analysis was processing until it hit a problem file, and then never progressed (which is why lots of files like the avi and SD wtv files didn't work either). The confusing thing is, there are a bunch of massive (~10gb) HD wtv files (like Avatar) that DID process.  So I'm not really sure what the problem is.  And I can't upload the files that do cause me problems, as they're over 2mb.  Can I send a dropbox link or something?

    Im uploading a couple more logs. The first one is analysis I forced (in command prompt), that ran until 10:26am before I shutdown the plex media server to try something else. It was either a 4MB or a 15Mb file. There's no logging past the start time, unfortunately...I'm not sure why.
    The second one is the log for a full length (half hour) HD video. It maybe gives a bit more information.

  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Those scanner logs look like either ffmpeg or mediainfo is really struggling with those files.  A local repro would be great.

    So "yes please" to a dropbox/skydrive link.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

    True...what would be causing that? Is ffmpeg involved with sorting out media info? Or just transcoding?

    I've put a few short video files in here:

  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for the samples.

    Amusingly, both MediaInfo and ffmpeg choke on these files.  And yes, both are used for media analysis.

    If you grab the latest MediaInfo.dll from http://mediainfo.sourceforge.net/en/Download/Windows and replace the one in the PMS program files directory, it appears to fix the problem for some of the files.  We'll update that soon.

    We're also due for an ffmpeg library update, but that's a bit more involved.  No ETA on that;  but when it happens hopefully it'll solve that part too.  Cross your fingers.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass
    edited April 2013

    Right...that sucks! I'll try that .dll then, thanks. 

    The source you sent me only allows you to download an .exe file, and it wants to install some "Delta Toolbar"? Is there somewhere one can just get the .dll file? Minus the dodgy toolbar? Or is the toolbar easy to get rid of afterwards? Also, where does it put the files when you install from the .exe?

    Thanks again

    *** Nevermind! The "custom" install was grayed out, but you can select it..so I've installed the new dll, and it seems to be helping. Will let you know how it goes!

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

    So, that looks to have helped. There are still files in my Movies folder than haven't finished figuring themselves out...but all our recently recorded stuff loads up fine now.

    Slightly different problem though...my media library hasn't been picking up new files the last few days. Do you know what might be causing that? I've tried clicking "Update Library" and told it to do a deep scan of the recorded tv folder...but it just refreshes the files already found. It doesn't find new ones.


  • roadrunner1024roadrunner1024 Posts: 4Members, Plex Pass ✭✭

    i'm having the Same issue dgre057, have updated the dll, so hoping that will solve teh streaming issue..

    however i can never get the library to update my recorded tv!

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

    OK, they seem to be updating fine again - not sure what the problem was.

    ANOTHER problem I have, though, is I can't stream HD files - they're all stutter. That's even if I set the transcoding quality really low. Does any one know why that would be? SD video transcodes and streams fine.

  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee


    Are the files DirectPlaying or transcoding?

    The usual causes of stuttering are network bandwidth constraints and CPUs being maxed out.  Simple stuff, but often hard to diagnose and track down.

  • dgre057dgre057 Posts: 39Members, Plex Pass Plex Pass

    So it looks like they were actually direct playing...or at least, the video was being direct played (at full 1080p despite being .wtv files), and the audio was being transcoded. I had been fiddling with the transcoding quality, but not the direct play, because I thought it was transcoding. Once I dropped the direct play quality to 720p it started streaming sweet. So it must have been a network limitation.

    Thanks again, at this stage everything is running smoothly :)

Sign In or Register to comment.