Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex DLNA Server not showing library on Samsung TV

tomkleibergtomkleiberg Posts: 2Members
edited March 2013 in DLNA

Hi all,

 

Few days (weeks even?) I have trying to get my library (movies section) available on my Samsung TV.

Setup:

- Samsung TV

- Ubuntu Server 12.04 LTS

- Plex 9.7.17

 

The only sections that are shown are: "Video", "Music", "Photo"

and one level deeper: "Video Shared", "Video Recommendations" and several others

When I try to go into these folders, I get an error. This error is solved when I make the entire plexmediaserver folder writeable:

chmod -R 777 /var/lib/plexmediaserver 

 

after doing this, I can get one level deeper, but all is empty. Above all, the library sections are not showing.

Strange things is that it recently stopped working.

 

I have tried many things:

- restart plex

- restart server

- reinstalled plex

- revert plex  to 9.6.x version

 

The "Plex DLNA Server.log" gives following errors:

 

Mar 31, 2013 15:31:55 [0x7f8f877fe700] DEBUG - OnBrowseDirectChildren for '99be9211-6884-4436-ab37-83a8ac5bae6c' with filter '*' and sort '', paged as 0 + 1
Mar 31, 2013 15:31:55 [0x7f8f877fe700] DEBUG - Mapped client to profile Samsung using header DLNADOC/1.50
Mar 31, 2013 15:31:55 [0x7f8f877fe700] DEBUG - Downloading document https://my.plexapp.com/pms/system/library/sections
Mar 31, 2013 15:31:55 [0x7f8f877fe700] DEBUG - Cache hit for document https://my.plexapp.com/pms/system/library/sections
Mar 31, 2013 15:31:55 [0x7f8f877fe700] DEBUG - HTTP requesting to: https://my.plexapp.com/pms/system/library/sections
Mar 31, 2013 15:31:56 [0x7f8f877fe700] ERROR - downloadContainer: expected MediaContainer element, found errors
Mar 31, 2013 15:31:56 [0x7f8f877fe700] ERROR - generateForPlexPath - unable to get directory /pms/system/library/sections
 
This is a snippet from the "Plex Media Server.log"
Mar 31, 2013 15:21:03 [0x7fdcdde0c700] DEBUG - File /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins changed: 1364736059 => 1364736060.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - Scanning for plug-ins in /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - Updating the list of agents known by the system.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/agents
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/agents
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 2971 bytes of content.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - The system knows about 11 agents.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - Waiting for all 0 plug-ins to finish starting.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] VERBOSE - [Event] Firing plex.event.server.plugins.started to 0 sink(s)
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] DEBUG - Done waiting for all plug-ins to start.
Mar 31, 2013 15:21:04 [0x7fdcdde0c700] ERROR - Couldn't create group: Not permitted
Mar 31, 2013 15:30:33 [0x7fdca4ff9700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51521] (1 live)
Mar 31, 2013 15:30:33 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:30:33 [0x7fdca4ff9700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:30:33 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:30:33 [0x7fdca4ff9700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:30:33 [0x7fdca67fc700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51523] (1 live)
Mar 31, 2013 15:30:33 [0x7fdca67fc700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:30:33 [0x7fdca67fc700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:30:33 [0x7fdca67fc700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:30:33 [0x7fdca67fc700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:40 [0x7fdca67fc700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51527] (1 live)
Mar 31, 2013 15:31:40 [0x7fdca67fc700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:40 [0x7fdca67fc700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:40 [0x7fdca67fc700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:40 [0x7fdca67fc700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:40 [0x7fdca4ff9700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51529] (1 live)
Mar 31, 2013 15:31:40 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:40 [0x7fdca4ff9700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:40 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:40 [0x7fdca4ff9700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:47 [0x7fdca67fc700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51532] (1 live)
Mar 31, 2013 15:31:47 [0x7fdca67fc700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:47 [0x7fdca67fc700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:47 [0x7fdca67fc700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:47 [0x7fdca67fc700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:47 [0x7fdca4ff9700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51534] (1 live)
Mar 31, 2013 15:31:47 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:47 [0x7fdca4ff9700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:47 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:47 [0x7fdca4ff9700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:53 [0x7fdca67fc700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51538] (1 live)
Mar 31, 2013 15:31:53 [0x7fdca67fc700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:53 [0x7fdca67fc700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:53 [0x7fdca67fc700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:53 [0x7fdca67fc700] VERBOSE - Completed request: GET /system/library/sections: 200
Mar 31, 2013 15:31:53 [0x7fdca4ff9700] DEBUG - Request: GET /system/library/sections [127.0.0.1:51540] (1 live)
Mar 31, 2013 15:31:53 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/library/sections
Mar 31, 2013 15:31:53 [0x7fdca4ff9700] DEBUG - HTTP requesting to: http://127.0.0.1:37070/system/library/sections
Mar 31, 2013 15:31:53 [0x7fdca4ff9700] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.
Mar 31, 2013 15:31:53 [0x7fdca4ff9700] VERBOSE - Completed request: GET /system/library/sections: 200
 
 
any help is much appreciated!
 

btw: my library sections ARE shown in the web interface and the Plex App on my ipad. it's only the TV that's not picking up the sections.

Tagged:

Comments

Sign In or Register to comment.