Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Linux client

Hello all, new to the forums but have been using Plex for about 6 months and love it. 

 

I saw in another thread that there was a linux client floating around these here forums: 

 

http://forums.plexapp.com/index.php/topic/26908-any-eta-on-a-linux-client/

 

I have been unable to find it so I thought I'd see if it's true and where I might be able to get it.

 

I'm running Ubuntu 12.04 and would love to make it my total home theater soultion with a Plex client.

 

Thank you very much for any help, cheers.

Tagged:

Comments

  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
  • HankeyHankey Posts: 7Members

    Wow, that was fast, thanks. 

    I am getting this error:

    The following packages have unmet dependencies:
     plexhometheater : Depends: libcec (>= 1.7) but it is not installable
    E: Unable to correct problems, you have held broken packages.
     

    I installed libcec from Synaptic but it didn't help.  Any ideas how to fix this dependancy? 

    Thanks again. 

  • HankeyHankey Posts: 7Members
    edited May 2013

    I should include some background, eh..?

    I ran:

    sudo add-apt-repository ppa:plexapp/plexht

    sudo apt-get update

    sudo apt-get install plexhometheater

    Then got:

    sudo apt-get install plexhometheater
    Reading package lists... Done
    Building dependency tree 
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
    plexhometheater : Depends: libavcodec53 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed or
    libavcodec-extra-53 (>= 6:0.10.6) but it is not going to be installed
    Depends: libavfilter2 (>= 6:0.10.5~) but it is not going to be installed
    Depends: libavformat53 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libavutil51 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libpostproc52 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libswresample0 (>= 6:0.10.5~) but it is not installable
    Depends: libswscale2 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    Then:

    sudo add-apt-repository ppa:jon-severinsson/ffmpeg

    Updated, re-tired

    sudo apt-get install plexhometheater

    Tem got the lates error..

    Thanks for any help!

  • drzoidberg33drzoidberg33 Posts: 2,484Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Hankey wrote on May 25 2013, 10:59 AM: »

    I should include some background, eh..?

    I ran:

    sudo add-apt-repository ppa:plexapp/plexht

    sudo apt-get update

    sudo apt-get install plexhometheater

    Then got:

    sudo apt-get install plexhometheater
    Reading package lists... Done
    Building dependency tree 
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
    plexhometheater : Depends: libavcodec53 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed or
    libavcodec-extra-53 (>= 6:0.10.6) but it is not going to be installed
    Depends: libavfilter2 (>= 6:0.10.5~) but it is not going to be installed
    Depends: libavformat53 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libavutil51 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libpostproc52 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    Depends: libswresample0 (>= 6:0.10.5~) but it is not installable
    Depends: libswscale2 (>= 6:0.10.5~) but 4:0.8.4-0ubuntu0.12.04.1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    Then:

    sudo add-apt-repository ppa:jon-severinsson/ffmpeg

    Updated, re-tired

    sudo apt-get install plexhometheater

    Tem got the lates error..

    Thanks for any help!

    If you read through the other thread you will find the answers you're looking for: http://forums.plexapp.com/index.php/topic/57542-ubuntu-ppa/#entry360119

  • HankeyHankey Posts: 7Members
    edited May 2013

    Thank you drzoidberg33.  For some reason, after I added the 2 other repo's as you suggested, it stll gave me the same error.  I had to load the libcec package from Synaptic, and after that, it installed fine.  Thank you very much for the help.

    I've been using a mac mini for 6 months or so as my media center with Plex.  I just built a new computer this week and am very glad to have Plex HT running on it!  Excellent job folks.

  • drzoidberg33drzoidberg33 Posts: 2,484Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Hankey wrote on May 25 2013, 12:34 PM: »

    Thank you drzoidberg33.  For some reason, after I added the 2 other repo's as you suggested, it stll gave me the same error.  I had to load the libcec package from Synaptic, and after that, it installed fine.  Thank you very much for the help.

    I've been using a mac mini for 6 months or so as my media center with Plex.  I just built a new computer this week and am very glad to have Plex HT running on it!  Excellent job folks.

    I have been waiting for a Linux Plex client for a very long time and I'm now patiently waiting for the next release because all my music is in FLAC and these don't play at all on the current builds.

  • HankeyHankey Posts: 7Members

    I also have quite a bit of my music in FLACC and was wondering when support would be implemented.  Plex is getting better by the day. 

  • erikhensarlingerikhensarling Posts: 3Members ✭✭

    Didn't really want to start a new thread for this so I'll ask here. I went with Xubuntu 13.04 and I am seeing talk of ubuntu 13 not working with PlexHT just yet. Am I totally hozed and need to start over with the last LTS?

  • tetristetris Posts: 2Members

    Hi, I installed plexHT and the instalation went fine :

    ~$ sudo apt-get install plexhometheater
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      libshairport1 libva-glx1
    The following NEW packages will be installed:
      libshairport1 libva-glx1 plexhometheater
    0 upgraded, 3 newly installed, 0 to remove and 7 not upgraded.
    Need to get 32.0 MB of archives.
    After this operation, 58.1 MB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Get:1 http://ubuntu.linux-bg.org/ubuntu/ precise/universe libshairport1 amd64 1.2.1~git20120110.aeb4987-1 [25.8 kB]
    Get:2 http://ppa.launchpad.net/plexapp/plexht/ubuntu/ precise/main plexhometheater amd64 0.9.9.7-201303220806-ubuntu33~precise1 [31.9 MB]
    Get:3 http://ubuntu.linux-bg.org/ubuntu/ precise/main libva-glx1 amd64 1.0.15-4 [10.9 kB]
    Fetched 32.0 MB in 34s (938 kB/s)                                              
    Selecting previously unselected package libshairport1.
    (Reading database ... 423510 files and directories currently installed.)
    Unpacking libshairport1 (from .../libshairport1_1.2.1~git20120110.aeb4987-1_amd64.deb) ...
    Selecting previously unselected package libva-glx1.
    Unpacking libva-glx1 (from .../libva-glx1_1.0.15-4_amd64.deb) ...
    Selecting previously unselected package plexhometheater.
    Unpacking plexhometheater (from .../plexhometheater_0.9.9.7-201303220806-ubuntu33~precise1_amd64.deb) ...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Setting up libshairport1 (1.2.1~git20120110.aeb4987-1) ...
    Setting up libva-glx1 (1.0.15-4) ...
    Setting up plexhometheater (0.9.9.7-201303220806-ubuntu33~precise1) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
     
     

    until I tried to run it and I got this  :wacko:  :

    :~$ plexhometheater.sh
    ERROR: Unable to create GUI. Exiting
    Exiting Plex Media Server queue...
    Segmentation fault (core dumped)
    
     

    I google it, but I couldn't find anything about that, and I am not that good in linux as well. Please, if anyone have idea what is going on and how to fix that error. Thanks


    The system is 12.04 (precise) 64-bit, 3.2.0-45-generic, GNOME 3.4.2

  • arynhardarynhard Posts: 1Members, Plex Pass

    How do I get permission to access the link to the ubuntu app? I get permission denied when I click on the link.

    Trudge wrote on May 25 2013, 9:59 AM: »
  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,479Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    You need to purchase Plexpass during the beta phase: https://my.plexapp.com/subscription/about
    Or wait until it gets released to the public.
    Or compile it from source: https://github.com/plexinc/plex-home-theater-public

    /Mark
  • Plex_newbPlex_newb Posts: 1Members
    drzoidberg33 wrote on May 25 2013, 11:13 AM: »

    If you read through the other thread you will find the answers you're looking for: http://forums.plexapp.com/index.php/topic/57542-ubuntu-ppa/#entry360119

    Sorry to drag this up,but I've tried to access the linked thread, and get an error stating that I don't have permission to view the thread. I'm at the stage the previous poster was, but am obviously missing something in trying to install this...Can anyone assist?

    Thanks in advance.

  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,479Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Sorry to drag this up,but I've tried to access the linked thread, and get an error stating that I don't have permission to view the thread. I'm at the stage the previous poster was, but am obviously missing something in trying to install this...Can anyone assist?

    Thanks in advance.


    It's a Plexpass only thread. Until the Linux client + win/Mac get out of beta access to it is limited.

    -Mark


    - Mark
Sign In or Register to comment.