Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

OSX Server: Can't get Plex Connect to work

HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

ATV3

Firmware 5.2.1 (6025)

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

External Smartstor DS4600, Firewire

Plex Connect Templates from 6/1/2013 1.19 p.m.

 

When I run the script I get this:

 

 

hkmacs:PlexConnect-XML_templates admin$ sudo ./PlexConnect.py
PlexConnect : ***
PlexConnect : PlexConnect
PlexConnect : Press ENTER to shut down.
PlexConnect : ***
PlexConnect : IP_self: 10.0.1.8
PlexGDM : ***
PlexGDM : looking up Plex Media Server
PlexGDM : ***
PlexGDM : servers discovered: 1
DNSServer : Failed to create socket on UDP port 53: [Errno 48] Address already in use
PlexConnect : DNSServer not alive. Shutting down.
 
Can anyone help, please!

Best Answer

«13

Answers

  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
    HKMacs wrote on June 2 2013, 9:22 AM: »

    ATV3

    Firmware 5.2.1 (6025)

    10.0.1.8

    iMac Late 2011, Mountain Lion Server 10.8.3

    10.0.1.8

    iMac Late 2011, Mountain Lion Server 10.8.3

    10.0.1.8

    External Smartstor DS4600, Firewire

    Plex Connect Templates from 6/1/2013 1.19 p.m.

    When I run the script I get this:

    hkmacs:PlexConnect-XML_templates admin$ sudo ./PlexConnect.py
    PlexConnect : ***
    PlexConnect : PlexConnect
    PlexConnect : Press ENTER to shut down.
    PlexConnect : ***
    PlexConnect : IP_self: 10.0.1.8
    PlexGDM : ***
    PlexGDM : looking up Plex Media Server
    PlexGDM : ***
    PlexGDM : servers discovered: 1
    DNSServer : Failed to create socket on UDP port 53: [Errno 48] Address already in use
    PlexConnect : DNSServer not alive. Shutting down.
     
    Can anyone help, please!

    are you already running a DNS server on the box?

  • elanelan Sheriff of Plexville MauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    You've probably enabled the DNS server portion of Mountain Lion Server. Turn it off.

    2013-06-01 at 11.42.24 PM.png
  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    Will that effect the DNS of my network?

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    And the web server!

    Something is happening but I just get this message:

    Accessing Trailers.

    Then...

    Trailers is unavailable.

    This is my terminal output so far...

    Attached file.

    This is not going to work.

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    Sorry forgot to upload attachment

  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass

    You have set your PMS and DNS server to the same IP.

    Your DNS server should be something else.

  • baabaa Posts: 3,952Members, Plex Pass, Forum Moderator Forum Mod

    >> Your DNS server should be something else.

    "something else": like the google DNSServer (8.8.8.8), the one of your ISP or the one in your router...

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    If I do that Mac OS X Server won't work and my domain name won't resolve and I lose all connection to the internet.

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    Has anyone got a fully-configured Mac OS X Server and Plex Connect to work together?

    If so, how?

  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass
    Have you tried putting a host files entry for trailers.apple.com (pointing towards your server local IP) in your server's host file?
  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    That sounds like good idea but I'm not quite sure how to put in the correct syntax. I have Gasmask installed.

    Would I add something like this:

    10.0.1.8 trailers.apple.com

    ?

  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass

    Yeah try that and then flush the DNS cache on your Mac (you may want to reboot the ATV as well to make sure).

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    Tried entering both:

    10.0.1.8 trailers.apple.com

    and

    10.0.1.8:32400 trailers.apple.com

    Neither worked as I still seem to have the DNS in use by OS X DNS Server.

  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass
    edited June 2013

    DNS servers have nothing to do with ports, they only resolve host names to IP addresses.

    You must have to add the entry in your OSX DNS server then, i do not know how to do this as i have never used it on OSX.

    EDIT: If you look at the picture Elan posted it looks as if you can add an entry there.

  • croaker_1croaker_1 Posts: 4Members, Plex Pass Plex Pass

    I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

    1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

    2. Turn of the Websites service

    3. Kill all httpd processes (in Terminal or Activity Monitor)

    4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

    I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

    Good luck!

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass

    I think for simplicity I'm best with my original solution which is to start Airplay then start Plex Home Theatre/Plex. The only problem with it is that I can't use the Apple Remote as it controls the Apple TV rather than Plex Home Theatre and consequently kills Airplay. So I use the bluetooth keyboard for the iMac instead as a controller. Fine for me in a room that has the TV and the iMac in close proximity (Hong Kong!!)  but not much of a solution for someone in a house or large apartment where they might be in separate rooms. I prefer to use Plex Home Theatre over the iPad or iPhone apps as I like to see the synopsis on pause.

  • HKMacsHKMacs Posts: 189Members, Plex Pass Plex Pass
    croaker_1 wrote on June 3 2013, 3:45 PM: »

    I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

    1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

    2. Turn of the Websites service

    3. Kill all httpd processes (in Terminal or Activity Monitor)

    4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

    I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

    Good luck!

    Please let me know if you have any success. Good luck!

  • chrisallenchrisallen New ZealandPosts: 472Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    croaker_1 wrote on June 3 2013, 3:45 PM: »

    I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

    1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

    2. Turn of the Websites service

    3. Kill all httpd processes (in Terminal or Activity Monitor)

    4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

    I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

    Good luck!

    See my post here if you wish to disable the httpd service from being loaded by launchd.

    http://forums.plexapp.com/index.php/topic/70073-error-48-port-80/#entry404999

  • elstreifelstreif Posts: 502Members ✭✭
    Same problem here. PlexConnect doesn't work because I'm running OS X Server (10.6.8).

    :(
  • f00b4rf00b4r Posts: 2,914Members, Plex Pass Plex Pass
    edited June 2013
    elstreif wrote on June 5 2013, 7:42 AM: »

    Same problem here. PlexConnect doesn't work because I'm running OS X Server (10.6.8).

    :(

    OSX server is not officially supported yet (mainly because none of us run it to test with) but the answers to your problem appear to be above:

    • You must either disable the web server, using WingmanNZ's instructions in the post above you, or change the port it uses to e.g. 8080
    • Add an additional primary DNS zone on your OSX Server named "trailers.apple.com" and a new host entry "trailers.apple.com" in the new "trailers" zone pointing at the IP address of your PMS

    EDITED: to include Longariva's additional information in post 23. 

«13
This discussion has been closed.