Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PlexConnect on synology

13468982

Answers

  • bjorn72bjorn72 Members Posts: 11

    Below, I have put the modified vhosts.conf.

    Photostation is accessible with https.

    So, I believe it should have something to do with setting the virtualhosts of the plexconnect to port 80....


    NameVirtualHost *:80

    LoadModule proxy_module modules/mod_proxy.so
    LoadModule proxy_http_module modules/mod_proxy_http.so

    <VirtualHost *:80>
            ProxyPreserveHost On
            ProxyPass / http://127.0.0.1:5000/
            ProxyPassReverse / http://127.0.0.1:5000/
    </VirtualHost>

    <VirtualHost *:80>
            ServerName trailers.apple.com
            ProxyPreserveHost On
            ProxyPass / http://127.0.0.1:81/
            ProxyPassReverse / http://127.0.0.1:81/
    </VirtualHost>
     

  • bjorn72bjorn72 Members Posts: 11
    Hmmm...found out that phpmyadmin is also not working anymore, neither is piwik.
    Bottomline, to me it seems that everything that uses port 80 will not work anymore after installing plexconnect.

    Therefore, I added an extra port 82 in DSM "webservices" tab http-service.
    Also, I changed port 80 in "Virtual host" tab "web-application" to 82 and added port 82 in my router.
    I am able to access photostation and other stuff now.

    But, I always have to add the portnumber after the ipaddress in the URL. Visitors of my site do have to do this as well.
    Is there any possibility to have plexconnect work with port 82 or somewhat and switching back to port 80 for photostation etc.?
  • bwynantsbwynants Members, Plex Pass Posts: 429 Plex Pass
    bjorn72 wrote on July 8 2013, 12:09 PM: »

    Therefore, I added an extra port 82 in DSM "webservices" tab http-service.
    Also, I changed port 80 in "Virtual host" tab "web-application" to 82 and added port 82 in my router.
    I am able to access photostation and other stuff now.

    reset you changes and try to add

    ServerName yourhostname

    to the first VirtualHost config in httpd-vhosts.conf

    would that work? 

  • bjorn72bjorn72 Members Posts: 11

    Okay, I will try later today...in the meanwhile can you confirm that:

    1.) plexconnect added the 2nd ServerName trailers.apple.com

         to the default httpd-vhosts.conf

    2.) hostname is my domain name (www.<mydomain.com>)?

    So it would look like:

    <VirtualHost *:80>
            ServerName www.<mydomain.com>

            ProxyPreserveHost On
            ProxyPass / http://127.0.0.1:5000/
            ProxyPassReverse / http://127.0.0.1:5000/
    </VirtualHost>

    3.) What does the file do anyway? the DSM via web is available on port 5000.

    Photostation uses port 80 by default, what is the link?

  • bwynantsbwynants Members, Plex Pass Posts: 429 Plex Pass
    edited July 2013
    bjorn72 wrote on July 8 2013, 2:09 PM: »

    1.) plexconnect added the 2nd ServerName trailers.apple.com

         to the default httpd-vhosts.conf

    2.) hostname is my domain name (www.<mydomain.com>)?

    3.) What does the file do anyway? the DSM via web is available on port 5000.

    Photostation uses port 80 by default, what is the link?

    1) yes

    2) yes if www.yourdomain.com is what you type in the browser

    3) allow to run trailers.apple.com on port 80 on top of the default services

  • gernot8783gernot8783 Members, Plex Pass Posts: 9 Plex Pass
    edited July 2013
    bwynants wrote on July 3 2013, 11:02 AM: »

    as mentioned
    as mentioned in the first post: based on v0.1 release of PlexConnect

    the bugfix is not in that version, instructions for installing a more recent version yourself are in the thread...

    editing settings:
    log on as root (ssh) and type
    vi /usr/local/plexconnect/share/PlexConnect/Settings.cfg

    Thank you,
     

    I have meanwhile tried everything suggested in this thread, adjusted the settings.cfg in any possible way, I have updated with the latest github but direct play still doesn't work. I am lost. Everything works with transcoding but my Synology cant stand transcoding so I need a way to make direct play work. I hope someone can shed some light into the dark.

    I have the following setup:

    ATV3 on 5.3 (6105)

    IP: 192.168.1.23

    DNS server 192.168.1.1 stated by ATV and à ISP DNS servers

    DNS-Server

    195.202.138.3

    195.202.128.3

    62.40.128.2

    according to my Netgear 3800 router

    PMS and PlexConnect are on a Synology 1511+ on FW DSM 4.2-3211

    192.168.1.19

    PMS version: 0.9.7.22.511-4b5280f  0.9.7.28.33

    PlexConnect 0.1-1 pulled from github yesterday

    settings.cfg:

    [PlexConnect]

    port_pms = 32400

    enable_plexgdm = False   

    ip_dnsmaster = 192.168.1.19

    ip_webserver = 0.0.0.0

    loglevel = Normal

    enable_dnsserver = True

    ip_pms = 192.168.1.19

    port_webserver = 81

    below the log

    pastebin:

    http://pastebin.com/xuJhig5p

    EDIT July 13th


    solved

    latest build seems to have fixed the transcoding overload - CPU now on 25% when playing 1080p DTS movies

    https://www.dropbox....oarch_0.1-3.spk

    update with latest Github brings the nice structure - perfect

    Thank you Plex!

    Thank you for looking into this.
    Gernot

  • AbmaonlineAbmaonline Members, Plex Pass Posts: 48 Plex Pass

    Don't know if it fixes your problem, but latest public version of the PMS is 0.9.7.28.33: http://www.plexapp.com/getplex/

  • bjorn72bjorn72 Members Posts: 11
    bwynants wrote on July 8 2013, 5:27 PM: »

    1) yes
    2) yes if www.yourdomain.com is what you type in the browser
    3) allow to run trailers.apple.com on port 80 on top of the default services


    Okay, I have changed the conf, rolled back the changes I made and restarted webstation and connected services (like wordpress, phpmyadmin, piwik). Nothing changed, that is When I enter my domainname I am forwarded to the webmanager login of the diskstation instead my domain.

    I still have the file index.php in the folder "web". That worked before the installation of plexconnect.
    When I enter http://www.<mydomain.com>/wordpress/ in my browser I get an error message from my Diskstation saying in Dutch "Sorry, de pagina die u zoekt kan niet weergegeven worden."
    Content of index.php is:
    <?php
    header('Location: http://www.<mydomain.com>/wordpress/');
    exit;
    ?>
  • gernot8783gernot8783 Members, Plex Pass Posts: 9 Plex Pass
    Abmaonline wrote on July 8 2013, 9:26 PM: »

    Don't know if it fixes your problem, but latest public version of the PMS is 0.9.7.28.33: http://www.plexapp.com/getplex/

    Hi, was not aware that it would take months until Synology pushs updates... I have manually updated PMS but no change :-(

  • defectadefecta Members, Plex Pass Posts: 15 Plex Pass

    Hey folks,

    Just dropping by to say thanks. This worked perfectly for me on my DS1512+.

    Followed your instructions and it worked first time. It did take a little while for it to get all the thumbnailing and menus rendered and working as intended but it was just a matter of being patient.

    Watching a movie on it now. 

    Thanks for your efforts. Great work. Heres hoping Apple doesn't plug this hole anytime soon.

    Cheers.

  • bwynantsbwynants Members, Plex Pass Posts: 429 Plex Pass
    edited July 2013
    bjorn72 wrote on July 8 2013, 9:57 PM: »

    bjorn72, on 08 Jul 2013 - 23:55, said:
    Okay, I have changed the conf, rolled back the changes I made and restarted webstation and connected services (like wordpress, phpmyadmin, piwik). Nothing changed, that is When I enter my domainname I am forwarded to the webmanager login of the diskstation instead my domain.

    I still have the file index.php in the folder "web". That worked before the installation of plexconnect.
    When I enter http://www.&lt;mydomain.com&gt;/wordpress/ in my browser I get an error message from my Diskstation saying in Dutch "Sorry, de pagina die u zoekt kan niet weergegeven worden."
    Content of index.php is:
    &lt;?php
    header('Location: http://www.&lt;mydomain.com&gt;/wordpress/');
    exit;
    ?&gt;

    any clue what port the website is running at? in stead of modifying that entry you could opt to duplicate it (remove the server alias in the first) and adjust the port in the second.
    Name

    VirtualHost *:80
    
    LoadModule proxy_module modules/mod_proxy.so
    LoadModule proxy_http_module modules/mod_proxy_http.so
    
    <VirtualHost *:80>
            ProxyPreserveHost On
            ProxyPass / http://127.0.0.1:5000/
            ProxyPassReverse / http://127.0.0.1:5000/
    </VirtualHost>
    
    <VirtualHost *:80>
            ServerName www.<mydomain.com>
            ProxyPreserveHost On
            ProxyPass / http://127.0.0.1:<websiteport>/
            ProxyPassReverse / http://127.0.0.1:<websiteport>/
    </VirtualHost>
    
    <VirtualHost *:80>
           ServerName trailers.apple.com
           ProxyPreserveHost On
           ProxyPass / http://127.0.0.1:81/
           ProxyPassReverse / http://127.0.0.1:81/
    </VirtualHost>  
     
  • bjorn72bjorn72 Members Posts: 11
    edited July 2013
    Didn't work. Homepage is also on port 80.
    It seems that your plexconnect interferes with the default port 80 of any other application.
    So, you will have to change the port of the default application to anyother than 80 and have plexconnect use port 80.
    I don't like that idea, as the links in the DSM package center of the diskstation come with the default port.

    Any other suggestion, e.g. Change the port plexConnect uses?
  • gerloopmansgerloopmans Members Posts: 3 ✭✭

    I can't get it to work...

    The log says that it is running and I see there are DNS request coming from the trailers.apple.com and he forwards it to the correct ip which is the synology NAS where the PMS server is installed

    but the apple tv keeps saying that the trailers are unavailable...

    does anyone have an idea why?

  • jsantosrjsantosr Members Posts: 5 ✭✭

    Hi, I'm working without problems with PMS and Plex Connect on my ATV3.

    I have problems with the Synology Hibernation functionality.

    When the Plex Connect is up, my Synology doesn't hibernate, if I stop the Application Plex Connect then yes, my Synology do it.

    I was reviewing the file PlexConnect.log and I can read that every 2 or  3 minutes a DNSServer line is writed, like next:

    21:14:47 DNSServer: ***forward request
    21:14:47 DNSServer: -> DNS response from higher level
    21:16:14 DNSServer: DNS request received!
    21:16:14 DNSServer: Source: ('192.168.0.72', 52865)
    21:16:14 DNSServer: Domain: 43-courier.push.apple.com
    21:16:14 DNSServer: ***forward request
    21:16:14 DNSServer: -> DNS response from higher level
    21:16:18 DNSServer: DNS request received!
    21:16:18 DNSServer: Source: ('192.168.0.72', 50296)
    21:16:18 DNSServer: Domain: itunes.apple.com
    21:16:18 DNSServer: ***forward request
    21:16:18 DNSServer: -> DNS response from higher level
    21:17:41 DNSServer: DNS request received!
    21:17:41 DNSServer: Source: ('192.168.0.72', 53533)
    21:17:41 DNSServer: Domain: 31-courier.push.apple.com
    21:17:41 DNSServer: ***forward request
    21:17:41 DNSServer: -> DNS response from higher level
    21:17:45 DNSServer: DNS request received!
    21:17:45 DNSServer: Source: ('192.168.0.72', 54943)
     
    The IP 192.168.0.72, is my ATV3 device.
     
    Anyone have same problem?
    How can I control it? I was reviewing the ATV3 configuration and I don't find where put it in shutdown status, and not on sleeping status?
    How can I decrease the log level? I try to set loglevel = Low, and same problem, my Synology device doens't hibernate.
     
    Many thanks for your help
  • institute11institute11 Members Posts: 1,454 ✭✭✭
    edited July 2013
    Maybe put your ATV to sleep? And set it to sleep after 30 minutes or so.
  • jaydenaphillipsjaydenaphillips Members Posts: 8

    For those having issues saying port 53 can't be bound check to make sure you aren't using the synology DHCP on any interface. I found that with that running port 53 was in use.

  • jsantosrjsantosr Members Posts: 5 ✭✭
    institute11, thanks for your quickly replay.
    the ATV is set to sleep afther 15', and all this networks traffic is done with the ATV in sleep mode.
    I don't know how set ATV in shutdown mode.
    There must be a way to hibernate Synology, can be setting PlexConnect without ask the DNSServer request from ATV.
  • rjblakerjblake Members, Plex Pass Posts: 156 Plex Pass
    Abmaonline wrote on July 7 2013, 2:37 PM: »

    Could you check if there is a /usr/syno/apache/conf/extra/httpd-vhosts.conf.bak and if so, post the contents here?

    I installed the package without making any changes to Apache, etc. - just installed Python, the PlexConnect. Killed off my PhotoStation and any other app using Port:80. I uninstalled but it still does not fix the problem. Guess it made some changes to some config files somewhere. I have no .bak file. Anybody know what changes were made and how I can back them out or fix my system?

  • bjorn72bjorn72 Members Posts: 11
    rjblake wrote on July 9 2013, 8:53 PM: »

    I installed the package without making any changes to Apache, etc. - just installed Python, the PlexConnect. Killed off my PhotoStation and any other app using Port:80. I uninstalled but it still does not fix the problem. Guess it made some changes to some config files somewhere. I have no .bak file. Anybody know what changes were made and how I can back them out or fix my system?


    Ahh...and I thought I was the only one....all suggestions made here to revert back to the original state do not work for me ( changes in the httpd-vhosts.conf)
  • AbmaonlineAbmaonline Members, Plex Pass Posts: 48 Plex Pass
    edited July 2013
    rjblake wrote on July 9 2013, 8:53 PM: »

    I installed the package without making any changes to Apache, etc. - just installed Python, the PlexConnect. Killed off my PhotoStation and any other app using Port:80. I uninstalled but it still does not fix the problem. Guess it made some changes to some config files somewhere. I have no .bak file. Anybody know what changes were made and how I can back them out or fix my system?

    What you can try:
    1) Move the plexconnect vhosts config to a new bak file:
    mv /usr/syno/apache/conf/extra/httpd-vhosts.conf /usr/syno/apache/conf/extra/httpd-vhosts.conf.bakplexconnect
     
    2) Restore the original vhosts:
    mv /usr/syno/apache/conf/extra/httpd-vhosts.conf.bak /usr/syno/apache/conf/extra/httpd-vhosts.conf
     
    3) Restart apache:
    /usr/syno/etc.defaults/rc.d/S97apache-user.sh restart
     
    If this doesn't fix things, you can try the following additional steps (disable vhosts all together):
    4) Edit /usr/syno/apache/conf/httpd.conf-user and look for the following lines:
    #Virtual hosts
    Include conf/extra/httpd-vhosts.conf
     
    5) Comment the second line with a #, so it looks like this
    #Virtual hosts
    #Include conf/extra/httpd-vhosts.conf
     
    6) Save and restart apache again
    /usr/syno/etc.defaults/rc.d/S97apache-user.sh restart
     
    This should bring you back in the original situation before plexconnect was installed (bwynants can confirm if this is still the case with the latest version).
     
    Edit: Did you guys make any special adjustments to photostation besides installing it? Maybe I will try to install it too, to see if I can reproduce this behavior.
13468982
Sign In or Register to comment.