Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server Not Seeing External Hard Drive

compascompas Posts: 6Members, Plex Pass

I am running Plex Media Server 0.9.8.1 on Ubuntu 12.04.  I have my movies on the local hard drive and tv shows on an external drive.  The MS sees the movies on the local drive just fine and they all show up in the library.  I am not able to see any of the tv shows on the external drive.  Any ideas on how to add these or why they may not be appearing?

Best Answer

  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,475Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Answer ✓
    compas wrote on July 1 2013, 4:46 AM: »

    sudo blkid gives:
    /dev/sdb1: LABEL="ioGear" UUID="7896A36E96A32C16" TYPE="ntfs"
     
    ls -lai /media:
    5 drwx


     1 colin colin 4096 Jun  9 13:56 ioGear
     
    So it does seem that the permissions aren't correct for this directory.  
     
    I don't see an entry for this drive in fstab.  Sorry for my lack of experience with this, but I'm not sure what this means " try in the mount options in fstab between defaults,auto and change it to defaults,permissions,auto".  
     
    It seems like this is the issue so any more guidance you can give is greatly appreciated.

    Create a directory in /media named externaldrive: sudo mkdir -p /media/externaldrive

    Create an entry in /etc/fstab that looks like this:
     
    UUID=7896A36E96A32C16 /media/externaldrive ntfs-3g defaults,permissions,auto 0 1

    Unmount your USB drive, then run from command: sudo mount /media/externaldrive

    Then you should be able to change permissions on you NTFS drive in /media/externaldrive, and also point plex to picking up media from that drive.

    /Mark

Answers

  • LLundbergLLundberg Posts: 53Members, Plex Pass Plex Pass

    Surely this has to be a permissions issue?

  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,475Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    compas wrote on June 27 2013, 4:20 AM: »

    I am running Plex Media Server 0.9.8.1 on Ubuntu 12.04.  I have my movies on the local hard drive and tv shows on an external drive.  The MS sees the movies on the local drive just fine and they all show up in the library.  I am not able to see any of the tv shows on the external drive.  Any ideas on how to add these or why they may not be appearing?

    Moar info please.

    • What filesystem is on the drive? (NTFS drive require special mount options)
    • Is the drive mounted under your user folder where the user plex that Plex Media Server runs as can't access it?
    • What is Plex Media Scanner.log telling you?

    /Mark

  • compascompas Posts: 6Members, Plex Pass

    It seems like it might be a permissions issue.  The drive is NTFS and I am able to read and write from it and it is mounted under /media.  I cannot change the permisions for group and others.  Could this be the problem?  How do I change those permissions if that is the issue?  Thanks for the help!

  • glougloumouthglougloumouth Posts: 30Members, Plex Pass

    Can you report a "sudo blkid", as well as "ls -lai /media" and "mount"?

     

    I look at my Linux Mint (Ubuntu based) box where my USB drive is and it gives:

     

    $ ls -lai /media
    total 20
    5242881 drwxr-xr-x  5 root     root     4096 jun  2 21:44 .
          2 drwxr-xr-x 24 root     root     4096 oct 25  2012 ..
          5 drwxrwxrwx  1 myuser   myuser   4096 jun  2 22:06 HPUSB2TBa
     
    My /etc/fstab for that drive (NTFS formatted):
    UUID=AE5CE52B5CE4EED1 /media/HPUSB2TBa ntfs-3g defaults,auto,umask=000,uid=1000,gid=1000 0 1
     
    I remember having permission issues with the drive and fixed it with proper  uid/gid mask to grant full right to "myuser" (with uid=1000, gid=1000). Check /etc/passwd to have the proper uid & gid for your user (although if you work with the account created by Linux installer, it will be 1000 & 1000).
     
    Let us know.
     
    Gl.
  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,475Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    glougloumouth wrote on June 29 2013, 2:01 PM: »

    Can you report a "sudo blkid", as well as "ls -lai /media" and "mount"?

    I look at my Linux Mint (Ubuntu based) box where my USB drive is and it gives:

    $ ls -lai /media
    total 20
    5242881 drwxr-xr-x 5 root root 4096 jun 2 21:44 .
    2 drwxr-xr-x 24 root root 4096 oct 25 2012 ..
    5 drwxrwxrwx 1 myuser myuser 4096 jun 2 22:06 HPUSB2TBa

    My /etc/fstab for that drive (NTFS formatted):
    UUID=AE5CE52B5CE4EED1 /media/HPUSB2TBa ntfs-3g defaults,auto,umask=000,uid=1000,gid=1000 0 1

    I remember having permission issues with the drive and fixed it with proper uid/gid mask to grant full right to "myuser" (with uid=1000, gid=1000). Check /etc/passwd to have the proper uid & gid for your user (although if you work with the account created by Linux installer, it will be 1000 & 1000).

    Let us know.

    Gl.


    For NTFS and using ntfs-3g, try in the mount options in fstab between defaults,auto and change it to defaults,permissions,auto and it should allow you to change permissions with chmod.

    /Mark
  • compascompas Posts: 6Members, Plex Pass

    sudo blkid gives:

    /dev/sdb1: LABEL="ioGear" UUID="7896A36E96A32C16" TYPE="ntfs"

    ls -lai /media:

    5 drwx


     1 colin colin 4096 Jun  9 13:56 ioGear

    So it does seem that the permissions aren't correct for this directory.  

    I don't see an entry for this drive in fstab.  Sorry for my lack of experience with this, but I'm not sure what this means " try in the mount options in fstab between defaults,auto and change it to defaults,permissions,auto".  

    It seems like this is the issue so any more guidance you can give is greatly appreciated.

  • ziggimonziggimon Plex Dev Team AarhusPosts: 2,475Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Answer ✓
    compas wrote on July 1 2013, 4:46 AM: »

    sudo blkid gives:
    /dev/sdb1: LABEL="ioGear" UUID="7896A36E96A32C16" TYPE="ntfs"
     
    ls -lai /media:
    5 drwx


     1 colin colin 4096 Jun  9 13:56 ioGear
     
    So it does seem that the permissions aren't correct for this directory.  
     
    I don't see an entry for this drive in fstab.  Sorry for my lack of experience with this, but I'm not sure what this means " try in the mount options in fstab between defaults,auto and change it to defaults,permissions,auto".  
     
    It seems like this is the issue so any more guidance you can give is greatly appreciated.

    Create a directory in /media named externaldrive: sudo mkdir -p /media/externaldrive

    Create an entry in /etc/fstab that looks like this:
     
    UUID=7896A36E96A32C16 /media/externaldrive ntfs-3g defaults,permissions,auto 0 1

    Unmount your USB drive, then run from command: sudo mount /media/externaldrive

    Then you should be able to change permissions on you NTFS drive in /media/externaldrive, and also point plex to picking up media from that drive.

    /Mark

  • compascompas Posts: 6Members, Plex Pass

    Thank you very much for the help! This solved the issue.

  • zunebuggyzunebuggy Posts: 6Members

    My problem is similar.  I already have my movies on my external 2TB hard drive.  I used NTFS Configuration Tool to mount it.  The problem is the hard drive is named FantonHD.  In the root I have a folder named Plex and under Plex I have folders named Movies, Home Movies, TV Shows, Photos and Music.

    If I click a section in Plex, say for example Music, and click Edit Music and Add Folder.  Then I click Browse folders, I see FantomHD.  I click that and there is no sub folders to select after that.

    I have browsed to Plex and then went back one level and did chmod -R xxx (tried many values) \Plex and no matter what I try Plex does not see my files.  In the folder location I manually typed /media/joe/FantomHD/Plex/Music and it does not see my files.  I know that is probably not right and the permissions are not right but I do not know what is right and how to fix it.

    Thank you.

  • guardianfxguardianfx Posts: 9Members, Plex Pass Plex Pass
    ziggimon wrote on July 1 2013, 9:03 AM: »

    Create a directory in /media named externaldrive: sudo mkdir -p /media/externaldrive

    Create an entry in /etc/fstab that looks like this:
     
    UUID=7896A36E96A32C16 /media/externaldrive ntfs-3g defaults,permissions,auto 0 1

    Unmount your USB drive, then run from command: sudo mount /media/externaldrive

    Then you should be able to change permissions on you NTFS drive in /media/externaldrive, and also point plex to picking up media from that drive.

    /Mark

    This fixed my issue as well. I am attempting to see how well Ubuntu would work for me and I had a media drive on Windows which housed my media and it was NTFS. Plex can now scan everything whereas before it couldn't.

    Given that I am brand spankin' new to linux, could you possibly explain exactly what is being done in each step? I can follow instructions well enough, but I would love to understand what I am typing in. Thanks!!!

  • izzojackalizzojackal Posts: 9Members, Plex Pass

    I am extremely new to linux as my microsoft took a dump. So I decided to give linux a try. I have no idea what it is you guys are talking about but I have the same issue.

    I have my media in an external hard drive (2TB) and in that hard drive are folders such as Movies, Pictures, and TV Shows. I can't get sub folders on plex as it just shows my external hard drive and nothing populates.. Please help as I don't know what I'm doing. Any help would be extremely helpful and then I can help others down the road. Maybe a step by step guide? I can't find any info on it anywhere else. I know about computers but my computer lingo is not to par with the rest of you and I'm afraid of messing something up as I have no money to replace anything. Thanks ahead of time

  • TrudgeTrudge Gone off to greener pastures.... Posts: 9,360Members ✭✭✭
    izzojackal wrote on October 15 2013, 3:51 PM: »

    I am extremely new to linux as my microsoft took a dump. So I decided to give linux a try. I have no idea what it is you guys are talking about but I have the same issue.

    I have my media in an external hard drive (2TB) and in that hard drive are folders such as Movies, Pictures, and TV Shows. I can't get sub folders on plex as it just shows my external hard drive and nothing populates.. Please help as I don't know what I'm doing. Any help would be extremely helpful and then I can help others down the road. Maybe a step by step guide? I can't find any info on it anywhere else. I know about computers but my computer lingo is not to par with the rest of you and I'm afraid of messing something up as I have no money to replace anything. Thanks ahead of time

    you've read the sticky at the top of the forum?

  • rpgmakerrpgmaker Posts: 2Members

    Hi guys, I was having the same problem and using this post on ubuntuforums I solved it: http://ubuntuforums.org/showthread.php?t=2087341&page=2&p=12747696#post12747696 mainly you just need to mount the the usb hdd to a directory under your home folder specifically editing the /etc/fstab file instead of relying on it being mounted automatically. It's kind of a hassle and sucks because I don't like having that directory mounted there but it is a solid workaround and it's way better this than to not be able to have my media on my external drive show up on plex.

    Step 1, look for the name of your drive under /dev using:

    sudo fdisk -l

    Step 2, open fstab file:

    sudo gedit /etc/fstab

    Step 3, add this line to the file, replacing the /dev path to the one you got on step 1, and replacing the home path to the one you want to use:

    /dev/sdc1 /home/user/videos/usb ntfs defaults 0 0

    Step 4, save the file, unmount your usb drive and mount it again and flex should be able to see it now.

    Step 5, If you still can't you might need to add the plex user to the plugdev group, I think this step is not needed (it was the first thing I tried and it didn't fix anything) using this:

    sudo gpasswd -a plex plugdev

  • izzojackalizzojackal Posts: 9Members, Plex Pass

    Every time I try the first line of sudo fdisk -l it asks for a password and I don't have a password on it...

  • alousyheroalousyhero Posts: 1Members

    I didn't want to start a new thread. I tried everything in this thread and it didn't work. Here's some info if anyone can help.

    david@david-GA-A75M-UD2H:~$ sudo blkid
    [sudo] password for david:
    /dev/sda1: UUID="07525c7d-e2c7-4520-be1f-ddfe923f90d9" TYPE="ext4"
    /dev/sda5: UUID="0a1bae8e-98bf-48c4-8021-1bbf95081619" TYPE="swap"
    /dev/sdc1: LABEL="MY BOOK" UUID="f46ec49d-3d38-4921-88a5-fdb05236c642" TYPE="ext4"
    david@david-GA-A75M-UD2H:~$ ls -lai /media
    total 16
    13107201 drwxr-xr-x   4 root root 4096 Jan  6 08:30 .
           2 drwxr-xr-x  23 root root 4096 Jan  5 22:30 ..
    13107202 drwxr-x---+  4 root root 4096 Jan  6 08:43 david
    13107204 drwxr-xr-x   2 root root 4096 Jan  6 08:30 externaldrive
    david@david-GA-A75M-UD2H:~$ sudo gpasswd -a plex plugdev
    Adding user plex to group plugdev
    david@david-GA-A75M-UD2H:~$

    I'm at a complete loss on what to do to get it to work.
     

  • Daniel.PasutDaniel.Pasut Posts: 1Members ✭✭
    Mark Walker wrote on July 1 2013, 9:03 AM: »

    Create a directory in /media named externaldrive: sudo mkdir -p /media/externaldrive

    Create an entry in /etc/fstab that looks like this:
     
    UUID=7896A36E96A32C16 /media/externaldrive ntfs-3g defaults,permissions,auto 0 1

    Unmount your USB drive, then run from command: sudo mount /media/externaldrive

    Then you should be able to change permissions on you NTFS drive in /media/externaldrive, and also point plex to picking up media from that drive.

    /Mark

     Thanks a lot Mark, worked perfectly for me!

Sign In or Register to comment.