If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Windows specific instructions for creating and installing the SSL cert

2456789

Answers

  • sgtblun7sgtblun7 Posts: 18Members

    worked great ;)

    thanks for the perfect documentation!

  • Hasten007Hasten007 Posts: 11Members

    Hi, i've done everything  you mentionned and I have a little problem   My ATV3 connects goods, but when I select a movie it says trailers unavailable, but it load my whole list of movies  whats wrong ?

  • Hasten007Hasten007 Posts: 11Members
    edited September 2013

    11:54:36 PlexConnect: started: 11:54:36
    11:54:36 PlexConnect: IP_self: 192.168.1.139
    11:54:36 DNSServer: started: 11:54:36
    11:54:36 DNSServer: ***
    11:54:36 DNSServer: Starting up.
    11:54:36 DNSServer: intercept: => 192.168.1.139
    11:54:36 DNSServer: restrain: => 127.0.0.1
    11:54:37 DNSServer: forward other to higher level DNS: 205.151.67.34
    11:54:37 DNSServer: ***
    11:54:37 WebServer: started: 11:54:37
    11:54:37 WebServer: ***
    11:54:37 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
    11:54:37 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
    11:54:37 WebServer: ***
    11:54:37 PlexGDM: ***
    11:54:37 PlexGDM: looking up Plex Media Server
    11:54:37 PlexGDM: ***
    11:54:38 PlexGDM: servers discovered: 1
    11:54:38 XMLConverter: PlexGDM - PMS: 192.168.1.139:32400
    11:55:10 DNSServer: DNS request received!
    11:55:10 DNSServer: Source: ('192.168.1.121', 49246)
    11:55:10 DNSServer: Domain: p48-buy.itunes.apple.com.akadns.net
    11:55:10 DNSServer: ***forward request
    11:55:10 DNSServer: -> DNS response from higher level
    11:55:12 DNSServer: DNS request received!
    11:55:12 DNSServer: Source: ('192.168.1.121', 62498)
    11:55:12 DNSServer: Domain: itunes.apple.com
    11:55:12 DNSServer: ***forward request
    11:55:12 DNSServer: -> DNS response from higher level
    11:55:12 DNSServer: DNS request received!
    11:55:12 DNSServer: Source: ('192.168.1.121', 58878)
    11:55:12 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
    11:55:12 DNSServer: ***forward request
    11:55:12 DNSServer: -> DNS response from higher level
    11:55:13 DNSServer: DNS request received!
    11:55:13 DNSServer: Source: ('192.168.1.121', 53515)
    11:55:13 DNSServer: Domain: trailers.apple.com
    11:55:13 DNSServer: ***intercept request
    11:55:13 DNSServer: -> DNS response: 192.168.1.139
    11:55:14 WebServer: serving application.js
    11:55:15 DNSServer: DNS request received!
    11:55:15 DNSServer: Source: ('192.168.1.121', 51241)
    11:55:15 DNSServer: Domain: atv.plexconnect
    11:55:15 DNSServer: ***intercept request
    11:55:15 DNSServer: -> DNS response: 192.168.1.139
    11:55:15 WebServer: serving .xml: /PlexConnect.xml
    11:55:15 ATVSettings: add section 007
    11:55:16 WebServer: serving  C:\Documents and Settings\Jimmy\Bureau\PlexConnect-XML_templates\assets\js\utils.js
    11:55:16 ATVLogger: loadItem: Library
    11:55:16 WebServer: serving .xml: /library/sections
     

  • Ian_EIan_E Posts: 5Members

    Hi, just got an Apple TV in the post today, trying to get this running without any luck.. the ATV is version 5.3

    a couple of quick questions after waiting for the light to go solid on the ATV, I install the fresh cert, do I need the ATV connected to a TV at this point ?

    the reason I ask, when I re connect the ATV to my telly, and open trailers, it just opens as normal, (aka just bog standard apple trailers.) I'm not getting unavailable at this time etc as some other are or the plex..

    20:37:58 PlexConnect: ***
    20:37:58 PlexConnect: PlexConnect
    20:37:58 PlexConnect: Press CTRL-C to shut down.
    20:37:58 PlexConnect: ***
    20:37:58 PlexConnect: started: 20:37:58
    20:37:58 PlexConnect: IP_self: 192.168.0.6
    20:37:59 DNSServer: started: 20:37:59
    20:37:59 DNSServer: ***
    20:37:59 DNSServer: DNSServer: Serving DNS on port 53.
    20:37:59 DNSServer: intercept: => 192.
    168.0.6
    20:37:59 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld
    .apple.com.edgesuite.net'] => 127.0.0.1
    20:37:59 DNSServer: forward other to higher level DNS: 8.8.8.8
    20:37:59 DNSServer: ***
    20:37:59 WebServer: started: 20:37:59
    20:37:59 WebServer: ***
    20:37:59 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
    20:37:59 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
    20:37:59 WebServer: ***
    20:37:59 PlexGDM: ***
    20:37:59 PlexGDM: looking up Plex Media Server
    20:37:59 PlexGDM: ***
    20:38:00 PlexGDM: servers discovered: 1
    20:38:00 XMLConverter: PlexGDM - PMS: 192.168.0.6:32400

    which looks ok ?

    DNS on ATV is the same as my router 192.168.0.1 - my pc ip is 192.168.0.6 posts 80 and 443 are open in my firewall

    I can see on the ATV that the profile is installed in profiles

    Any ideas ? I would love to get this working on my new ATV as I use plex on my ipad and it's great but it would be super nice to have some 5.1 sound

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    You need to set the DNS on the ATV to be the ip of your PC, that way plexconnect will act as DNS and process trailers.apple.com requests while forwarding others.
  • institute11institute11 Posts: 1,454Members ✭✭✭
    Please do not double post in the forum, you end wasting someone's time and spread the help too thin.
  • jmoportugaljmoportugal Posts: 1Members
    Thanks for the tuto, the only problm now are the subs, subs dont always work, dont know why, strange.


    Sent from my iPhone using Tapatalk
  • Ian_EIan_E Posts: 5Members

    That got it thanks

  • LexyLexy Posts: 36Members, Plex Pass Plex Pass

    Thank you for doing this 2600Sam! Last week I had trouble making the instructions at langui.sh work for me, so I gave up until today. However, your instructions helped me get PlexConnect back up and running again.

    As a side note, I did follow the langui.sh instructions exactly, but the difference for me this time was upgrading to the latest versions of PMS and PlexConnect as well as NOT using the light version of Win32 OpenSSL. I don't know if others have been successful using the light version, but perhaps that is what was tripping me up?

    Anyway, thank you again!

  • itzvaibhavitzvaibhav Posts: 11Members ✭✭

    I performed the complete process again but no luck. I get trailers unavailable.

    08:41:51 PlexConnect: ***
    08:41:51 PlexConnect: PlexConnect
    08:41:51 PlexConnect: Press CTRL-C to shut down.
    08:41:51 PlexConnect: ***
    08:41:51 PlexConnect: started: 08:41:51
    08:41:51 PlexConnect: IP_self: 192.168.1.2
    08:41:51 DNSServer: started: 08:41:51
    08:41:51 DNSServer: ***
    08:41:51 DNSServer: DNSServer: Serving DNS on port 53.
    08:41:51 DNSServer: intercept: => 192.
    168.1.2
    08:41:51 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld
    .apple.com.edgesuite.net'] => 127.0.0.1
    08:41:51 DNSServer: forward other to higher level DNS: 8.8.8.8
    08:41:51 DNSServer: ***
    08:41:52 WebServer: started: 08:41:52
    08:41:52 WebServer: ***
    08:41:52 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
    08:41:52 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
    08:41:52 WebServer: ***
    08:41:52 PlexGDM: ***
    08:41:52 PlexGDM: looking up Plex Media Server
    08:41:52 PlexGDM: ***
    08:41:53 PlexGDM: servers discovered: 1
    08:41:53 XMLConverter: PlexGDM - PMS: 192.168.1.2:32400
    08:42:04 DNSServer: DNS request received!
    08:42:04 DNSServer: Source: ('192.168.1.102', 51772)
    08:42:04 DNSServer: Domain: p40-buy.itunes.apple.com.akadns.net
    08:42:04 DNSServer: ***forward request
    08:42:04 DNSServer: -> DNS response from higher level
    08:42:04 DNSServer: DNS request received!
    08:42:04 DNSServer: Source: ('192.168.1.102', 61453)
    08:42:04 DNSServer: Domain: p40-buy.itunes.apple.com.akadns.net
    08:42:04 DNSServer: ***forward request
    08:42:04 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 62611)
    08:42:08 DNSServer: Domain: itunes-cdn.apple.com.akadns.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 61333)
    08:42:08 DNSServer: Domain: itunes-cdn.apple.com.akadns.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 52634)
    08:42:08 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 59617)
    08:42:08 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 65141)
    08:42:08 DNSServer: Domain: e673.g.akamaiedge.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 64636)
    08:42:08 DNSServer: Domain: a771.da1.akamai.net
    08:42:08 DNSServer: ***forward request
    08:42:08 DNSServer: -> DNS response from higher level
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 57343)
    08:42:08 DNSServer: Domain: trailers.apple.com
    08:42:08 DNSServer: ***intercept request
    08:42:08 DNSServer: -> DNS response: 192.168.1.2
    08:42:08 DNSServer: DNS request received!
    08:42:08 DNSServer: Source: ('192.168.1.102', 62388)
    08:42:08 DNSServer: Domain: trailers.apple.com
    08:42:08 DNSServer: ***intercept request
    08:42:08 DNSServer: -> DNS response: 192.168.1.2
     
     
    The settings file has
     

    [PlexConnect]

    logpath = .

    enable_dnsserver = True

    ip_webserver = 0.0.0.0

    prevent_atv_update = True

    port_dnsserver = 53

    enable_plexconnect_autodetect = True

    port_pms = 32400

    port_webserver = 80

    ip_plexconnect = 0.0.0.0

    certfile = c:\plexconnect\assets\certificates\trailers.pem

    ip_dnsmaster = 8.8.8.8

    loglevel = Normal

    ip_pms = 192.168.178.10

    enable_plexgdm = True

    port_ssl = 443

    What is that missing here.??

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    edited September 2013

    If you browse to https://192.168.1.2:443 what do you get?

    You should get a Certificate error (Unless you actually imported the certificate onto your PC).

    If you do get the certificate error then PlexConnect can find your trailers.pem file, so you then need to try removing all certificates/profiles you create on the ATV and install the trailers.cer file again. 

    Oh and Make sure you are using openSSL 32 bit not 64bit as lots of issues have been reported due to the use of the 64bit version.

  • TEATOWLTEATOWL Posts: 21Members, Plex Pass Plex Pass

    I've been struggling with this fix since the update. I simply changed the file extension on the certificate from .der to .cer and all is now working...hope this helps someone. Thanks guys for the great work  :)

  • KentasticKentastic Posts: 1Members, Plex Pass Plex Pass
    Just wanted to post this thank you to 2600Sam for the precise instructions. I followed them and with only one "do over" (I forgot to enter something in the Identifier field and couldn't figure out why the cert wouldn't install to the ATV) got everything working on my windows 7 32-bit mini-pc. I've been trying for days on my Mac and just couldn't get it working. (Which is ironic because the instructions are simpler for a Mac install.)

    Thanks,
    Ken
  • riche543riche543 Posts: 78Members
    Great ken glad its working for you. I did exactly the same thing in identifier field , & couldn't work out why the cert wouldn't install to the atv. Took me hrs too work it out.
    Lol


    Riche


    Sent from my iPhone using Tapatalk 2
  • Neo121183Neo121183 Posts: 1Members

    I'm having issues installing the profile to my ATV3.

    When I press install nothing happens.

    Console says something like this:

    Payload identifier missing code 1002

    Thnx

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    Neo,

    The two posts directly before you talk about having to add something into the identifier code.

    I think you will find this is a field when you Create the profile in the iPhone tool.
  • maraxionmaraxion Posts: 21Members ✭✭
    edited September 2013

    Seems there are lacking something in the guide?

    "press and the shift key and RIGHT click on the screen you should see"

    Press what and the shift key? Iv tried only the shift key and right mouse button but that doessent do anything in my windows xp.

  • 2600Sam2600Sam Posts: 12Members
    edited September 2013
    maraxion wrote on September 7 2013, 6:48 PM: »

    Seems there are lacking something in the guide?

    "press and the shift key and RIGHT click on the screen you should see"

    Press what and the shift key? Iv tried only the shift key and right mouse button but that doessent do anything in my windows xp.

    i believe this is a Windows 7 and higher menu option

    for below windows 7 users you will have to open a command prompt and change directory to where ever you created your "Cert" directory

    HTH

    I also edited the original post and remove the word <and> after <press>, sorry about that!

  • maraxionmaraxion Posts: 21Members ✭✭
    edited September 2013

    I see, thanks for the clarify.

    Used cmd.exe and ran the bat. It then created the folowing files in the root of my C drive, not my cert folder offcource:

    Trailers.key

    trailers.pem

    trailers.der

    .rnd

    Had to manualy run trailers.der to install cert.

    Other than that it worked great on windows XP, and now plex server works great again :)

  • Mr.MuyaMr.Muya Posts: 11Members ✭✭

    Funny thing is I had no luck on my new win 8 64 bit notebook. But when i dusted off my old win 7 32 bit notebook it worked on my first try. :D Thank You 2600Sam.

Sign In or Register to comment.