If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Windows specific instructions for creating and installing the SSL cert

1234689

Answers

  • mylesismemylesisme Posts: 1Members

    Thank you very much, friend.

  • my plex is now working again. Not sure exactly what it was that fixed it. I downgraded firmware from 6.0 to 5.3 as there was supposedly problems also followed instruction for certificate from here: http://forums.plexapp.com/index.php/topic/79540-windows-specific-instructions-for-creating-and-installing-the-ssl-cert/ instead of original.I think there was issues with my certificate so followed these instruction precisely  Happy its finally working again thanks for everyone help :)

  • alexeliassonalexeliasson Posts: 22Members ✭✭

    I don't have any micro-usb cable, does that mean that I can't install plexconnect correctly? Is this Certficate/ssl thing essential since the latest ATV update? 

    I've never tried PlexConnect, not any version. 

  • 2600Sam2600Sam Posts: 12Members
    alexeliasson wrote on September 28 2013, 11:24 AM: »

    I don't have any micro-usb cable, does that mean that I can't install plexconnect correctly? Is this Certficate/ssl thing essential since the latest ATV update? 

    I've never tried PlexConnect, not any version. 

    yes the certificate/ssl thing is essential, even before the latest ATV update because of something apple did :(

    I used and old cable from a blackberry phone to hook mine up!

  • roryholland2roryholland2 Posts: 16Members

    hi guys.. first of all, sorry or the noob question. but will my windows pc haev to permanently be connected to my ATV3 or is it just for the installation/setup process?

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    Just for the certificate install
  • roryholland2roryholland2 Posts: 16Members

    Ok so once the install and setup is done i can disconnect my laptop and Plex will run? What about the DNS address? just change it to automatic and it will work?

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    PMS and plexconnect need to be running, your ATV's DNS needs to point to the ip of your plex connect machine. Then plexconnect will intercept all calls to trailers.apple and present your plex media. You just need to connect via the USB to install the certificate.
  • roryholland2roryholland2 Posts: 16Members

    Ok, so basically my pc needs to be running all the time as that will be my "plex connect machine"? 

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    Yes.
  • roryholland2roryholland2 Posts: 16Members

    Great, thanks for your help Drewbie

  • roryholland2roryholland2 Posts: 16Members

    Wow 4 hours of trying to get tehis to work and still no luck :(

    Here is my Settings.cfg:

    [PlexConnect]

    port_pms = 32400

    ip_dnsmaster = 8.8.8.8

    loglevel = Normal

    enable_dnsserver = True

    ip_pms = 192.168.178.10

    enable_plexgdm = True

     

    And here is my PlexConnect log:

    PlexConnect: started: 23:12:00
    PlexConnect: ***
    PlexConnect: PlexConnect
    PlexConnect: Press ENTER to shut down.
    PlexConnect: ***
    PlexConnect: started: 23:12:00
    PlexConnect: IP_self: 10.0.0.6
    PlexGDM: ***
    PlexGDM: looking up Plex Media Server
    PlexGDM: ***
    PlexGDM: servers discovered: 1
    PlexConnect: PMS: 10.0.0.6:32400
    DNSServer: started: 23:12:02
    DNSServer: ***
    DNSServer: Starting up.
    DNSServer: intercept trailers.apple.com: 10.0.0.6
    DNSServer: forward other to higher level DNS: 8.8.8.8
    DNSServer: ***
    WebServer: started: 23:12:02
    WebServer: ***
    WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
    WebServer: ***
    DNSServer: DNS request received!
    DNSServer: Source: ('10.0.0.3', 59151)
    DNSServer: Domain: trailers.apple.com
    DNSServer: ***intercept request
    DNSServer: -> DNS response: 10.0.0.6
     

    I am still getting the "Trailers is not available msg" If someone coul dplease help me out or point me in the right direction it would be greatly appreciated.

    Thanking you in advance :)

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass

    How old is your version of Plexconnect.

    PlexConnect: Press ENTER to shut down. tells me very.

    Download the latest version form giuthub  https://github.com/iBaa/PlexConnect

    The version you are running does not have the certificate code so will not work.

  • roryholland2roryholland2 Posts: 16Members

    Not sure on version on PlexConnect. Will try the one from Github and try that. Does everything else look ok?

  • drewbiedrewbie Posts: 1,121Members, Plex Pass Plex Pass
    Too hard to tell as that version is so old it does not even have the certificate changes.
  • institute11institute11 Posts: 1,454Members ✭✭✭
  • roryholland2roryholland2 Posts: 16Members

    already downloaded the latest one from Drewbies link, will only be able to test it tonight.

  • SouljackerSouljacker Posts: 34Members
    edited October 2013

    EDIT: NEVERMIND guys. Wasn't using PlexConnect's latest release. Just tried it now and it worked beautifully :)

    Hi, this is my first time using Plexconnect

    I've followed all instructions here https://github.com/iBaa/PlexConnect/wiki/Windows-7-and-ATV-with-5.2-firmware-and-ethernet-internet-connection-installation-guide and at this topic

    I've set my ATV's DNS to 192.168.1.107. 

    This is my cmd window:

    09:25:00 PlexConnect: started: 09:25:00
    09:25:00 PlexConnect: ***
    09:25:00 PlexConnect: PlexConnect
    09:25:00 PlexConnect: Press ENTER to shut down.
    09:25:00 PlexConnect: ***
    09:25:00 PlexConnect: IP_self: 192.168.1.107
    09:25:00 PlexConnect: started: 09:25:00
    09:25:00 PlexGDM: ***
    09:25:00 PlexGDM: looking up Plex Media Server
    09:25:00 PlexGDM: ***
    09:25:01 PlexGDM: servers discovered: 1
    09:25:01 PlexConnect: PMS: 192.168.1.107:32400
    09:25:01 DNSServer: started: 09:25:01
    09:25:01 DNSServer: ***
    09:25:01 DNSServer: Starting up.
    09:25:01 DNSServer: intercept trailers.apple.com: 192.168.1.107
    09:25:01 DNSServer: forward other to higher level DNS: 8.8.8.8
    09:25:01 DNSServer: ***
    09:25:01 WebServer: started: 09:25:01
    09:25:02 WebServer: ***
    09:25:02 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
    09:25:02 WebServer: ***
    09:33:42 DNSServer: DNS request received!
    09:33:42 DNSServer: Source: ('192.168.1.109', 57894)
    09:33:42 DNSServer: Domain: trailers.apple.com
    09:33:42 DNSServer: ***intercept request
    09:33:42 DNSServer: -> DNS response: 192.168.1.107
    09:33:43 DNSServer: DNS request received!
    09:33:43 DNSServer: Source: ('192.168.1.109', 64359)
    09:33:43 DNSServer: Domain: trailers.apple.com
    09:33:43 DNSServer: ***intercept request
    09:33:43 DNSServer: -> DNS response: 192.168.1.107
    09:33:43 DNSServer: DNS request received!
    09:33:43 DNSServer: Source: ('192.168.1.109', 51049)
    09:33:43 DNSServer: Domain: www.apple.com
    09:33:43 DNSServer: ***forward request
    09:33:43 DNSServer: -> DNS response from higher level
    09:33:43 DNSServer: DNS request received!
    09:33:43 DNSServer: Source: ('192.168.1.109', 62452)
    09:33:43 DNSServer: Domain: www.apple.com
    09:33:43 DNSServer: ***forward request
    09:33:43 DNSServer: -> DNS response from higher level
    09:33:43 DNSServer: Warning: DNS error (10054): An existing connection was forci
    bly closed by the remote host
    09:33:43 DNSServer: DNS request received!
    09:33:43 DNSServer: Source: ('192.168.1.109', 59317)
    09:33:43 DNSServer: Domain: e3191.dscc.akamaiedge.net
    09:33:43 DNSServer: ***forward request
    09:33:43 DNSServer: -> DNS response from higher level
     
    Also, this is the message I get when I try accessing 192.168.1.107 at my browser:
     
    Error response

    Error code 403.

    Message: Not Serving Client 192.168.1.107.

    Error code explanation: 403 = Request forbidden -- authorization will not help.

     

     

     

     

    What should I do?

     

    Thanks!

  • roryholland2roryholland2 Posts: 16Members

    ok so i can access trailers and my channels, but when i click on something to watch it tells me trailers is unavailable? any ideas?

  • roryholland2roryholland2 Posts: 16Members

    it even says that when i try watch content off my HDD

Sign In or Register to comment.