If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Wrong audio/Commentary tracks playing after new update

slimmaticslimmatic Posts: 4Members
edited September 2013 in Plex Classic for Roku

So we had the issue with the Roku 1 & 2 before with the audio track playing the commentary (both english, so Plex defaulted to commentary for some reason). A trick we found on the forum for fixing this was to play the movie in Plex on our PC and switch through the tracks using the "A" key. Then when we exited and played the movie through the Roku again it would play the correct track (defaulted to PC settings).

 

After the new update, this is no longer the case. We have looked everywhere! Haven't found any setting on the Roku or Plex that will fix this issue. We have a ton of kids movies that we now can't play because the audio track can't be switched off of the commentary. And we haven't seen anyone else post with this issue after the update either, does anyone have any ideas?

Best Answer

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Accepted Answer

    I'd be curious to see the media info for the file. (Plex/Web, pull up the video, click Media Info, then View XML, and paste in here.) It should only choose the wrong thing if the streams are in a funky order. Regardless, you can go into the Playback Options for the video on the Roku and select which audio stream you want. If it seems like it's not respecting what you choose, then you *may* get better results by also forcing it to Direct Stream/Transcode.

Answers

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Accepted Answer

    I'd be curious to see the media info for the file. (Plex/Web, pull up the video, click Media Info, then View XML, and paste in here.) It should only choose the wrong thing if the streams are in a funky order. Regardless, you can go into the Playback Options for the video on the Roku and select which audio stream you want. If it seems like it's not respecting what you choose, then you *may* get better results by also forcing it to Direct Stream/Transcode.

  • slimmaticslimmatic Posts: 4Members

    Here is the XML from the video

    MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="2" librarySectionUUID="12c5caf8-2123-4f80-8180-9070c28cbd43" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1365384609"><Video ratingKey="371" key="/library/metadata/371" guid="com.plexapp.agents.imdb://tt0097757?lang=en" studio="Silver Screen Partners" type="movie" title="The Little Mermaid" titleSort="Little Mermaid" contentRating="G" summary="This colorful adventure tells the story of an impetuous mermaid princess named Ariel who falls in love with the very human Prince Eric and puts everything on the line for the chance to be with him. Memorable songs and characters -- including the villainous sea witch Ursula." rating="8.5" viewOffset="29000" viewCount="6" lastViewedAt="1378045114" year="1989" tagline="Somewhere under the sea and beyond your imagination is an adventure in fantasy." thumb="/library/metadata/371/thumb/1342045985" art="/library/metadata/371/art/1342045985" duration="4960294" originallyAvailableAt="1989-11-17" addedAt="1342044424" updatedAt="1342045985"><Media id="371" duration="4960294" bitrate="2163" width="720" height="476" aspectRatio="1.78" audioChannels="6" audioCodec="ac3" videoCodec="h264" videoResolution="sd" container="mkv" videoFrameRate="24p"><Part id="468" key="/library/parts/468/file.mkv" duration="4960294" file="M:\Movies\0 - Animated Kids Movies\The Little Mermaid (1989)\The Little Mermaid (1989) - 480p.mkv" size="1341388688" container="mkv"><Stream id="13185" streamType="1" codec="h264" index="0" bitrate="1715" language="English" languageCode="eng" anamorphic="1" bitDepth="8" cabac="1" chromaSubsampling="4:2:0" colorSpace="yuv" duration="4960294" frameRate="23.976" frameRateMode="cfr" hasScalingMatrix="0" height="476" level="41" pixelAspectRatio="32:27" profile="high" refFrames="7" scanType="progressive" width="720"/><Stream id="13186" streamType="2" selected="1" codec="ac3" index="1" channels="6" bitrate="448" language="English" languageCode="eng" bitDepth="16" bitrateMode="cbr" dialogNorm="-27" duration="4960289" samplingRate="48000"/><Stream id="13187" streamType="2" codec="aac" index="2" channels="2" language="English" languageCode="eng" duration="4960289" profile="he-aac / lc" samplingRate="48000"/><Stream id="13188" streamType="3" default="1" index="3" language="English" languageCode="eng" format="srt"/></Part></Media><Genre id="109" tag="Fantasy"/><Genre id="110" tag="Romance Film"/><Genre id="87" tag="Musical"/><Genre id="112" tag="Costume drama"/><Genre id="34" tag="Animation"/><Genre id="38" tag="Family"/><Writer id="3758" tag="Sam Graham"/><Writer id="3759" tag="Chris Hubbell"/><Writer id="94" tag="Roger Allers"/><Writer id="3760" tag="Howard Ashman"/><Writer id="200" tag="John Musker"/><Writer id="3761" tag="Gerrit Graham"/><Writer id="95" tag="Ron Clements"/><Director id="91" tag="John Musker"/><Director id="90" tag="Ron Clements"/><Country id="39" tag="USA"/><Role id="96" tag="Frank Welker" role=""/><Role id="3762" tag="Rene Auberjonois" role=""/><Role id="167" tag="Jason Marin" role="Flounder"/><Role id="3763" tag="Nancy Cartwright" role=""/><Role id="3270" tag="Paddi Edwards" role="Flotsam"/><Role id="3764" tag="Ben Wright" role="Grimsby"/><Role id="2428" tag="Edie McClurg" role=""/><Role id="1406" tag="Mark Hamill" role=""/><Role id="2869" tag="Tim Curry" role=""/><Role id="102" tag="Jim Cummings" role="Additional Voices"/><Role id="2243" tag="Kimmy Robertson" role="Alana"/><Role id="3765" tag="Matthew Balaban" role="Attina"/><Role id="1667" tag="Jodi Benson" role="Princess Ariel"/><Role id="3735" tag="Samuel E. Wright" role="Sebastian"/><Role id="3730" tag="Pat Carroll" role="Ursula"/><Role id="3766" tag="Christopher Daniel Barnes" role="Prince Eric"/><Role id="3733" tag="Kenneth Mars" role="King Triton"/><Role id="3767" tag="Buddy Hackett" role="Scuttle"/></Video></MediaContainer>

    We have tried switching the audio stream on the roku and it still plays the commentary track.

    I just tried your suggestion of changing playback to directstream/transcoding and it worked for this particular movie. Hopefully it will work for any others that have this issue as well!

    Thanks for your help-

  • david@theingram.comdavid@theingram.com Posts: 1Members, Plex Pass

    This is ocurring for me as well.  Only sometimes does the "directstream/transcoding" method allow the correct audio track to play.  I did not have this issue prior to update.

    I notice also that, when using the "directstream/transcoding" method, and it works, that the audio quality is lessened.

    I implore that the Plex developers correct this issue to allow the correct audio stream to be used.

    Best Regards,

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    slimmatic wrote on September 2 2013, 11:43 PM: »

    We have tried switching the audio stream on the roku and it still plays the commentary track.

    I just tried your suggestion of changing playback to directstream/transcoding and it worked for this particular movie. Hopefully it will work for any others that have this issue as well!

    Ok, thanks. So it's choosing the wrong stream for Direct Play and working fine for transcoding, which isn't terribly surprising. When we transcode it, we have full control over which stream is sent back. When we Direct Play, it's up to the Roku video player to choose the right stream. But I'm surprised it picked the wrong audio. Is the Roku configured to do surround sound or stereo only? (In the Roku Player Settings, not within the Plex channel.)

  • slimmaticslimmatic Posts: 4Members
    schuyler wrote on September 3 2013, 7:34 AM: »

    Ok, thanks. So it's choosing the wrong stream for Direct Play and working fine for transcoding, which isn't terribly surprising. When we transcode it, we have full control over which stream is sent back. When we Direct Play, it's up to the Roku video player to choose the right stream. But I'm surprised it picked the wrong audio. Is the Roku configured to do surround sound or stereo only? (In the Roku Player Settings, not within the Plex channel.)

    The Roku is configured to stereo, as we have it hooked up to our TV. We do not have surround sound in that room so we didn't choose that setting-

    Also, I did notice that this issue is only occurring on our Roku 2, the Roku 1 did not have any problems playing correct audio after the update.

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Terrific, thanks! That's a bug that we can get fixed in the next update to the Roku channel. It should have noticed that the stereo stream was suspicious (as potentially commentary) and avoided Direct Playing.

  • RyanRCRyanRC Posts: 118Members, Plex Pass Plex Pass
    edited September 2013

    I don't know if this is any help or not, but I have been learning my way through converting a lot of Blu-Ray, DVD and other forms of video over the mp4 & MKV's for use on Plex with handbrake and for use on my Roku's.

    An I don't know why, but it seems that even when I put several audio tracks on there, they can not be switched even if I do them in Plex/Web as the only thing that will play is what ever is the first audio track.

    I'll admit I haven't persured it deap in the settings where I'm messing with the transcodeing choices, kinda thought I was setting things up to not need any transcoding by doing them in handbrake like many recommend. As well am running myPlex off a pretty cheap laptop with 3T USB drive on it, so I am trying to have as little need for transcoding as possble.

    But at any rate, basically I'm writing this to tell you that for me I have learned that if there is a certain audio track I want from the various ones something might have that I am converting, I make sure I put it first.

    So don't know if that will help you, kinda looks like your putting the 6 ch's first but perhaps those are ones that have that?

    Anyway, know it might be a pain, but if you could do this you might try redoing them with checking to be sure which ever track isn't a problem an plays right is used for the first one, and reconverting it with that first.

    Btw some of the ways I have been testing my conversions first for all kinds of things is to do a test run of say 120 seconds or something, then put that file in what ever myPlex folder I am going to be using it in first, then see how that works.

    Then if all is OK, then I let the many hour conversion run.

    Hope that is if some help

    .

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Should be fixed in the 2.6.8 update, currently available in the PlexTest channel. Thanks again for the report.

  • ngs428ngs428 Posts: 180Members, Plex Pass Plex Pass

    I can confirm that there is still an issue here.  I am using a Roku 3 with the latest PLEX versions on my windows 7 PC and on the Roku.  I played a few files to test this and when I use Direct Play the first audio track is played.  I am using MKV files with streams in this order DTS 5.1, AC3 5.1 and AAC 2.0 in them.  Direct Play picks the DTS track each time.  When I switch to Automatic the audio track that i select is always played.  Not sure what is going on here, but it is not playing the correct track in Direct play.  

    Here is the media info for one of the files that has this behavior:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="9" librarySectionUUID="79643e2f-2b0e-4bd6-8652-d93971f150d1" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1365384173">
    <Video ratingKey="91049" key="/library/metadata/91049" guid="com.plexapp.agents.imdb://tt0162222?lang=en" studio="DreamWorks" type="movie" title="Castaway"contentRating="PG-13" summary="A FedEx executive must transform himself physically and emotionally to survive a crash landing on a deserted island."rating="6.6999998092651403" viewOffset="40000" lastViewedAt="1387424416" year="2000" tagline="At the edge of the world, his journey begins."thumb="/library/metadata/91049/thumb/1387423175" art="/library/metadata/91049/art/1387423175" duration="8627946" originallyAvailableAt="2000-12-22"addedAt="1387423164" updatedAt="1387423175">
    <Media videoResolution="480" id="75757" duration="8627946" bitrate="3223" width="718" height="472" aspectRatio="1.78" audioChannels="6" audioCodec="dca"videoCodec="h264" container="mkv">
    <Part id="89311" key="/library/parts/89311/file.mkv" duration="8627946" file="H:\Videos\Movies (MKV)\Castaway (2000) (480p, DTS 5.1).mkv"size="3476493062" container="mkv">
    <Stream id="110487" streamType="1" codec="h264" index="0" bitrate="1829" anamorphic="1" bitDepth="8" cabac="1" chromaSubsampling="4:2:0"codecID="V_MPEG4/ISO/AVC" colorSpace="yuv" frameRateMode="vfr" hasScalingMatrix="0" height="472" level="30" pixelAspectRatio="32:27" profile="high"refFrames="4" scanType="progressive" width="718"/>
    <Stream id="110488" streamType="2" selected="1" codec="dca" index="1" channels="6" bitrate="755" language="English" languageCode="eng" bitDepth="24"bitrateMode="cbr" codecID="A_DTS" duration="8627946" profile="es" samplingRate="48000"/>
    <Stream id="110489" streamType="2" codec="ac3" index="2" channels="6" bitrate="640" language="English" languageCode="eng" bitDepth="16"bitrateMode="cbr" codecID="A_AC3" dialogNorm="-31" duration="8627946" samplingRate="48000"/>
    <Stream id="110490" streamType="2" codec="aac" index="3" channels="2" language="English" languageCode="eng" codecID="A_AAC" duration="8627946"profile="lc" samplingRate="48000"/>
    <Stream id="110491" streamType="3" default="1" index="4" language="English" languageCode="eng" codecID="S_VOBSUB" format="vobsub"/>
    </Part>
    </Media>
    <Genre id="487" tag="Adventure"/>
    <Writer id="8277" tag="William Broyles Jr"/>
    <Director id="1323" tag="Robert Zemeckis"/>
    <Producer id="4357" tag="Tom Hanks"/>
    <Producer id="4358" tag="Robert Zemeckis"/>
    <Producer id="4359" tag="Steve Starkey"/>
    <Producer id="4360" tag="Jack Rapke"/>
    <Producer id="4361" tag="Cherylanne Martin"/>
    <Producer id="4362" tag="Steven J. Boyd"/>
    <Country id="493" tag="USA"/>
    <Role id="513" tag="Tom Hanks" role=""/>
    <Role id="2144" tag="Helen Hunt" role=""/>
    </Video>
    </MediaContainer>
  • ngs428ngs428 Posts: 180Members, Plex Pass Plex Pass

    I see the thread is shown as "Answered", but I am still experiencing the issue as stated in my last post.  

    Plex Team please look into this.

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    If you force Direct Play, then we just give the file to the Roku's video player. We can't really tell it which stream to play. If you leave it on Automatic, then we decide if the Roku is going to pick the stream you want when we decide whether or not to direct play. We strongly recommend leaving the setting on Automatic, for this and  many other reasons.

  • ngs428ngs428 Posts: 180Members, Plex Pass Plex Pass

    Thanks for the reply.  Does the video and audio still direct play if I choose automatic?  If I have compatible H.264 MKVs with DTS audio will it direct play on the Automatic setting?

    Could you explain exactly what "Automatic" does?

    Thanks!

  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Automatic does what it thinks is best given all of the information it has. If direct play is supported, it'll direct play. But if you've selected a stream that won't work with direct play, then it won't direct play. In the scenario you described, automatic would almost certainly direct stream (i.e. repackage the streams you want in a new container, without converting them).

  • ferchizzleferchizzle Posts: 31Members, Plex Pass Plex Pass
    edited November 19

    @schulyer i know this is an old post and do not know if you are still with the Plex team. I am encountering the same issue w my Plex Player in that it automatically plays the Director Commentary for certain movies that have that track encoded when I select "Direct Play" and turn off "Direct Stream". Is there a way for Plex to allow the user to select the track through Plex Media Player? At present it does not and the only option I have is to turn on Direct Stream which forces Plex Server to unnecessarily transcode the audio track to aac and the video track to it's native format.

Sign In or Register to comment.