Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex App doesn't work on OSX Maverick

The PMS works just fine. But the actual player always quite unexpectedly. I did a fresh install of mavericks yesterday and it STILL quits everything I start it up. I can even launch it at all anymore.
Tagged:

Comments

  • hoomanbahranihoomanbahrani Posts: 31Members, Plex Pass Plex Pass

    I'm having issues as well. I can move around and play, but once I play a TV show, or movie, then try to ESC back a menu, it freezes. 

  • magnusalexmagnusalex Posts: 38Members, Plex Pass

    Could it be that you experience the same error as I do? Check this thread: http://forums.plexapp.com/index.php/topic/84006-plex-0954-keeps-crashing-on-startup-exc-bad-access-kern-protection-failure/

    Nothing to do with Mavericks, but it happened at the same time as Mavericks was released - so you might THINK it's Mavericks.

  • PowerTowerPro_PowerTowerPro_ Posts: 217Members, Plex Pass Plex Pass

    Plex needs to support full screen. The best part of Mavericks is that displays can have separate spaces. When this option is enabled the white menu bar is visible over the interface. We need a fix for this ASAP.

  • Zillion_Zillion_ Posts: 22Members, Plex Pass Plex Pass

    Temporarily switch to another skin, e.g. Simplex or the default skin; the problem is in PlexAEON.

  • David SchlüterDavid Schlüter Posts: 9Members

    I can play tv-shows all day, but when I watch youtube movies online like Fox, after so many minutes it freezes, its not random, its a fixed freeze.

  • Herr+TriggerHerr+Trigger Posts: 2Members

    I'm having an issue as well.  Not sure if it's simply a setting that i've borked in the process of trying to fix things, or if it's the new Mavericks os x update or something to do exclusively with the Plex media player.  

    I'm unable to play any videos with plex anymore. 

    My setup:

    late 2012 mac mini 2.6 GHz core i7

    16 GB ram

    Intel HD graphics 4000

    OS X (10.9)

    OS is on an ssd (crucial I think, it's been awhile since i installed it),

    4x western digital elements external USB drives (2x2 TB,2x1TB)

    I just deleted and reinstalled the plex client so I'm running the latest version.

    doesn't seem to matter what sort of format I try to play, .mkv .avi .mp4 I get nothing, no video or audio at all anymore.

    The app previously played everything I threw at it flawlessly.  Any suggestion on what to try to fix this?

    The app doesn't crash when i try to open a video, it just open up to the menu and stops, I'm able to navigate the menu fine, but nothing i've done seems to get me anywhere.

  • wahlman.jwahlman.j Posts: 3,229Members, Plex Pass Plex Pass
    Im working fine here on mavericks.
  • LasmamoeLasmamoe Posts: 2Members

    I'm having the exact same issue as 'Herr+Trigger'.

    The app opens up fine, but the video doesn't play. Theres only a black screen and a menu on the left.

    Plex worked fine for me until i updated to Mavericks, and it's really annoying because i have searched for hours, and Plex is the only app that is able to play 1080 mkv files without any lag.

  • almarmaalmarma Posts: 38Members ✭✭
    edited November 2013
    Same problem here :'(. The other day I tried, as somebody posted here in the forum, to go to Preferences -> Mission Control, and disable "The screens has different spaces" (sorry if the text is not 100% exact! because my Mac is in Spanish ;). After doing that and rebooting, it worked with a clean Plex app. Then I changed the skin to Retroplex, and the problem came back. Then I deleted the Retroplex folder, but the problem is here yet: it crash continuously offering to send a report to Apple. I'll try to delete it again, including the "Library -> Application support -> Plex" to see if it works again with the default skin and settings :(

    UPDATE: after deleting that folder, deleting the .app, and copying a new copy, the problem is still there for me. Really sad :(
  • LasmamoeLasmamoe Posts: 2Members

    Almarma: I just tried unchecking the "display has different spaces" and it didn't work :/

  • PezmanPezman Posts: 8Members
    edited November 2013

    I have the same issue.   I've detailed what I tried here.  I'm up for any advice: http://forums.plexapp.com/index.php/topic/85108-plex-refuses-to-play-externally-loaded-media/?p=502783

Sign In or Register to comment.