Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Some videos play in fast forward without audio?

I have plex clients running on my mac and on linux 12.04 Ubuntu.  Both have been working flawlessly for months, but recently my linux client (Version: 0.9.10.2.44-201309051833-ubuntu6~ubuntu12.04.1) started having issues with certain videos.  The mac client doesn't have any problems with the same videos, and its only certain videos that linux has the issue with.  I'm noticing it on some episodes of shows but not on other episodes.

 

What happens is that from the moment I start the show it plays in fast forward without audio.  I've restarted both the linux OS, plexhometheater, and the windows 2008 server that runs PMS, nothing seems to resolve the issue.  I checked some episodes that I watched a few weeks ago, they're now having the same issue while weeks ago they played just fine.  Any suggestions on what's wrong?  Feels like it is some misconfiguration that maybe I set one day when messing with settings?  Is there something I can do to provide some debug logs that would help with troubleshooting?

 

Thanks for any help that can be provided, I'm a big fan of plex and have been spreading the word of it's awesomeness!  It re-kindled my interest in all my scattered folders of media by pulling it all together in one single interface, irrelevant of the file's location, PURE WIN.

«1

Comments

  • MattyKMattyK Posts: 72 Plex Pass

    I found this issue with XBMC on Linux.  It turned out to be the audio driver - did you by any chance run an update recently?

  • poplexitypoplexity Posts: 2

    I just checked the apt logs and there weren't any updates made between the time that we watched epsiodes without issue and now when the same episodes have this issue.  A full removal of everything and then a re-install took care of it..

    apt-get --purge remove plexhometheater

    apt-get --purge autoremove

    rm -rf /home/ME/.plexht

    apt-get install plexhometheater

    Seems like it must have been something I did when playing with my preferences, would be nice to know what that was, but its also nice to have plex back in action.  Now, more importantly, back to re-watching the latest season of Game of Thrones!

  • drunkenm666drunkenm666 Posts: 17 ✭✭
    edited November 2013

    Hi!

    Sorry for hijacking this thread, but I have the same problem since yesterday. I've updated my plexhometheater from version 0.9.10.2.44-201309051833-ubuntu6 to 1.0.2.141-201311211455-ubuntu28 yesterday. I had no problems with 0.9.10, but 1.0.2 plays back most of the videos with fast forward and no sound.

    There were also some other updates, which I automatically installed (would have never thought that something like this might happen):

    root@*****:~# grep -i \ installed /var/log/dpkg.log | grep -i 11-22
    2013-11-22 18:24:57 status installed desktop-file-utils 0.20-0ubuntu3
    2013-11-22 18:24:57 status installed bamfdaemon 0.2.126-0ubuntu1
    2013-11-22 18:24:57 status installed gnome-menus 3.4.0-0ubuntu1
    2013-11-22 18:24:58 status installed man-db 2.6.1-2ubuntu1
    2013-11-22 18:24:59 status installed firefox 25.0.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:24:59 status installed firefox-globalmenu 25.0.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:24:59 status installed firefox-locale-en 25.0.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:36 status installed desktop-file-utils 0.20-0ubuntu3
    2013-11-22 18:25:36 status installed bamfdaemon 0.2.126-0ubuntu1
    2013-11-22 18:25:36 status installed gnome-menus 3.4.0-0ubuntu1
    2013-11-22 18:25:37 status installed man-db 2.6.1-2ubuntu1
    2013-11-22 18:25:37 status installed plexhometheater 1.0.2.141-201311211455-ubuntu28~ubuntu12.04.1
    2013-11-22 18:25:37 status installed thunderbird 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:37 status installed thunderbird-locale-en 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:37 status installed thunderbird-gnome-support 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:37 status installed thunderbird-globalmenu 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:37 status installed thunderbird-locale-en-gb 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 18:25:37 status installed thunderbird-locale-en-us 1:24.1.1+build1-0ubuntu0.12.04.1
    2013-11-22 19:30:10 status installed doc-base 0.10.3
    2013-11-22 19:30:10 status installed man-db 2.6.1-2ubuntu1
    2013-11-22 19:30:10 status installed libglib2.0-0 2.32.4-0ubuntu1
    2013-11-22 19:30:11 status installed libcdaudio1 0.99.12p2-10build1
    2013-11-22 19:30:11 status installed libcelt0-0 0.7.1-1
    2013-11-22 19:30:11 status installed libflite1 1.4-release-4
    2013-11-22 19:30:11 status installed libgme0 0.5.5-2
    2013-11-22 19:30:11 status installed libgstreamer-plugins-bad0.10-0 0.10.22.3-2ubuntu2.2
    2013-11-22 19:30:11 status installed libmimic0 1.0.4-2.1build1
    2013-11-22 19:30:11 status installed libmms0 0.6.2-2
    2013-11-22 19:30:11 status installed libfftw3-3 3.3-1ubuntu1
    2013-11-22 19:30:11 status installed libofa0 0.9.3-4
    2013-11-22 19:30:11 status installed libopenal-data 1:1.13-4ubuntu3
    2013-11-22 19:30:11 status installed libopenal1 1:1.13-4ubuntu3
    2013-11-22 19:30:11 status installed libslv2-9 0.6.6+dfsg1-1
    2013-11-22 19:30:11 status installed libsoundtouch0 1.6.0-2build1
    2013-11-22 19:30:11 status installed libspandsp2 0.0.6~pre18-2build1
    2013-11-22 19:30:11 status installed libvo-aacenc0 0.1.1-2
    2013-11-22 19:30:11 status installed libvo-amrwbenc0 0.1.1-2
    2013-11-22 19:30:11 status installed libwildmidi-config 0.2.3.4-2.1precise1
    2013-11-22 19:30:11 status installed libwildmidi1 0.2.3.4-2.1precise1
    2013-11-22 19:30:11 status installed libxvidcore4 2:1.3.2-6
    2013-11-22 19:30:11 status installed libzbar0 0.10+doc-7build2
    2013-11-22 19:30:11 status installed gstreamer0.10-plugins-bad 0.10.22.3-2ubuntu2.2
    2013-11-22 19:30:11 status installed freepats 20060219-1
    2013-11-22 19:30:11 status installed gstreamer0.10-ffmpeg 0.10.13-4
    2013-11-22 19:30:11 status installed libc-bin 2.15-0ubuntu10.5
    root@*****:~#

    I already tried reinstalling PlexHT, but no success. I have an Ubuntu 12.04 and my media server is pretty much useless in this state. :(

    @MattyK: which driver caused the problems for you?

    EDIT: on my Windows box I have a Plex MediaCenter as client (0.9.504), that on is working fine and my LG TV with MediaLink is also working. So the problem is definitely with the Linux client.

  • AstralisAstralis Posts: 13 ✭✭
    edited November 2013

    Before launching PHT, enter this in the terminal:

    export AE_ENGINE=SOFT

    This bug can occur when you enable PHT to send audio straight to the receiver and you use the Pulse Audio engine (which Plex does).

  • drunkenm666drunkenm666 Posts: 17 ✭✭
    edited November 2013

    @Astralis: thanks for the tip. I tried it - with "half" success. Most of the videos are not playing in Fast Forward anymore, but unfortunately there is still no sound. :( Curiously I got the following error while launching with AE_ENGINE=SOFT:

    drunkenm@mediasrv:~$ export AE_ENGINE=SOFT ; plexhometheater.sh
    Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
    libva: VA-API version 0.32.0
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva: va_openDriver() returns -1
    drunkenm@mediasrv:~$ unset AE_ENGINE
    drunkenm@mediasrv:~$ plexhometheater.sh
    drunkenm@mediasrv:~$

    Without setting the variable there was no such error.

  • AstralisAstralis Posts: 13 ✭✭

    @drunkenm666 VDPAU is used for hardware acceleration.

    This is my terminal with AE_ENGINE=SOFT enabled:

    sh pht.sh
    libva info: VA-API version 0.33.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_33
    libva info: va_openDriver() returns 0
    (no errors)
     
  • macerymacery Posts: 2 Plex Pass
    I'm seeing the same issue with pht on Ubuntu. I have found that if I set my local media server setting to 20Mb and force the server to transcode it plays fine, and to not the server and the client are the same linux machine but it works. Can't wait to find a fix and Allow for direct-play again.
  • I don't think it's an issue with Ubuntu especially. I ran Plex Media Server on a Windows 7 machine and PHT on an Arch Linux 64 bit machine and had the same issue. Now the same machine is on Ubuntu 13.10 and it sort of works fine. (Audio won't come out of the built-in speakers and FHD videos are laggy as heck, but it works.)

  • drunkenm666drunkenm666 Posts: 17 ✭✭
    edited November 2013

    @Astralis: thanks for the tip. I created the link, and I didn't have any more error messages while starting PlexHT, but unfortunately still no sound.

    Later, I removed the link, and it's extremely curios - the error message did not return! I'm guessing, that Linux(?), Plex(?) loaded the .so, while the link was there and stored it somewhere (or remembered, where the link was pointed - which on my system is: /usr/lib/x86_64-linux-gnu/libvdpau.so.1 --> /usr/lib/x86_64-linux-gnu/libvdpau.so.1.0.0).

    So, that's curiosity part 1.

    Here's part two: there was another update for PlexHT in the repository (http://ppa.launchpad.net/plexapp/plexht/ubuntu/) with version: 1.0.4.144-201311241233-ubuntu32~ubuntu12.04.1 (judging by the date it was compiled and put up yesterday). I also tried installing that one, but with no success (normal speed video, but no sound). After seeing that this version doesn't work either, I tried reinstalling 0.9.10.2.44-201309051833-ubuntu6~ubuntu12.04.1 (from: https://launchpad.net/~plexapp/+archive/plexht/+build/4936929) - this is the version I had originally installed. Before I installed the 0.9.10, I removed 1.0.4.144 with "apt-get purge". But the problem still persists!

    In conclusion: going back to the original version I had installed, the problem is still there. So I'm back to my original question: could it be another package I updated/installed (see list in post #4) which affects PlexHT?

  • AstralisAstralis Posts: 13 ✭✭

    A lot of gstreamer packages were updated, and I know that they are used for media playback in Ubuntu (and other distros). I don't know if they are used by Plex though.

    Have you checked any of these boxes? http://i.imgur.com/ssZuU7B.png Having them checked gives me sound problems as well.

  • drunkenm666drunkenm666 Posts: 17 ✭✭

    Hi Astralis!

    I also suspected the gstreamer plugins - no wonder, they have "bad" in the name... - and uninstalled them right away. Unfortunately that didn't help either.

    So, today I completely removed PlexHT again (also removed .plexht in my home dir) and reinstalled it. Problem was still there - UNTIL I deactived the audio options, like on your screenshot! Everything works like a charm!

    I really hope, that this gets fixed soon, and that I can take some load off my server, which is connected to a Pioneer VSX-922-K, which is more than capable of decoding AC3, DTS and whatnot. But it look like, that I'm stuck currently with the server having to decode the audio stream. Well, at least it works. :)

    Thanks again for everybody trying to help me and thanks for the Plex team for making this AWESOME piece of software (the server and the many clients for the different OSes)!!!

    P.S.: Too bad, that I like the old skin better, but on that one I didn't find these options! They must have been new to this version, that's why I still had no sound when I tried to reinstall the 0.9.x - it was probably saved in my .plexht folder and since I had no option in 0.9.x to disable them, I didn't realize that.

  • AstralisAstralis Posts: 13 ✭✭
    edited November 2013

    The options are actually there on the old skin as well. http://i.imgur.com/XpE6ZvF.png

    Glad it worked out for you!

  • CoenicCoenic Posts: 11 Plex Pass

    Hey guys! Im also having this problem, i want Plex to send audio over to my TV via HDMI.. that works if i open a video in vlc or youtube. I have set Audio Output to HDMI in both tabs "Audio Output" and "Advanced -> Audio output device" Under the tab "Audio Output" is everything unchecked. Running Ubuntu 12.04. Any idea's how to make this work? 

  • CoenicCoenic Posts: 11 Plex Pass
    Coenic wrote on November 26 2013, 10:01 PM: »

    Hey guys! Im also having this problem, i want Plex to send audio over to my TV via HDMI.. that works if i open a video in vlc or youtube. I have set Audio Output to HDMI in both tabs "Audio Output" and "Advanced -> Audio output device" Under the tab "Audio Output" is everything unchecked. Running Ubuntu 12.04. Any idea's how to make this work? 

    Forgot to say, the audio works if i set Audio Output to Build-in audio analog stereo.

  • AstralisAstralis Posts: 13 ✭✭
    Coenic wrote on November 26 2013, 10:03 PM: »

    Forgot to say, the audio works if i set Audio Output to Build-in audio analog stereo.

    Did you try to set AE_ENGINE to SOFT?

  • CoenicCoenic Posts: 11 Plex Pass
    edited November 2013
    Astralis wrote on November 26 2013, 10:06 PM: »

    Did you try to set AE_ENGINE to SOFT?

    I ran the command " export AE_ENGINE=SOFT " in the terminal, but it aint working :(

    any specific folder i need to run it in?

  • AstralisAstralis Posts: 13 ✭✭

    No specific folder, just run it before you run Plex.

  • CoenicCoenic Posts: 11 Plex Pass
    Astralis wrote on November 26 2013, 10:19 PM: »

    No specific folder, just run it before you run Plex.

    I have done that.. didn't do any good I'm afraid.

  • CoenicCoenic Posts: 11 Plex Pass

    Thanks for all the help guys, maybe just me who are stupid and wrote "export" before " AE_ENGINE=SOFT "

    Atleast it worked after i just wrote in 
    AE_ENGINE=SOFT in the terminal. Thanks once again!

  • drunkenm666drunkenm666 Posts: 17 ✭✭
    edited November 2013
    Coenic wrote on November 26 2013, 10:41 PM: »

    Thanks for all the help guys, maybe just me who are stupid and wrote "export" before " AE_ENGINE=SOFT "

    Atleast it worked after i just wrote in 
    AE_ENGINE=SOFT in the terminal. Thanks once again!

    If you have PlexHT installed via the Ubuntu PPA, you should have "plexhometheater.sh" as startup script (which calls the plexhometheater binary and sets "XBMC_HOME" path). The script comes pre-filled with the "export AE_ENGINE=SOFT" line, it's just commented out. Simply edit the file, remove the "#" in front of the line and you're set. That's what I did. ;)

«1
Sign In or Register to comment.