Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Fedora 18: "404 Not Found" when accessing the Plex Manager via a Web Browser

2»

Comments

  • jasalcidojasalcido Members, Plex Pass Posts: 1

    I had the same 404 Not Found issue happen on a new install of plexmediaserver 0.9.8 on RHEL 6 using the CENTOS rpm package.  After much debugging found the information in this thread helpful but not complete.  The problem, as stated earlier, is due to rsync not having correct selinux permissions for /var filesystem.  The error happens because when you start the plexmediaserver service the plugin files are copied from /usr/lib/plexmediaserver to /var/lib/plexmediaserver.  This fails and so the files used by the web service are not found.

    To get around this I found that the plexrsync.pp module did not include all permissions needed. My module file used that ended up clearing out the issues is this:

    module myplex 6.0;

     
    require {
    type rsync_t;
    type var_lib_t;
    class file { create read rename getattr open setattr };
    class dir { create add_name setattr rename remove_name };
    }
     
    #============= rsync_t ==============
     
    #!!!! This avc is allowed in the current policy
    allow rsync_t var_lib_t:dir { create add_name setattr rename remove_name  };
     
    #!!!! This avc is allowed in the current policy
    allow rsync_t var_lib_t:file { create read rename getattr open setattr };
     
     
    then to compile, i ran as root:
     
    # checkmodule -M -m -o myplex.mod myplex.te
    # semodule_package -o myplex.pp -m myplex.mod
    # semodule -i myplex.pp
     
    then stop the plex server:
     
    # service plexmediaserver stop
     
    Now follow the suggestion in a previous post and clean out the plugin directory under /var/lib/plexmediaserver so it can be repopulated correctly.
     
    # cd /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins
    # rm -rf *.bundle
     
    now start the plex server:
     
    # service plexmediaserver start
     
    open the web interface at http://localhost:32400/web/index.html/ 
     
    if you tail /var/log/messages you will see that there are no new selinux issues from rsync.  At this point, my web interface started.  However it stopped at "waiting for server to start" message.  I just clicked on skip link and started configuring server.  
     
    Hopefully this helps future packaging on selinux-enabled servers.
     
2»
Sign In or Register to comment.