Jump to content


Photo

Plex Skin Installer Script


  • Please log in to reply
115 replies to this topic

#1 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 06:56 PM

New graphical skin installer by Vicarious 'Preen Skin Manager' here: http://forums.plexap...dpost__p__94206

Preen Skin manager is now the recommended way of installing Plex skins, thanks Vicarious!!

Plex Skin Installer/Update Script
Version 2.0.0 (August 30th, 2010)



August 30th, 2010

Skin installer version 2.00 for Plex .9 only
Installs the following skins for Plex .9

PlexAeon 9
ReFocus
Lithium
Confluence Redux

This script is for people who want to run a command line script

INSTALLATION

1. Download the PlexSkinInstaller script above.
2. If you haven't done so already then download and install GIT from here: http://git-osx-insta...tel-leopard.dmg or a newer version.
3. Open Terminal (It's in Applications/Utilities, or use spotlight to find it)
4. Find the PlexSkinInstaller script you downloaded unzip and run it. TIP: The easiest way to do this is drag and drop it into the Terminal window, then press return to run it.
If you get "Permission denied" errors when running the script then run it with sudo in front of the command.

Wait for the script to finish, restart Plex and your ready to go.



--------------------------------------------------------------------------------

OLD Plex .8 Version of skin installer. (Only for Plex .85 version)

Attached File  PlexSkinInstaller85.zip   280KB   1661 downloads

July 9th. 2010

Added: New skin Mediastream_Redux/Confluence by El Massman

Added: New skin Stark-for-Plex modified by El Massman
Removed: PlexBackRow until there is a developer

Added: New skin PlexBackrow (needs a developer, if your willing then send me a message)
Added: New skin PleXperience modified by ericmatthys

Changed: Now compatible with MacPorts installed GIT
Added: New Skin PlexEllipsis modified by ericmatthys
Changed: Plex Scripts no longer have to be copied out of the extras directory, so Plex program updates no longer break scripts such as OSD_Subtitles.
Fixed for Plex 0.8.3
OSD Subtitle fix, PlexXTV ownership changed to Tassitassi for any further mods to that skin.


This script will automatically download and install all current Plex skins, or if they are already installed, will update them all. This gives everyone an easy way to install and update the skins, even from WITHIN Plex.

Big thanks to all the skin developers out there who helped me bring this together!

Currently supported .8 skins:

PlexAeon http://forums.plexap...dpost__p__47182
PlexAlaska http://forums.plexap...425-plexalaska/
Aeon Slim for Plex http://forums.plexap...skin-aeon-slim/
PlexXTV http://forums.plexap...-skin-for-plex/
Lithium http://forums.plexap...c/9458-lithium/
PlexEllipsis http://forums.plexap...l__plexellipsis
PleXperience http://forums.plexap...0-plexperience/
PlexBackrow (Removed) http://forums.plexap...-skin-for-plex/
Stark-for-Plex http://forums.plexap...dpost__p__80395
Mediastream_Redux/Confluence http://forums.plexap...dpost__p__89652





Have fun and report any bugs in the forums!
Maverick214

#2 someone

someone

    Dedicated Member

  • Members
  • PipPipPip
  • 490 posts
  • Location: Germany

Posted 24 October 2009 - 07:47 PM

Great work, Maverick!

But I think I'm too dumb to use Plex. I never added an application to Plex before (except from the apps of the appstore)... and I don't know why, but it doesn't work for me. Every time I select your automator script (also tested with different applications) Plex jumps back to the root of the programs. But the app I wanted to add isn't there...

Any hint what I'm doing wrong? Also tested with different skins, even with Mediastream I can't add an external application.

Edit: because it worked on my iMac I edited the sources.xml on my Mini manually and added the source. Now it's there. Don't know what was wrong here.

#3 flynfish

flynfish

    Member

  • Members
  • PipPip
  • 81 posts
  • Location: Boulder, CO

Posted 24 October 2009 - 08:58 PM

When I try running the script in terminal it says I don't have GIT installed and need to install it. I have git installed though and have used it to update Plex Aeon many times before.

#4 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 08:59 PM

Great work, Maverick!

But I think I'm too dumb to use Plex. I never added an application to Plex before (except from the apps of the appstore)... and I don't know why, but it doesn't work for me. Every time I select your automator script (also tested with different applications) Plex jumps back to the root of the programs. But the app I wanted to add isn't there...

Any hint what I'm doing wrong? Also tested with different skins, even with Mediastream I can't add an external application.

Edit: because it worked on my iMac I edited the sources.xml on my Mini manually and added the source. Now it's there. Don't know what was wrong here.


Not sure why it wouldn't add. I removed a few of the old scripts. So it's not confusing when users try to add the script.
I'm getting your updates, keep up the good work!

#5 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 09:03 PM

When I try running the script in terminal it says I don't have GIT installed and need to install it. I have git installed though and have used it to update Plex Aeon many times before.


It looks for it in /usr/local/git can you open terminal and type

cd /usr/local/git

And tell me if it says that directory does not exist?
Maybe for some reason git installed somewhere else.
Anyone else see this error?

#6 cybo

cybo

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 24 October 2009 - 09:13 PM

Working perfectly here. Thanks, Maverick!

#7 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 09:31 PM

Working perfectly here. Thanks, Maverick!


Great! At least it's not just me. :)

#8 someone

someone

    Dedicated Member

  • Members
  • PipPipPip
  • 490 posts
  • Location: Germany

Posted 24 October 2009 - 09:34 PM

Not sure why it wouldn't add. I removed a few of the old scripts. So it's not confusing when users try to add the script.
I'm getting your updates, keep up the good work!

Now it's also working for me. I used the growl-version, but Growl wasn't running properly... after using the non-Growl version it's running perfect.

Many thanks again!

#9 flynfish

flynfish

    Member

  • Members
  • PipPip
  • 81 posts
  • Location: Boulder, CO

Posted 24 October 2009 - 09:36 PM

It looks for it in /usr/local/git can you open terminal and type

cd /usr/local/git

And tell me if it says that directory does not exist?
Maybe for some reason git installed somewhere else.
Anyone else see this error?


Ah my bad. I installed git using macports a while back so it isn't located in usr/local/git . I will either change your script or install git into that dir.

#10 mjollymo

mjollymo

    Member

  • Members
  • PipPip
  • 19 posts

Posted 24 October 2009 - 10:36 PM

I am probably just not doing something right, but for some reason I don't see the PlexSkinUpdater script in the extras folder within PlexAeon. I am only seeing OpenSubtitles, VideoIntro, and XBMC Lyrics.

I have run the skin installer twice, and that part worked perfectly.

#11 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 10:50 PM

Now it's also working for me. I used the growl-version, but Growl wasn't running properly... after using the non-Growl version it's running perfect.

Many thanks again!


If you running snow leopard then there is a new snow leopard compatible version out.

#12 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 10:58 PM

I am probably just not doing something right, but for some reason I don't see the PlexSkinUpdater script in the extras folder within PlexAeon. I am only seeing OpenSubtitles, VideoIntro, and XBMC Lyrics.

I have run the skin installer twice, and that part worked perfectly.


Hmm, I don't know. Seems to be there. You can delete the entire PlexAeon skin directory and run the Skin Installer again to re-download.
Double check your in the PlexAeon Extras directory and not the Plex script directory.

#13 mjollymo

mjollymo

    Member

  • Members
  • PipPip
  • 19 posts

Posted 24 October 2009 - 11:34 PM

Hmm, I don't know. Seems to be there. You can delete the entire PlexAeon skin directory and run the Skin Installer again to re-download.
Double check your in the PlexAeon Extras directory and not the Plex script directory.


Trashing the skin and running the Installer again did the trick! Thanks.

Was able to add the updater and tested it out, worked perfectly.

#14 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 24 October 2009 - 11:50 PM

Trashing the skin and running the Installer again did the trick! Thanks.

Was able to add the updater and tested it out, worked perfectly.


Great!

#15 feikenberg

feikenberg

    Member

  • Members
  • PipPip
  • 71 posts

Posted 25 October 2009 - 12:18 AM

Maverick, I'm getting some "permission denied" errors while running the script, so I think you should add that you have to be an admin user or run the script with sudo. Am I right?

#16 Maverick214

Maverick214

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2248 posts
  • Location: Canada

Posted 25 October 2009 - 12:43 AM

Maverick, I'm getting some "permission denied" errors while running the script, so I think you should add that you have to be an admin user or run the script with sudo. Am I right?


Oh, maybe that's because the script updates your path variable if Git didn't do it.
I will add a note.

Thanks!

#17 iMarc

iMarc

    Dedicated Member

  • Members
  • PipPipPip
  • 149 posts

Posted 25 October 2009 - 09:54 PM

Awesome Maverick,
Works like a charm.

Could anyone tell me how to open the favorites in PlexAlaska?
At this point I'll have to switch to Mediastream to start the update-sequenze, after that back to PlexAlaska.
Mac Mini 2.26GHz 4GB RAM 160GB HDD| PlexNine| DVI->HDMI| Sony Bravia 40" LCD| and Harmony One

#18 someone

someone

    Dedicated Member

  • Members
  • PipPipPip
  • 490 posts
  • Location: Germany

Posted 25 October 2009 - 10:57 PM

Awesome Maverick,
Works like a charm.

Could anyone tell me how to open the favorites in PlexAlaska?
At this point I'll have to switch to Mediastream to start the update-sequenze, after that back to PlexAlaska.

With Plex 0.8.2 it wasn't possible to access the context menu in the home screen without modifications. I added a temporary solution for the default home screen and home2. Update PlexAlaska and then just push "down" on your remote in that home screens.

#19 iMarc

iMarc

    Dedicated Member

  • Members
  • PipPipPip
  • 149 posts

Posted 26 October 2009 - 09:46 AM

With Plex 0.8.2 it wasn't possible to access the context menu in the home screen without modifications. I added a temporary solution for the default home screen and home2. Update PlexAlaska and then just push "down" on your remote in that home screens.


Home 2 o3 are not selected in my setup, however, I've tried it and the button down option does not work.
What I do have is this:
I already made notice of flashing setting screen, in Home 2 even the home screen flashes
Mac Mini 2.26GHz 4GB RAM 160GB HDD| PlexNine| DVI->HDMI| Sony Bravia 40" LCD| and Harmony One

#20 sirphuzz

sirphuzz

    Member

  • Members
  • PipPip
  • 29 posts

Posted 26 October 2009 - 07:10 PM

I can't get this to work.

I try with sudo rights and I get error: "command not found". Am I missing some files?

I've run the PlexAeonupdate script and it works fine. I also checked that my git is located in /usr/local/git, and it is.

What could this be?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users