Jump to content


Photo

FeedMe Plugin


  • Please log in to reply
17 replies to this topic

#1 mikebeecham

mikebeecham

    Dedicated Member

  • Members
  • PipPipPip
  • 177 posts
  • Location: Dorset, England

Posted 24 February 2010 - 09:23 AM

Hi guys,

I wonder whether it might be a possibility to add Google Read integration into FeedMe? I have used GR a lot in the past, and being able to just integrate with it, rather than trying to remember the feed link to all my feeds would be great.

Is this too much work?

Thanks



Mike

#2 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 24 February 2010 - 04:41 PM

Hi Mike,

the answer is I'm not sure, but I'll take a look. Looking at ways to getting lists of feeds into the plugin is on my list of things to look into it.

Jonny

Hi guys,

I wonder whether it might be a possibility to add Google Read integration into FeedMe? I have used GR a lot in the past, and being able to just integrate with it, rather than trying to remember the feed link to all my feeds would be great.

Is this too much work?

Thanks



Mike



#3 mikebeecham

mikebeecham

    Dedicated Member

  • Members
  • PipPipPip
  • 177 posts
  • Location: Dorset, England

Posted 24 February 2010 - 08:23 PM

Hi Mike,

the answer is I'm not sure, but I'll take a look. Looking at ways to getting lists of feeds into the plugin is on my list of things to look into it.

Jonny



Thanks mate - I'm hoping it wont be too much work. I only say this because I have a couple of podcast apps from low-key coders, and they've managed to do it...

Will leave it to you.




Mike

#4 freddy

freddy

    Member

  • Members
  • PipPip
  • 47 posts
  • Location: Virginia

Posted 03 March 2010 - 05:39 AM

looking for some help...

i have added Autoweek video podcast to FeedMe but it goes into the audio feeds and not the video feeds. how do i force it to go to the video feeds since it is a video podcast after all?

thank you.

#5 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 03 March 2010 - 06:06 AM

Hi Freddy,

the section the podcast goes into is determined by the mime types of the individual podcasts within the feed. To go into the video section there must be a video podcast available, and the same for audio. One source can go into both.

The only feed I came across was this which is audio:
http://www.autoweek....=rss06&mime=xml

Can you post the URL for the feed you see being categorized incorrectly and I'll take a look?

thanks
Jonny

looking for some help...

i have added Autoweek video podcast to FeedMe but it goes into the audio feeds and not the video feeds. how do i force it to go to the video feeds since it is a video podcast after all?

thank you.



#6 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 03 March 2010 - 06:22 AM

Mike,

started to look into this a little and was wondering about how the other apps you mention and how they deal with authentication. Can you tell me the apps you mean and/or your expectations regarding private vs public feed lists? Thanks.

Looks like there isn't an official API but maybe other ways in, just trying to figure out the best approach.

Jonny

Thanks mate - I'm hoping it wont be too much work. I only say this because I have a couple of podcast apps from low-key coders, and they've managed to do it...

Will leave it to you.




Mike



#7 mikebeecham

mikebeecham

    Dedicated Member

  • Members
  • PipPipPip
  • 177 posts
  • Location: Dorset, England

Posted 03 March 2010 - 10:28 PM

Mike,

started to look into this a little and was wondering about how the other apps you mention and how they deal with authentication. Can you tell me the apps you mean and/or your expectations regarding private vs public feed lists? Thanks.

Looks like there isn't an official API but maybe other ways in, just trying to figure out the best approach.

Jonny


Hi Jonny,

The apps I'm talking about are podcasting apps on my Android mobile device. Essentially, you can choose to 'add feed', and one of the options it gives you is for Google Reader. If you choose this, then it asks you for your Reader account details (essentially your Gmail account username and password).

From that point (and as long as you've entered the correct authentication details) then you will get a list of all the feeds that your currently subscribed to in Google Reader. You can then choose which feeds to import from Google Reader into your app.

The applications which do this are: Acast (crap!!) and BeyondPod, which does it so much better.

I hope this helps.




Mike

#8 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 March 2010 - 01:16 AM

Thanks Mike, I'll take a look at those apps. I basically can't find any reader API documented that uses authentication to get private feeds, but it must be possible since other apps use it. I need to keep looking I guess :)

Hi Jonny,

The apps I'm talking about are podcasting apps on my Android mobile device. Essentially, you can choose to 'add feed', and one of the options it gives you is for Google Reader. If you choose this, then it asks you for your Reader account details (essentially your Gmail account username and password).

From that point (and as long as you've entered the correct authentication details) then you will get a list of all the feeds that your currently subscribed to in Google Reader. You can then choose which feeds to import from Google Reader into your app.

The applications which do this are: Acast (crap!!) and BeyondPod, which does it so much better.

I hope this helps.




Mike



#9 freddy

freddy

    Member

  • Members
  • PipPip
  • 47 posts
  • Location: Virginia

Posted 04 March 2010 - 01:49 AM

Hi Freddy,

the section the podcast goes into is determined by the mime types of the individual podcasts within the feed. To go into the video section there must be a video podcast available, and the same for audio. One source can go into both.

The only feed I came across was this which is audio:
http://www.autoweek....=rss06&mime=xml

Can you post the URL for the feed you see being categorized incorrectly and I'll take a look?

thanks
Jonny


Jonny,

this is the url: http://www.autoweek.com/section/rss07
it shows up as video in the audio feeds not the video feeds.

thanks for the help.

#10 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 March 2010 - 02:15 AM

Hi Freddy,

thanks for providing the feed. If you look at the feed (open URL in browser and do a right click view page source) you'll see each item is specified as audio, eg.

<enclosure url="http://miad.autoweek.com/vidcast/awnews_3_2_10v4.m4v" type="audio/mpeg"/>

The type designation is what Feed Me uses to determine if the source is audio or video. They are telling us it is audio, so there's not much I can do here since in theory the m4v container can be used for audio. If it was a plugin for a specific source we could override their error but since this is for generic sources we have to believe them. Maybe you could email the provider and tell them the mime type is wrong on their feed and it's confusing your feed reader?

Jonny

Jonny,

this is the url: http://www.autoweek.com/section/rss07
it shows up as video in the audio feeds not the video feeds.

thanks for the help.



#11 freddy

freddy

    Member

  • Members
  • PipPip
  • 47 posts
  • Location: Virginia

Posted 05 March 2010 - 03:24 AM

Hi Freddy,

thanks for providing the feed. If you look at the feed (open URL in browser and do a right click view page source) you'll see each item is specified as audio, eg.

<enclosure url="http://miad.autoweek.com/vidcast/awnews_3_2_10v4.m4v" type="audio/mpeg"/>

The type designation is what Feed Me uses to determine if the source is audio or video. They are telling us it is audio, so there's not much I can do here since in theory the m4v container can be used for audio. If it was a plugin for a specific source we could override their error but since this is for generic sources we have to believe them. Maybe you could email the provider and tell them the mime type is wrong on their feed and it's confusing your feed reader?

Jonny


Thanks for your help Jonny...

#12 XStream

XStream

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 March 2010 - 05:37 PM

The following video feed does not play in feed me plugin:

http://timesofindia....deo/3812907.cms

When you view page source the following line can be observed:

<media:content type="video/quicktime" expression="full" url="http://timesofindia....w/5682642.cms">

But Feed Me complains that the video format could not be retrieved.

Can you please investigate? Thanks...

#13 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 15 March 2010 - 12:40 AM

Yeah, simple answer, the link at the end of the content isn't actually 'video/quicktime' but a html page. Feed Me can only deal with direct content, there's no way to know how to extract video content from a web page in a generic manner (ie all sites are different).

Try writing to the content provider and let them know their video rss feeds don't actually contain video, and it is confusing your feed reader. You never know it may work?

Jonny

The following video feed does not play in feed me plugin:

http://timesofindia....deo/3812907.cms

When you view page source the following line can be observed:

<media:content type="video/quicktime" expression="full" url="http://timesofindia....w/5682642.cms">

But Feed Me complains that the video format could not be retrieved.

Can you please investigate? Thanks...



#14 Pleximan

Pleximan

    Member

  • Members
  • PipPip
  • 47 posts

Posted 20 September 2011 - 08:40 PM

Hi,
I´m trying to add a feed manually but all I get is "the feed was invalid".
I have tried "http://".... and "feed://".... but no luck. :)

Could it be a dead plug in or what?

Any ideas?

thanks

#15 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 21 September 2011 - 02:54 AM

Hi,
I´m trying to add a feed manually but all I get is "the feed was invalid".
I have tried "http://".... and "feed://".... but no luck. :)

Could it be a dead plug in or what?

Any ideas?

thanks


Feed URL?

#16 Pleximan

Pleximan

    Member

  • Members
  • PipPip
  • 47 posts

Posted 21 September 2011 - 07:54 AM

Feed URL?



I have tried several,

http://svt.se/rss/nyheter/inrikes/
http://www.aftonbladet.se/rss.xml

This two feeds returned "Invalid feed".....

Thanks for attending to my issue.

/ P

#17 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 21 September 2011 - 06:39 PM

I have tried several,

http://svt.se/rss/nyheter/inrikes/
http://www.aftonbladet.se/rss.xml

This two feeds returned "Invalid feed".....

Thanks for attending to my issue.

/ P


Well, neither of the feeds you listed contain video or audio items so they are invalid.

FeedMe only works for feeds that contain direct links to either audio or video media items.

Jonny

#18 Pleximan

Pleximan

    Member

  • Members
  • PipPip
  • 47 posts

Posted 21 September 2011 - 07:12 PM

Well, neither of the feeds you listed contain video or audio items so they are invalid.

FeedMe only works for feeds that contain direct links to either audio or video media items.

Jonny


Ok, i thought it could be used get news in written form as well.

Do you know if there is such plugin for plex?

Thanks for your time.

/ P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users