Jump to content


Photo

SVT Play krånglar


  • Please log in to reply
55 replies to this topic

#21 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7685 posts
  • Location: Sweden

Posted 09 July 2010 - 12:39 PM

Kanonbra jobbat Magnus. Zippa och skicka upp den som bundle i Campfire så pratar jag med Isaac så den kommer ut i App Storen så snart som möjligt.

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#22 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7685 posts
  • Location: Sweden

Posted 10 July 2010 - 03:14 PM

Nu ligger nya versionen av SVT Play uppladdad i App Store. Gå in och uppdatera och se om det fungerar för er.
Tack Magnus för gott arbete!

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#23 frpet1

frpet1

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 July 2010 - 07:05 PM

Här är en version som fungerar!

[...]

Ett problem kan vara att SVT verkar gå över till MP4 och erbjuda olika upplösningar för olika bandbredder... Denna kod klipper ju bara den URL som kommer först i listan. Enligt frpet så är det (enligt stickprovskontroll) den mest högupplösta versionen som kommer först.

a) Det kan man inte alltid veta
B) Det kanske inte alltid är lämpligt, om man inte har bra bandbredd.


Härligt!

Magnus, borde man kanske upp:a VERSION= i patchen också?

Atrus, kan du commit:a Magnus patch?

Edit: Never mind... jag hade en cached sida så jag såg inte Atrus svar, och efter att ha sökt efter uppdatering i Plex igen så hittades nya versionen.

Edited by frpet1, 10 July 2010 - 07:10 PM.


#24 Vic Vega

Vic Vega

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 14 July 2010 - 07:08 PM

Testkör nya svt play appen på två olika maskiner men endast vissa program går att starta.

Kan någon tex få igång Nyheter -> Aktuellt ?

#25 Magnus Lööf

Magnus Lööf

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 14 July 2010 - 07:27 PM

Testkör nya svt play appen på två olika maskiner men endast vissa program går att starta.

Kan någon tex få igång Nyheter -> Aktuellt ?


Det verkar vara en viss fördröjning innan vissa högupplösta program startar, kan ta upp till en halv minut. (Medan man väntar är skärmen helt svart).

Jag får upp tidigare utsändningar av Aktuellt, dock inte den som sänds "Live".

Om man går in på aktuellt medan programmet sänds så fungerar det INTE.

Dessutom behöver menyn Livsändningar lite kärlek, SVTs sida har förmodligen gjorts om:

21:26:28.795608: com.plexapp.plugins.svtplay     :   (Framework) Handling request :  /video/svt/live||||Livesändningar
21:26:28.795824: com.plexapp.plugins.svtplay     :   


- - - - - - - - - - - - - - - 
Request 1 ['live||||Lives\xc3\xa4ndningar']
21:26:29.273745: com.plexapp.plugins.svtplay     :   (Framework) Request to http://svtplay.se/?cb,a1364145,1,f,-1/pb,a1596757,1,f, return 87160 bytes
21:26:29.291671: com.plexapp.plugins.svtplay     :   (Framework) An exception happened:
Traceback (most recent call last):
  File "/Users/tv/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/0/Python/PMS/Plugin.py", line 468, in __run
    result = handler(pathNouns, count)
  File "/Users/tv/Library/Application Support/Plex Media Server/Plug-ins/SVT Play.bundle/Contents/Code/__init__.py", line 83, in HandleRequest
    menuItems.extend(BuildLiveMenu())
  File "/Users/tv/Library/Application Support/Plex Media Server/Plug-ins/SVT Play.bundle/Contents/Code/__init__.py", line 145, in BuildLiveMenu
    liveName = strip_all(unicode(element.xpath("../../../h3/text()")[0]))
IndexError: list index out of range


#26 Tvamvarg

Tvamvarg

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 10 August 2010 - 09:01 AM

Funkar fint - tackar. Dock får man vad jag kan se inte upp 'more' eller liknande på exv In Treatment då det innehåller >5 episoder.

#27 nisse

nisse

    Member

  • Members
  • PipPip
  • 42 posts

Posted 11 August 2010 - 06:18 AM

Hej

Har precis laddat in den uppdaterade plugin:en för SVT Play.
Det skumma är att jag bara får ljudet men ingen bild.

Dilalogruta "Öpnnar ström" visas. Ljud men ingen bild alltså.

Har testat med t.ex. "ScreenCastsOnline". Där får jag både ljud och bild.
Nån idé?

#28 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7685 posts
  • Location: Sweden

Posted 11 August 2010 - 11:39 AM

Hej

Har precis laddat in den uppdaterade plugin:en för SVT Play.
Det skumma är att jag bara får ljudet men ingen bild.

Dilalogruta "Öpnnar ström" visas. Ljud men ingen bild alltså.

Har testat med t.ex. "ScreenCastsOnline". Där får jag både ljud och bild.
Nån idé?

Kolla så du inte råkat uppdatera till Flash 10.1 (och isåfall måste du nedgradera till en 10.0-version). Det är möjligt att ScreenCastsOnline använder t.ex. Silverlight och det är därför den fungerar.

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#29 nisse

nisse

    Member

  • Members
  • PipPip
  • 42 posts

Posted 11 August 2010 - 04:21 PM

Kolla så du inte råkat uppdatera till Flash 10.1 (och isåfall måste du nedgradera till en 10.0-version). Det är möjligt att ScreenCastsOnline använder t.ex. Silverlight och det är därför den fungerar.


Jag har googlat runt efter 10.0, men inte hittat nåt. Var hittaar jag flash player 10.0?

#30 Magnus Lööf

Magnus Lööf

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 August 2010 - 04:36 PM

Jag har googlat runt efter 10.0, men inte hittat nåt. Var hittaar jag flash player 10.0?


http://lmgtfy.com/?q...chived versions ;-)

#31 nisse

nisse

    Member

  • Members
  • PipPip
  • 42 posts

Posted 11 August 2010 - 04:44 PM

http://lmgtfy.com/?q=adobe+flash+player+archived+versions ;-)


Tack! Jag la in version 10.0.42.34. Nu funkar SVT Play igen.

#32 Tvamvarg

Tvamvarg

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 12 August 2010 - 05:03 AM

Kolla så du inte råkat uppdatera till Flash 10.1 (och isåfall måste du nedgradera till en 10.0-version). Det är möjligt att ScreenCastsOnline använder t.ex. Silverlight och det är därför den fungerar.

Vore nice med 10.1-stöd dock. Vet du något om möjligheter/planer där?

#33 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7685 posts
  • Location: Sweden

Posted 12 August 2010 - 10:55 AM

Vore nice med 10.1-stöd dock. Vet du något om möjligheter/planer där?

Absolut, de jobbar på det :)

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#34 Pelle

Pelle

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 16 August 2010 - 09:46 PM

Absolut, de jobbar på det :)


Jag använder inte Plex, men har noterat att på svtplay fungerar bara live-sändningarna om man stänger av hårdvaruaccelerationen i flash player (högerklicka på en film och välj inställningar). Det kanske kan få det att fungera i Plex också?

Kanske dags att testa Plex igen, det var något år sedan nu...

#35 tassitassi

tassitassi

    Rock Star

  • Members
  • PipPipPipPipPip
  • 599 posts

Posted 17 August 2010 - 01:06 PM

Jag använder inte Plex, men har noterat att på svtplay fungerar bara live-sändningarna om man stänger av hårdvaruaccelerationen i flash player (högerklicka på en film och välj inställningar). Det kanske kan få det att fungera i Plex också?

Kanske dags att testa Plex igen, det var något år sedan nu...


Ja, tekniskt sett så borde det funka i Plex, om jag inte misstar mig.

#36 Lunkan

Lunkan

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 03 September 2010 - 08:41 PM

Hej på er, väldigt ny i forumet men använt plex någon månad iaf.

Tyvärr verkar inte svtplay "fixat sig" i den nya releasen heller :(

Har någon lite info om när stödet för flash är åtgärdat?

#37 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7685 posts
  • Location: Sweden

Posted 04 September 2010 - 11:31 PM

Hej på er, väldigt ny i forumet men använt plex någon månad iaf.

Tyvärr verkar inte svtplay "fixat sig" i den nya releasen heller :(

Har någon lite info om när stödet för flash är åtgärdat?

Om du syftar på stöd för Flash 10.1 så har utvecklarna inte hittat någon lösning ännu. Adobe spärrade i 10.1 den lösning som vi använt hittills. Inget datum kan ges eftersom ingen lösning hittats ännu.

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#38 Akrug

Akrug

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 September 2010 - 03:47 PM

När jag går in i Livesändningar får jag över huvud taget inte upp någon undermeny. Är detta samma problem som andra haft tidigare? Så här säger loggen:

Sep 19, 2010 17:41:40 [0xb079a000] DEBUG - Request: GET /video/svt/live||||Livesändningar [::ffff:192.168.0.10]
Sep 19, 2010 17:41:40 [0xb079a000] DEBUG - Plug-in com.plexapp.plugins.svtplay has been used 42 times.
Sep 19, 2010 17:41:40 [0xb079a000] DEBUG - [com.plexapp.plugins.svtplay] Sent command: GET /video/svt/live||||Livesändningar

Sep 19, 2010 17:41:40 [0xb079a000] DEBUG - Reading 0 bytes in the body, code is 500
Sep 19, 2010 17:41:40 [0xb079a000] DEBUG - [com.plexapp.plugins.svtplay] Completed command GET /video/svt/live||||Livesändningar in 0.000241 seconds.


#39 dontpanic

dontpanic

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 05 October 2010 - 07:03 AM

Om du syftar på stöd för Flash 10.1 så har utvecklarna inte hittat någon lösning ännu. Adobe spärrade i 10.1 den lösning som vi använt hittills. Inget datum kan ges eftersom ingen lösning hittats ännu.


Jag har senaste versionen av OSX och flash. Är det för att jag har senaste versionen som det inte fungerar? Jag får bara upp en myrornaskrig-bild i kanske 2 sekunder sen svart, ibland fungerar endast ljudet.

#40 Jess

Jess

    Member

  • Members
  • PipPip
  • 16 posts

Posted 05 October 2010 - 07:32 AM

Jag har senaste versionen av OSX och flash. Är det för att jag har senaste versionen som det inte fungerar? Jag får bara upp en myrornaskrig-bild i kanske 2 sekunder sen svart, ibland fungerar endast ljudet.



jag kör version flash v 10.1.85.3
Funkar utmärkt för mig




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users