Jump to content


Photo

Help with port forwarding


  • Please log in to reply
21 replies to this topic

#1 cyclopsthere

cyclopsthere

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 September 2010 - 01:11 AM

Forgive me if I'm one of 1000 people asking this question but I haven't been able to find the answer quite yet on the forums.

I'm attempting to setup port forwarding on my Time Machine (Airport Extreme) so I can access Plex from my iPhone and I can't seem to connect no matter what I try.

I've attached the configuration I'm attempting to use on the Airport Extreme, then I add my public IP address to plex and the standard port yet I'm unable to connect.

I can only assume I'm not forwarding the ports correctly.

Any help would be great.

#2 tuyenvo

tuyenvo

    Member

  • Members
  • PipPip
  • 19 posts

Posted 01 September 2010 - 01:38 AM

Here here. I could use some help, as well. Been banging my head on this issue since I first downloaded the iPhone app.

#3 tpaster

tpaster

    Member

  • Members
  • PipPip
  • 20 posts

Posted 01 September 2010 - 01:47 AM

Yes some basic instructions on how to set this up would be great. Though my understanding is that in future releases the handshake between router and PMS will be handled automatically. Thanks.

#4 tuyenvo

tuyenvo

    Member

  • Members
  • PipPip
  • 19 posts

Posted 01 September 2010 - 01:49 AM

Yes some basic instructions on how to set this up would be great. Though my understanding is that in future releases the handshake between router and PMS will be handled automatically. Thanks.


After some more fiddling, I just figured it out. Here's the setting on the port forwarding page on my Time Capsule. The Private IP address needs to be the IP address of the computer that the PMS is on. That was my issue before I updated it.

Attached Files



#5 drewojensen

drewojensen

    Member

  • Members
  • PipPip
  • 11 posts

Posted 01 September 2010 - 03:09 AM

I'm also stuck not getting my porting to work. I've got a good ole' linksys wrt45gs and I've followed everything to the T at portforward.com and nothing. At first I thought it was maybe that I have it running through a switch so I connect my mini directly up to the wireless router and still nothing. I do have a dsl modem which can do port forwarding but from everything I've read that shouldn't be a problem.

#6 BEASTMAN

BEASTMAN

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 September 2010 - 04:32 AM

Okay, this is starting to drive me a little nuts.

I want to be able to setup the app to work over 3g. Wifi works great.

I have setup the port forwarding like the screenshot above with the only difference being the ip is formatted 10.0.1.X

I have a Time Capsule plugged into an AT&T U-Verse 2Wire modem/router in bridge mode

Any advice would be greatly appreciated

#7 Jarpo

Jarpo

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 September 2010 - 04:57 AM

I've gotten mine to work with the iPhone app over 3G.
The first thing I did was set a username and password on the plex media server.
Then I looked up my WAN IP address (I'm using a router). Using your 192.168.xxx.xxx won't work over 3G because that is a local address.
You will need to look in your router's status or WAN menu to find your global IP address. That will be the IP address that you enter into the iOS app for the server.
The last step is to find the IP address of the computer that is using the Plex Media Server. In my case it is 192.168.1.106. I forward the port 32400 in TCP only, like the above poster shows in his picture, to that IP address and it connected easily over 3G.

#8 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 01 September 2010 - 02:59 PM

I posted more detailed instructions here. but remember, port forwarding usually has to be attached to created a static IP address via DHCP (instructions of which are also in the prior link). when you are trying to connect to a machine on your local network (this includes a TC, NAS or otherwise), your router may be assigning dynamic addresses to the hardware, and so if you port forward (which requires an IP address), it may not always work. the directions i provided at the link do this but

1. you need to define a static IP address for the machine you wish to access from outside your network
2. you need to define which port forward is assigned to that IP and possibly
3. you need to use a service like DynDNS so that rather than have to memorize your external IP address which is assigned by your ISP (which may also be dynamic) you can have a static external IP address.

#9 bmorris110

bmorris110

    Dedicated Member

  • Members
  • PipPipPip
  • 187 posts
  • Location: Atlanta

Posted 06 September 2010 - 04:05 AM

I posted more detailed instructions here. but remember, port forwarding usually has to be attached to created a static IP address via DHCP (instructions of which are also in the prior link). when you are trying to connect to a machine on your local network (this includes a TC, NAS or otherwise), your router may be assigning dynamic addresses to the hardware, and so if you port forward (which requires an IP address), it may not always work. the directions i provided at the link do this but

1. you need to define a static IP address for the machine you wish to access from outside your network
2. you need to define which port forward is assigned to that IP and possibly
3. you need to use a service like DynDNS so that rather than have to memorize your external IP address which is assigned by your ISP (which may also be dynamic) you can have a static external IP address.


You don't need DynDNS, just add it as a bookmark to your bookmark bar or iPhone home screen. I do that for Clutch/Transmission.
But ever since I got AT&T U-verse, they seemed to have blocked my ports. Clutch worked fine with Comcast.
Mac Mini (2009) OSX 10 4GB RAM, Plex 0.9

I  my bushel of Macs.
www.brandonmorris.com

#10 bmorris110

bmorris110

    Dedicated Member

  • Members
  • PipPipPip
  • 187 posts
  • Location: Atlanta

Posted 06 September 2010 - 04:07 AM

Okay, this is starting to drive me a little nuts.

I want to be able to setup the app to work over 3g. Wifi works great.

I have setup the port forwarding like the screenshot above with the only difference being the ip is formatted 10.0.1.X

I have a Time Capsule plugged into an AT&T U-Verse 2Wire modem/router in bridge mode

Any advice would be greatly appreciated


I too have AT&T U-verse.
I have been trying to get Clutch/Transmission to work.
It was working fine with Comcast, but not with AT&T.

I'm trying to find a fix too as well.
I know you have to turn on DMZplus mode on the gateway.
But the ports are still closed.
Mac Mini (2009) OSX 10 4GB RAM, Plex 0.9

I  my bushel of Macs.
www.brandonmorris.com

#11 bmorris110

bmorris110

    Dedicated Member

  • Members
  • PipPipPip
  • 187 posts
  • Location: Atlanta

Posted 06 September 2010 - 04:12 AM

I've gotten mine to work with the iPhone app over 3G.
The first thing I did was set a username and password on the plex media server.
Then I looked up my WAN IP address (I'm using a router). Using your 192.168.xxx.xxx won't work over 3G because that is a local address.
You will need to look in your router's status or WAN menu to find your global IP address. That will be the IP address that you enter into the iOS app for the server.
The last step is to find the IP address of the computer that is using the Plex Media Server. In my case it is 192.168.1.106. I forward the port 32400 in TCP only, like the above poster shows in his picture, to that IP address and it connected easily over 3G.


So in the Plex iOS app I put my Global IP, but in the Airport mapping, I put my Manual local IP for the 192.168.1.x?
Mac Mini (2009) OSX 10 4GB RAM, Plex 0.9

I  my bushel of Macs.
www.brandonmorris.com

#12 bmorris110

bmorris110

    Dedicated Member

  • Members
  • PipPipPip
  • 187 posts
  • Location: Atlanta

Posted 06 September 2010 - 04:29 AM

Okay, this is starting to drive me a little nuts.

I want to be able to setup the app to work over 3g. Wifi works great.

I have setup the port forwarding like the screenshot above with the only difference being the ip is formatted 10.0.1.X

I have a Time Capsule plugged into an AT&T U-Verse 2Wire modem/router in bridge mode

Any advice would be greatly appreciated


I got Clutch to work finally with AT&T. I suppose DMZplus worked?

This helped alot:
http://wiki.plexapp....ex.php/Plex_iOS
Mac Mini (2009) OSX 10 4GB RAM, Plex 0.9

I  my bushel of Macs.
www.brandonmorris.com

#13 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 06 September 2010 - 11:09 AM

You don't need DynDNS, just add it as a bookmark to your bookmark bar or iPhone home screen. I do that for Clutch/Transmission.
But ever since I got AT&T U-verse, they seemed to have blocked my ports. Clutch worked fine with Comcast.


You don't need a service like DynDNS if your ISP gives you a static IP address, if they don't, you need it.

#14 bmorris110

bmorris110

    Dedicated Member

  • Members
  • PipPipPip
  • 187 posts
  • Location: Atlanta

Posted 09 September 2010 - 03:34 PM

You don't need a service like DynDNS if your ISP gives you a static IP address, if they don't, you need it.


they don't. but dyndns just gives you a text address instead of numbers.
just type in the numbers one time in your phone or browser then bookmark it your bar or homescreen.
Mac Mini (2009) OSX 10 4GB RAM, Plex 0.9

I  my bushel of Macs.
www.brandonmorris.com

#15 Ron V

Ron V

    Member

  • Members
  • PipPip
  • 27 posts

Posted 13 October 2010 - 11:53 PM

Works great for me! Note that you may need to set up port forwarding on two routers if, for example, you have a cable modem hooked up to a separate wifi router.

Plex hardware setup:

  • Plex Media Server: 2011 MacMini - 2GHz Intel Core i7, 8GB RAM, 10TB LaCie 5big Thunderbolt external drive, Mac OS X Lion Server, wired network
  • Additional Plex Server: 2010 MacMini 2.4GHz Intel Core Duo, 8GB RAM, Mac OS Lion - wired network
  • Plex Clients: 2x Roku2 XS, 2x Roku3 (1 wired via 1GB switch, remainder via wifi), 1x Chromecast, and multiple iOS, Android, Kindle Fire HDX devices.

#16 Ynot

Ynot

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 11 June 2011 - 05:16 PM

I'm attempting to set this up, but right from the get go I'm having problems. In the image above it shows a typical IP addy in the "Private IP Address:" field. Mine shows the AirPort addy 10.0.1.201. I cannot delete that addy completely, just the "201", to be able to enter the other address supplied by my ISP. Under the "Choose a service" drop-down it doesn't matter what's chosen, this field remains the same. I am able to input 32400 in the TCP fields.

If it matters, my setup is a ISP (Charter) provided router (Motorola Surfboard) connected to my Time Capsule. I do not own a static IP addy, it's dynamic.

Where do I get my "Global IP"?

Thanks for any help.

#17 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 11 June 2011 - 07:07 PM

The first step of the wiki entry details setting up a dyndns account so you can use a constant hostname instead of a changing external (or global) ip address.
http://wiki.plexapp....gurePortForward

If you need further help setting up your time capsule to give a static ip to your PMS box and forward ports to this static ip, some further details about your network would be helpful. I imagine your surfboard is acting as a simple modem and not a router, but it's possible it's acting as a router as well and you're effectively double NAT'ed and I recommend changing it to act as a dumb modem.
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#18 MJJ23

MJJ23

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 June 2011 - 11:07 AM

Hi, i use public transport about 3-4 hours a day, and i would love to know how to port forward so i could watch movies that i have on my Plex server on my iPhone, over 3G. I have cable internet, i use a Netgear CGD24N v2. If someone would please help me with how to port forward, it would be very much appreciated. Thank you.

#19 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 13 June 2011 - 01:05 PM

Hi, i use public transport about 3-4 hours a day, and i would love to know how to port forward so i could watch movies that i have on my Plex server on my iPhone, over 3G. I have cable internet, i use a Netgear CGD24N v2. If someone would please help me with how to port forward, it would be very much appreciated. Thank you.

From what I can tell you'll need to talk to your ISP to set up port forwarding on this router.
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#20 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 13 June 2011 - 05:54 PM

Hi, i use public transport about 3-4 hours a day, and i would love to know how to port forward so i could watch movies that i have on my Plex server on my iPhone, over 3G. I have cable internet, i use a Netgear CGD24N v2. If someone would please help me with how to port forward, it would be very much appreciated. Thank you.


Have you read the wiki?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users