Jump to content


Photo

Requests/improvements for Rapier


  • Please log in to reply
14 replies to this topic

#1 Maximo

Maximo

    Member

  • Members
  • PipPip
  • 46 posts

Posted 19 October 2010 - 10:17 PM

Hi!

I Love this skin. I realise this is not the most used nor your highest prioritised skin, but I hope you could make some changes/additions if only for me :P

First some bugs:

1. Almost everytime the media server dialog pop ups saying "Waiting for server", the dialog window flashes on/off during the operation before it disappears. It should just pop up stay there and go away when its done, no flashing.
2. I have problems with the itunes integration. Shows no icons in the menu where you can choose artist/album/playlist ++. And when i select one of the menu items, lets say artists, nothing displays. No playlists, no albums.
3. When i turn of studio flags in preferences they still show. If this is toggled off the WarnerBrothers, Disney ++ logos shouldn't show when browsing movies, right?
4. Realy slow opening of iphoto pictures. Browsing is fast, but when you select a single image to view fullscreen it takes ages before opening.

Then some requests:
1. Please make it a preference to make the top menu almost totaly black, set the opacity (10%, 30%, 50%), And an option to hide it, only showing the clock.
2. Set individually icons for media server sections on the home menu. (Own icons for movies/tvshow).

This are the once i can think of right now. I read in another topic on the rapier section that you don't have much time to work on this skin. I would like to help you out on this one, but i have almost no coding skills. I have design experience and would like to help out if i can, although your skin already looks polished and nice! Hope that either you or someone else can continue working on this skin.

Thanks!
-Kris
  • Fereefricle, boppreeds, InsichsineDew and 14 others like this

#2 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 21 October 2010 - 03:06 AM

I too was bothered by the 'generic' Plex icons, so I worked these up a couple of week ago. While you can hard-code an icon to a particular 'slot' in the library (see below), changes to your media sections can/will result in (say) the music icon attached to the TV Shows library. I don't know enough about XML or skinning to know how they could be added or matched dynamically.


Attached File  PMS_Icons.png   212.52KB   23 downloads


Attached File  Screen shot 2010-10-07 at 8.14.46 AM.png   764.36KB   24 downloads
  • Woodierge, aspelsota, Petshence and 1 other like this

#3 Maximo

Maximo

    Member

  • Members
  • PipPip
  • 46 posts

Posted 21 October 2010 - 09:42 AM

I too was bothered by the 'generic' Plex icons, so I worked these up a couple of week ago. While you can hard-code an icon to a particular 'slot' in the library (see below), changes to your media sections can/will result in (say) the music icon attached to the TV Shows library. I don't know enough about XML or skinning to know how they could be added or matched dynamically.


Attached File  PMS_Icons.png   212.52KB   23 downloads


Attached File  Screen shot 2010-10-07 at 8.14.46 AM.png   764.36KB   24 downloads


Oh I love em!

Do you mind sharing the icons?
Just to clarify; did you get the icons to stick to the right section when you finaly found the right slot? Or do they change for every reboot?

Thanks a lot!
-Kris
  • Woodierge, Petshence and pattAloff like this

#4 Roosie

Roosie

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 23 October 2010 - 04:44 PM

Hi!

I Love this skin. I realise this is not the most used nor your highest prioritised skin, but I hope you could make some changes/additions if only for me :P

First some bugs:

1. Almost everytime the media server dialog pop ups saying "Waiting for server", the dialog window flashes on/off during the operation before it disappears. It should just pop up stay there and go away when its done, no flashing.
2. I have problems with the itunes integration. Shows no icons in the menu where you can choose artist/album/playlist ++. And when i select one of the menu items, lets say artists, nothing displays. No playlists, no albums.
3. When i turn of studio flags in preferences they still show. If this is toggled off the WarnerBrothers, Disney ++ logos shouldn't show when browsing movies, right?
4. Realy slow opening of iphoto pictures. Browsing is fast, but when you select a single image to view fullscreen it takes ages before opening.

Then some requests:
1. Please make it a preference to make the top menu almost totaly black, set the opacity (10%, 30%, 50%), And an option to hide it, only showing the clock.
2. Set individually icons for media server sections on the home menu. (Own icons for movies/tvshow).

This are the once i can think of right now. I read in another topic on the rapier section that you don't have much time to work on this skin. I would like to help you out on this one, but i have almost no coding skills. I have design experience and would like to help out if i can, although your skin already looks polished and nice! Hope that either you or someone else can continue working on this skin.

Thanks!
-Kris


I love them, can you share them with us?
  • Woodierge and pattAloff like this

#5 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 24 October 2010 - 04:26 PM

Thanks for the interest in the home icons. I'll be glad to share them, but installation is not for those afraid to get their hands dirty. ;) It's gonna require a good write-up to explain how to do it and I haven't found the time yet.

Kris: Yes, the icons 'stick' in the slot where you place them (even through reboot). The issue is that if you then add/delete a section in the library, you will probably need to edit the the code. As I said, I need to write it up.
  • pattAloff likes this

#6 zank

zank

    Dedicated Member

  • Members
  • PipPipPip
  • 195 posts

Posted 25 October 2010 - 07:30 PM

isnt there an option in the skin settings to enable custom category icons and thus not requiring detailed skin changes?

#7 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 25 October 2010 - 08:35 PM

Well, there is, except it doesn't work. I suspect that is due to the 'dynamic' nature of the Plex Media Server libraries. As I've used neither XBMC, nor any version of Plex < 0.9, I can't say how it was supposed to work. In fact, if you set a custom icon in the skin settings, the 'hard' icon changes I've made are ignored.

#8 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 25 October 2010 - 11:25 PM

OK, here you go. Let's see if I can make sense of this. There may be another way to make this happen, but I haven't found it (yet).

Icons are available here:

Attached File  Rapier-homecategory-icons.zip   985.38KB   62 downloads

Rapier Icons:

Attached File  home-icon-pms.PNG   155.25KB   14 downloads

Rapier [MikotoBuild] Icons:

Attached File  home-icon-Mikoto-pms.PNG   101.94KB   5 downloads

Credit for the original Rapier icons goes to user scarf ([RELEASE] Rapier 3.06)
Credit for the original Rapier Mikoto icons goes to user Matteius ([MOD] DHARMA Rapier [MikotoBuild] v1.1.2)
Credit for the original Plex icon goes to the Plex Team!

To install:

Extract the icons and place them in the ~/Library/Application Support/Plex/skin/Rapier-for-Plex/images/homecategories/icons folder.

Here is the dirty part. In the file 720p/includes_Home.xml (found in the Rapier-for-Plex folder), beginning at line 321, you will find this section of code:

<control type="image">
                <description>PMS Dynamic Sections Icon</description>
                <include>HomeMenuIconDim</include>
                <texture>pms.png</texture>
                <aspectratio>keep</aspectratio>
                <visible>Container(300).HasFocus(1000)</visible>
                <include>HomeMenuIconAnim</include>
            </control>
            
            …
            …
            
            <control type="image">
                <description>PMS Dynamic Sections Icon</description>
                <include>HomeMenuIconDim</include>
                <texture>pms.png</texture>
                <aspectratio>keep</aspectratio>
                <visible>Container(300).HasFocus(1020)</visible>
                <include>HomeMenuIconAnim</include>
            </control>

where 'Container(300).HasFocus(1000)' points to the first library section in the Media Manager, 'Container(300).HasFocus(1001)' the second, etc. If 'Movies' is your first library section, just change the <texture>pms.png</texture to <texture>../images/homecategories/icons/home-movies-icon-pms.png</texture>, etc.

Original library sections:
Attached File  Screen shot 2010-10-24 at 1 copy.PNG   14.85KB   4 downloads

Home screen:
Attached File  Screen shot 2010-10-07 at copy.PNG   161.3KB   6 downloads


Now for the tricky part. The 'Container(300).HasFocus(10xx)' icons are assigned to the library sections is alphabetical order. If, say, you add a new library section and call it 'Local', the '…HasFocus(1000)' icon will be associated with the 'Local' section, NOT the 'Movies' section.

Updated library sections:
Attached File  Screen shot 2010-10-24 at 2 copy.PNG   15.53KB   5 downloads

Home screen (Local section now has Movie icon):
Attached File  Screen shot 2010-10-24 at copy.PNG   160.73KB   7 downloads

So, you'll have to keep track of your library sections and change the includes_Home.xml file accordingly.


While there does appear to be code to change the home icons via the skin preferences, I'm sure that's from the original XBMC code. The dynamic nature of the new Plex/PMS architecture kind of puts the squash on that.

[remember, always work from a copy of the original file.]

That's all I got. I'm sure I left something out, but I'm sure you'll let me know. ;)

Edited by gedoode, 26 October 2010 - 12:48 AM.


#9 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7442 posts
  • Location: Maui

Posted 25 October 2010 - 11:57 PM

There is support for associating a poster/icon for each section in the Media Manager, so I wonder if this just needs to be exposed in the skin.

Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.


#10 Reddragon220

Reddragon220

    Skinning God

  • Members
  • PipPipPip
  • 276 posts
  • Location: New York

Posted 26 October 2010 - 12:33 AM

Edited into oblivion.

#11 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 26 October 2010 - 01:17 AM

elan,

That sounds like a much more elegant (and magical!) solution than what I have above. I'd seen the 'Choose Icon' option in the 'Customize Section' part of the Media Manager and just assumed it was for the small icon next to the section name. As is, the Custom Category Icons in the skin preferences DO change the icons for the "plug-in" sections, just not for the PMM library sections.

Thanks!

#12 Maximo

Maximo

    Member

  • Members
  • PipPip
  • 46 posts

Posted 26 October 2010 - 02:10 PM

There is support for associating a poster/icon for each section in the Media Manager, so I wonder if this just needs to be exposed in the skin.


Hey elan! Thanks for stopping by the minority of plexville and share your great word of visdom :) I think this will be the best solution for the problem. Just hope El Massman will dedicate a bit of his busy time to implement this.


elan,

That sounds like a much more elegant (and magical!) solution than what I have above. I'd seen the 'Choose Icon' option in the 'Customize Section' part of the Media Manager and just assumed it was for the small icon next to the section name. As is, the Custom Category Icons in the skin preferences DO change the icons for the "plug-in" sections, just not for the PMM library sections.

Thanks!


Hey gedoode! Thanks for your workaround for this problem. Will try it when i get the time. Yes in the settings you can change menu icons for plug-ins. The "Choose Icon" in the Media Manager changes does not change the small icons to the lefte in the Media Manager. Rather if you change for example the movies icon and select in in the Rapiers main menu, when you come to the list where you can select "all movies", "by year", "by actor"++ this icon will show next to the list (original list view). So I believe this could be implemented in the main menu as well.

-Kris

#13 degTech

degTech

    Member

  • Members
  • PipPip
  • 54 posts
  • Location: Alabama, USA

Posted 26 October 2010 - 11:01 PM

Hey gedoode! Thanks for your workaround for this problem. Will try it when i get the time. Yes in the settings you can change menu icons for plug-ins. The "Choose Icon" in the Media Manager changes does not change the small icons to the lefte in the Media Manager. Rather if you change for example the movies icon and select in in the Rapiers main menu, when you come to the list where you can select "all movies", "by year", "by actor"++ this icon will show next to the list (original list view). So I believe this could be implemented in the main menu as well.

-Kris


Thanks for the tip on the custom icon being displayed in the 'Extra Menu Level'. Once I started hacking on the icons, never moved past the home menu to notice it. If I could just figure out how that icon gets placed there, we might get somewhere on getting the icon on the home screen. I'm trying to wrap my head around the concepts of skinning XML (and getting a headache).

deg

#14 Maximo

Maximo

    Member

  • Members
  • PipPip
  • 46 posts

Posted 28 November 2010 - 07:32 AM

Hi again!

gedoode: have your search for the section icon led to anything?

Also is this skin dead? By that i mean that the author's not uptading it anymore... El Massman said that he wished he could give this skin to someone else because he had to much on his hands. If i only could xml coding.... hmm. somone willing to give this awsome skin a chance?

Thanks
Kris out..

#15 john04

john04

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 23 April 2012 - 09:52 AM

1. Almost everytime the media server dialog pop ups saying "Waiting for server", the dialog window flashes on/off during the operation before it disappears. It should just pop up stay there and go away when its done, no flashing.
2. I have problems with the itunes integration. Shows no icons in the menu where you can choose artist/album/playlist ++. And when i select one of the menu items, lets say artists, nothing displays. No playlists, no albums.
3. When i turn of studio flags in preferences they still show. If this is toggled off the WarnerBrothers, Disney ++ logos shouldn't show when browsing movies, right?
4. Realy slow opening of iphoto pictures. Browsing is fast, but when you select a single image to view fullscreen it takes ages before opening.