Jump to content


Photo

Plex Client for Apple TV (2G)


  • Please log in to reply
1768 replies to this topic

#1181 Bennsen

Bennsen

    Member

  • Members
  • PipPip
  • 20 posts

Posted 07 January 2011 - 02:06 AM

Did you do this from a fresh JB?

I tried this using both the com.nito.nitoTV package as well as the .deb that's available for DL from that link.

With the .deb file, it completely broke my installation and I needed to restore to factor settings and JB again.

With the com.nito.nitoTV package, it seemed to work however the screen was constantly flashing until I removed the com.plex.client-plugin

Seems like it'd be better to wait for ambertation.de to come back online


i restore to original os 4.2.1
then i jb with pwnage.
after that i install nitoTV via ssl@ip-apple-tv Terminal:

Command 1.
echo “deb http://awkwardtv.dyndns.tv ./” > /etc/apt/sources.list.d/awkwardtv.list

Command 2.
apt-get update

Command 3.
apt-get install com.nito.nitoTV

Command 4.
killall AppleTV



and then i do this installation
http://appletvblogr....-1-frappliance/

Posted Image
Posted Image
Posted Image
Apple TV 2G
iOS 4.2.1

#1182 Confuzed One

Confuzed One

    Member

  • Members
  • PipPip
  • 11 posts

Posted 07 January 2011 - 02:21 AM

My AppleTV2 went to sleep, and when i re-opened it (after 1 hour), 4x my PMS name showed up... when i clicked on one, it simply rebooted the Lowtide.

And now there is no way to refresh the server screen.. i simply "wait" for my server name to popup?

#1183 squirrellydw

squirrellydw

    Dedicated Member

  • Members
  • PipPipPip
  • 186 posts

Posted 07 January 2011 - 02:51 AM

From the screenshot above the cover art looks great. Maybe move it up and to the left and put the plot info beside the cover art?

#1184 lofty

lofty

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 January 2011 - 03:11 AM

I was up with plex but ended up doing a fresh start.

In following Bennson directions i get the following in my terminal window (takes awhile too)

.............

Err http://www.ambertation.de ./downloads/PLEX/ Release.gpg
POSIX: Operation timed out
Ign http://www.ambertation.de ./downloads/PLEX/ Release
Ign http://www.ambertation.de ./downloads/PLEX/ Packages
Ign http://www.ambertation.de ./downloads/PLEX/ Packages
Err http://www.ambertation.de ./downloads/PLEX/ Packages
POSIX: Operation timed out
Fetched 23.3kB in 6min 16s (62B/s)
W: Failed to fetch http://www.ambertati...LEX/Release.gpg POSIX: Operation timed out

W: Failed to fetch http://www.ambertati...LEX/Packages.gz POSIX: Operation timed out

E: Some index files failed to download, they have been ignored, or old ones used instead.
Apple-TV:~ root#

...............

i'm currently stumpped

#1185 GabLeRoux

GabLeRoux

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 January 2011 - 03:24 AM

ambertation.de is still down, I tried so many things to get it to work that I have to restore my appleTV :(. Any mirrors out there!? Arrgh

#1186 lofty

lofty

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 January 2011 - 03:41 AM

ack :( now my server won't show up

PLEX is absolutely amazing, and getting better each day, just these damn installation setbacks when the servers (ambertation) go down more than my wife.

#1187 Bennsen

Bennsen

    Member

  • Members
  • PipPip
  • 20 posts

Posted 07 January 2011 - 04:06 AM

ambertation.de is still down, I tried so many things to get it to work that I have to restore my appleTV :(. Any mirrors out there!? Arrgh

what is with: http://appletvblogr....-1-frappliance/
Apple TV 2G
iOS 4.2.1

#1188 Bennsen

Bennsen

    Member

  • Members
  • PipPip
  • 20 posts

Posted 07 January 2011 - 04:08 AM

I was up with plex but ended up doing a fresh start.

In following Bennson directions i get the following in my terminal window (takes awhile too)

.............

Err http://www.ambertation.de ./downloads/PLEX/ Release.gpg
POSIX: Operation timed out
Ign http://www.ambertation.de ./downloads/PLEX/ Release
Ign http://www.ambertation.de ./downloads/PLEX/ Packages
Ign http://www.ambertation.de ./downloads/PLEX/ Packages
Err http://www.ambertation.de ./downloads/PLEX/ Packages
POSIX: Operation timed out
Fetched 23.3kB in 6min 16s (62B/s)
W: Failed to fetch http://www.ambertati...LEX/Release.gpg POSIX: Operation timed out

W: Failed to fetch http://www.ambertati...LEX/Packages.gz POSIX: Operation timed out

E: Some index files failed to download, they have been ignored, or old ones used instead.
Apple-TV:~ root#

...............

i'm currently stumpped


i do not install plex via terminal - i install nitoTV.

for plex i use this way: http://appletvblogr....-1-frappliance/
Apple TV 2G
iOS 4.2.1

#1189 lofty

lofty

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 January 2011 - 04:31 AM

got it :)

installed nito through terminal.
tried to install plex through trminal - but got errors (server wouldn't show)

>> Installed plex through nito.tv << !! then it worked !!

updated to 0.5.7 through SFTP
everything working good on my quick test.

looking forward to new updates

FEATURE SUGGESTIONS

#1 on the list would be the option to resume or restart a show
I know you guys are working on scrubbing.

perhaps an option to password protect shows from media server - a master password and a quick checkbox in media server to enable password before a video is loaded.(keeps the kids from watching true blood and dexter)

#1190 bvkakalot

bvkakalot

    Member

  • Members
  • PipPip
  • 59 posts

Posted 07 January 2011 - 04:33 AM

Hey guys... Is there anyone know how I can activate the subtitles when watching movies on aTV through PLEX. I do have the movies file (.mkv) and the subtitles file, but i don't know how to turn in on when watching on aTV?

Just want to know if I can do it or not? Thanks alot.

#1191 Agent007PR

Agent007PR

    Member

  • Members
  • PipPip
  • 35 posts

Posted 07 January 2011 - 05:09 AM

Hey B0bben,

Just tried the last build from github and my server list disappeared and couldn't get it back even if i removed the lowtide.plist. Any ideas? The previous 1 from today worked fine...

#1192 nekton1

nekton1

    Dedicated Member

  • Members
  • PipPipPip
  • 176 posts

Posted 07 January 2011 - 05:17 AM

Ran the 0.5.7 zip update using Fetch to put PLEX.frappliance in the correct place and then used killall Lowtide from terminal to restart.
Lost ability to see PMS on MacPro (Ethernet LAN). Tried restarting TV2 and Plex and ended up with multiple servers of the same name under PLEX menu. None would play.
Then ran latest PLEX update 0.9.1.13 and restarted both PMS and ATV2 and it all came good again with single server name under PLEX menu.
Plays fine as before (no FF scrubbing, etc) but ffmpeg is still running when Plex client paused — been paused 5 minutes now but ffmepg still at >200%.

Correction— at 8 minutes after pausing client, ffmpeg has stopped.

#1193 leeyoon

leeyoon

    Member

  • Members
  • PipPip
  • 12 posts

Posted 07 January 2011 - 08:55 AM

Ok compadres, here's a new version for testing.

Changes:

  • Summary texts for series
  • Cover art is now shown if available, otherwise we fallback to thumb/art
  • Show server directly in the main menu instead of extra scene/menu

Please report back how the last item on list works for you. Is it finding your server(s) as it should, or is it funky?
Also, I'm sure most of you will agree that thumbs are better then coverart right? ;)

Thx for all the kind words as well!

Cheers,
b0bben & camelot

PS:
I named the file as version 0.5.7 out of the blue (almost), i have no idea actually what the version should be. I just thought I had seen Frank use 0.5.6.
Versioning is good, m'kay?


great work!! many thanks!!
Can I count subtitle supports on my wish-list for next release? ;)
ATV2 : AppleTV2,1_4.2.1_8C154
PLEX : 0.6.6
STATUS : Jailbreaked-tethered
Hardware: iMac 27" 2.4GHz Intel Core 2 Duo 4GB RAM
Network and Storage : Time Capsule Wireless N network

#1194 b0bben

b0bben

    Plex Dev Team

  • Castle Keeper
  • PipPipPipPipPip
  • 525 posts
  • Location: Göteborg, Sweden

Posted 07 January 2011 - 10:02 AM

Alright, so it seems the machine finder is unstable for you guys as well. That's what we've been seeing as well.
We'll see what we can do about it to make it more robust.

lofty: rating is not impossible since both plex and atv have support for it I think. Will look at it at some point.

bvkakalot: no subtitle support yet, haven't gotten that far yet. We're still working on the basic stuff, like getting music to play ;)

Cheers,
b0bben
In Soviet Russia, Plex watches YOU!
Twitter: twitter.com/b0bben

#1195 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1890 posts

Posted 07 January 2011 - 11:41 AM

A can confirm machine finder is unstable too. But interestingly when I selected the duplicate .local address which was showing up as a server it appeared to restart lowtide and now only the proper library shows up.

#1196 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1890 posts

Posted 07 January 2011 - 12:48 PM

One other thing, and I know this is a PMS problem, but maybe we can find a work around for the Plex ATV app, I like many others use the tremendously awesome PlexFlix to integrate my netflix queue into my library. As such, all the .strm files show up in Plex ATV (and iOS) but can't be played, just gets an error. Would it be possible for the ATV app to 'skip' over those files so as not to show up on the ATV? While I am more familiar with which library files are real vs strm's, my family isn't (which is what makes PlexFlix so great, the seamless integration of physical vs cloud files) and just provides confusion.

I know this isn't a high priority, but was just throwing it out there.

Quite a trio we have working on this, again thank a ton to quiqueck, b0bben and camelot for their efforts...

#1197 ingensoppa

ingensoppa

    Member

  • Members
  • PipPip
  • 97 posts
  • Location: Sweden

Posted 07 January 2011 - 01:23 PM

Updated to new 0.5.7 and it broke My plex menu on atv running 4.0

I now get 3 versions of PMS on appletv. And when i click one of them it kickes me out to atv main menu and all instances of PMS dissapears. Tried restarting PMS, lowtide and reboot via nitotv
iMac 27, Macbook Air, iPad2, iPhone 4S, AppleTV2 (with plex)...... And a time capsule... What a geek!

#1198 operator

operator

    Member

  • Members
  • PipPip
  • 26 posts

Posted 07 January 2011 - 02:25 PM

can someone explain what Nito TV exactly do ?

#1199 b0bben

b0bben

    Plex Dev Team

  • Castle Keeper
  • PipPipPipPipPip
  • 525 posts
  • Location: Göteborg, Sweden

Posted 07 January 2011 - 02:55 PM

nekton1: I'm sorry. I've lied. Transcoding doesnt stop on pause, only when you "quit" the movie.

b0bben
In Soviet Russia, Plex watches YOU!
Twitter: twitter.com/b0bben

#1200 b0bben

b0bben

    Plex Dev Team

  • Castle Keeper
  • PipPipPipPipPip
  • 525 posts
  • Location: Göteborg, Sweden

Posted 07 January 2011 - 02:59 PM

operator: nitotv is not actually needed (but it's still awesome) per se.
What you do need is the package beigelist which makes it possible to put stuff in the menu and such.

beigelist is available thru nitotv's repository and it installs together with nitotv, that's why everybody is installing it.

//b0bben
In Soviet Russia, Plex watches YOU!
Twitter: twitter.com/b0bben