Jump to content


Photo

Plex Client for Apple TV (2G) version 0.6.4 available


  • This topic is locked This topic is locked
123 replies to this topic

#1 b0bben

b0bben

    Plex Dev Team

  • Castle Keeper
  • PipPipPipPipPip
  • 525 posts
  • Location: Göteborg, Sweden

Posted 12 January 2011 - 11:11 PM

Hi all,

A new version of the Plex client for the Apple TV (2G) is now available.

Changes in this version:
  • Scrubbing, that is fast forward, rewind and seek implemented
  • Resume now works, even if you watched a part of the video on some other device/computer
  • Video plugins now work again
  • + more minor fixes

Upgrading instructions *:

apt-get update
apt-get upgrade

Install instructions:
Please see post 1 in this thread http://forums.plexap...or-apple-tv-2g/

Please post your feedback in this thread.

If you need help with jailbreaking, please visit this wiki page http://wiki.plexapp...._Client_Install
Try keeping jailbreaking questions out of this thread, so we can focus on the feedback.

Thanks for your support everyone, we love you all!

//b0bben, quequick and ccjensen

* If you ever installed this from a zip file posted on the forum, please do this to get back to normal state again:
apt-get remove com.plex.client-plugin
rm -R /Applications/AppleTV.app/Appliances//PLEX.frappliance
apt-get install com.plex.client-plugin

In Soviet Russia, Plex watches YOU!
Twitter: twitter.com/b0bben

#2 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 12 January 2011 - 11:18 PM

Sweet! Thanks all!

#3 bvkakalot

bvkakalot

    Member

  • Members
  • PipPip
  • 59 posts

Posted 12 January 2011 - 11:41 PM

OMG!!! Thanks B0bben. I will try it tonight when I get home... So excited...

#4 diegarcia85

diegarcia85

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 12 January 2011 - 11:41 PM

@b0bben hi, great new version of Plex For ATV2. Are subtitles in your list?? Please answer. Thanks a lot

Hi all,

A new version of the Plex client for the Apple TV (2G) is now available.

Changes in this version:

  • Scrubbing, that is fast forward, rewind and seek implemented
  • Resume now works, even if you watched a part of the video on some other device/computer
  • Video plugins now work again
  • + more minor fixes

Upgrading instructions *:

apt-get update
apt-get upgrade

Install instructions:
Please see post 1 in this thread http://forums.plexap...or-apple-tv-2g/

Please post your feedback in this thread.

If you need help with jailbreaking, please visit this wiki page http://wiki.plexapp...._Client_Install
Try keeping jailbreaking questions out of this thread, so we can focus on the feedback.

Thanks for your support everyone, we love you all!

//b0bben, quequick and ccjensen

* If you ever installed this from a zip file posted on the forum, please do this to get back to normal state again:
apt-get remove com.plex.client-plugin
rm -R /Applications/AppleTV.app/Appliances//PLEX.frappliance
apt-get install com.plex.client-plugin



#5 bvkakalot

bvkakalot

    Member

  • Members
  • PipPip
  • 59 posts

Posted 12 January 2011 - 11:43 PM

@b0bben hi, great new version of Plex For ATV2. Are subtitles in your list?? Please answer. Thanks a lot


I don't think so.

#6 magnificent3

magnificent3

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 12 January 2011 - 11:49 PM

Works GREAT!!!! CONGRATS!!!!

:)

Thank you so much!

#7 akula169

akula169

    Member

  • Members
  • PipPip
  • 33 posts

Posted 12 January 2011 - 11:59 PM

Initial tests are looking good.

Thanks so much, 2x awesome!

#8 Shaveblog

Shaveblog

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 13 January 2011 - 12:12 AM

Apologies if this has been answered elsewhere in the threads, I tried searching and couldn't find the answer.

How is the video quality of this Plex ATV client on a typical 720p or 1080p TV compared to a Mac running Plex for OSX? I understand the difference between streaming the actual file on a Mac running Plex and the same file streaming as transcoded video to an ATV running Plex, but in real world terms, is the video quality good enough to consider going with ATV/Plex instead, or is it still mainly proof of concept?

I've been building Hackintoshes purely to act as Plex boxes since Plex became available, and it's by far my favorite HTPC software. But if the video quality on the new $99 ATV running the Plex app is comparable in subjective terms, I'd switch in a heartbeat.

My hat's off to you guys for enabling Plex on ATV -- just how good does it look, really?

#9 shoxcorp

shoxcorp

    Member

  • Members
  • PipPip
  • 21 posts

Posted 13 January 2011 - 12:17 AM

I can't thank you enough for this. You guys all rock.

Just tested it with a tv show, works amazing!

Keep it up guys!

ps. would be great if we could add .srt subs in the "feature requests" list =)

#10 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 13 January 2011 - 12:17 AM

Apologies if this has been answered elsewhere in the threads, I tried searching and couldn't find the answer.

How is the video quality of this Plex ATV client on a typical 720p or 1080p TV compared to a Mac running Plex for OSX? I understand the difference between streaming the actual file on a Mac running Plex and the same file streaming as transcoded video to an ATV running Plex, but in real world terms, is the video quality good enough to consider going with ATV/Plex instead, or is it still mainly proof of concept?

I've been building Hackintoshes purely to act as Plex boxes since Plex became available, and it's by far my favorite HTPC software. But if the video quality on the new $99 ATV running the Plex app is comparable in subjective terms, I'd switch in a heartbeat.

My hat's off to you guys for enabling Plex on ATV -- just how good does it look, really?



Here's my humble opinion.... it looks great. I watched a 1080p rip of Toy Story 3 using 0.6.3 - looked pretty darn good, watched another 1080p of the movie 300, same deal...i mean ATV is 720p capable, and I assume (maybe incorrectly...b0bben, quiqueck please clarify), that PMS is transcoding it for 720p....



#11 nekton1

nekton1

    Dedicated Member

  • Members
  • PipPipPip
  • 176 posts

Posted 13 January 2011 - 12:32 AM

Installed 0.6.4 as described and now I can see Servers under PLEX menu and Version 0.6.4
When I click Servers, it shows two servers with same name and when I click one or other it lists the TV Shows and Movies BUT when I select something to play it crashes back to main menu.
Any ideas from install logs below. This is an ATV running first version of jb 4.01 with Lowtide. b0bbin, the scripts seem to be wrong for Lowtide judging from the parts marked in red.


Robertsnow:~ robertsnow$ ssh root@192.168.0.4
root@192.168.0.4's password:
Apple-TV:~ root# apt-get remove com.plex.client-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
beigelist mobilesubstrate
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
com.plex.client-plugin
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 1876kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 1266 files and directories currently installed.)
Removing com.plex.client-plugin ...
dpkg - warning: while removing com.plex.client-plugin, directory `/Applications/Lowtide.app/Appliances' not empty so not removed.
dpkg - warning: while removing com.plex.client-plugin, directory `/Applications/Lowtide.app' not empty so not removed.
Apple-TV:~ root# rm -R /Applications/AppleTV.app/Appliances//PLEX.frappliance
rm: cannot remove `/Applications/AppleTV.app/Appliances//PLEX.frappliance': No such file or directory

Apple-TV:~ root# apt-get install com.plex.client-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
beigelist mobilesubstrate
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
com.nito
The following NEW packages will be installed:
com.nito com.plex.client-plugin
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 402kB of archives.
After this operation, 2914kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
com.nito com.plex.client-plugin
Install these packages without verification [y/N]? y
Get:1 http://www.ambertation.de ./downloads/PLEX/ com.nito 0-1 [2552B]
Get:2 http://www.ambertation.de ./downloads/PLEX/ com.plex.client-plugin 0.6.1 [400kB]
Fetched 402kB in 4s (84.4kB/s)
Selecting previously deselected package com.nito.
(Reading database ... 1256 files and directories currently installed.)
Unpacking com.nito (from .../com.nito_0-1_iphoneos-arm.deb) ...
Selecting previously deselected package com.plex.client-plugin.
Unpacking com.plex.client-plugin (from .../com.plex.client-plugin_0.6.1_iphoneos-arm.deb) ...
Setting up com.nito (0-1) ...
Setting up com.plex.client-plugin (0.6.1) ...
Apple-TV:~ root# apt-get update
Get:1 http://apt.thebigboss.org stable Release.gpg [197B]
Get:2 http://apt.awkwardtv.org ./ Release.gpg [197B]
Hit http://apt.saurik.com tangelo-3.7 Release.gpg
Get:3 http://apt.modmyi.com stable Release.gpg [189B]
Get:4 http://cydia.zodttd.com stable Release.gpg [189B]
Ign http://www.ambertation.de ./downloads/PLEX/ Release.gpg
Get:5 http://apt.thebigboss.org stable Release [183kB]
Hit http://apt.saurik.com tangelo-3.7 Release
Hit http://apt.awkwardtv.org ./ Release
Get:6 http://apt.modmyi.com stable Release [238B]
Get:7 http://cydia.zodttd.com stable Release [1619B]
Err http://apt.awkwardtv.org ./ Release

Ign http://apt.modmyi.com stable Release
Ign http://apt.saurik.com tangelo-3.7/main Packages/DiffIndex
Get:8 http://apt.modmyi.com stable/main Packages/DiffIndex [3756B]
Hit http://www.ambertation.de ./downloads/PLEX/ Release
Get:9 http://apt.awkwardtv.org ./ Release [278B]
Hit http://apt.saurik.com tangelo-3.7/main Packages
Get:10 http://cydia.zodttd.com stable/main Packages/DiffIndex [3756B]
Get:11 http://apt.modmyi.com stable/main Packages [1181kB]
Ign http://apt.awkwardtv.org ./ Release
Ign http://www.ambertation.de ./downloads/PLEX/ Packages/DiffIndex
Get:12 http://cydia.zodttd.com stable/main 2011-01-09-2009.31+2011-01-12-2308.44.pdiff [16.6kB]
Hit http://apt.awkwardtv.org ./ Packages/DiffIndex
Get:13 http://cydia.zodttd.com stable/main 2011-01-09-2009.31+2011-01-12-2308.44.pdiff [16.6kB]
Get:14 http://www.ambertation.de ./downloads/PLEX/ Packages [1319B]
Get:15 http://cydia.zodttd.com stable/main 2011-01-09-2009.31+2011-01-12-2308.44.pdiff [16.6kB]
Get:16 http://apt.thebigboss.org stable/main Packages/DiffIndex [3756B]
Get:17 http://nitosoft.com Release.gpg [487B]
Get:18 http://nitosoft.com Release [276B]
Get:19 http://nitosoft.com Packages [2405B]
Get:20 http://apt.thebigboss.org stable/main 2011-01-09-0731.24+2011-01-12-1810.33.pdiff [6328B]
Get:21 http://apt.thebigboss.org stable/main 2011-01-09-0731.24+2011-01-12-1810.33.pdiff [6328B]
Get:22 http://apt.thebigboss.org stable/main 2011-01-09-0731.24+2011-01-12-1810.33.pdiff [6328B]
Fetched 1406kB in 9s (155kB/s)
Reading package lists... Done
W: GPG error: http://apt.modmyi.com stable Release: The following signatures were invalid: BADSIG 87F92E166197E890 Kyle Matthews (poetic_folly) <kyle@modmyifone.com>
W: GPG error: http://apt.awkwardtv.org ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 89711CE585F73AB5

Apple-TV:~ root# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
com.plex.client-plugin
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 458kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
com.plex.client-plugin
Install these packages without verification [y/N]? y
Get:1 http://www.ambertation.de ./downloads/PLEX/ com.plex.client-plugin 0.6.4 [458kB]
Fetched 458kB in 3s (132kB/s)
(Reading database ... 1269 files and directories currently installed.)
Preparing to replace com.plex.client-plugin 0.6.1 (using .../com.plex.client-plugin_0.6.4_iphoneos-arm.deb) ...
Unpacking replacement com.plex.client-plugin ...
Setting up com.plex.client-plugin (0.6.4) ...
Apple-TV:~ root# killall Lowtide
Apple-TV:~ root#

#12 Rauf

Rauf

    Member

  • Members
  • PipPip
  • 33 posts

Posted 13 January 2011 - 12:39 AM

Installed new version. Great job.
1. Scrubbing works.
2. Resume works
3. Bug with duplicate server fixed.

sorry but have to ask again. How to set up default language for movie? F.e my mkv file has english+french+russian sound tracks. How to set up default language to english?

#13 nekton1

nekton1

    Dedicated Member

  • Members
  • PipPipPip
  • 176 posts

Posted 13 January 2011 - 12:53 AM

In my pooched install the duplicate server bug is NOT fixed and although clicking either server lists the Movies and TV Shows on the PMS fine, selecting anything causes Lowtide to CRASH.
Need some help here guys.


Installed new version. Great job.
1. Scrubbing works.
2. Resume works
3. Bug with duplicate server fixed.

sorry but have to ask again. How to set up default language for movie? F.e my mkv file has english+french+russian sound tracks. How to set up default language to english?



#14 SkuiD87

SkuiD87

    Dedicated Member

  • Members
  • PipPipPip
  • 275 posts
  • Location: London, UK

Posted 13 January 2011 - 12:54 AM

Installed 0.6.4 as described and now I can see Servers under PLEX menu and Version 0.6.4
When I click Servers, it shows two servers with same name and when I click one or other it lists the TV Shows and Movies BUT when I select something to play it crashes back to main menu.
Any ideas from install logs below. This is an ATV running first version of jb 4.01 with Lowtide. b0bbin, the scripts seem to be wrong for Lowtide judging from the parts marked in red.


Mine installed fine but I'm having the exact same symptoms as you (Multiple servers showing up and crash when you try to run a movie.)

I'm running software 4.0. Could it be that we're on older firmware? b0bben...please advise.

Hardware:
iMac 27" 3.5GHz i7 (Quad-core) 16GB RAM
Storage:
6TB External HDD (WD MyBook) Firewire 800

6TB External HDD (WD MyBook) Firewire 800
2TB External HDD (WD MyBook) Firewire 800
Network:
Time Capsule (Airport) Wireless N network (802.11ac)

Virgin Media UK - 120Mbps Down, 12Mbps Up


#15 worstepisodeever

worstepisodeever

    Dedicated Member

  • Members
  • PipPipPip
  • 203 posts

Posted 13 January 2011 - 12:59 AM

just want to verify before I update that this will work ok for those of us who are still on the the original jailbreak/4.0 software?? We don't have to do anything special??

#16 SkuiD87

SkuiD87

    Dedicated Member

  • Members
  • PipPipPip
  • 275 posts
  • Location: London, UK

Posted 13 January 2011 - 01:04 AM

just want to verify before I update that this will work ok for those of us who are still on the the original jailbreak/4.0 software?? We don't have to do anything special??


Can't say for sure but so far myself and another user (both on older software) have had the exact same problems (read above thread).

I've my SHSH blobs backed up so I'm gonna go ahead and upgrade to 4.2.1 and see if it works. I'll post results in a bit (in the process of upgrading to new firmware now).

Hardware:
iMac 27" 3.5GHz i7 (Quad-core) 16GB RAM
Storage:
6TB External HDD (WD MyBook) Firewire 800

6TB External HDD (WD MyBook) Firewire 800
2TB External HDD (WD MyBook) Firewire 800
Network:
Time Capsule (Airport) Wireless N network (802.11ac)

Virgin Media UK - 120Mbps Down, 12Mbps Up


#17 Rauf

Rauf

    Member

  • Members
  • PipPip
  • 33 posts

Posted 13 January 2011 - 01:06 AM

Mine installed fine but I'm having the exact same symptoms as you (Multiple servers showing up and crash when you try to run a movie.)

I'm running software 4.0. Could it be that we're on older firmware? b0bben...please advise.


I am on the latest firmware. everything works great - movies, music, plugins.

#18 worstepisodeever

worstepisodeever

    Dedicated Member

  • Members
  • PipPipPip
  • 203 posts

Posted 13 January 2011 - 01:07 AM

Can't say for sure but so far myself and another user (both on older software) have had the exact same problems (read above thread).

I've my SHSH blobs backed up so I'm gonna go ahead and upgrade to 4.2.1 and see if it works. I'll post results in a bit (in the process of upgrading to new firmware now).




sweet, thanks for the heads up. Ill wait for verification before updating since a tethered jailbreak isn't really an option since my devices are in other rooms.

#19 Wormhole

Wormhole

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1886 posts

Posted 13 January 2011 - 01:25 AM

just reporting, music, libraries work fine, video plugins do sort of. Food Network for example only gets audio, video is static jumbled picture. Netflix works, but PlexFlix strm files sort of work...the progress bar is totally off, and the start at beginning or resume sort of works...but i love that it actually plays the strm file rather than getting a error loading message....tremendous work guys.

#20 SkuiD87

SkuiD87

    Dedicated Member

  • Members
  • PipPipPip
  • 275 posts
  • Location: London, UK

Posted 13 January 2011 - 01:39 AM

sweet, thanks for the heads up. Ill wait for verification before updating since a tethered jailbreak isn't really an option since my devices are in other rooms.


OK, I just updated to the latest firmware and everything works perfectly. I think the issue was the old firmware. Perhaps it needs an update to make it work with older firmware.

Hardware:
iMac 27" 3.5GHz i7 (Quad-core) 16GB RAM
Storage:
6TB External HDD (WD MyBook) Firewire 800

6TB External HDD (WD MyBook) Firewire 800
2TB External HDD (WD MyBook) Firewire 800
Network:
Time Capsule (Airport) Wireless N network (802.11ac)

Virgin Media UK - 120Mbps Down, 12Mbps Up





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users