Jump to content


Photo

Best way to connect to a ReadyNAS NV+?


  • Please log in to reply
8 replies to this topic

#1 wootcat

wootcat

    Dedicated Member

  • Members
  • PipPipPip
  • 140 posts
  • Location: Wisconsin

Posted 03 December 2008 - 07:42 PM

I downloaded and installed Plex yesterday. It looks incredibily cool.

Hopefully someone here can tell me the best way to connect to my ReadyNAS NV+. All my media is on that NAS and I'm not sure of the best way to tell Plex how to find it. I saw options for UPnP and SMB shares, but I don't think the NV+ knows SMB. In my searches for an answer to this question, I also came across some posts about UPnP not being reliable at this point, so any help is greatly appreciated!

Thanks! Looking forward to getting this working!

#2 deanm3

deanm3

    Dedicated Member

  • Members
  • PipPipPip
  • 102 posts
  • Location: NYC

Posted 03 December 2008 - 09:22 PM

Your best best is to setup an AFP share on the ReadyNAS NV+. In your system settings on the ReadyNAS admin panel, make sure you have {Optimize for MAC OSX} enabled. The readynas nv+ over a gigiabit cat6 connection can easily handle a 1080p stream through AFP.

Enjoy

#3 wootcat

wootcat

    Dedicated Member

  • Members
  • PipPipPip
  • 140 posts
  • Location: Wisconsin

Posted 03 December 2008 - 10:48 PM

Cool. That's how I set it up when I got it. Now, what's the best way to connect to my media share in the Plex configuration?

#4 sreisz

sreisz

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 December 2008 - 01:22 AM

I mounted a share using Go -> Connect to Server -> Enter server address from Finder (I used smb://..., but after reading this thread, I may change things around to use afp://...).

The share is now in /Volumes/sharename. It shows up in the Brows option under Add Source. If you want to get a more specific directory under your share, select the share using the Browse option, then add the subdir by selecting the path to the share and hitting enter.

Cool. That's how I set it up when I got it. Now, what's the best way to connect to my media share in the Plex configuration?



#5 John Lockwood

John Lockwood

    Dedicated Member

  • Members
  • PipPipPip
  • 450 posts
  • Location: London,UK

Posted 05 December 2008 - 01:36 PM

Your best best is to setup an AFP share on the ReadyNAS NV+. In your system settings on the ReadyNAS admin panel, make sure you have {Optimize for MAC OSX} enabled. The readynas nv+ over a gigiabit cat6 connection can easily handle a 1080p stream through AFP.

Enjoy


The ReadyNAS supports both SMB and AFP. From a Mac point of view normally using the AFP method would be the best option, but the Mac can of course do both.

XBMC and hence Plex can store the login details for an SMB connection which you have defined as a source so that if needed XBMC/Plex can then automatically reconnect to the device. Unfortunately, this is not a feature provided for AFP connections. (Because AFP is pretty much Mac only, XBMC has not been written to take this in to consideration even though it would be technically possible to do.)

Therefore you have three options.

1. Use SMB connections from your Mac to get the auto-reconnect facility
2. Use AFP connections and remember to manually login, creating an Alias to the ReadyNAS which you can double-click on might be a partial solution
3. Set your User Account in Mac OS X to automatically open the AFP connection in 'Login Items', you will also need to make sure the username/password is stored in your Keychain.

I am probably going to use option 3.

#6 wootcat

wootcat

    Dedicated Member

  • Members
  • PipPipPip
  • 140 posts
  • Location: Wisconsin

Posted 05 December 2008 - 05:41 PM

The ReadyNAS supports both SMB and AFP. From a Mac point of view normally using the AFP method would be the best option, but the Mac can of course do both.

XBMC and hence Plex can store the login details for an SMB connection which you have defined as a source so that if needed XBMC/Plex can then automatically reconnect to the device. Unfortunately, this is not a feature provided for AFP connections. (Because AFP is pretty much Mac only, XBMC has not been written to take this in to consideration even though it would be technically possible to do.)

Therefore you have three options.

1. Use SMB connections from your Mac to get the auto-reconnect facility
2. Use AFP connections and remember to manually login, creating an Alias to the ReadyNAS which you can double-click on might be a partial solution
3. Set your User Account in Mac OS X to automatically open the AFP connection in 'Login Items', you will also need to make sure the username/password is stored in your Keychain.

I am probably going to use option 3.


Yeah, Option 3 for me too, as that's how I set up my system before Plex came along. My NAS drives are mounted automatically upon login. At some point though, my connections will break. Plex sees "Media" (my media share) as "Media-4". About a year ago, I had a problem with the appended "-#" and vaguely remember why and how those numbers got there. When and if Media-4 becomes Media-5, I will probably have to reconnect everything.

#7 Mako Nakor

Mako Nakor

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 887 posts
  • Location: Virginia

Posted 05 December 2008 - 06:11 PM

Yeah, Option 3 for me too, as that's how I set up my system before Plex came along. My NAS drives are mounted automatically upon login. At some point though, my connections will break. Plex sees "Media" (my media share) as "Media-4". About a year ago, I had a problem with the appended "-#" and vaguely remember why and how those numbers got there. When and if Media-4 becomes Media-5, I will probably have to reconnect everything.


When my volume directory added numbers to my volumes I was able to delete folders that the filesystem created there to get the previous number back. Another solution is in terminal you can do

ln -s [source] [target]

To make a symbolic link from the old name to the new name of the volume.

#8 John Lockwood

John Lockwood

    Dedicated Member

  • Members
  • PipPipPip
  • 450 posts
  • Location: London,UK

Posted 07 December 2008 - 03:17 AM

Yeah, Option 3 for me too, as that's how I set up my system before Plex came along. My NAS drives are mounted automatically upon login. At some point though, my connections will break. Plex sees "Media" (my media share) as "Media-4". About a year ago, I had a problem with the appended "-#" and vaguely remember why and how those numbers got there. When and if Media-4 becomes Media-5, I will probably have to reconnect everything.


I have seen two scenarios lead to this (nothing to do with Plex).

1. As Mac OS X is a variety of Unix all volumes are attached to 'mount points' these are folders to which the volume/device is linked. In the old days one had to set this up manually under Unix, Mac OS X does it automatically by creating a folder in /Volumes to act as the 'mount point' and then attaching the volume to it. However I have seen in the past, these mount points get left behind and this means next time it mounts the same volume is gets a number added on the end to differentiate it. The same would happen if you did genuinely have to volumes with the same name. Use the Terminal program to do an ls -l of /Volumes to see if any orphaned mount points are present (do this when not connected) and then remove them.

2. The other circumstance I have seen this is when two tasks login to the same volume at roughly the same time. In my case this is when our office Anti-Virus software (Sophos Anti-Virus for Mac) automatically logs in to the file server to download any updates, if a user then logs in to the file server themselves at roughly the same time, this results in two connections, and one would be 'mounted' with a number added on the end to differentiate it.

In your case I think option 1 above is the most likely cause.

#9 wootcat

wootcat

    Dedicated Member

  • Members
  • PipPipPip
  • 140 posts
  • Location: Wisconsin

Posted 08 December 2008 - 04:29 PM

Mako and John,

Thanks for the refresher :) That will help me out a lot.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users