Jump to content


Photo

Roku streaming: stuck at retrieving


  • Please log in to reply
156 replies to this topic

#1 heyhi

heyhi

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 May 2011 - 11:50 PM

When I start the plex channel up, it connects to the plex media server, but once i click on channels, it gets stuck at retrieving.

any tips or ideas would be helpful
thanks

#2 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 03 May 2011 - 11:55 PM

Have you disabled capability checking in the PMS options?

Jonny

#3 deweydm

deweydm

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 04 May 2011 - 12:04 AM

Have you disabled capability checking in the PMS options?

Jonny



Having the same problem. Giving it another try with capability checking disabled, but it doesn't seem to be making a difference. Finds my plex media server (0.9.2.7-ff76e66 on Mac OS X 10.6.7), but doesn't get past retrieving... under Video and Channel Directory.

#4 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 04 May 2011 - 12:12 AM

Same problem with my MacBook Pro.

#5 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 12:34 AM

Hate to ask this but you have added content to the Plex Media Server haven't you? Either local content and/or plugins? The behaviour you are describing would be seen with a PMS with no content.

Jonny

#6 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 04 May 2011 - 01:04 AM

Yes, I have both local content and plugins. I can access the content fine using the Plex client on my iPod Touch, but it keeps saying "retrieving" on the Roku client. It also takes quite awhile just to get to the Channels-Search-Settings screen.

#7 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 01:24 AM

So you don't see sections for your local content on the Channels-Search-Settings screen? You should see an entry for every movie and tv section you added to PMS.

This one has me a little stumped right now. Are you using the default PMS port?

Jonny

Yes, I have both local content and plugins. I can access the content fine using the Plex client on my iPod Touch, but it keeps saying "retrieving" on the Roku client. It also takes quite awhile just to get to the Channels-Search-Settings screen.



#8 dshack

dshack

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 May 2011 - 01:34 AM

I have the exact situation. Media server is running, and Roku finds it, but it is stuck at "retrieving" when browsing channels.

#9 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 01:39 AM

And you've disabled capability checking? Can you see local content?

Other details on your set up? PMS version, port number, other network details?

This works (on Mac PMS) for many people so we need to figure out what's different here.

I have the exact situation. Media server is running, and Roku finds it, but it is stuck at "retrieving" when browsing channels.



#10 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 04 May 2011 - 02:46 AM

Jonny,

No, when I click on Channels, I get a screen with Video and Channel Directory options. No matter which option I select, the screen still says "retrieving." I am using PMS 0.9.2.7. My iPod Touch connects to the PMS at 32400. Not sure how to check which Port the Plex client on the Roku is using. My Roku is wired to my router. I have tried using both a wireless and wired connection to the router with my MacBook Pro, and I get the same problem. I have disable capability checking entered; I have no problems seeing the plugins with my iPod.

Mike

#11 DoctaMike

DoctaMike

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 04 May 2011 - 03:31 AM

I've been having the same issue, but I found that having PMS running on both my Mac Mini and Macbook seems to fix it. If PMS is only running on my Mac Mini (where all of my content is) I experience the same problem that everyone else in this thread is. But for some reason having two instances of PMS running fixes the issue. Both have capability checking disabled, both are up to date. However, I've noticed that it's not a perfect fix. Sometimes even with both servers running I still won't see anything.

#12 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 04 May 2011 - 01:37 PM

I might add that when I open the Plex client on Roku, it seems to find the PMS server on my MacBook Pro pretty quickly, but then it can take as long as two minutes to get to the Channels-Search-Preferences screen.

BTW, I appreciate your efforts very much to try to bring Plex to the Roku. Some of the comments on other threads on this forum criticizing you for your unpaid volunteer efforts in this regard are pretty nuts.

#13 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 02:01 PM

Thanks, that's another useful data point that shouldn't occur. I still haven't the foggiest idea what's causing it but hopefully it'll help me track it down.

Jonny

I might add that when I open the Plex client on Roku, it seems to find the PMS server on my MacBook Pro pretty quickly, but then it can take as long as two minutes to get to the Channels-Search-Preferences screen.

BTW, I appreciate your efforts very much to try to bring Plex to the Roku. Some of the comments on other threads on this forum criticizing you for your unpaid volunteer efforts in this regard are pretty nuts.



#14 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 03:32 PM

Another question: once it gets to the 'Channels-Search-Preferences' screen are there no other sections on this screen? In addition to these three there should also be sections for your Movies and TV local content added via PMS. Could it be that PMS has crashed between discovery and getting to this screen?

Jonny

I might add that when I open the Plex client on Roku, it seems to find the PMS server on my MacBook Pro pretty quickly, but then it can take as long as two minutes to get to the Channels-Search-Preferences screen.

BTW, I appreciate your efforts very much to try to bring Plex to the Roku. Some of the comments on other threads on this forum criticizing you for your unpaid volunteer efforts in this regard are pretty nuts.



#15 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 04 May 2011 - 03:39 PM

Another question: once it gets to the 'Channels-Search-Preferences' screen are there no other sections on this screen? In addition to these three there should also be sections for your Movies and TV local content added via PMS. Could it be that PMS has crashed between discovery and getting to this screen?

Jonny


No, I don't see any Movies or TV Local Content sections available on the "Channels-Search-Preferences" screen. I only get the Channels, Search or Preferences options on that screen. I don't know if this means that the PMS has crashed in getting to this screen. During this exact same time, I can still access my local content and plugins via the Mac and iOS clients, so I would think not?

#16 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 04:04 PM

Very odd. The behaviour suggests nothing is coming back from PMS but, if your other clients can access the same PMS then it's still running.

To be continued when I'm not at work ...

Jonny

No, I don't see any Movies or TV Local Content sections available on the "Channels-Search-Preferences" screen. I only get the Channels, Search or Preferences options on that screen. I don't know if this means that the PMS has crashed in getting to this screen. During this exact same time, I can still access my local content and plugins via the Mac and iOS clients, so I would think not?



#17 mgfarkas

mgfarkas

    Member

  • Members
  • PipPip
  • 17 posts
  • Location: C-U, Illinois

Posted 04 May 2011 - 07:30 PM

Thanks very much for putting in the effort to create the Plex channel for Roku!

I too am experiencing the stuck at retrieving issue. Am currently connected wirelessly (router is 5 feet from the Roku) and changing the quality settings to lowest did not fix for me. Will connect with ethernet cable tonight and try again.

#18 Jonny Wray

Jonny Wray

    Plex Star

  • Castle Keeper
  • PipPipPipPipPipPip
  • 1325 posts
  • Location: Oxford

Posted 04 May 2011 - 08:27 PM

Thanks for trying it out.

Quality settings shouldn't affect the display of content, only it's playback. Something else, very annoying, is clearly going on here.

Jonny

Thanks very much for putting in the effort to create the Plex channel for Roku!

I too am experiencing the stuck at retrieving issue. Am currently connected wirelessly (router is 5 feet from the Roku) and changing the quality settings to lowest did not fix for me. Will connect with ethernet cable tonight and try again.



#19 jpkboca

jpkboca

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 05 May 2011 - 12:22 AM

I have simillar issues.

It finds the media server right away.


It then shows the Channels/Search/Pref screen

When i click on channels it will say retrieving forever.....

Yesterday I got it to go and show Recent, Categories, Featured, etc. But when I hit any of them it'd sit on Retrieving... (except Categories let me hit a category before it did that).

I tried both Wireless and Wired.

My Server is 0.9.7.2 mac osx

Thanks for all your help!

#20 youngml2010

youngml2010

    Member

  • Members
  • PipPip
  • 12 posts

Posted 05 May 2011 - 12:34 AM

Removing and reinstalling the Plex client on the Roku doesn't seem to help for me.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users