Jump to content


Photo

Excessive Log File Size


  • Please log in to reply
23 replies to this topic

#1 pacnow

pacnow

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 May 2011 - 10:39 AM

I ran out of disk space, after checking what it was, I found the C:\Users\xxxxxx\AppData\Local\Plex Media Server\Logs\Plex Media Server.log was 155 GB and growing. I just started my library so my collection is about 30 divx files, very modest collection, nothing other than some divx and mkv files. Is it safe to destroy this gigantic log file and what is the meaning of this?

Windows 7 64, 9GB Ram

pacnow

#2 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 11 May 2011 - 03:08 PM

I ran out of disk space, after checking what it was, I found the C:\Users\xxxxxx\AppData\Local\Plex Media Server\Logs\Plex Media Server.log was 155 GB and growing. I just started my library so my collection is about 30 divx files, very modest collection, nothing other than some divx and mkv files. Is it safe to destroy this gigantic log file and what is the meaning of this?

Windows 7 64, 9GB Ram

pacnow

Yeah, stop PMS and delete the log. How long was it running? If you can start it up again and it starts growing again I'm sure the devs would be interested in seeing it before it gets over a GB.
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#3 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7412 posts
  • Location: Maui

Posted 11 May 2011 - 09:31 PM

Wow! Was the server running for a long time? Anything suspicious in the log that kept repeating?

Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.


#4 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 12 May 2011 - 01:29 PM

Wow! Was the server running for a long time? Anything suspicious in the log that kept repeating?

I'm curious myself but I was hesitant to ask him to try opening a 155GB file. :)
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#5 John P

John P

    Member

  • Members
  • PipPip
  • 10 posts

Posted 05 June 2011 - 04:21 PM

I was wondering about this too. I just installed PLEX and have noticed that it continually writing to the server log. I started it yesterday and my server log was 16 Mb today. Every second or so it is writing status. I figured out that it is because the media manager is open. If you leave the media manager application open it continually causes writing to the server log. I added it as a start up tab which I guess is a bad idea in this case. Maybe a future release can take that into account and not log the media manager communication for non activity.

Jun 05, 2011 11:16:20 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:20 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:21 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:21 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:22 [000016D0] DEBUG - Request: GET /library/sections/5/timeline?start=1307286405 [127.0.0.1] (1 live)
Jun 05, 2011 11:16:22 [000016D0] DEBUG - * start => 1307286405
Jun 05, 2011 11:16:22 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 0 elements.
Jun 05, 2011 11:16:24 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:24 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:24 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:24 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:26 [000016D0] DEBUG - Request: GET /library/sections/5/timeline?start=1307286405 [127.0.0.1] (1 live)
Jun 05, 2011 11:16:26 [000016D0] DEBUG - * start => 1307286405
Jun 05, 2011 11:16:26 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 0 elements.
Jun 05, 2011 11:16:26 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:26 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:27 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:27 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:30 [000016D0] DEBUG - Request: GET /library/sections/5/timeline?start=1307286405 [127.0.0.1] (1 live)
Jun 05, 2011 11:16:30 [000016D0] DEBUG - * start => 1307286405
Jun 05, 2011 11:16:30 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 0 elements.
Jun 05, 2011 11:16:30 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:30 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.
Jun 05, 2011 11:16:30 [000016D0] DEBUG - Request: GET /library/sections [127.0.0.1] (1 live)
Jun 05, 2011 11:16:30 [000016D0] DEBUG - It took 0.000000 sec to serialize a list with 1 elements.

#6 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 06 June 2011 - 04:39 AM

I was wondering about this too. I just installed PLEX and have noticed that it continually writing to the server log. I started it yesterday and my server log was 16 Mb today. Every second or so it is writing status. I figured out that it is because the media manager is open. If you leave the media manager application open it continually causes writing to the server log. I added it as a start up tab which I guess is a bad idea in this case. Maybe a future release can take that into account and not log the media manager communication for non activity.

Good catch, sounds to me like this is at least part of the problem. :) 16 MB * 70 days only comes to about 1 GB though, so something else might be going on (bunch of errors scanning when windows PMS initially came out?).
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#7 branflakes

branflakes

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 12 August 2011 - 06:55 PM

plex newbie here as well. i installed last week to trial stream to android. android streaming works like a champ, as does local xbmc plug-in.

so, i left the server on and media manager up. my brother was doing some remote testing for me for about 6 hours which required me to open the outside ports. after running for 1.5 days, i looked at the server and realized i had ZERO disk space available (had been down to about 10gb). so, i offloaded 52gb of material and left on overnight. so, after i moved it at approximately 8:30PM EST i had 52gb +/- available. when i woke up this morning at 7:30AM EST i checked the server again. 42gb +/- remaining. WTF????

so, i go into emergency anti-hacker mode. shut down all non-essential services, disconnect pipes, close all ports, etc. and begin looking for someone's shadow ftp server hosting torrents or something. when a search of the most recently modified results nets nothing i d/l a file size checking program. here's what i found:

Posted Image

so, WTF? Why would the log file grow 10gb overnight? and no i didn't go trying to open it and pick it apart. it was a 30gb log file, or so it said.

#8 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 12 August 2011 - 07:00 PM

Sounds like it's ballooning somewhat consistently for you, maybe you could inspect it after an hour or so when it's still manageable?
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#9 branflakes

branflakes

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 12 August 2011 - 08:11 PM

i will try it out this evening. thanks for the reply!

#10 kuliksco

kuliksco

    Member

  • Members
  • PipPip
  • 12 posts

Posted 28 August 2011 - 05:02 PM

same thing here. i have plex running on my windows SSD drive and it filled up the entire drive with a 50G log file.

how can i turn off logging or at least reduce the verbosity? i have only been running plex for about a month and only streaming to a roku2.

#11 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 29 August 2011 - 04:36 PM

same thing here. i have plex running on my windows SSD drive and it filled up the entire drive with a 50G log file.

how can i turn off logging or at least reduce the verbosity? i have only been running plex for about a month and only streaming to a roku2.

There's no way to disable logging at the moment and I assume the verbosity is as low as it can go. The devs disable some log messages for releases but since plex is still beta there's quite a few left on to diagnose user problems. Quite a few people have reported this issue but they either can't reproduce it or don't post back if they do so I'm kinda in the dark as to what's causing it. Someone mentioned a bunch of log messages being written when a browser window was left open on the manager screen but it didn't seem like enough to generage GB of log messages.
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#12 beezn

beezn

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 September 2011 - 09:47 AM

I'm getting the same issue. really messed up I think.

#13 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 30 September 2011 - 01:49 PM

I'm getting the same issue. really messed up I think.

Can you reproduce it reliably? If we're talking GB sized log files you should be able to wait a few minutes and it'll grow exponentially. If you can stop PMS before it gets over a GB maybe we can actually find out what's going on. :/
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#14 beezn

beezn

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 01 October 2011 - 09:14 PM

Can you reproduce it reliably? If we're talking GB sized log files you should be able to wait a few minutes and it'll grow exponentially. If you can stop PMS before it gets over a GB maybe we can actually find out what's going on. :/


I tried but it hasnt even hit 1 meg in size since I cleared the old one last night. it was over 130 gb in size before.

#15 beezn

beezn

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 October 2011 - 09:04 AM

here is a log file, hope it helps, its all greek to me. http://dl.dropbox.co...edia Server.log

#16 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 06 October 2011 - 04:43 PM

Nothing jumps out at me as problematic, which isn't surprising as it's only 1.5MB. Something generating 100GB of log messages (or even 1GB) would stand out right away and the file would be growing exponentially. This is unfortunately very difficult to track down as it seems hard to duplicate and likely to not be noticed until it's far too large to open. :/ Thanks for trying to help though. :)
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#17 beezn

beezn

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 07 October 2011 - 10:34 AM

I just checked it again, the file is now 24 GB in size... WTF? suggestions?

#18 JoToFoSho

JoToFoSho

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2882 posts
  • Location: Dayton OH

Posted 07 October 2011 - 10:56 AM

Hmm, you could try using this program to open the file maybe. http://www.swiftgear...r/features.html

Some log message is likely being written repeatedly thousands of times per millisecond to get it that large so it should be fairly obvious. Let us know if you're able to find anything. :)
~John T.

New here? Read the wiki and watch the screencast! You'll save yourself a lot of time and frustration! :) If that didn't help, posting log files can help us track down your issue.

#19 kuliksco

kuliksco

    Member

  • Members
  • PipPip
  • 12 posts

Posted 07 October 2011 - 01:41 PM

of course if you had a linux server or cygwin installed you could "tail -100000 > temp.log" or something like that.

#20 beezn

beezn

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 08 October 2011 - 09:17 AM

ok, I came home and the file was only 3 meg, checked a few hours later and it is a gig, if anyone wants to look at it here you go. http://dl.dropbox.co...edia Server.log thanks again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users