Jump to content


Photo

myplex was unable to connect to my server


  • Please log in to reply
209 replies to this topic

#21 r3dlink13

r3dlink13

    Member

  • Members
  • PipPip
  • 33 posts
  • Location: Columbus, Ohio

Posted 02 November 2011 - 03:10 PM

Had same error on OSX.
Resolved removing manually the old instance of plex media server in Library/Application Support/Plex and the helper too.
It seems that some instances of the old versions remains and uses the same config files and/or ports.
Just removed the app, restarted and putted the new media server in startup items.

Now it works nicely.

Hope it helps.



This solved it for me too. I removed the old plex media server, the plex helper, and the two plex helper config files. I also made sure the new plex media server is in the Applications folder, rather than replacing the old one in Application Support. No system restart was needed either. Just make sure to close plex and the media manager, and quit plexhelper from Activity Monitor before deleting/moving files.

Hope this helps!

Edit: I should probably mention that I manually set the port to 32400 which is forwarded by my router, in case that makes a difference.

WINDOWS 8.1 x64 | 3.4GHz CORE i7-3770 | RADEON HD 7970 ~ 15" MACBOOK PRO 2007 | 2.4GHz CORE 2 DUO
GALAXY NEXUS ~ NEXUS 7 2013
LIFETIME PLEXPASS


Zhearts.png


#22 Symbiote

Symbiote

    Member

  • Members
  • PipPip
  • 38 posts

Posted 02 November 2011 - 05:01 PM

Well I finally got it working by enabling UPnP on my router and enabling publishing to MyPlex and leave Manually set port unchecked. I then uninstalled the Plex iOS app and restarted my iPhone and then reinstalled and logged into MyPlex on the app and then magically I saw my server. For some reason it doesnt work when I wanted to set it up manually. I can see they were trying very hard to make this work magically with just using a single login. However some people prefer to do things manually and not have UPnP enabled. It is not working properly when trying to set it up that way. I noticed when trying to change the port number it continues to stay at the old port when looking at netstat.

#23 Symbiote

Symbiote

    Member

  • Members
  • PipPip
  • 38 posts

Posted 02 November 2011 - 06:23 PM

Apparently I spoke too soon. It did work for a while but when I went back into now every video I try to play says "Couldn't start playback Plex was unable to play this video." Same video that was working just a few minutes ago.

BTW... This is after already trying the previously mentioned tips about completely removing and re-installing and rebooting. Glad to hear that worked for some but unfortunately not for me.
  • jordanklog likes this

#24 Pewter Tankard

Pewter Tankard

    Member

  • Members
  • PipPip
  • 19 posts

Posted 02 November 2011 - 07:07 PM

Had same error on OSX.
Resolved removing manually the old instance of plex media server in Library/Application Support/Plex and the helper too.
It seems that some instances of the old versions remains and uses the same config files and/or ports.
Just removed the app, restarted and putted the new media server in startup items.

Now it works nicely.

Hope it helps.



Indeed. Works fine now from remote addresses.

Thanks :-)



#25 suffolkmac

suffolkmac

    Member

  • Members
  • PipPip
  • 18 posts
  • Location: New York

Posted 03 November 2011 - 03:00 AM

Still a problem!
I've read this series of postings with care, but so far none of the resolutions that have helped others has led to success for my MacMini. I've tried them all.
-My myPlex account is active and accepts plexit videos.
-I have a Queue in the 9.5.1 Plex app and can view the items in Queue.
-I can sign into myPlex through a browser and view items in the Media Queue, but there are no Servers published to myPlex.
-And, of course, there are no servers shared with me.
-I can use a 2nd Mac on our local network and function fully with the 9.5.0 Plex Media Server.
-I can use the iOS Plex2 on an original iPad over our wireless LAN and function with the PMS.
-I have setup Plex Media Server preferences for myPlex: signed in OK; the server is published to myPlex; checked manually specify port 32400; green light on server published to port 32400
But, RED LIGHT, "myplex was unable to connect to your server"

Running Plex on Macmini, wireless LAN base station is an Airport Extreme, 802.11b/g compatible, running version 5.7

#26 iGarth

iGarth

    Member

  • Members
  • PipPip
  • 17 posts

Posted 03 November 2011 - 04:24 PM

This solved it for me too. I removed the old plex media server, the plex helper, and the two plex helper config files. I also made sure the new plex media server is in the Applications folder, rather than replacing the old one in Application Support. No system restart was needed either. Just make sure to close plex and the media manager, and quit plexhelper from Activity Monitor before deleting/moving files.

Hope this helps!

Edit: I should probably mention that I manually set the port to 32400 which is forwarded by my router, in case that makes a difference.


I just followed this advice and it worked for me as well. Thanks!

#27 yogesh3789

yogesh3789

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 November 2011 - 05:30 PM

sholve this problem by manualy forwarding port # 32400 in my router settings.

#28 xoofoo

xoofoo

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 03 November 2011 - 08:05 PM

Arrrrgh

I followed exactly all steps described before for uninstall etc... (although it was my first install of Plex with v 9.5)
got the same result.

"Server is mapped to port 32400 ()"
"MyPlex was unable to connect to your server"

what stroke me is that my own IP address does not appear in () there: "Server is mapped to port 32400 ()"
apparently it should...

I went through the wiki, and created a dyndns 'since I do not have a static IP address...
started again the Media server... Same result...

I am running MAC OS X server 10.6.7 connected through ethernet to my router.
Works perfectly on local network.

Help is much welcome

Edit: port 32400 is forwarded on my router

#29 Flamerock

Flamerock

    Member

  • Members
  • PipPip
  • 11 posts

Posted 04 November 2011 - 05:41 AM

If you are having issues with myPlex connecting to your account, I would check to see if you are blocking access to Amazon's EC2 IP's.

It appears that plex is using their services to host the myPlex site. The netrange is: 50.16.0.0 - 50.19.255.255.

In short, check your hosts and/or your permallow lists (peerblock etc...) and add this host range. As of right now, the host range appears to be limited to 50.18.*.*..., so the 50.16.*.*, 50.17.*.*, and 50.19.*.* are not being used... That may change as more and more users start to use the service. With the recent GoogleTV app, that will probably happen very soon...

-Jason


YUP that was it for me, Peer Guardian was running and blocking. Since I dont show the growl notices for blocks it was invisible. Turned PG off and now myplex is published fine!

#30 bushd

bushd

    Dedicated Member

  • Members
  • PipPipPip
  • 192 posts
  • Location: Stuttgart, Germany

Posted 04 November 2011 - 07:24 PM

I had the same Problem. Got the 'Server is mapped to port 32400 ()' error. After deactivating the OS X 10.7 Firewall I got it working with manual port forwarding.
I then tried adding the Server to the Firewall, but it didn't work.
I find it kind of annoying not being able to activate the systems firewall when I want to use myPlex. I guess this feature needs some fixes.

#31 suffolkmac

suffolkmac

    Member

  • Members
  • PipPip
  • 18 posts
  • Location: New York

Posted 04 November 2011 - 08:05 PM

myPlex up and running. Three shares by 3rd parties. Response times still pending.




It has been awhile since last changes to LAN address on Mac mini where PMS running and router where needed to forward a port.




For those still having difficulty, here are two links I found helpful. The first is a very helpful outside overview of computer sharing via the Internet. Some of the screenshots are dated by a couple of years, but the overview is an easy read with an thorough outline of what needs to be accomplished by the server administrator (you). The second is the specific key section of the Plex wiki documentation on myPlex.




http://homepage.mac...._fwd_intro.html




http://wiki.plexapp...._Release#myPlex



#32 whoshoo

whoshoo

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 05 November 2011 - 06:52 AM

myPlex up and running. Three shares by 3rd parties. Response times still pending.




It has been awhile since last changes to LAN address on Mac mini where PMS running and router where needed to forward a port.




For those still having difficulty, here are two links I found helpful. The first is a very helpful outside overview of computer sharing via the Internet. Some of the screenshots are dated by a couple of years, but the overview is an easy read with an thorough outline of what needs to be accomplished by the server administrator (you). The second is the specific key section of the Plex wiki documentation on myPlex.




http://homepage.mac...._fwd_intro.html




http://wiki.plexapp...._Release#myPlex


Thanks suffolkmac, the first link was very informative. Unfortunately, I am with xoofoo and I am still unable to publish my server. I have made sure that peerguardian isn't running, port forwarded (manually opened not only 32400 but the native port that plex tries to connect through when manually portforwarding isn't selected), and even gone ahead and deleted files like previous posts have mentioned.

Any other suggestions?

#33 xoofoo

xoofoo

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 06 November 2011 - 06:48 PM

Thanks suffolkmac. I did not think about my firewall... :unsure: Now works perfectly.

I have a Mac Mini server on which I was trying to run Plex, and a MacBook. Installed Plex on MacBook, and worked from 1st attempt.
Came back to Mac Mini, set the same internet connection settings, failed. Opened the Server preferences, disabled Firewall; Works!

whoshoo, if it happens that you run Plex on a Mac Mini Server, go to the server preferences, in the security pane, and de-activate the firewall, or better include Plex in the list of available services.

Thanks again for your help!

#34 Xac

Xac

    Member

  • Members
  • PipPip
  • 27 posts

Posted 07 November 2011 - 04:55 PM

It looks like completely removing and reinstalling does not work for anyone who is getting the "Server is mapped to port 32400 ()" message. This appears to be a different issue. I have completely uninstalled (including all 9 files in /Library/...) Plex and reinstalled, and I'm still not getting a connection to MyPlex. I had port forwarding working fine with Plex 9 before the MyPlex stuff. Since this upgrade has caused me to not be able to use Plex the way I've been using it, I have to downgrade. Please tell me there are people addressing this issue and a bugfix will be out soon.

#35 whoshoo

whoshoo

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 12 November 2011 - 12:51 AM

I seem to have the same problems Xac.
And xoofoo, I was doing all of the above steps without a firewall enabled in OSX. I have tried both with the firewall running and without.
I understand this is a preview release so I may just have to wait it out.

#36 senjakongen

senjakongen

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 12 November 2011 - 02:53 PM

Hi

I'm having the same issue. I get the message: "Server is mapped to port 32400 ()" with a green light, followed by "myPlex was unable to connect to your server"
Remote sharing worked fine on Plex nine over the same port so that should not be the problem. I've tried removing the files stated in a previous post, but that did not help.

I have not tried removing plex completely from the Mac and reinstalling, but I understand from other posts that it will not help.

Anyone have any idea on what the problem is?

Regards
Thomas - A very happy, but a little frustrated Plex user :)

#37 techbam

techbam

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 12 November 2011 - 06:44 PM

I get the "server is mapped to 32400(wan Ip)" as green but i get red for the" myPlex was unable to connect to your server." i have it manually forwarding port 32400 and have tried two different native ports as well as enabling UPnP i have tried completely exiting out of everything restarting and deleting the app and data using clean my mac and have restarted and installed plex media server again i then was struck with the same issue. i have tried setting my computer as the dmz host. i have my computers mac address set up as reserved in the dchp settings. i have deactivated any firewall that i could find this includes the mac os x lion one as well as any apps i may have that are filtering it. i have deactivated the firewall on my router even. i need help i paid 4.99 for the iOS app so i could watch my movies on 3g this has become rather disappointing. and with dyndns allowing only paid subscriptions i see this as not only what should have been the "easiest path" but the only way as well.

-Blaine Miller
Owner of Bakersfield Computer Service

#38 techbam

techbam

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 November 2011 - 04:10 AM

i was able to fix it and heres how i quit out of everything plex from the activity monitor. then i disabled the library folder under my username from being hidden via the terminal command

chflags nohidden ~/Library/

then i went to ~/Library/Application Support/ and deleted anything with plex in the title. and then i went to the applications folder and deleted plex and plex media server. then i emptied the trash can and restarted. before reinstalling plex i enabled UPnP on my router and disabled any manual port forwarding settings that may have been applied. i then put plex media server into the applications folder and ran it set it up completely how i wanted it and the myplex worked on sign in also to note that i waited till plex media manger updated the meta data for all of the movies i added from the initial setup dialog. and from there i installed plex 9.5 .1 on my other computers and it seemed to work just find. and anither note the que only shows up if you have stuff added to it. and as far as the app for the iphone goes it works well but when you skip ahead into the video file it plays and then stops every 10 minutes or less so its better not to skip that is on 3g anyways.

#39 senjakongen

senjakongen

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 November 2011 - 03:32 PM

Hi

I'm having the same issue. I get the message: "Server is mapped to port 32400 ()" with a green light, followed by "myPlex was unable to connect to your server"
Remote sharing worked fine on Plex nine over the same port so that should not be the problem. I've tried removing the files stated in a previous post, but that did not help.

I have not tried removing plex completely from the Mac and reinstalling, but I understand from other posts that it will not help.

Anyone have any idea on what the problem is?

Regards
Thomas - A very happy, but a little frustrated Plex user :)


Ok, I finally got things working. As I expected it was not a port forwarding problem since it worked fine in Plex NINE.
I cant really say what the problem was, but I reinstalled the mac completely an when I installed PMS everything worked fine. The conclusion is that there must have been something from the Plex NINE installation that caused the troubles.

Regards
Thomas - Plex FTW

#40 oSPANNERo

oSPANNERo

    Member

  • Members
  • PipPip
  • 78 posts

Posted 14 November 2011 - 06:12 PM

Ok, I finally got things working. As I expected it was not a port forwarding problem since it worked fine in Plex NINE.
I cant really say what the problem was, but I reinstalled the mac completely an when I installed PMS everything worked fine. The conclusion is that there must have been something from the Plex NINE installation that caused the troubles.

Regards
Thomas - Plex FTW


Sounds like I am going to be doing a PLEX PMS wipe and reinstall tonight... :blink: