Jump to content


Photo

PMS Secure access on Readynas


  • Please log in to reply
6 replies to this topic

#1 wibblewobble04

wibblewobble04

    Member

  • Members
  • PipPip
  • 30 posts

Posted 01 December 2011 - 03:44 PM

Hi I found this entry in the Samsung Client forum. This workaround allows the Samsung client to access the PMS remotely, and would seem the only way to go until the client has been updated to support myPlex.

"To disable myPlex secure access do the following: OSX PMS - open terminal and paste this line: "defaults write com.plexapp.plexmediaserver disableRemoteSecurity -bool YES" - Then restart pms".


There was also an option for doing the same under Windows.


Is there a way to do this for the ReadyNAS?


Many thanks.

#2 Tobias Hieta

Tobias Hieta

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 3645 posts
  • Location: Gävle, Sweden

Posted 01 December 2011 - 05:28 PM

In $PLEX_HOME/Library/Application Support/Plex Media Server/Preferences.xml. I think you'll figure out what to do there :)

Follow me on twitter @tobiashieta or G+


#3 wibblewobble04

wibblewobble04

    Member

  • Members
  • PipPip
  • 30 posts

Posted 01 December 2011 - 07:20 PM

You are a star!! Thank you very much Posted Image

#4 cheets

cheets

    Member

  • Members
  • PipPip
  • 17 posts
  • Location: Finland

Posted 05 December 2011 - 04:48 PM

I've tried adding disableRemoteSecurity="1", "true", "YES" but I can't get it working. I've restarted pms after each edit. I've tested with Plex iOS client by adding the server through ip (using 3G on iPhone), I get an error about authentication. I am trying to get PMS to work on a remote Samsung TV. Samsung gives an error that it can't connect to the PMS.

I've had the PMS on ubuntu for a long time now and used the username/password authentication before. I'm now using myPlex of course and it works. Does the previous username/password mess this or is my attribute wrong? I'd like to be able to connect using the Samsung TV and that requires that all connections are accepted without authentication.

#5 cheets

cheets

    Member

  • Members
  • PipPip
  • 17 posts
  • Location: Finland

Posted 07 December 2011 - 07:21 AM

Well solved my situation so far by ssh tunneling. It's on the wiki, but if you want to share your tunnel to your tv you have to include -o 'GatewayPorts yes' parameter in the ssh command. So what I have is PMS (Linux) <-> SSH tunnel (that my friend opens in his iMac) <-> Samsung TV (on my friends LAN and it uses the SSH tunnel on iMac, so connects to the iMac LAN IP).

#6 ChuckFlix

ChuckFlix

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 13 December 2011 - 10:25 PM

Tobias - What was the final verdict on this? I have tried every value I can think of for it and none seem to work.

How do you disable myplex on a Linux Version of PMS?

#7 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7412 posts
  • Location: Maui

Posted 14 December 2011 - 06:10 PM

Hmm, the disableRemoteSecurity="1" should work, as long as there is no password already set in the database from a prior version. If there was you would need to clear it.

Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users