Jump to content


Photo

Can't get channel to play


  • Please log in to reply
43 replies to this topic

#1 loisannie@gmail.com

loisannie@gmail.com

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 December 2011 - 06:08 PM

I installed the Hulu channel onto Plex on my Roku. I disabled capability checking, so now it loads, but when I click on an actual show it goes to the "retrieving" page then goes back to the selection page. So the actual show never loads. Does anyone know how to fix this?? I'm not very tech savvy so help is much appreciated!!

#2 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 27 December 2011 - 06:19 PM

I could be wrong but I believe the Hulu channel doesn't work at the moment, I think it needs to be updated. I'll try to test it out soon.
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#3 loisannie@gmail.com

loisannie@gmail.com

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 December 2011 - 06:21 PM

Thanks!!

#4 Jam

Jam

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 4042 posts
  • Location: Manchester, UK

Posted 27 December 2011 - 06:32 PM

WebKit-based channels (those that use Flash or Silverlight video streams) don't currently work with the Roku client. We're working to address this issue.

#5 loisannie@gmail.com

loisannie@gmail.com

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 December 2011 - 07:37 PM

Thanks so much! Where will it be posted when it's fix?

#6 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 28 December 2011 - 03:35 PM

I've updated my branch to fix some issues with the channels. Right now you need to be in development mode to apply the changes.

Once we have a chance to cut a new release you'll automatically get the update within 24hrs of us uploading it to Roku.
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#7 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 28 December 2011 - 06:22 PM

So after some discussing things with Elan, I went and created a Beta version of the channel. You can add it by going here:

https://owner.roku.com/add/PlexBeta

And then on your Roku, enter the Channel Store and exit to pull down the update right away. I'll be trying to update that a bit more regularly with fixes while we wait a bit in between major releases to ensure stability (because there is no way to downgrade on the Roku, having a stable and a testing version is the best model, in my opinion).
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#8 Baloeb

Baloeb

    Member

  • Members
  • PipPip
  • 66 posts

Posted 28 December 2011 - 10:35 PM

Ok, this might seem like a dumb question, but how do you remove channels that don't work? I've installed the beta channel.

#9 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 28 December 2011 - 10:39 PM

Are you referring to Roku channels or Plex channels? It's unfortunately a little ambigious since Plex plugins are also called channels.

Roku channels you can, from the home screen, press the * button (options, I believe) on the remote, and remove the channel from that menu. The exception is if you've sideloaded a channel via developer mode, that chanel will have to be removed via the web interface on your unit.

As for Plex channels... honestly, I don't know. I've only added them, I haven't removed any yet. I'm basically building a collection to test with and see what works and what doesn't. I probably need to check and see if any of them need an update....
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#10 J.P.

J.P.

    Member

  • Members
  • PipPip
  • 35 posts

Posted 28 December 2011 - 10:39 PM

So after some discussing things with Elan, I went and created a Beta version of the channel. You can add it by going here:

https://owner.roku.com/add/PlexBeta

And then on your Roku, enter the Channel Store and exit to pull down the update right away. I'll be trying to update that a bit more regularly with fixes while we wait a bit in between major releases to ensure stability (because there is no way to downgrade on the Roku, having a stable and a testing version is the best model, in my opinion).


Alan,

This is great, thank you so much! Just loaded up the new beta channel, and ESPN3 and NBC started playing. Only issue is there is no sound. OSX, latest PMC. I have Soundflower installed on my server, does this have an impact?

Thanks!

J.P.

#11 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 28 December 2011 - 10:50 PM

Alan,

This is great, thank you so much! Just loaded up the new beta channel, and ESPN3 and NBC started playing. Only issue is there is no sound. OSX, latest PMC. I have Soundflower installed on my server, does this have an impact?

Thanks!

J.P.


I'm glad to hear that it's helping! I'm on a PC for my PMS (which I dual-boot between Win 7 and Ubuntu 11.10), so I can't really comment too much about a Mac. However, from a quick moment of Googling it seems like Soundflower handles sound routing between applications. That does sound like something that could cause issues. I know when I exited a channel that was playing a video during testing, a few times I actually had some few split seconds of sound come out the PC speakers instead of from the TV. And given that the PMS hands things off to ffmpeg to transcode, it sounds like Soundflower could be something that would interfere. However, that shouldn't be specific to the Roku client, just any remote client in general, so you should be able to pose that question (and the next logical one... "if it does, how can I best handle it without uninstalling the software?") on the Mac sub-forums here.

I'd be very curious to know the answer, just for general tech support future reference and all-around trivia gathering. :) I'd love to get my hands on a Mac to test with, I just don't have the spare $$ to part with to pick one up.

Also, disregarding the sound issue, how was the video quality of ESPN3? It was really, really bad to me, and I'm not sure if that's my PMS not having the horsepower to transcode as fast as it downloads + streams, and not buffering appropriately, or just the general video quality of the plugin. I'd test under the Laika client but I'm in Linux right now on my laptop, and I haven't managed to finagle Laika into running under Wine yet.

Edited by Alan Morgan, 28 December 2011 - 10:51 PM.

Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#12 J.P.

J.P.

    Member

  • Members
  • PipPip
  • 35 posts

Posted 28 December 2011 - 11:38 PM

Got the sound working!

1. Upgraded to the newest version of plex server (0.9.5.2) - didn't get the sound working initially
2. Unplugged Roku, waited 30 sec, and booted - didn't get the sound working initially
3. Uninstalled soundflower - channel wouldn't even load
4. Reinstalled soundflower - Channel worked with sound!!

Video quality is very good. looks like HD res with good bitrate, but the framerate may be a little low. I have a quad core 3GHz, so it seems to be handling it well.

Thanks again, this is fantastic!

#13 Baloeb

Baloeb

    Member

  • Members
  • PipPip
  • 66 posts

Posted 29 December 2011 - 05:58 AM

Sorry, I forgot they're both called channels. I meant the channels inside plex, such as youtube. I was going to remove the ones that don't work to make it easier for my family, but I couldn't figure out how to do it. By the way, I tried hulu and it worked fine for me now! The only complaint I have about the beta release is it seems like the back button on the roku remote doesn't work. You can still go back by pressing up, but it would be nice if the button worked.

#14 loisannie@gmail.com

loisannie@gmail.com

    Member

  • Members
  • PipPip
  • 14 posts

Posted 29 December 2011 - 06:14 AM

Yeah I don't know why - but for some reason it still doesn't work for me... Should I remove the old Plex channel too? Maybe it will work then?

#15 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 29 December 2011 - 09:11 AM

Yeah I don't know why - but for some reason it still doesn't work for me... Should I remove the old Plex channel too? Maybe it will work then?


Can you give me a little bit more detail on what's not working, as in what symptom are you experiencing now (whether it's the same or different), and what OS your PMS is. Note that some of the channels aren't going to work on a Linux PMS, because the Linux PMS doesnt support Flash and Silverlight.
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#16 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 29 December 2011 - 09:12 AM

Sorry, I forgot they're both called channels. I meant the channels inside plex, such as youtube. I was going to remove the ones that don't work to make it easier for my family, but I couldn't figure out how to do it. By the way, I tried hulu and it worked fine for me now! The only complaint I have about the beta release is it seems like the back button on the roku remote doesn't work. You can still go back by pressing up, but it would be nice if the button worked.


I'll look into how to remove them and get back to you. Wife is sleeping atm, so it'll be later.

Glad to hear Hulu works!

Are there specific spots where the back button doesn't work, or across the board? If specific spots, which ones?

Thanks for the feedback!
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#17 Mr.Fallen

Mr.Fallen

    Member

  • Members
  • PipPip
  • 13 posts

Posted 29 December 2011 - 05:11 PM

I'll repost this here, I may have posted the original message in the wrong area.

I am having a problem with my Roku accessing my Plex Media Server. I installed the PMS on my desktop, which is a Windows XP based system, added some local music files, but did not tweek anything. I then installed the Plex Media Center on the same computer, added a few internet channels, all seemed to work properly. I then added the latest Plex/Roku app on my new Roku 2 XS, configured it but could not get it to add apps to the video screen.

I read here to turn off the Compatibility Checking, I did so. Now my Plex app on my Roku adds channels fine. The first channel was CNET and all seemed to work okay. I then added more channels, NBC, Hulu, Netflex, etc., but when I try to load a program on any of these channels, the loading bar shows up, but it stalls and times out without loading the program. The first channel I had installed, CNET, still works fine.

Any help would be grealy appreciated.

Thank you,
Gary

#18 Jam

Jam

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 4042 posts
  • Location: Manchester, UK

Posted 29 December 2011 - 08:58 PM

Channels that use Flash or Silverlight video (like Hulu and Netflix) aren't supported on Windows XP, because the audio capture APIs aren't advanced enough. The media server makes use of the newer audio support added in Windows Vista.

#19 Alan Morgan

Alan Morgan

    Rock Star

  • Castle Keeper
  • PipPipPipPipPip
  • 770 posts

Posted 29 December 2011 - 11:16 PM

Also, several of the Plex channels require the newer PlexBeta Roku channel to work, as well.
Former member of the Plex for Roku development team

Units Owned: Roku 1 XD, Roku 2 XS

Posted Image

#20 loisannie@gmail.com

loisannie@gmail.com

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 December 2011 - 12:40 AM

I have Windows XP, so I guess that is why Hulu won't work?? I do have a computer with Vista. Do I just download PMS onto that computer to get it to work?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users