Jump to content


Photo

myPlex was unable to connect to your server


  • Please log in to reply
12 replies to this topic

#1 ath3na

ath3na

    Member

  • Members
  • PipPip
  • 11 posts

Posted 02 March 2012 - 01:38 PM

So a week ago everything connected and worked fine. I was able to connect to my server from myPlex on Android, iPad, and via web browser. A few days ago it would no longer connect. I checked the port forwarding, etc. and that is all still working fine. I continue to get the message that "myPlex was unable to connect to your server" but the light is green for the port mapping.

I'm not even sure what to try, but I'm pretty disappointed considering I've only had myPlex server installed for a month and the first time I try to go out of town and watch the things available on my PC, it's not going to work, it seems.

I leave to go out of town tomorrow. I had posted in another thread previously but hadn't gotten a response so I was hoping that this may help. Any help would be greatly appreciated! I would love more than anything to get this working before I leave tomorrow.

Thanks so much, in advance!

--
ath3na

P.S. In a previous post someone asked for the log file to be zipped. In the case that this would help in the troubleshooting, I thought I'd go ahead and post them. They are attached. Thanks again!

Attached Files



#2 Chris C

Chris C

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 11165 posts
  • Location: Austin, TX

Posted 10 March 2012 - 07:32 PM

Hey, ath3na

I saw in another thread that you said you upgraded to the 0.9.5.3 release. Could you please do the following to get some fresh logs from that new version?

1. Quit and restart the Plex Media Server so we get fresh logs.

2. Open the Preferences, go to the myPlex tab, and ensure it finishes attempting to connect.

3. Take a screenshot of that preference tab.

4. Zip up the "Plex Media Server.log" file and attach it here again.

5. Either attach the screenshot here or else send it to me in a private message (and reference this thread URL) if you like, since it should have your private IP address.


In addition:

- What router are you using?

- Does the router have uPnP and/or NAT-PMP enabled (if so, which one or both)?

- Are you manually forwarding any ports for the Plex Media Server?

Need help? Having trouble?
» Visit our Support Site for documentation, guides, and more - including the Getting Started section!
» Attach Log Files when reporting issues // See how to attach files in the forums
» Name and Organize your content correctly for best results

(no private messages for support unless requested, please)


#3 ath3na

ath3na

    Member

  • Members
  • PipPip
  • 11 posts

Posted 11 March 2012 - 05:05 PM

Hey, ath3na

I saw in another thread that you said you upgraded to the 0.9.5.3 release. Could you please do the following to get some fresh logs from that new version?

1. Quit and restart the Plex Media Server so we get fresh logs.

2. Open the Preferences, go to the myPlex tab, and ensure it finishes attempting to connect.

3. Take a screenshot of that preference tab.

4. Zip up the "Plex Media Server.log" file and attach it here again.

5. Either attach the screenshot here or else send it to me in a private message (and reference this thread URL) if you like, since it should have your private IP address.


In addition:

- What router are you using?

- Does the router have uPnP and/or NAT-PMP enabled (if so, which one or both)?

- Are you manually forwarding any ports for the Plex Media Server?


Attached is the log and screenshot.

My router is a Netgear N300 (model: WNR3500L) with the latest firmware. uPnp is turned on but I'm pretty certain NAT-PMP is not supported. I've often considered installing Tomato firmware but have not. I am manually forwarding the same port listed in the preferences dialog, 32800.

Thanks SO much, in advance, for your help!

-ath3na

Attached Files



#4 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 11 March 2012 - 05:53 PM

Have you tried disabling all but the network interface that connects to your router?
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#5 ath3na

ath3na

    Member

  • Members
  • PipPip
  • 11 posts

Posted 11 March 2012 - 11:16 PM

Have you tried disabling all but the network interface that connects to your router?


Yes- I've disabled all while troubleshooting. I even tried disabling IPv6, as I read on another thread that this could be part of the problem. None of that seemed to help. I mainly don't understand why it worked and then stopped.

#6 Chris C

Chris C

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 11165 posts
  • Location: Austin, TX

Posted 12 March 2012 - 02:43 AM

The logs appear to indicate that as far as the PMS side of things is concerned, things are set correctly. It detected your external WAN IP as 174.108.xxx.xxx and that you claim to have port 32400 available and forwarded to internal IP 192.168.1.100:32400. Up to that point, it all looks good. However, the logs then show the error:

Mar 11, 2012 12:53:02 [7552] DEBUG - MyPlex: Published Mapping State <--- 422
Mar 11, 2012 12:53:02 [7552] WARN - MyPlex: Invalid response when mapping state (code=422):<?xml version="1.0" encoding="UTF-8"?>
<MediaContainer size="1">
<Server name="Home-PC" host="" port="32400" machineIdentifier="xxxxxxxxxxxxxxxxxxxxx" version="0.9.5.3" />
</MediaContainer>


<?xml version="1.0" encoding="UTF-8"?>
<errors>
  <error>Address timeout while connecting to 174.108.xxx.xxx:32400</error>
</errors>
This indicates that the myPlex server was unable to connect back to your machine. When I attempt to see if I can get a manual connection to your IP:port via either HTTP or telnet, I'm likewise unsuccessful, which makes me think that the port forwarding isn't actually working correctly.

Now, just to verify, in your router settings, precisely what are your port forwarding settings?


Since your router supports uPnP, have you tried simply removing your manual port forward and letting the Plex Media Server auto-configure the connection? If so, what results do you get on the PMS preferences myPlex tab? Also, what are the "Plex Media Server.log" results?

Need help? Having trouble?
» Visit our Support Site for documentation, guides, and more - including the Getting Started section!
» Attach Log Files when reporting issues // See how to attach files in the forums
» Name and Organize your content correctly for best results

(no private messages for support unless requested, please)


#7 ath3na

ath3na

    Member

  • Members
  • PipPip
  • 11 posts

Posted 13 March 2012 - 11:31 PM

The logs appear to indicate that as far as the PMS side of things is concerned, things are set correctly. It detected your external WAN IP as 174.108.xxx.xxx and that you claim to have port 32400 available and forwarded to internal IP 192.168.1.100:32400. Up to that point, it all looks good. However, the logs then show the error:

Mar 11, 2012 12:53:02 [7552] DEBUG - MyPlex: Published Mapping State <--- 422
Mar 11, 2012 12:53:02 [7552] WARN - MyPlex: Invalid response when mapping state (code=422):<?xml version="1.0" encoding="UTF-8"?>
<MediaContainer size="1">
<Server name="Home-PC" host="" port="32400" machineIdentifier="xxxxxxxxxxxxxxxxxxxxx" version="0.9.5.3" />
</MediaContainer>


<?xml version="1.0" encoding="UTF-8"?>
<errors>
  <error>Address timeout while connecting to 174.108.xxx.xxx:32400</error>
</errors>
This indicates that the myPlex server was unable to connect back to your machine. When I attempt to see if I can get a manual connection to your IP:port via either HTTP or telnet, I'm likewise unsuccessful, which makes me think that the port forwarding isn't actually working correctly.

Now, just to verify, in your router settings, precisely what are your port forwarding settings?


Since your router supports uPnP, have you tried simply removing your manual port forward and letting the Plex Media Server auto-configure the connection? If so, what results do you get on the PMS preferences myPlex tab? Also, what are the "Plex Media Server.log" results?


So, I rebooted the router and modem and then deleted the port forwarding config and went with dedicated uPnP as you suggested. Seems that one of those things fixed it. Thanks for your help! I'll post again should I have future problems! Again, thanks SO much! It was a strangely simple fix, that didn't work before... but did this time, and either way I'm grateful!

-ath3na

#8 ghitis

ghitis

    Member

  • Members
  • PipPip
  • 14 posts

Posted 18 March 2012 - 05:17 PM

The program works great at home for me within the home network, but I am still unable to publish the server and access it from outside the home network. Same error: "my plex was unable to connect to your server"

Any ideas?

I use a windows 7 64 bit PC.

#9 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 18 March 2012 - 05:39 PM

The program works great at home for me within the home network, but I am still unable to publish the server and access it from outside the home network. Same error: "my plex was unable to connect to your server"

Any ideas?

I use a windows 7 64 bit PC.


If you could provide the your logs and answer the same questions Chris C. posted in the 2nd post of this thread it will help to get a better idea of what is going on.
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#10 ghitis

ghitis

    Member

  • Members
  • PipPip
  • 14 posts

Posted 18 March 2012 - 11:33 PM

If you could provide the your logs and answer the same questions Chris C. posted in the 2nd post of this thread it will help to get a better idea of what is going on.


i hope that doc includes what you need to help.
Attached File  Doc3.doc   300.5KB   16 downloads

#11 Chris C

Chris C

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 11165 posts
  • Location: Austin, TX

Posted 19 March 2012 - 05:51 AM

i hope that doc includes what you need to help.
Attached File  Doc3.doc   300.5KB   16 downloads

Sorry, I don't have MS Word and that file was blank when I tried opening it in both Preview and TextEdit. Please zip up the .log file after following the instructions as mentioned and provide answers to the other questions, then we can see if we can help.

Need help? Having trouble?
» Visit our Support Site for documentation, guides, and more - including the Getting Started section!
» Attach Log Files when reporting issues // See how to attach files in the forums
» Name and Organize your content correctly for best results

(no private messages for support unless requested, please)


#12 nickel715

nickel715

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 August 2013 - 08:39 AM

i've the same problem. I've an native ipv6 internet connection so my plex server is not accessible by the ipv4 address. 

I checked my log an found this:

<?xml version="1.0" encoding="UTF-8"?>
<errors>
  <error>Address timeout while connecting to 123.123.123.123:32400</error>
</errors>

 

so it seems plex try to connect to my server via ipv4 address, is there a way to tell plex using the ipv6 address?

 

Enabling IPv6 in Settings > Network doesn't help :(



#13 ciacci

ciacci

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 03 March 2014 - 07:07 PM

Same problem here, old plex server installed on Mac mini core duo (v. 0.9.8.6), I'm behind two router: Cisco 1700 from internet provider and Netopia TL-R600VPN from my side, with previous router all was fine (so i think the Cisco is not a problem, when i change to Netopia, myplex stops to work.

I try with UPNP and without, try to configure the NAT to port 32400 directly but not work, any suggestion?

 

Attached Files