Jump to content


Photo

Metadata agents for exported XBMC library

posters

  • Please log in to reply
521 replies to this topic

#441 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 09 March 2014 - 03:16 PM

I'll have a look at that over the week. :)



#442 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 11 March 2014 - 06:58 PM

@all:

Please update and try the support for opensubtitles and podnapisi subtitle agents. Does it work? Please report.



#443 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 11 March 2014 - 07:12 PM

@all:

Please update and try the support for opensubtitles and podnapisi subtitle agents. Does it work? Please report.

Perfect!!! Thanks a lot!!!!

It works great

 

***Would you be able to do the same for TV theme song plex agent?


 all-banner.jpg


#444 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 12 March 2014 - 07:51 AM

Nice it works. :) I'll try the theme song agent again, but AFAIR I already did sometime and it did not work. I'll report back later.



#445 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 12 March 2014 - 12:28 PM

Nice it works. :) I'll try the theme song agent again, but AFAIR I already did sometime and it did not work. I'll report back later.

oh right, we already discussed this, sorry, I forgot....


 all-banner.jpg


#446 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 12 March 2014 - 06:05 PM

No problem. :) I'm glad you forgot, because whatever I did the last time, it seems I did it wrong. This time it seems to work. Please update once Guillaume pulls my change and test. :)



#447 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 12 March 2014 - 06:18 PM

No problem. :) I'm glad you forgot, because whatever I did the last time, it seems I did it wrong. This time it seems to work. Please update once Guillaume pulls my change and test. :)

You're the man!


 all-banner.jpg


#448 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 12 March 2014 - 06:28 PM

No problem. :) I'm glad you forgot, because whatever I did the last time, it seems I did it wrong. This time it seems to work. Please update once Guillaume pulls my change and test. :)

No sure if it's related to the NFO importer but Plex TV theme song agent generates errors:

2014-03-12 14:20:46,479 (fe8) :  DEBUG (runtime:717) - Handling request GET /:/plugins/com.plexapp.agents.plexthememusic/messaging/function/X0FnZW50S2l0OlNlYXJjaA__/Y2VyZWFsMQoxCmxpc3QKMApyMAo_/Y2VyZWFsMQoyCmRpY3QKZGljdAo0CnMyCnhuczQKbGFuZ3M3ClRWX1Nob3dzMTAKbWVkaWFfdHlwZWIwczYKbWFudWFscjEKczYKa3dhcmdzMwpzNDUKY29tLnBsZXhhcHAuYWdlbnRzLnhibWNuZm90djovLzI1ODYxOD9sYW5nPXhuczQKZ3VpZGIxczUKZm9yY2VzMjgKY29tLnBsZXhhcHAuYWdlbnRzLnhibWNuZm90dnMxMwpwcmltYXJ5X2FnZW50cjAK
2014-03-12 14:20:46,479 (fe8) :  DEBUG (runtime:814) - Found route matching /:/plugins/com.plexapp.agents.plexthememusic/messaging/function/X0FnZW50S2l0OlNlYXJjaA__/Y2VyZWFsMQoxCmxpc3QKMApyMAo_/Y2VyZWFsMQoyCmRpY3QKZGljdAo0CnMyCnhuczQKbGFuZ3M3ClRWX1Nob3dzMTAKbWVkaWFfdHlwZWIwczYKbWFudWFscjEKczYKa3dhcmdzMwpzNDUKY29tLnBsZXhhcHAuYWdlbnRzLnhibWNuZm90djovLzI1ODYxOD9sYW5nPXhuczQKZ3VpZGIxczUKZm9yY2VzMjgKY29tLnBsZXhhcHAuYWdlbnRzLnhibWNuZm90dnMxMwpwcmltYXJ5X2FnZW50cjAK
2014-03-12 14:20:46,479 (fe8) :  INFO (agentkit:915) - Searching for matches for {'guid': 'com.plexapp.agents.xbmcnfotv://258618?lang=xn', 'force': True, 'primary_agent': 'com.plexapp.agents.xbmcnfotv'}
2014-03-12 14:20:46,479 (fe8) :  DEBUG (model:32) - Loading model with GUID com.plexapp.agents.xbmcnfotv://258618?lang=xn
2014-03-12 14:20:46,479 (fe8) :  DEBUG (model:223) - Deserializing from C:\Users\Administrator\AppData\Local\Plex Media Server\Metadata\TV Shows\0\624af85fca5f4da19f657dd3e3c87fb2f62c316.bundle\Contents\com.plexapp.agents.xbmcnfotv\Info.xml
2014-03-12 14:20:46,588 (fe8) :  DEBUG (runtime:918) - Response: [200] str, 604 bytes
2014-03-12 14:20:46,602 (12bc) :  DEBUG (runtime:717) - Handling request GET /:/plugins/com.plexapp.agents.plexthememusic/messaging/function/X0FnZW50S2l0OlVwZGF0ZU1ldGFkYXRh/Y2VyZWFsMQoxCmxpc3QKMApyMAo_/Y2VyZWFsMQoxCmRpY3QKNwpzMgp4bnM0CmxhbmdiMXM1CmZvcmNlbnMxMApwYXJlbnRHVUlEczcKVFZfU2hvd3MxMAptZWRpYV90eXBlczUKMjc3NjFzNApkYmlkczQ1CmNvbS5wbGV4YXBwLmFnZW50cy54Ym1jbmZvdHY6Ly8yNTg2MTg%40bGFuZz14bnM0Cmd1aWRzNgoyNTg2MThzMgppZHIwCg__
2014-03-12 14:20:46,602 (12bc) :  DEBUG (runtime:814) - Found route matching /:/plugins/com.plexapp.agents.plexthememusic/messaging/function/X0FnZW50S2l0OlVwZGF0ZU1ldGFkYXRh/Y2VyZWFsMQoxCmxpc3QKMApyMAo_/Y2VyZWFsMQoxCmRpY3QKNwpzMgp4bnM0CmxhbmdiMXM1CmZvcmNlbnMxMApwYXJlbnRHVUlEczcKVFZfU2hvd3MxMAptZWRpYV90eXBlczUKMjc3NjFzNApkYmlkczQ1CmNvbS5wbGV4YXBwLmFnZW50cy54Ym1jbmZvdHY6Ly8yNTg2MTg@bGFuZz14bnM0Cmd1aWRzNgoyNTg2MThzMgppZHIwCg__
2014-03-12 14:20:46,602 (12bc) :  DEBUG (model:32) - Loading model with GUID com.plexapp.agents.xbmcnfotv://258618?lang=xn
2014-03-12 14:20:46,602 (12bc) :  ERROR (model:194) - Cannot read model from C:\Users\Administrator\AppData\Local\Plex Media Server\Metadata\TV Shows\0\624af85fca5f4da19f657dd3e3c87fb2f62c316.bundle\Contents\com.plexapp.agents.plexthememusic
2014-03-12 14:20:46,602 (12bc) :  DEBUG (networking:172) - Requesting 'http://127.0.0.1:324...ata/27761/tree'
2014-03-12 14:20:46,727 (12bc) :  DEBUG (networking:172) - Requesting 'http://tvthemes.plexapp.com/258618.mp3'
2014-03-12 14:20:46,900 (12bc) :  ERROR (networking:223) - Error opening URL 'http://tvthemes.plexapp.com/258618.mp3'
2014-03-12 14:20:46,900 (12bc) :  DEBUG (model:218) - Serializing to C:\Users\Administrator\AppData\Local\Plex Media Server\Metadata\TV Shows\0\624af85fca5f4da19f657dd3e3c87fb2f62c316.bundle\Contents\com.plexapp.agents.plexthememusic\Info.xml
2014-03-12 14:20:46,900 (12bc) :  DEBUG (runtime:918) - Response: [200] str, 16 bytes

 all-banner.jpg


#449 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 12 March 2014 - 09:48 PM

Okay. :( Looking into it, the ids generated by the XBMCnfoTVAgent differ from what the plex music agent expects. So it is not possible to fetch the theme file of the plex server. I'll see if I can make them match.

 

edit:

When scanning with TheTVDB, I get the same IDs for my tv test section and no theme for most of the shows in there either. So it seems that the problem could be that there are shows that have no theme available on the plextheme server. Please check that the id matches the show you want the theme for. If it does, there propably is no theme.

 

In the example you provided the thememusic agent tries to access id 258618. This is for the show Men at Work on thetvdb, correct? Plex has no theme for that or http:// tvthemes.plexapp.com/258618. mp3 would work. But it doesn't.



#450 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 21 March 2014 - 01:10 AM

I'm almost 95% sure of this issue... lol

 

the nfo importer doesn't add the srt subtitle file as subtitle in PMS on scan.

Only way is to use "local media asset" additionally to the importer. When I add this one additionally, PMS gets the subtitle (srt) in database. Without it, only with nfo importer, nothing even if file is present.

 

***Not talking about the Open Subtitle agent in PMS, talking about existing srt files in movie folder.

 

In my structure I have two kinds of formats:

2014-03-20%209-10-47%20PM.jpg

 

2014-03-20%209-11-14%20PM.jpg

 

I think it should get multiple file naming conventions for .srt files personally.

 

The problem:

2014-03-20%209-13-49%20PM.jpg

 

Open Subtitle agent doing it in PMS:

2014-03-20%209-14-09%20PM.jpg

 

What it should do (what Local Media Asset does right now)

2014-03-20%209-14-46%20PM.jpg


 all-banner.jpg


#451 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 21 March 2014 - 07:59 AM

I'll see if I can add this function.



#452 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 21 March 2014 - 12:13 PM

I'll see if I can add this function.

Thanks, Appreciate it  :)


 all-banner.jpg


#453 shockwave

shockwave

    Dedicated Member

  • Members
  • PipPipPip
  • 114 posts

Posted 21 March 2014 - 12:56 PM

Thanks, Appreciate it  :)

 

 

I'll see if I can add this function.

 

Why add it at all? I don't see anything wrong with using local media assets in addition to the xbmc agent. Adding function for something that already does what you need is redundant I think.



#454 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 21 March 2014 - 01:08 PM

Why add it at all? I don't see anything wrong with using local media assets in addition to the xbmc agent. Adding function for something that already does what you need is redundant I think.

Why double scanning with a second agent when only one can do it all? And it's part of what it should do IMO anyway.

Before he fixed it, there were issues with TV show images (Frodo standards), using local media asset was still working but he fixed it and now the nfo importer does it all... I don't see the difference..


 all-banner.jpg


#455 shockwave

shockwave

    Dedicated Member

  • Members
  • PipPipPip
  • 114 posts

Posted 21 March 2014 - 01:15 PM

Why double scanning with a second agent when only one can do it all? And it's part of what it should do IMO anyway.

Before he fixed it, there were issues with TV show images (Frodo standards), using local media asset was still working but he fixed it and now the nfo importer does it all... I don't see the difference..

 

Just thought @SirG already did so much for this project already that we should be grateful it works at all. Adding this would mean also adding support for ass, ssa, sub/idx and sup too which I'm not sure how difficult that would be.

 

:-)



#456 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 21 March 2014 - 01:27 PM

Just thought @SirG already did so much for this project already that we should be grateful it works at all. Adding this would mean also adding support for ass, ssa, sub/idx and sup too which I'm not sure how difficult that would be.

 

:-)

If there is one person that appreciates this agent, it's me... Without it, I'm not even sure I would use Plex based on my environment... (along with Trakt channel)

Doesn't mean it can't be better though. 

Not a rush or a deal breaker, just stating a missing feature... 

The goal I think is to only use the nfo importer when already have data in folders (well except for Plex specific items like fetching subtitles with Open Subtitle agent, etc...)

 

It's like not making request to Plex team just because we need to be graceful about the solution. 

 

But I agree that the agents are really solid and works perfectly at this stage so this isn't a high priority request (compared to when it wasn't fetching images from Frodo standard naming convention, etc...)


 all-banner.jpg


#457 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 21 March 2014 - 03:16 PM

If you have ideas, don't hesitate to post them. :) If I feel something would be a useful addition I add it to my todo list. If not, I'll propably tell you to do it yourself. :P I'm always open for discussion, so even then you might be able to persuade me. :)

 

What I add to the todo, I'll work on, if I have the freetime. I'm doing it for fun, so if something proves to be a task too time consuming or complicated for me to handle, I'll drop it or leave it for a retry later. ^_^ Multiepisode nfos as an example, I had several failed tries on that, until I got the correct hints to make it work. I'm no professional programmer, so sometimes there might be things I just can't handle. :) But I'll try at least and until now, I think we manged to iron out most of the problems the agents had. :)

 

So let's keep up the good work. :) Keep your ideas coming and I'll see what I can to about it. :)



#458 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 24 March 2014 - 03:03 AM

Just a heads up in advance about TV NFO importer.

see http://themetabrowse...s/1/topics/8533

 

Since the support of the multi episode in MetaBrowser, the NFOs now has <multiepisodenfo> and NFO importer doesn't fetch episode metadata since then.

I'm still waiting on Fatal reply on this (since this seems to occur on "single episode" files also for nothing) BUT XBMC is reading them fine still...

 

Just wanted to have your opinion on this...

 

**Update: for the single episode file that still added  <multiepisodenfo>, issue is resolved in a maintenance update.

So besides the fact that refreshing an episode isn't enough and I have to fix match the entire show to correct in Plex, not an issue from your point of view.

*BTW that's annoying, if metadata in NFO has been scanned, if it's changed, refreshing won't update it, need to fix match the entire show...


 all-banner.jpg


#459 SlrG

SlrG

    Dedicated Member

  • Members
  • PipPipPip
  • 137 posts

Posted 24 March 2014 - 01:36 PM

Even if removed for single episodes, it still breaks the agents recognition of multi episode nfos. I sent a PR to Guillaume to fix this. :)

 

Sadly I don't know how to force the agent to always update on rescan. :( It bugs me too and I already tried to find out If there is something I can do about it, but I did not find a solution.



#460 sfnetwork

sfnetwork

    Rock Star

  • Members
  • PipPipPipPipPip
  • 865 posts
  • Location: Quebec, Canada

Posted 24 March 2014 - 01:41 PM

Even if removed for single episodes, it still breaks the agents recognition of multi episode nfos. I sent a PR to Guillaume to fix this. :)

 

Sadly I don't know how to force the agent to always update on rescan. :( It bugs me too and I already tried to find out If there is something I can do about it, but I did not find a solution.

Thanks, appreciate it.


 all-banner.jpg






Also tagged with one or more of these keywords: posters

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users