Jump to content


Photo

Duplicate Movie Entries


  • Please log in to reply
11 replies to this topic

#1 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 25 March 2012 - 06:44 PM

I'm running PMS 9.5.2 on Windows Home Server 1.0.

I've reinstalled Plex and set it up so that metadata info is on another drive. Everything has been going well, but all of a sudden Plex has been duplicating movies in my library. I inititialy saw it as mismatched entries and easily fixed those issues. But now I am seeing actual duplicates and I see no way to remove those enteries. I've googled this issue and searched this forum with no luck. I've also looked through the FAQ's and tried some of the items mentioned, but they don't seem to work for me, or the options don't show up. This is very frustrating for me. I really want Plex to work for me, and it has all the clients for the devices I have. But these little things that pop up are really annoying...

Thanks!

Eric

#2 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 25 March 2012 - 06:54 PM

I'm running PMS 9.5.2 on Windows Home Server 1.0.

I've reinstalled Plex and set it up so that metadata info is on another drive. Everything has been going well, but all of a sudden Plex has been duplicating movies in my library. I inititialy saw it as mismatched entries and easily fixed those issues. But now I am seeing actual duplicates and I see no way to remove those enteries. I've googled this issue and searched this forum with no luck. I've also looked through the FAQ's and tried some of the items mentioned, but they don't seem to work for me, or the options don't show up. This is very frustrating for me. I really want Plex to work for me, and it has all the clients for the devices I have. But these little things that pop up are really annoying...

Thanks!

Eric


I would try these things
- ensure "Empty trash automatically after every scan" is enabled on the Library tab of the PMS perferences.
- ensure that your media is named as per the naming guide
- the is a newer 9.5.3 version of the server available, upgrading might help
- perform a deep scan (and even a forced refresh) on the sections that you are seeing the duplicates on.

How have you ensured the metadata is located on a different drive? Check that it's not still using all the old metadata as well as what you have setup in the new location.

http://wiki.plexapp....MS_Naming_Guide
http://wiki.plexapp....nager#Deep_Scan
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#3 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 25 March 2012 - 08:47 PM

I have setup the metadata location based on this post here.

I'll be honest, I am not 100% using the naming convention. The files are named after the movie and reside in their own directory (i.e \\server\share\Movies\Back To The Future\Back To The Future.mp4), which has been working just great until the last 24 hours when the last 5 movies that I ripped started duplicating. I have over 400 movies ripped and don't relish the idea of going back and renaming each movie.

I was on 9.5.3, but I read in a post that there were issues with that build, so I rolled back to 9.5.2 until the next build comes out.

I'll try the deep scan, and I'll rename the problem files to the naming convention to see if that helps clear up the issue.

Thanks for the help!

Eric

#4 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 25 March 2012 - 09:09 PM

I did a "forced refresh" and I renamed the files, but it didn't help. I'm still getting duplicate entries for each new movie that I've added today. I don't think the problem is with the way I'm naming the movies or in the metadata within the file itself. Something is causing Plex to duplicate the entries for each new file added. While I don't know why Plex is doing it, it could easily be (temporarily) solved if we had the ability to delete indivdual entries (a feature which I can't seem to find or is noticably absent).

Thanks!

Eric

#5 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 25 March 2012 - 09:29 PM

I did a "forced refresh" and I renamed the files, but it didn't help. I'm still getting duplicate entries for each new movie that I've added today. I don't think the problem is with the way I'm naming the movies or in the metadata within the file itself. Something is causing Plex to duplicate the entries for each new file added. While I don't know why Plex is doing it, it could easily be (temporarily) solved if we had the ability to delete indivdual entries (a feature which I can't seem to find or is noticably absent).

Thanks!

Eric


If you try and play all the duplicates of the same movie do they all play? And if so, do they play the right movie or is it something else?
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#6 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 25 March 2012 - 11:32 PM

If you try and play all the duplicates of the same movie do they all play? And if so, do they play the right movie or is it something else?


I haven't tried that yet, I'll give it a shot. I did however look at each of the pair of entries, and they are exact matches to the same file. They both reference the same movie file.

I also removed the section they were stored in and then added it back. When I add the section back, the duplicates don't reappear. I still have more movies to add tonight, so I'll let you know if the duplicates both play the same movie (if I get more duplicates tonight)...

Thanks!

Eric

#7 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 26 March 2012 - 12:42 AM

If you try and play all the duplicates of the same movie do they all play? And if so, do they play the right movie or is it something else?


Well I just added a new movie and PMS added two entries for the same movie. Both entries are identical and play the same file. The only way I know to remove these duplicates is to remove the section and then add it back, which is a pain because I have about 5-7 movies that I have to tweak every time to fix them when added new. Oh, well...

Thanks!

Eric

#8 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 14 April 2012 - 08:13 PM

Ok, this is really getting frustrating. Every couple of days I have to delete my library and re-add it to get rid of the duplicate entries. Now that's not evern working, because it's adding duplicates back into the mix when I re-add the library.

Please give us the ability to remove duplicates or fix the issue!

FYI, I'm running the 0.9.6.0 beta and the issue is still there...

#9 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 09 May 2012 - 01:19 AM

Ok, this is really getting frustrating. Every couple of days I have to delete my library and re-add it to get rid of the duplicate entries. Now that's not evern working, because it's adding duplicates back into the mix when I re-add the library.

Please give us the ability to remove duplicates or fix the issue!

FYI, I'm running the 0.9.6.0 beta and the issue is still there...

Can you;
1) Restart your pms
2) Run a deep scan
3) Upload your Plex Media Server.log and Plex Media Scanner.log files
4) let us know the names of a few movies that are duplicates so we can track down the log activity.

http://wiki.plexapp....#Plex_Log_Files
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#10 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 09 May 2012 - 03:50 AM

Ok, following what you said to do, here (attached) are the log files requested. I'm down to one file right now that is being duplicated: Pirates of the Carribean: The Curse of the Black Pearl.

Please let me know what else I can do...

Thanks Trudge!

Eric

Attached Files



#11 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 09 May 2012 - 04:00 AM

Ok, following what you said to do, here (attached) are the log files requested. I'm down to one file right now that is being duplicated: Pirates of the Carribean: The Curse of the Black Pearl.

Please let me know what else I can do...

Thanks Trudge!

Eric

You have 2 copies of it. :)

May 08, 2012 18:42:19:890 [6408] DEBUG - Adding subdirectory for scanner: D:\shares\Videos\Movies\The Pirates of the Caribbean - The Curse of the Black Pearl
May 08, 2012 18:42:19:875 [6408] DEBUG - Adding subdirectory for scanner: D:\shares\Videos\Movies\Pirates of the Caribbean - The Curse of the Black Pearl

Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#12 zoxxo

zoxxo

    Member

  • Members
  • PipPip
  • 46 posts
  • Location: Sammamish, WA

Posted 09 May 2012 - 04:15 AM

Wow now I feel really stupid. Sorry Trudge, and thanks for helping me find this totally obvious mistake on my part.

Now the last problem is solved and there is nothing to stop me from enjoying Plex in all it's glory and coolness.

Thanks for the help!

Eric