Jump to content


Photo

Plex not showing all TV shows


  • Please log in to reply
16 replies to this topic

#1 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 04:12 PM

I just built 2 Ubuntu 12.04 server VMs on ESXi. I got Plex installed and working, but it's only showing 4 TV shows (out of 30). I have nfs mounts to an OpenMediaVault NAS. Movies work fine. I can browse in nautilus and see all the TV show folders and files. I noticed in the terminal doing an ls for the directory shows a green highlight around the blue text for the folders that are showing up in Plex. Also, my main Plex Server (Ubuntu 11.04) has the same nfs mappings and all of my TV shows come up on that server.

Any thoughts on what I can try?

EDIT: ls -l reveals that the TV shows that Plex sees have drwxrwxrwx in the left column, whereas the shows that are missing only have drwx in that column. I'm not familiar with what that means or how to change all folders to drwxrwxrwx. A quick Googling suggest that it might be how nfs mounts. The only option I put in fstab is auto. Any tips on nfs mount options would be appreciated as well. :)

#2 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1950 posts
  • Location: Aarhus - Denmark

Posted 29 April 2012 - 04:34 PM

Force a deepscan or force refresh, could be an option.

http://wiki.plexapp....MS_MediaManager

Goto section 2.3.2, About refreshing content manually. And see if that helps.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#3 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 04:49 PM

Force a deepscan or force refresh, could be an option.

http://wiki.plexapp....MS_MediaManager

Goto section 2.3.2, About refreshing content manually. And see if that helps.

/Mark


Thanks for the response! I tried holding Alt and clicking Refresh and it starts scanning but quickly finishes. I wasn't aware of that though, so it's good to know!

#4 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1950 posts
  • Location: Aarhus - Denmark

Posted 29 April 2012 - 04:58 PM

In your fstab, you can also use the option mode=755 to try and force a globally readable mount.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#5 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 05:54 PM

In your fstab, you can also use the option mode=755 to try and force a globally readable mount.

/Mark


It errors out when I add that option. I tried mount with rw and that brought the permissions to drwxrwx, which is what my Movies are set at. I noticed the Movie folders all have blue text with green background. Any idea how I can set folders to have a green background... whatever that setting means? The frustrating part is that I can do an ls -l on my main working desktop, and it shows the same permissions on the folder, but all my shows work fine on that Plex Server.

#6 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1950 posts
  • Location: Aarhus - Denmark

Posted 29 April 2012 - 06:01 PM

It errors out when I add that option. I tried mount with rw and that brought the permissions to drwxrwx, which is what my Movies are set at. I noticed the Movie folders all have blue text with green background. Any idea how I can set folders to have a green background... whatever that setting means? The frustrating part is that I can do an ls -l on my main working desktop, and it shows the same permissions on the folder, but all my shows work fine on that Plex Server.


Ok.. The green background means that the folder/file is world writable. Consider it a warning from the OS that this could be dangerous. To get permissions to get that way from command line as root run chmod -R 777, though i would recommend chmod -R 755 instead. That should give plex access to your media files.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#7 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 06:11 PM

I tried running sudo chmod -R 755 /mnt/tv, which is my nfs mount, and it tells me that "Operation is not permitted". Is this because it's a nfs mount and not a local drive? I can still read and write to the mount. Creating a new, empty folder in /mnt/tv doesn't show the green highlight.

#8 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1950 posts
  • Location: Aarhus - Denmark

Posted 29 April 2012 - 06:26 PM

If mode isnt supported, you can try option umask=022 that should work.

Maybe you could print yoyrvfstab line to help debug on it.

/Mark.
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#9 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 06:40 PM

I received an error that an incorrect mount option was specified. Here's my fstab line for this mount:

192.168.1.108:/tv/TV /mnt/tv nfs rw,user,umask=022 0 0

#10 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1950 posts
  • Location: Aarhus - Denmark

Posted 29 April 2012 - 07:25 PM

my bad on the umask option, on my phone I didn't notice it under fat option, and thought it was nfs option.

If you setup your NFS mounts in the same manor on your ubuntu 12.04 as on your 11.04, it sounds as if something has changed on Ubuntu.

What options are set on your OpenMediaVault NAS?

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#11 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 29 April 2012 - 09:21 PM

Actually I hadn't put the mount in fstab on the 11.04 box. I just manually mount it (mount -t nfs 192.168.1.108:/tv/TV /mnt/tv). I haven't bothered making it permanent since I'm moving away from that box. I guess that's something I could try it just manually mounting it and seeing it that works on the 12.04 vm, although I'm not sure what the difference would be as I don't put options when mapping manually.

The OMV NAS settings shares out to 192.168.1.0/24 with rw,async options. This is for both media (where Movies reside) and tv shares. What's confusing is even in fstab I'm mounting the media share with the same options and Plex picks up all of my Movies just fine.

#12 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 05 May 2012 - 08:48 PM

Ok this is getting ridiculous. I can't get it to mount in a way that Plex reads it. My current Plex server can read from the same NFS mount just fine. I tried using rsync -rpltD to copy to a different drive with another NFS share. Same issue. Could this be an issue with Ubuntu 12.04? I guess I can try setting up another VM with an older version of Ubuntu to see if that works. It just doesn't seem to make sense. Any other ideas would be appreciated.

#13 gatorman22

gatorman22

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 08 May 2012 - 04:24 PM

I had a weird issue with permissions at first too. I have a user 'plex' that handles the server execution. What I did was 'chown -R plex:plex Library' and 'chmod -R 777 Library' as root. Now as far as mounting that on a remote machine with NFS, I haven't done that. Best of luck.

#14 Tobias Hieta

Tobias Hieta

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 3652 posts
  • Location: Gävle, Sweden

Posted 08 May 2012 - 04:45 PM

The new release 0.9.6.1 actually allows you to run PlexMediaServer as another user than plex. Edit /etc/defaults/plexmediaserver and change it there if you want to. Note that there is a good reason why it was separated from the start, limited access == limited damage.

IF you decide to run it as something else than the plex user, PLEASE DON'T RUN IT AS ROOT, that will make me very sad and you even more sad when a bug removes your whole diskdrive or posts your porn to twitter.

Follow me on twitter @tobiashieta or G+


#15 gatorman22

gatorman22

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 08 May 2012 - 07:42 PM

posts your porn to twitter.


Impossible! I don't have Twitter!!

#16 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 11 May 2012 - 11:58 PM

Ha! Thanks for the replies. :)

I'd rather not run Plex as a different user. It might be a workaround, but I should be able to get it to work, since all my movies plus a few TV shows actually show up in Plex.

I tried a few things and here's what I've found. The TV shows that are showing up in Plex were rsync'd from a local drive to the nfs share. The shows that are missing were all rsync'd from an external usb drive. I copied from the nfs share, back to local drive, deleted the show from the nfs share, then copied it back using "cp -R --preserve=timestamps" and now Plex pulls the show in! This sucks though, since it means I have to recopy 500+ gigs of data, twice. Would anyone know of an easier way to fix the data that's already on the nfs share?

#17 snowglyder

snowglyder

    Member

  • Members
  • PipPip
  • 22 posts

Posted 12 May 2012 - 04:22 AM

I got it all working without having to recopy everything. I had to rebuild the folders and their seasons for all of the shows that Plex wasn't recognising, then move the data to the newly created structure. I'm sure someone who knows bash could script this, but I did it all manually. I know it had something to do with permissions, but no matter what I tried via command line, I could not chown or chmod within the nfs share. I'm all working now though!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users