Jump to content


Photo

How to change user/password for PMS?


  • Please log in to reply
13 replies to this topic

#1 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 21 June 2012 - 02:21 PM

Alright, im trying to figure out how to change the username and password to access the /manage url. Also, when logging in localy there is no authentication at all(?)

First of all I want to enable username/password login even for local, since im on a huge student LAN where we can all see eachother, that means all people in my buidling could easily just connect to my server which is totally insane. How do I fix this?

Second, how do I change the password when loggin in for another network? When logged in in the /manage panel there is no setting for this.

I can not use myplex for login to the panel, I need to set user/pass for PMS to stream from other programs rather than plex-client (and then myplex is out of the question). How do I set user/pass?

Using debian btw.

Regards.

#2 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1941 posts
  • Location: Aarhus - Denmark

Posted 21 June 2012 - 02:37 PM

Hi and welcome to the forums.

In regards to password protecting you management interface, I'm afraid the only way to have authentication is to use the myPlex portal. Info on myPlex portal here: http://wiki.plexapp....ndex.php/MyPlex

Once you setup a myPlex account you can go on to getting the management security setup. As of the latest beta 0.9.6.4, there is a new option for the preferences.xml file that will allow you to define what networks can access you server without password. So in this case where you have a huge student network the sane thing would be to set it up so only localhost can access the management page password free. See this page for preferences.xml settings: http://wiki.plexapp....ble_preferences

The option you are looking for is allowedNetworks. Simply edit /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml and add to the Preferences section the option this way: allowedNetworks="127.0.0.1/255.255.255.0"

Then restart Plex Media Server and hopefully it should work for you.

Update: If that is not a viable solution, I'm wonder if setting up an apache with proxypass on / with htaccess could do it for you (has to be a full host to enable all traffic via the proxy module)? I don't know if clients like that solution, but since you looking at having non-plex clients access it, they might be able to get the content you want.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#3 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 21 June 2012 - 03:32 PM

Hi and welcome to the forums.

In regards to password protecting you management interface, I'm afraid the only way to have authentication is to use the myPlex portal. Info on myPlex portal here: http://wiki.plexapp....ndex.php/MyPlex

Once you setup a myPlex account you can go on to getting the management security setup. As of the latest beta 0.9.6.4, there is a new option for the preferences.xml file that will allow you to define what networks can access you server without password. So in this case where you have a huge student network the sane thing would be to set it up so only localhost can access the management page password free. See this page for preferences.xml settings: http://wiki.plexapp....ble_preferences

The option you are looking for is allowedNetworks. Simply edit /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml and add to the Preferences section the option this way: allowedNetworks="127.0.0.1/255.255.255.0"

Then restart Plex Media Server and hopefully it should work for you.

Update: If that is not a viable solution, I'm wonder if setting up an apache with proxypass on / with htaccess could do it for you (has to be a full host to enable all traffic via the proxy module)? I don't know if clients like that solution, but since you looking at having non-plex clients access it, they might be able to get the content you want.

/Mark


Using allowedNetworks to only allow localhost will be perfect. Thanks.

However, the second thing to change the user/password for logging in then? Since using other programs for streaming will require this. If this isn't possible it is kinda wierd locking in your own product forcing using myplex-portal? :/ Which means back to XBMC again..

#4 lazybones

lazybones

    Rock Star

  • Members
  • PipPipPipPipPip
  • 706 posts

Posted 21 June 2012 - 03:46 PM

Using allowedNetworks to only allow localhost will be perfect. Thanks.

However, the second thing to change the user/password for logging in then? Since using other programs for streaming will require this. If this isn't possible it is kinda wierd locking in your own product forcing using myplex-portal? :/ Which means back to XBMC again..



If you arn't using multipule remote devices and have everything local there isn't much point using plex over xbmc to begin with.. myPlex makes remote access very easy as it essentially acts like a dyndns service for the app and allows content sharing to other users running plex.

#5 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 21 June 2012 - 03:54 PM

If you arn't using multipule remote devices and have everything local there isn't much point using plex over xbmc to begin with.. myPlex makes remote access very easy as it essentially acts like a dyndns service for the app and allows content sharing to other users running plex.


Well I'm currently trying setting up a new server on another location (just to NOT have my server localy on my student lan..) and need to be able to change the user/password for PMS. This is because some applications probes the movie/serie-database and cannot use myplex but it works like a charm with the "standard" PMS user/pass. But for some reason its removed to change this in the latest version? How to fix this(any workaround?)

#6 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1941 posts
  • Location: Aarhus - Denmark

Posted 21 June 2012 - 03:58 PM

Hi w00t,

I can follow your thoughts on the authentication mechanism, and it is locking users to one authentication method to rule them all. However it does simplify access significantly and covers over 99% of the userbases needs. But it's all in the hands of the devs here. There at the moment just is other authentication method. In regards to controlling access to pms, using apache mod_proxy would allow access from apache to the system via localhost, and give you a controlling layer for the clients to access through. You could even add ip/password restrictions, to your liking. Though I have not personally tested having mod_proxy between clients and pms, it might be a viable solution to your issue. And if as you say, are going to be using non plex clients (I count plexbmc as a plex client), then the last hurdle of having two services on port 32400 can be overcome by having apache listen on a different port.

What are the clients you want to use. And can they run on other ports than 32400. If not set up an alias ip for apache and add at to e allowed networks list in preferences.

Well, my tired brain needs a break with a beer.

Hope I gave you some ideas on a solution that would suit your needs. And if you want I posted a working config somewhere on e forum for getting a proxy set up. Or just let me know and ill repost it. Just requires the vhost conf to be dedicated to pms, because he API/interface to pms is not pure http.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#7 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1941 posts
  • Location: Aarhus - Denmark

Posted 21 June 2012 - 04:21 PM

Well I'm currently trying setting up a new server on another location (just to NOT have my server localy on my student lan..) and need to be able to change the user/password for PMS. This is because some applications probes the movie/serie-database and cannot use myplex but it works like a charm with the "standard" PMS user/pass. But for some reason its removed to change this in the latest version? How to fix this(any workaround?)



If its just probing PMS for info, a proxy might just do it for you.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#8 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 26 June 2012 - 11:12 AM

Hi w00t,

I can follow your thoughts on the authentication mechanism, and it is locking users to one authentication method to rule them all. However it does simplify access significantly and covers over 99% of the userbases needs. But it's all in the hands of the devs here. There at the moment just is other authentication method. In regards to controlling access to pms, using apache mod_proxy would allow access from apache to the system via localhost, and give you a controlling layer for the clients to access through. You could even add ip/password restrictions, to your liking. Though I have not personally tested having mod_proxy between clients and pms, it might be a viable solution to your issue. And if as you say, are going to be using non plex clients (I count plexbmc as a plex client), then the last hurdle of having two services on port 32400 can be overcome by having apache listen on a different port.

What are the clients you want to use. And can they run on other ports than 32400. If not set up an alias ip for apache and add at to e allowed networks list in preferences.

Well, my tired brain needs a break with a beer.

Hope I gave you some ideas on a solution that would suit your needs. And if you want I posted a working config somewhere on e forum for getting a proxy set up. Or just let me know and ill repost it. Just requires the vhost conf to be dedicated to pms, because he API/interface to pms is not pure http.

/Mark


Well, this is a reasonable workaround that could work. Need some time to think this through tho.

For example, if we take PleXBMC (as you count as a plex client) how do you use this today? Since it actually does exactly what I'm asking for in this topic. It require username and password to connect to the plex media server.

#9 Mark Walker

Mark Walker

    HACK THE PLANET!

  • Plex Ninja
  • PipPipPipPipPipPip
  • 1941 posts
  • Location: Aarhus - Denmark

Posted 26 June 2012 - 11:18 AM

I have no experience with plexbmc, so I can't say. I do know from the plexbmc thread: http://forums.plexap...c/page__st__460 that the dev is working on getting myplex support into that. I guess that would solve your issue?

So hopefully it will be done in reasonable time and you can enjoy plex.

/Mark
Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

My Plex world:
Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 60GB Vertex SSD, 7x1.5TB SATA Drives
Channel PMS/HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
Clients: Hackintosh - Xeon E3-1275v2, 27" CinemaDisplay, 2010 15" MBP, ATV2, Roku3, iPhone 3gs 32GB, iPhone 5 64GB, iPad 3 16GB

#10 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 26 June 2012 - 11:35 AM

I have no experience with plexbmc, so I can't say. I do know from the plexbmc thread: http://forums.plexap...c/page__st__460 that the dev is working on getting myplex support into that. I guess that would solve your issue?

So hopefully it will be done in reasonable time and you can enjoy plex.

/Mark


Alright. Well, I might solve it by using mod_proxy. Found a new addon to xbmc that works with myplex also, havn't tried that one yet but I guess some of my users could use xbmc if they want then :)

#11 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 30 June 2012 - 03:45 PM

The option you are looking for is allowedNetworks. Simply edit /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml and add to the Preferences section the option this way: allowedNetworks="127.0.0.1/255.255.255.0"

Then restart Plex Media Server and hopefully it should work for you.


Just triend a new setup with this paramter, and it does not work. I have edited the file "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml" and added allowedNetworks="127.0.0.1/255.255.255.0" and rebooted. I still can access from network. Any clue?

#12 Tobias Hieta

Tobias Hieta

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 3637 posts
  • Location: Gävle, Sweden

Posted 30 June 2012 - 06:31 PM

You must be running 0.9.6.4.

Follow me on twitter @tobiashieta or G+


#13 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 01 July 2012 - 10:32 AM

You must be running 0.9.6.4.


Well, thanks. That explains alot :)

#14 w00t

w00t

    Member

  • Members
  • PipPip
  • 19 posts

Posted 16 July 2012 - 09:46 AM

You must be running 0.9.6.4.


I have some problems to find a good solution for all this.

What I want;
  • No access for anyone(/any network) to /manage. - solved by using allowedNetworks=127.0.0.1/255.255.255.0. Am I right?
  • No access for anyone to be able to find my server and stream in the local network. - is this also solved by using alloedNetworks? Or will the library be found in the local network anyway?
  • Encrypted streaming in some way. As far as I understand, all information is in plaintext?
  • Clients should only be able to stream via some form of login.

Problems;
  • When using allowedNetworks, it seems like the local discovery is removed which is great since I want security with user/pass access and not a completely open server.. However, this makes it troublesome to communicate with the server when I'm on the same LAN. Myplex is talking to the server via my external IP, logging in to myplex via the client it is trying to connect to my external IP, which fails since I'm on a NAT'ed network and can only reach the server by local IP.
  • Creating some sort of tunneling to the server when not on the same LAN (like SSH-tunnel, OpenVPN etc.) to get encryption, same problem as above arise.

Any suggestions how to "design" a working setup?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users