Jump to content


Photo

Xbox and Other DLNA Clients Cannot Connect to Server


  • Please log in to reply
2 replies to this topic

#1 andrewmudd

andrewmudd

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 03 July 2012 - 08:23 PM

I've got PMS version 0.9.6.3.140-9c9f5ce running on a MacBook. I've been able to connect to PMS with Plex on another machine, but unable to get any DLNA clients to connect.

Mainly, what I care about is getting my Xbox working. I can see the server listed when I look for it on my Xbox, but when I click into it, it tries to connect and then fails. I then tried to connect using VLC on a Windows laptop, and got much the same result: The server is listed, but there is no content listed and when I double-click it, nothing happens.

I've got log files if those are helpful.

Thanks!

#2 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 03 July 2012 - 10:08 PM

I've got PMS version 0.9.6.3.140-9c9f5ce running on a MacBook. I've been able to connect to PMS with Plex on another machine, but unable to get any DLNA clients to connect.

Mainly, what I care about is getting my Xbox working. I can see the server listed when I look for it on my Xbox, but when I click into it, it tries to connect and then fails. I then tried to connect using VLC on a Windows laptop, and got much the same result: The server is listed, but there is no content listed and when I double-click it, nothing happens.

I've got log files if those are helpful.

Thanks!

Seems that if nothing can connect it will be something laptop side - have you tried to disable the firewall to see if it helps?

can you run lsof -i :1900 from a terminal window to check that something else it not using the port Plex DLNA needs?

you can check out your Plex Media Server.log and Plex DLNA Server.log files (upload them if if they are all gibberish to you) ? http://wiki.plexapp...._PMS_TipsTricks

failing that, there are 2 newer beta versions of the server available, both with bug fixes, try out the .9.6.5 versions -> http://elan.plexapp....erver-v0-9-6-5/
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#3 andrewmudd

andrewmudd

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 17 July 2012 - 12:56 AM

Seems that if nothing can connect it will be something laptop side - have you tried to disable the firewall to see if it helps?

can you run lsof -i :1900 from a terminal window to check that something else it not using the port Plex DLNA needs?

you can check out your Plex Media Server.log and Plex DLNA Server.log files (upload them if if they are all gibberish to you) ? http://wiki.plexapp...._PMS_TipsTricks

failing that, there are 2 newer beta versions of the server available, both with bug fixes, try out the .9.6.5 versions -> http://elan.plexapp....erver-v0-9-6-5/


And then I totally forgot that I posted this. Here's the output of lsof:
Plex\x20D 49441 andrew 17u IPv4 0x06104b80 0t0 UDP *:ssdp

And the logs are attached. I tried 0.9.6.5 and it behaved the same way. I'm able to connect to the PMS via Plex if I'm on the same machine, but VLC on the same machine is unable to browse the media; it behaves much the same way as the Xbox -- shows the server, doesn't show anything in it, whereas the Xbox shows the server and then says it cannot connect. Don't know if that's helpful.

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users