Jump to content


Photo

Plex & Firecore aTV Flash (black) 1.7 Conflict Issues!


  • Please log in to reply
13 replies to this topic

#1 Plexmark

Plexmark

    Member

  • Members
  • PipPip
  • 53 posts
  • Location: Toronto, Canada

Posted 12 July 2012 - 07:34 PM

Just a heads up for all jailbroken ATV2 users with Firecore aTV Flash (black). Note today's release of version 1.7 appears to have severe conflict issues with Plex (if installed). Scroll down on the Firecore user forum feedback page on this current release for further details:

http://blog.firecore.com/8555

Recommend holding off from updating to v1.7 until this issue is sorted out as it appears that if Plex is installed and the "Maintenance" link is updated, this will result in a perpetual rebooting loop of your ATV2, requiring you to SSH into your ATV2 and then having to perform a re-jailbreak...Yikes! Plex may or may not be functional afterwards. A real pain! Posted Image

I hope PLEX will continue to support ATV2 (and future jail-broken ATV3), although it's recognized that resources and the associated development effort for this platform is limited as it remains an "unofficial" Plex client which sadly lacks an App Store.

I'm sticking with v.1.6 as everything works for now and off course I'm on this forum so obviously PLEX is important to me with a daily serving - breakfast, lunch and dinner.

Mac Client / Server (PMS Primary): Mac Mini (Late 2012) 2.6Ghz i7 Quad Core | HD 4000 | 16GB RAM | 256 SSD

Mac Client: MacBook Pro 15" (Late 2013) 2.3Ghz i7 Quad Core | Nvidia 750GT | 16GB RAM | 512 SSD - PCIe
iOS Clients: iPhone 5 64GB LTE | iPad 4 64GB LTE | Apple TV2 (JB) | Apple TV 3 (Airplay only)
NAS Server / Media Storage: Synology DS712+ and DX513 expansion unit | 18TB total | Dual RAID 5 Volumes (Main /Backup) | Dual LAN with failover

Automation: SABnzbd + SickBeard + CouchPotato Server
Plex Remotes: Harmony 900 (RF) + Remote Buddy; Airplay via iPhone / iPad
Gigabit LAN via Asus RT-AC68U dual band router and Cisco SG100D-08 Gigabit Switch
Wired / Wireless Broadband: ~200+MBps D/L; 10MBps U/L


#2 dinoc@spamarrest.com

dinoc@spamarrest.com

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 12 July 2012 - 08:08 PM

Just a heads up for all jailbroken ATV2 users with Firecore aTV Flash (black). Note today's release of version 1.7 appears to have severe conflict issues with Plex (if installed). Scroll down on the Firecore user forum feedback page on this current release for further details:

http://blog.firecore.com/8555

Recommend holding off from updating to v1.7 until this issue is sorted out as it appears that if Plex is installed and the "Maintenance" link is updated, this will result in a perpetual rebooting loop of your ATV2, requiring you to SSH into your ATV2 and then having to perform a re-jailbreak...Yikes! Plex may or may not be functional afterwards. A real pain! Posted Image

I hope PLEX will continue to support ATV2 (and future jail-broken ATV3), although it's recognized that resources and the associated development effort for this platform is limited as it remains an "unofficial" Plex client which sadly lacks an App Store.

I'm sticking with v.1.6 as everything works for now and off course I'm on this forum so obviously PLEX is important to me with a daily serving - breakfast, lunch and dinner.


Any idea where can I download v1.6? I updated to 1.7 and run into the plex problem, and since I mostly use plex I would rather revert to 1.6

#3 gluzy

gluzy

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 12 July 2012 - 10:08 PM

Hi,
There it is à link where you can find the old version : http://www.sinfuliph...ad.php?t=108862

#4 kkanuck

kkanuck

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 12 July 2012 - 11:47 PM

I tried to go back to 1.6 but fire core checks for version, and then tells me I have an old version and it will not allow me to in tall 1.6? Any ways around this by chance? I have the 1.6 dmg file on my computer but it is useless.

#5 PCKid

PCKid

    Member

  • Members
  • PipPip
  • 72 posts

Posted 13 July 2012 - 03:50 AM

I tried to go back to 1.6 but fire core checks for version, and then tells me I have an old version and it will not allow me to in tall 1.6? Any ways around this by chance? I have the 1.6 dmg file on my computer but it is useless.


Try restoring ATV2 with iTunes to the original. Then use Seas0nPass to jailbreak it and then run your Black 1.6.dmg via the Mac and update it that way. That should work. I've just restored to the non jailbroken ATV2 on my iTunes. I think I'm going to leave it that way. If I want to watch any TV Series our Movies I can use Handbrake with the default Apple TV2 preset and batch convert them. It does my mkvs and m2ts files just as well and the end result on my 200hz 55" LCD screen looks fantastic. So that way I don't have to go through all these steps and heartaches to get it to work. That time spent could be used to do the Handbrake conversions. I do love the look of Plex but now don't think it's worth all the hassles anymore. Just my 2 cents worth.

#6 gluzy

gluzy

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 July 2012 - 10:54 AM

I have do that but is not working, it install the lastest version of Atv Flash :(

#7 Plexmark

Plexmark

    Member

  • Members
  • PipPip
  • 53 posts
  • Location: Toronto, Canada

Posted 13 July 2012 - 01:03 PM

This is Firecore's official response regarding Plex & v. 1.7

http://forum.firecor...2#comment-51721

It appears that the Plex plugin will no longer be supported on this and future Firecore updates unless the Plex Devs throw some effort into updates for the ATV2 platform.

Mac Client / Server (PMS Primary): Mac Mini (Late 2012) 2.6Ghz i7 Quad Core | HD 4000 | 16GB RAM | 256 SSD

Mac Client: MacBook Pro 15" (Late 2013) 2.3Ghz i7 Quad Core | Nvidia 750GT | 16GB RAM | 512 SSD - PCIe
iOS Clients: iPhone 5 64GB LTE | iPad 4 64GB LTE | Apple TV2 (JB) | Apple TV 3 (Airplay only)
NAS Server / Media Storage: Synology DS712+ and DX513 expansion unit | 18TB total | Dual RAID 5 Volumes (Main /Backup) | Dual LAN with failover

Automation: SABnzbd + SickBeard + CouchPotato Server
Plex Remotes: Harmony 900 (RF) + Remote Buddy; Airplay via iPhone / iPad
Gigabit LAN via Asus RT-AC68U dual band router and Cisco SG100D-08 Gigabit Switch
Wired / Wireless Broadband: ~200+MBps D/L; 10MBps U/L


#8 dinoc@spamarrest.com

dinoc@spamarrest.com

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 July 2012 - 05:27 PM

I did the following as a workaround.

Jailbreak with Seasonpass
Installed ATV 1.7
Installed XBMC from the maintenance menu

Loaded XBMC and install Plexbmc plugin/addon & configured to the plex server ip
Install Confluence.xbmc skin
Enable plexbmc integration

Works a treat :)

#9 furby

furby

    Dedicated Member

  • Members
  • PipPipPip
  • 347 posts

Posted 14 July 2012 - 07:06 AM

Looks like they've fixed it :)

Update: We've managed to build a new version of Plex that includes a workaround for the looping/crashing issue. This updated version (0.10.0.101-6) is now available through the Maintenance --> Manage Extras menu. This build includes no new features, it just prevents the Apple TV from crashing when is Plex installed.


A series isn't in the order you expect - Check TheTVDB series specific information


#10 dreamcode

dreamcode

    Member

  • Members
  • PipPip
  • 10 posts

Posted 14 July 2012 - 08:45 AM

omg thanx to you all who ever you are for fixing the plex loop on apple tv.
:D

#11 youngdreamers

youngdreamers

    Member

  • Members
  • PipPip
  • 28 posts

Posted 14 July 2012 - 01:41 PM

Interesting.. I updated my ATV2 with the latest firecore 1.7 but I'm not experiencing such issue....

#12 ChrisOSX

ChrisOSX

    Member

  • Members
  • PipPip
  • 23 posts

Posted 14 July 2012 - 02:09 PM

Interesting.. I updated my ATV2 with the latest firecore 1.7 but I'm not experiencing such issue....

Maybe they updated it before you updated yours. You wouldn't experience the bugs like other people.



For the update at hand it is working, Icon missing from home, and Grid view still not functioning in Movie view, but it functions.

For the time being I was doing what dinoc@spamarrest.com a few posts up did and used XBMC. It's totally not ideal, but it got the job done.


Here's a icon I got from somewhere else on the forum. SSH and install to root/Applications/AppleTV/Appliances/PLEX.frappliance. Leave it named AppIcon.png
Attached File  AppIcon.png   12.1KB   6 downloads

#13 elstreif

elstreif

    Dedicated Member

  • Members
  • PipPipPip
  • 439 posts
  • Location: Canada

Posted 18 July 2012 - 04:39 PM

1342200424[/url]' post='279097']
I did the following as a workaround.

Jailbreak with Seasonpass
Installed ATV 1.7
Installed XBMC from the maintenance menu

Loaded XBMC and install Plexbmc plugin/addon & configured to the plex server ip
Install Confluence.xbmc skin
Enable plexbmc integration

Works a treat :)


Could you do a step-by-step tutorial on how you did this, please? I installed XBMC On mt ATV2 but I can't add shares for some reason and the plexbmc plugin fails to install.
 Mac mini 1.83 GHz (OS X Server 10.6.8)  Panasonic 32" LCD  SONY HT-CT150 Home Theater System 

#14 ChrisOSX

ChrisOSX

    Member

  • Members
  • PipPip
  • 23 posts

Posted 22 July 2012 - 01:00 PM

All is working now for Plex. I can verify for 5.0.2 and 4.4.4 on the Main Menu. No more need for XBMC.

Just run a apt-get update.....and apt-get upgrade through terminal, or your fav terminal program.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users