Jump to content


Photo

NBC Plugin Not working for me


  • Please log in to reply
24 replies to this topic

#1 ecd1973

ecd1973

    Member

  • Members
  • PipPip
  • 26 posts

Posted 15 October 2012 - 03:28 PM

I have been having issues using the NBC plugin. I can't get anything to play from there through multiple clients. Clients tried: PS3, Google TV (Vizio costar, Samsung Stratosphere Android Smartphone). Can someone take a look at the NBC Plugin?

ECD

#2 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2896 posts
  • Location: Canada

Posted 15 October 2012 - 03:41 PM

I have been having issues using the NBC plugin. I can't get anything to play from there through multiple clients. Clients tried: PS3, Google TV (Vizio costar, Samsung Stratosphere Android Smartphone). Can someone take a look at the NBC Plugin?

ECD


Are you able to use the plugin with the Desktop Plex client? What platform are you running PMS on?

If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#3 ecd1973

ecd1973

    Member

  • Members
  • PipPip
  • 26 posts

Posted 15 October 2012 - 05:30 PM

Are you able to use the plugin with the Desktop Plex client? What platform are you running PMS on?


Plex Media Server is running on a Windows 7 32 bit machine. No, the NBC Plugin does not work directly on the server either using the Plex Desktop Client. It grinds for a while and eventually just says something along the lines of "Plex could not play that".

#4 Gerk

Gerk

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPip
  • 915 posts
  • Location: Canada

Posted 15 October 2012 - 07:19 PM

Having just experienced this type of issue myself is it a problem with the flash plugin on your PMS? I can play NBC fine with latest OSX PMS, latest OSX client, and latest iOS client ok (but I had to reinstall flash on my PMS machine as it was not working properly even in a web browser).

#5 ecd1973

ecd1973

    Member

  • Members
  • PipPip
  • 26 posts

Posted 15 October 2012 - 08:49 PM

Having just experienced this type of issue myself is it a problem with the flash plugin on your PMS? I can play NBC fine with latest OSX PMS, latest OSX client, and latest iOS client ok (but I had to reinstall flash on my PMS machine as it was not working properly even in a web browser).



I can view NBC.com videos directly on the site via Chrome. When I try to go to the same video in the Plex client on the server I get a pop up with the name of the episode and "NBC.com video widget" underneath indefinitely with a cancel button. It allows me to cancel and exit gracefully, but the plex client never displays the video. I tried looking at the plugin log and no obvious errors pop up there.

#6 ecd1973

ecd1973

    Member

  • Members
  • PipPip
  • 26 posts

Posted 19 October 2012 - 03:02 PM

Is anyone else having a problem with the NBC Plugin? I can't get it to work on any client, including the PC that the server is running on.

#7 sander1

sander1

    Channel Developer/Admin

  • Castle Keeper
  • PipPipPipPipPipPip
  • 2595 posts
  • Location: The Netherlands

Posted 19 October 2012 - 03:17 PM

Hi!
This sounds like a missing Flash plugin issue. Chrome comes bundled with the Flash plugin, that's why videos work in Chrome. PMS can't make use of this Flash plugin. Please check this webpage with a browser other than Chrome or Internet Explorer and follow the instructions to install Flash.

Or go here: http://get.adobe.com.../otherversions/ and select your OS from the first dropdown menu and "Flash ... for Other Browsers" from the second. After downloading the installer, quit all browsers and PMS before running the Flash installer.

Posted Image

Always attach log files if you are reporting an issue: Log file info & location

Problem with indexing files? Check the Naming Guide


#8 ecd1973

ecd1973

    Member

  • Members
  • PipPip
  • 26 posts

Posted 19 October 2012 - 05:59 PM

Hi!
This sounds like a missing Flash plugin issue. Chrome comes bundled with the Flash plugin, that's why videos work in Chrome. PMS can't make use of this Flash plugin. Please check this webpage with a browser other than Chrome or Internet Explorer and follow the instructions to install Flash.

Or go here: http://get.adobe.com.../otherversions/ and select your OS from the first dropdown menu and "Flash ... for Other Browsers" from the second. After downloading the installer, quit all browsers and PMS before running the Flash installer.

Posted Image


I definitely have the flash plugin for non-IE (checked in Firefox). Plus, all other flash-based plugins are working fine. Just NBC for some reason is not.

#9 kb1234

kb1234

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 24 October 2012 - 03:15 AM

I had a similiar problem on my Vista 32 box. The NBC channel reports that the flash plugin is not installed. The other channels that rely on flash work fine (with the exception of Hulu which just sits there trying to reconnect). I believe this is an issue with recent flash versions. I have downgraded flash to 10.3.183.29 and the problem is resolved (so is the Hulu issue).

#10 Colt42

Colt42

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 27 October 2012 - 05:35 PM

*BUMP*

Having exact same issue with NBC and Hulu. Everything is installed correctly as explained before. These channels do-not run in Desktop app or through Media Streamer (Sony SMP-N200) while a lot of other channels run perefect, e.g. ABC, CBS, Citytv, Crackle, etc.
What's the issue here, how come only NBC and Hulu (as far as i know) don't work?
It should be noted Hulu and NBC run fine on Serviio. Which leads to assume this is a plugin issue or PMS issue with Plex. Can any dev address this?

EDIT: ESPN3 is another one like Hulu and NBC that doesn't work.
At first I thought this was my problematic Media Streamer SMP-N200, but these won't play on the Desktop Plex app neither for some reason (play fine through websites).

#11 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2896 posts
  • Location: Canada

Posted 31 October 2012 - 07:28 PM

*BUMP*

Having exact same issue with NBC and Hulu. Everything is installed correctly as explained before. These channels do-not run in Desktop app or through Media Streamer (Sony SMP-N200) while a lot of other channels run perefect, e.g. ABC, CBS, Citytv, Crackle, etc.
What's the issue here, how come only NBC and Hulu (as far as i know) don't work?
It should be noted Hulu and NBC run fine on Serviio. Which leads to assume this is a plugin issue or PMS issue with Plex. Can any dev address this?

EDIT: ESPN3 is another one like Hulu and NBC that doesn't work.
At first I thought this was my problematic Media Streamer SMP-N200, but these won't play on the Desktop Plex app neither for some reason (play fine through websites).


A little more information about your setup might help. What operating system are you running PMS on? Can you upload a copy of your Plex Media Server log and the NBC plugin log? Check my sig for link to directions.

If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#12 midnightyell

midnightyell

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 15 November 2012 - 09:13 AM

I'm new to Plex, so please forgive some ignorance on my part. I'm trying to watch 30Rock on my phone using the NBC plugin, and it's not working, though the same stream works fine when I watch it using PMC. I get an error message that says "Unable to play media No playable media was found for this item."

Many other shows also fail in this way, but I am able to use the same plugin for classic Battlestar Galactica episodes just fine on my phone.

I'm running PMS 0.9.6.9.240-8fd9c6a on OSX 10.8.2, using Plex 2.5.2 for iOS on my iPhone 4, which is running iOS 6.0.1.

I currently have Flash 11,5,502,110 installed on OSX, but have also tried several other versions going back 6 months or more - 10.x as well as 11.X, all to no avail.


The PMS log looks like this when the phone requests that the show be started, and fails:

Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - Request: GET /system/:/services/url/lookup?url=http%3A//www.nbc.com/30-rock/video/theres-no-i-in-america/1422505/&X-Plex-Client-Capabilities=protocols%3Dhttp-live-streaming%2Chttp-mp4-streaming%2Chttp-streaming-video%2Chttp-streaming-video-720p%2Chttp-mp4-video%2Chttp-mp4-video-720p%3BvideoDecoders%3Dh264%7Bprofile%3Ahigh%26resolution%3A1080%26level%3A51%7D%3BaudioDecoders%3Dmp3%2Caac%7Bbitrate%3A160000%7D&X-Plex-Client-Platform=iOS&X-Plex-Product=Plex%2FiOS&X-Plex-Version=2.5.2 [192.168.1.74:49588] (1 live)
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - * url => http://www.nbc.com/3...merica/1422505/
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - * X-Plex-Client-Capabilities => protocols=http-live-streaming,http-mp4-streaming,http-streaming-video,http-streaming-video-720p,http-mp4-video,http-mp4-video-720p;videoDecoders=h264{profile:high&resolution:1080&level:51};audioDecoders=mp3,aac{bitrate:160000}
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - * X-Plex-Client-Platform => iOS
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - * X-Plex-Product => Plex/iOS
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - * X-Plex-Version => 2.5.2
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/:/services/url/lookup?url=http%3A//www.nbc.com/30-rock/video/theres-no-i-in-america/1422505/
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - (Capabilities) Adding WebKit.
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - (Capabilties) Passing down capabilities of 'protocols=http-live-streaming,http-mp4-streaming,http-mp4-video,http-mp4-video-720p,http-streaming-video,http-streaming-video-720p,webkit;videoDecoders=h264{profile:high&resolution:1080&level:51};audioDecoders=mp3,aac{bitrate:160000}' to plug-in.
Nov 15, 2012 02:57:35 [0xb0207000] DEBUG - HTTP requesting to: http://127.0.0.1:515...merica/1422505/
Nov 15, 2012 02:57:36 [0xb0207000] DEBUG - [com.plexapp.system] HTTP reply status 500, with 4360 bytes of content.




And like this when it is successful in starting BSG:

Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - Request: GET /system/:/services/url/lookup?url=http%3A//www.nbc.com/classic-tv/battlestar-galactica/video/battlestar-galactica-part-one/213504/&X-Plex-Client-Capabilities=protocols%3Dhttp-live-streaming%2Chttp-mp4-streaming%2Chttp-streaming-video%2Chttp-streaming-video-720p%2Chttp-mp4-video%2Chttp-mp4-video-720p%3BvideoDecoders%3Dh264%7Bprofile%3Ahigh%26resolution%3A1080%26level%3A51%7D%3BaudioDecoders%3Dmp3%2Caac%7Bbitrate%3A160000%7D&X-Plex-Client-Platform=iOS&X-Plex-Product=Plex%2FiOS&X-Plex-Version=2.5.2 [192.168.1.74:49610] (1 live)
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - * url => http://www.nbc.com/c...art-one/213504/
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - * X-Plex-Client-Capabilities => protocols=http-live-streaming,http-mp4-streaming,http-streaming-video,http-streaming-video-720p,http-mp4-video,http-mp4-video-720p;videoDecoders=h264{profile:high&resolution:1080&level:51};audioDecoders=mp3,aac{bitrate:160000}
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - * X-Plex-Client-Platform => iOS
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - * X-Plex-Product => Plex/iOS
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - * X-Plex-Version => 2.5.2
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - [com.plexapp.system] Sending command over HTTP (GET): /system/:/services/url/lookup?url=http%3A//www.nbc.com/classic-tv/battlestar-galactica/video/battlestar-galactica-part-one/213504/
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - (Capabilities) Adding WebKit.
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - (Capabilties) Passing down capabilities of 'protocols=http-live-streaming,http-mp4-streaming,http-mp4-video,http-mp4-video-720p,http-streaming-video,http-streaming-video-720p,webkit;videoDecoders=h264{profile:high&resolution:1080&level:51};audioDecoders=mp3,aac{bitrate:160000}' to plug-in.
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - HTTP requesting to: http://127.0.0.1:515...art-one/213504/
Nov 15, 2012 03:01:09 [0xb0081000] DEBUG - [com.plexapp.system] HTTP reply status 200, with 1355 bytes of content.
Nov 15, 2012 03:01:10 [0xb0081000] DEBUG - Request: GET /video/:/transcode/segmented/start.m3u8?url=http%3A%2F%2Fplexapp.tv%2Fembed%2Fnbc.php%3Fvid%3D213504&webkit=1&subtitleSize=100&audioBoost=100&ratingKey=http%3A%2F%2Fwww.nbc.com%2Fclassic-tv%2Fbattlestar-galactica%2Fvideo%2Fbattlestar-galactica-part-one%2F213504%2F&identifier=com.plexapp.plugins.nbc&key=http%3A%2F%2F192.168.1.39%3A32400%2Fsystem%2F%3A%2Fservices%2Furl%2Flookup%3Furl%3Dhttp%253A%2F%2Fwww.nbc.com%2Fclassic-tv%2Fbattlestar-galactica%2Fvideo%2Fbattlestar-galactica-part-one%2F213504%2F&session=A7136A79-2F00-4EB3-92B5-46F9FC1867A4&quality=7&3g=0&X-Plex-Access-Key=KIMDVPSKH4YHDL8DOARH&X-Plex-Access-Code=fHzZt0f5oyJyhHPrTLOYJ6F9BNo7%2BxPnXt1DlSZG5is%3D&X-Plex-Access-Time=1352970070&X-Plex-Client-Capabilities=protocols%3Dhttp-live-streaming%2Chttp-mp4-streaming%2Chttp-streaming-video%2Chttp-streaming-video-720p%2Chttp-mp4-video%2Chttp-mp4-video-720p%3BvideoDecoders%3Dh264%7Bprofile%3Ahigh%26resolution%3A1080%26level%3A51%7D%3BaudioDecoders%3Dmp3%2Caac%7Bbitrate%3A160000%7D [192.168.1.74:49611] (1 live)
Nov 15, 2012 03:01:10 [0xb0081000] DEBUG - * url => http://plexapp.tv/em....php?vid=213504
Nov 15, 2012 03:01:10 [0xb0081000] DEBUG - * webkit => 1
Nov 15, 2012 03:01:10 [0xb0081000] DEBUG - * subtitleSize => 100
Nov 15, 2012 03:01:10 [0xb0081000] DEBUG - * audioBoost => 100
...
...
...


Is anyone else encountering this? Do I need to post any more information?

Thanks in advance.

#13 sander1

sander1

    Channel Developer/Admin

  • Castle Keeper
  • PipPipPipPipPipPip
  • 2595 posts
  • Location: The Netherlands

Posted 15 November 2012 - 01:43 PM

Hi midnightyell!
There was a problem with the NBC channel due to changes on the NBC website. An update for the channel and service code has just been pushed out to the store.

Always attach log files if you are reporting an issue: Log file info & location

Problem with indexing files? Check the Naming Guide


#14 midnightyell

midnightyell

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 15 November 2012 - 05:02 PM

Hi midnightyell!
There was a problem with the NBC channel due to changes on the NBC website. An update for the channel and service code has just been pushed out to the store.



Seems to work now. Thanks!

#15 mborden115

mborden115

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 December 2012 - 12:03 PM

Hi, This channel is not working for me. I just installed it today. Is anyone else having an issue with NBC?

#16 sander1

sander1

    Channel Developer/Admin

  • Castle Keeper
  • PipPipPipPipPipPip
  • 2595 posts
  • Location: The Netherlands

Posted 06 December 2012 - 07:47 PM

[...]
It should be noted Hulu and NBC run fine on Serviio.
[...]

Hello Colt42,
Can you please provide us with a link to the Serviio NBC plugin? I can't find it... It's kinda hard to imagine that theirs is working and ours is not, since we must be doing almost the same thing to get NBC video playback working.

Always attach log files if you are reporting an issue: Log file info & location

Problem with indexing files? Check the Naming Guide


#17 optikhog

optikhog

    Member

  • Members
  • PipPip
  • 11 posts

Posted 07 December 2012 - 04:35 PM

The other channels that rely on flash work fine (with the exception of Hulu which just sits there trying to reconnect). I believe this is an issue with recent flash versions. I have downgraded flash to 10.3.183.29 and the problem is resolved (so is the Hulu issue).


I was really hoping this would resolve the issue for my installation but downgrading Flash did nothing for me. Ahh well, I can live without Hulu and NBC. I would like it if someone could stabilize this channel, though...

#18 Jarecki

Jarecki

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 19 December 2012 - 05:43 AM

BUMP

Same issue, NBC widget will just stay loading. All other channels work.

Running windows 7, 32 bit. Latest Flash (dropped back a version and forward again as suggested earlier). Tried the channel on Desktop Client and on Roku, both just hang and wait.


Have no problem pulling up the video via Chrome or Firefox.

Notes attached.

Attached Files



#19 wmbell

wmbell

    Dedicated Member

  • Members
  • PipPipPip
  • 447 posts

Posted 19 December 2012 - 05:57 AM

Yep. The NBC Channel has been having issues for a little over a week, now.
I just got around to posting a ticket in Lighthouse.

It is posted as Ticket #1143


:huh:

#20 sander1

sander1

    Channel Developer/Admin

  • Castle Keeper
  • PipPipPipPipPipPip
  • 2595 posts
  • Location: The Netherlands

Posted 19 December 2012 - 11:09 AM

I would like it if someone could stabilize this channel, though...

Unfortunately there is no way to 'stabilize' anything as long as this isn't an official plugin :( This will keep breaking when NBC decides to make changes to their website. Due to their streaming format, we're also unable to use anything other than their Flash player. Posted Image

Always attach log files if you are reporting an issue: Log file info & location

Problem with indexing files? Check the Naming Guide





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users