Jump to content


Photo

Automatic download of subtitles


  • Please log in to reply
39 replies to this topic

#1 MrConn

MrConn

    Member

  • Members
  • PipPip
  • 22 posts
  • Location: Sauda / Norway

Posted 15 November 2012 - 12:54 PM

Hi!
I have Plex Media Server 0.9.7.2 installed on a Windows 7 Home Premium x64 machine, and everything works smootly with one exeption; subtitle downloading.
Can someone please tell me, step by step, how to enable it?

I've googled, searched the forums, read the FAQ and tried everything I can imagine, but still no luck! :(

Server: Synology DiskStation DS713+ 2-bay NAS

Disks: 2x Western Digital® Red 3TB NAS Harddrive

Clients: Samsung 46" 3D LED Smart TV UE46ES8005, iPad 2, iPhone 4s, Nokia Lumia 920


#2 iawa2k

iawa2k

    Member

  • Members
  • PipPip
  • 14 posts
  • Location: London, UK

Posted 15 November 2012 - 05:31 PM

I am probably well off on this one but do you not find it under "Languages" in the server preferences? I have "Subtitle Mode" and "Prefer subtitles in" options.

Also in the Media Manager go to the "Metadata Agent Settings" and make sure that under "Personal Media" and "Personal Media Shows" you have the OpenSubtitles.org option ticked and you can choose preferences for languages if you highlight the OpenSubtitles.org line and choose Preferences from there.

Obviously if it's 1 thing specifically go to OpenSubtitles.org and see if it exists, if not then you will not find subtitles in Plex most likely but can always find some, manually download them and stick them in the same folder as the media file with the same name (other than extension - usually .srt).

Hopefully that makes sense and helps you!
Plex Server (0.9.7.7.339-5ec3b53)
Running on iMac (2012) - Core i7 3.4GHz, 12GB RAM, 128GB SSD + 1TB HDD, AMD Radeon HD 6970M 2GB, 10.8.2
Storage is ReadyNAS NV+ 1GB RAM with 6TB on Gigabit network over AFP

Raspberry Pi Model B running RaspBMC (XBMC 12.0 Frodo) current as of 7th Dec & PleXBMC V2.0 Beta 6
Running over 100Mbps network local to PMS

iOS Clients (latest as of 7th Dec 2012)
Running on iPhone 4S & iPhone 5 (4S on stable iOS 6, iP5 on iOS 6 Beta 6.0.2) & iPad 3rd Gen Wifi 32GB (iOS Beta 6.0.2)

Mac Client (0.9.5.4)
Running on MacBook Air 11" (2012) Core i7 2GHz, 8GB RAM, 256GB SSD, 10.8.2

Apple TV2 Client (latest as of 7th Dec 2012)
1st Gen (720p) ATV2 over 300Mbps 5GHz Wifi link from 5th Gen Airport Extreme

[b]PS3 Slim CECH-3000 (4.31) over DLNA on gigabit ethernet


[b]PS3 "Phat" CECHAxx (4.31) over DLNA on 54Mbps 2.4GHz Wifi from 5th Gen Airport Extreme


Connection at server end is over a FTTC broadband line (60Mbps Down/18Mbps Up actual throughput)

#3 MrConn

MrConn

    Member

  • Members
  • PipPip
  • 22 posts
  • Location: Sauda / Norway

Posted 16 November 2012 - 11:24 AM

I've tried this. This is how it "should" work! But unfortunatly it doesnt in Windows... :(

Server: Synology DiskStation DS713+ 2-bay NAS

Disks: 2x Western Digital® Red 3TB NAS Harddrive

Clients: Samsung 46" 3D LED Smart TV UE46ES8005, iPad 2, iPhone 4s, Nokia Lumia 920


#4 iawa2k

iawa2k

    Member

  • Members
  • PipPip
  • 14 posts
  • Location: London, UK

Posted 16 November 2012 - 11:31 AM

I've tried this. This is how it "should" work! But unfortunatly it doesnt in Windows... :(


Remove OpenSubtitles.org plugin, restart server and then re-install? Probably beyond my experience after this.
Plex Server (0.9.7.7.339-5ec3b53)
Running on iMac (2012) - Core i7 3.4GHz, 12GB RAM, 128GB SSD + 1TB HDD, AMD Radeon HD 6970M 2GB, 10.8.2
Storage is ReadyNAS NV+ 1GB RAM with 6TB on Gigabit network over AFP

Raspberry Pi Model B running RaspBMC (XBMC 12.0 Frodo) current as of 7th Dec & PleXBMC V2.0 Beta 6
Running over 100Mbps network local to PMS

iOS Clients (latest as of 7th Dec 2012)
Running on iPhone 4S & iPhone 5 (4S on stable iOS 6, iP5 on iOS 6 Beta 6.0.2) & iPad 3rd Gen Wifi 32GB (iOS Beta 6.0.2)

Mac Client (0.9.5.4)
Running on MacBook Air 11" (2012) Core i7 2GHz, 8GB RAM, 256GB SSD, 10.8.2

Apple TV2 Client (latest as of 7th Dec 2012)
1st Gen (720p) ATV2 over 300Mbps 5GHz Wifi link from 5th Gen Airport Extreme

[b]PS3 Slim CECH-3000 (4.31) over DLNA on gigabit ethernet


[b]PS3 "Phat" CECHAxx (4.31) over DLNA on 54Mbps 2.4GHz Wifi from 5th Gen Airport Extreme


Connection at server end is over a FTTC broadband line (60Mbps Down/18Mbps Up actual throughput)

#5 browngeek

browngeek

    Member

  • Members
  • PipPip
  • 53 posts

Posted 22 November 2012 - 07:12 AM

According to the wiki: http://wiki.plexapp....e_PMS_Subtitles , subtitles don't work with Windows. Is that still the case?

In "General Subtitle Support" the last sentence reads: "Subtitles are not currently supported on Windows."

#6 burial666

burial666

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 January 2013 - 05:08 PM

hi...this is a critical issue for me...ccan anyone comment when isss ttthis issue gonna fix?

#7 mguru

mguru

    Dedicated Member

  • Members
  • PipPipPip
  • 111 posts

Posted 12 January 2013 - 05:59 PM

hi...this is a critical issue for me...ccan anyone comment when isss ttthis issue gonna fix?

Try this:
Indeed, the language preference popup is missing from PMS for Windows and automatic subtitle fetching can't work with default settings.
However, there is a workaround :

From windows file explorer, open and edit C:\Users\<xxx>\AppData\Local\Plex Media Server\Plug-in Support\Preferences\com.plexapp.agents.opensubtitles.xml

You have to setup langPref1 and langPref2 parameters

Personally, I use this setup:

<?xml version='1.0' encoding='utf-8'?>
<PluginPreferences>
<langPref1>16</langPref1>
<langPref2>1</langPref2>
</PluginPreferences>

It means langPref1 = french and langPref2 = english

You will be able to find indexes for other languages under : C:\Users\<xxx>\AppData\Local\Plex Media Server\Plug-ins\OpenSubtitles.bundle\Contents\DefaultPrefs.json

#8 linusv

linusv

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 January 2013 - 04:57 PM

Hi all,
I to have problem getting the subtitles to work.
This is the log file:
2013-01-15 17:37:49,368 (1c08) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952334519.gz'
2013-01-15 17:37:49,421 (c24) : INFO (logkit:16) - Looking for match for GUID a86a617ac7595d71 and size 677607564
2013-01-15 17:37:49,434 (678) : INFO (logkit:16) - Looking for match for GUID 6df8b551b3d65d73 and size 454469347
2013-01-15 17:37:49,677 (c24) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1951645020.gz'
2013-01-15 17:37:49,727 (678) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1953067138.gz'
2013-01-15 17:37:49,930 (1c08) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952334519.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-15 17:37:49,940 (1c08) : INFO (logkit:16) - Looking for match for GUID e7172c392ec886d7 and size 323973718
2013-01-15 17:37:50,117 (1c08) : INFO (logkit:16) - No subtitles available for language swe
2013-01-15 17:37:50,161 (c24) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1951645020.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-15 17:37:50,171 (c24) : INFO (logkit:16) - Looking for match for GUID a86a617ac7595d71 and size 677607564
2013-01-15 17:37:50,262 (678) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1953067138.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-15 17:37:50,273 (678) : INFO (logkit:16) - Looking for match for GUID 6df8b551b3d65d73 and size 454469347
2013-01-15 17:37:50,318 (1c08) : INFO (logkit:16) - Looking for match for GUID 5d296cbe750b8376 and size 541894499
2013-01-15 17:37:50,365 (c24) : INFO (logkit:16) - No subtitles available for language swe
2013-01-15 17:37:50,474 (678) : INFO (logkit:16) - No subtitles available for language swe
2013-01-15 17:37:50,535 (c24) : INFO (logkit:16) - Looking for match for GUID 10a11bb58a5f4462 and size 689847108
2013-01-15 17:37:50,604 (1c08) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952325591.gz'
2013-01-15 17:37:50,647 (678) : INFO (logkit:16) - Looking for match for GUID 00a356a9c3f9263c and size 426181406
2013-01-15 17:37:50,714 (c24) : INFO (logkit:16) - No subtitles available for language eng
2013-01-15 17:37:50,716 (c24) : INFO (logkit:16) - Looking for match for GUID 10a11bb58a5f4462 and size 689847108

An interesting thing is that when I try to download subtitles via XBMC i get "error extracting subtitles" from opensubtitles.org.

Can someone confirm that my server is set up properly and that subtitles IS supposed to work with windows?
As soon as this will start working I´ll unistall XBMC straight away... :)

Regards Linus

Win7 Ultimate X64
Latest version plex server.

#9 linusv

linusv

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 17 January 2013 - 10:35 AM

Opensubtitles works with XBMC again, but not in plex server. Isn´t there anyone else who has had this problem and found a fix for it?

#10 linusv

linusv

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 28 January 2013 - 07:43 PM

I´m sorry to write in this thread again.
Can someone please give some directions. I´ve tried everything and I´m gonna start pulling my hair soon. :)

I´ve followed the guide in the wiki all the way but it´s simply not working. Latest log:

2013-01-29 17:09:03,384 (1f1c) : INFO (logkit:16) - Looking for match for GUID 09583637f21b104b and size 586137723
2013-01-29 17:09:03,684 (1f1c) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952726982.gz'
2013-01-29 17:09:04,549 (1f1c) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952726982.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-29 17:09:04,552 (1f1c) : INFO (logkit:16) - Looking for match for GUID 09583637f21b104b and size 586137723
2013-01-29 17:09:04,726 (1f1c) : INFO (logkit:16) - No subtitles available for language swe
2013-01-29 17:09:04,898 (1f1c) : INFO (logkit:16) - Looking for match for GUID e19361ed07405758 and size 586528325
2013-01-29 17:09:05,237 (1f1c) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952801549.gz'
2013-01-29 17:09:05,957 (1f1c) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952801549.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-29 17:09:05,964 (1f1c) : INFO (logkit:16) - Looking for match for GUID e19361ed07405758 and size 586528325
2013-01-29 17:09:06,142 (1f1c) : INFO (logkit:16) - No subtitles available for language swe
2013-01-29 17:09:06,315 (1f1c) : INFO (logkit:16) - Looking for match for GUID c62974f96c14ab18 and size 586009452
2013-01-29 17:09:06,785 (1f1c) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952782261.gz'
2013-01-29 17:09:07,446 (1f1c) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952782261.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-29 17:09:07,450 (1f1c) : INFO (logkit:16) - Looking for match for GUID c62974f96c14ab18 and size 586009452
2013-01-29 17:09:07,631 (1f1c) : INFO (logkit:16) - No subtitles available for language swe
2013-01-29 17:09:07,825 (1f1c) : INFO (logkit:16) - Looking for match for GUID a44303caf680b6a5 and size 586666883
2013-01-29 17:09:08,157 (1f1c) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952516913.gz'
2013-01-29 17:09:09,150 (1f1c) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952516913.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-01-29 17:09:09,154 (1f1c) : INFO (logkit:16) - Looking for match for GUID a44303caf680b6a5 and size 586666883
2013-01-29 17:09:09,332 (1f1c) : INFO (logkit:16) - No subtitles available for language swe
2013-01-29 17:09:09,519 (1f1c) : INFO (logkit:16) - Looking for match for GUID 55a79df141a1f391 and size 586765440
2013-01-29 17:09:09,881 (1f1c) : DEBUG (networking:166) - Requesting 'http://dl.opensubtit...d/1952516913.gz'
2013-01-29 17:09:10,674 (1f1c) : DEBUG (networking:194) - Not caching 'http://dl.opensubtit...d/1952516913.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)

Thanks in advance!

#11 nbrunaud

nbrunaud

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 11 March 2013 - 03:38 PM

+1

It's the same for me.

My understanding is that the ".gz" file extension is not supported... neither unzipped...

It's a pitty because the file enclosed in it is an ".srt" file which is supported.

 

any solution or idea would be appreciate :-)

Is there a way to force opensubtitle search to return directly the .srt file ?

Is there a way to learn plex to unzip gz files ?



#12 nbrunaud

nbrunaud

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 11 March 2013 - 09:57 PM

i dont know if i have fully solved the pb, but here is an idea that eliminates the "not caching" error.

 

in file networking.py (located in installation dir and cache also).

i 've just add 'gz','gzip' in the list of allowed contents (see below).

 

 

  def _content_type_allowed(self, content_type):
    for t in ['html', 'xml', 'json', 'javascript','gz','gzip']:
      if t in content_type:
        return True
    return False


#13 bjorninge

bjorninge

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 April 2013 - 01:01 PM

I'm also having problems with subtitles not being downloaded. Where's the logs referred to two posts above located?



#14 achelous

achelous

    Member

  • Members
  • PipPip
  • 24 posts

Posted 03 May 2013 - 10:01 AM

any updates on this ? 


Posted Image

#15 knights

knights

    Member

  • Members
  • PipPip
  • 58 posts

Posted 05 August 2013 - 10:23 AM

any updates on this ? 

I was wondering the same. Anyone got ideas ?



#16 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7659 posts
  • Location: Sweden

Posted 05 August 2013 - 10:32 AM

This is an old thread, so lets gather up what your specific issue is before we start solving something that maybe already is solved.
Yes, Opensubtitles should be supported when using PMS on Windows (afaik). So if it doesn't work then we kind start from there.
The reason why it didn't work for linusv above is because he is requesting swedish subtitles for Family Guy, and that specific episode doesn't have swedish subtitles. It did have english subs though, but the settings for the OS agent needs to include that you want english subs as well for it to work.

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#17 knights

knights

    Member

  • Members
  • PipPip
  • 58 posts

Posted 05 August 2013 - 10:36 AM

Well, I agree but when finding a thread that seems having 100% having the same problem, I prefer not to start a new one.

 

Opensubtitles is searching for a subtitles, it does find the correct hit, but it never gets downloaded. Below is a line from the opensubtitles.log

 

2013-08-05 11:30:16,510 (e08) :  DEBUG (networking:172) - Requesting 'http://dl.opensubtit...d/1953630475.gz'
2013-08-05 11:30:16,706 (e08) :  DEBUG (networking:200) - Not caching 'http://dl.opensubtit...d/1953630475.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)



#18 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7659 posts
  • Location: Sweden

Posted 05 August 2013 - 10:38 AM

Agreed :)

Can attach the whole log please?

 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino


#19 knights

knights

    Member

  • Members
  • PipPip
  • 58 posts

Posted 05 August 2013 - 10:46 AM

Attached is the log. When I copy/paste the URL into mty browser, it perfectly downloads the correct subtitles: e.g.
 
2013-08-05 12:41:41,489 (23c) :  DEBUG (networking:200) - Not caching 'http://dl.opensubtit...d/1953654422.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-08-05 12:41:41,542 (23c) :  INFO (logkit:16) - Looking for match for GUID 64c3abbcc713a3be and size 1226302679
 

Spoiler


Edited by Atrus, 05 August 2013 - 10:55 AM.
Added a spoiler tag for readability


#20 Atrus

Atrus

    Plex Star

  • Plex Ninja
  • PipPipPipPipPipPip
  • 7659 posts
  • Location: Sweden

Posted 05 August 2013 - 10:54 AM

Attached is the log. When I copy/paste the URL into mty browser, it perfectly downloads the correct subtitles: e.g.
 
2013-08-05 12:41:41,489 (23c) :  DEBUG (networking:200) - Not caching 'http://dl.opensubtit...d/1953654422.gz' (content type 'application/x-gzip' not cacheable in Agent plug-ins)
2013-08-05 12:41:41,542 (23c) :  INFO (logkit:16) - Looking for match for GUID 64c3abbcc713a3be and size 1226302679
 

Spoiler

 

Interesting. It does not seem to go into "fetching" mode. How long has this been going on? Can you remember the last PMS version where this worked?


 Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS 
New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
Always attach log files if you are reporting an issue: Log file info & location
Get Plex guides here: Howto name your files  NAS guide  Troubleshooting  Plex Support Page
 
Personal websites that I work with daytime: Vinnarum Casino





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users