Jump to content


Photo

YouTUBE on ROKU


  • Please log in to reply
6 replies to this topic

#1 rc.vempati

rc.vempati

    Member

  • Members
  • PipPip
  • 69 posts

Posted 21 November 2012 - 05:54 PM

I have noticed an issue yesterday playing YouTUBE videos on ROKU using Plex. I am able to play the videos using Plex Center windows client. But when it comes to ROKU, the progress bar shows complete but does not display the video.

Is YOUTUBE restricting playing videos from ROKU? I know they are implementing so many policies not to play on ROKU.

BTW, I can play the videos using Transcoding. But not DIRECT Play.

Is there any way in ROKU to send fake http headers so that YouTUBE does not know the hits are coming from ROKU. I think in ROKU we can define the HTTP headers. Just a thought on how to address the issue.

I am sure, they are restricting ROKU.

#2 rc.vempati

rc.vempati

    Member

  • Members
  • PipPip
  • 69 posts

Posted 21 November 2012 - 09:50 PM

I tested by getting the final url of the youtube video. I was able to play using direct play on Roku. Some thing else stopped playing youtube on Roku using Direct Play.

#3 @joewatchestv

@joewatchestv

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 22 November 2012 - 09:29 PM

I've had the same issue for the last couple days. What other client can I use to stream YouTube to Roku?

#4 trekkeriii

trekkeriii

    Member

  • Members
  • PipPip
  • 15 posts

Posted 23 November 2012 - 05:50 AM

Another channel that streams YouTube:

https://owner.roku.com/add/VideoBuzz

#5 stevyd

stevyd

    Member

  • Members
  • PipPip
  • 32 posts

Posted 25 November 2012 - 06:01 PM

I've also been experiencing an issue with the YouTube channel on roku. After lots of playing around i've come to the conclusion that (my issue at least) is due to the "Automatic" transcoding setting not using the right mode. So basically when set to auto it will try and transcode the youtube video which then subsequently fails. However if you force it to "Direct Play /w Fallback" The video Direct plays absolutely fine on the roku and the PMS logs show that it is indeed direct playing.

I would really like a feature so you can force particular channels to use a particular transcoding setting as I have another channel - CBS iirc that will only work if "Direct Stream" is selected.

So to everyone having issues try selecting the Direct Play setting in your roku client and see if that solves your issue. It's a shame Auto doesn't work as I have to keep changing this setting for different channels.

#6 rc.vempati

rc.vempati

    Member

  • Members
  • PipPip
  • 69 posts

Posted 28 November 2012 - 04:01 AM

Finally, I was able to solve the issue by updating the URL service by removing the options for FLVs. Now ROKU picks one of the MP4 which can played using "direct play" with out transcoding.

ACTUAL CODE:

YOUTUBE_VIDEO_FORMATS = ['Standard', 'Medium', 'High', '720p', '1080p']
YOUTUBE_FMT = [ 34, 18, 35, 22, 37]
YOUTUBE_CONTAINERS = ['flv', 'mp4', 'flv', 'mp4', 'mp4']
YOUTUBE_VIDEORES = ['sd', 'sd', '480', '720', '1080']
YOUTUBE_VIDEOCODEC = ['h264', 'h264', 'h264', 'h264', 'h264']
YOUTUBE_AUDIOCODEC = ['aac', 'aac', 'aac', 'aac', 'aac']

CHANGED TO:

YOUTUBE_VIDEO_FORMATS = ['Medium', '720p', '1080p']
YOUTUBE_FMT = [ 18, 22, 37]
YOUTUBE_CONTAINERS = ['mp4', 'mp4', 'mp4']
YOUTUBE_VIDEORES = ['sd', '720', '1080']
YOUTUBE_VIDEOCODEC = ['h264', 'h264', 'h264']
YOUTUBE_AUDIOCODEC = ['aac', 'aac', 'aac']

#7 stevyd

stevyd

    Member

  • Members
  • PipPip
  • 32 posts

Posted 28 November 2012 - 08:41 PM

The above fix certainly made "Automatic" work however it's transcoding all youtube videos. By setting to a Direct Play setting it can direct play absolutely fine. So it seems like there is still an issue with the client/server knowing when transcoding is necessary




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users