Jump to content


Photo

PMS --> Daten auf NAS


  • Please log in to reply
9 replies to this topic

#1 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 23 December 2012 - 09:04 PM

Hallo,

ich bin langsam am verzweifeln. Ich habe so viele Probleme, dass ich mich garnicht um alles gleichzeitg kümmern kann. Darum fang ich erst mal mit den wichtigsten an.

Ich habe einen MacMini (late 2012 MacOS 10.8.2). Diesen ist mit HDMI am TV. Installiert ist Plex Media Center (9.5.4) und Plex Media Server(Version 0.9.7.7). Die Daten liegen auf einem NAS (DS111) und die ist per afp am Mac eingebunden.

Problem 1.
Obwohl ich am PMS die Funktion "Update my library when changes to my folders are detected" aktiviert ist, werden neue Datein nicht automatisch erkannt. Liegt das am NAS oder am Protokoll??

Problem 2.
Wenn der Mac im Ruhezustand ist und Plex Media Center gestartet ist, dann kann ich oft keine Filme abspielen, da das NAS nicht mit aufwacht. Ich muss dann irgendwie das NAS wecken, dann laufen die Filme. Warum wird das NAS nicht aufgeweckt, obwohl ich auf die Datei zugreife? Mit dem PMS funktioniert das. Sobald der aktiviert wird, übers iPad z.B., dann wacht das NAS auf.

Danke schon mal und einen schönen 4. Advent:D

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC


#2 Massaguana

Massaguana

    Rock Star

  • Members
  • PipPipPipPipPip
  • 599 posts
  • Location: Äppelwoitown

Posted 24 December 2012 - 08:31 AM

Moin moin.

was gibt es denn noch für Probleme? Möglicherweise hängen die zusammen.

Zum Problem 1. Gewöhn dich dran. Ist bei mir auch so. Als Ursache kommt alles in Frage, ich erinnere mich das in früheren Versionen das bei NAS Systemen auch Funktionierte. Einzige Möglichkeit währe das NAS per iSCSI als intere Festplatte einzubinden, das bringt ber wieder andere Nachteile. Ich habe dies für mich folgendermaßen gelöst. Kopiere ich neue Filme Serien, stoße ich einfach per Browser oder iOS App (Unsupportet Appstore, Library Updater) die Aktualisierung an.

Problem 2: Kann dir nicht ganz Folgen. Warum musst du dein PMS Aktivieren? Der muss "immer" laufen. Der ist doch auch auf dem Mac mini oder?

Grüße
Massaguana

Primary PMS: Thecus N10850, 16GB RAM, Intel Xeon Quad "E3-1225" 3,1 GHz

Media Storage: Thecus N10850 24TB Storage, Thecus N700ProV2 12TB Storage

Desktop Clients: 1x Mac mini, 1 x MacPro 5,1, 1 x 15 MBP, 1 x13" MB, 2 x 27" iMac
Mobile Clients: 2 x iPhone 5, 1 x iPhone 4, 2 x iPad Air

Airplay Targets: 1 x Denon AVR-4311 


#3 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 24 December 2012 - 01:30 PM

Danke für die Antwort.
Zu 1. Ok dann muss ich mal überlegen was ich da mache.

Zu 2. Vielleicht hab ich mich bisschen blöd ausgedrückt. Also der Mac legt sich schlafen mit gestartetem Plex Media Center. In der Zwischenzeit ist das NAS auch schlafen gegangen. Dann wecke ich den Mac und sehe Plex Media Center. Dann starte ich nen Film und der geht nicht, weil er den Pfad nicht findet, weil das NAS schläft. Dann muss ich Plex beenden und wieder starten. Dann läuft NAS an.

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC


#4 C-lon

C-lon

    Member

  • Members
  • PipPip
  • 82 posts

Posted 24 December 2012 - 02:01 PM

1. M.E. ist dies nur mit HFS+ möglich (file system) - ob es lokal oder auch im Netz sein muss / kann, weiss ich nicht
2. HDD-Spindown auf der Synology oder OSX-Sleep unterbinden

#5 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 24 December 2012 - 02:42 PM

Ist schon klar das ich den Spindown ausschalten kann. Ich möchte dies nur nicht.

@Massaguana

Die weiteren Probleme sind übringes, das nach dem Ruhezustand die Harmony One nicht mehr in Plex funktioniert, und stattdessen iTunes gestartet wird. Wenn ich dann in Plex navigiere, dann wird die ganze Zeit die Lautstärke verändert.

Des weiteren ist mit gerade aufgefallen, das nach dem Ruhezustand die Diskstation nicht mehr richtig erkannt wird. Alle Ordner sind leer. Dann muss ich einmal den Server auswerfen, dann gehts wieder.

Oh man nur Probleme, und alles wegen dem Ruhezustand. Das kann doch nicht so schwer sein. Ich habe, bevor ich mir den MacMini geholt habe, den ganzen Kram aufm MacBook Pro getestet. Da hat alles ohne Probleme funktioniert...

edit:
Damit die Harmony One wieder ordnetlich funktioniert, muss ich im Plex Media Center unter Remote, die Harmony (Universalfernbedieung) wieder neu auswählen.

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC


#6 Massaguana

Massaguana

    Rock Star

  • Members
  • PipPipPipPipPip
  • 599 posts
  • Location: Äppelwoitown

Posted 25 December 2012 - 08:34 AM

Hi,

das das NAS beim Play drücken nicht Startet soll so nicht sein. Das schon mal ist klar. Das muss Funktionieren. Hab selbst so ein System laufen. Bei mir wacht der von selbst auf, kann schon mal 1 min Dauern bis alle Platten da sind aber das ist Normal. Wie lange wartest du bevor du sagt es geht nicht?

Das einzige was mir auffällt ist da du AFP nutzt, das hat bei mir nicht so richtig Funktioniert, ich nutze SMB. Das kannst du ja noch einmal ausprobieren.

- Hast du die Netzlaufwerke im Autostart drin?
- Wie hast du den Plex Server bezüglich Aktualisierung eingestellt? Sind die Filme im Media Manager Verfügbar oder haben die ein "!"?

Grüße
Massaguana

Primary PMS: Thecus N10850, 16GB RAM, Intel Xeon Quad "E3-1225" 3,1 GHz

Media Storage: Thecus N10850 24TB Storage, Thecus N700ProV2 12TB Storage

Desktop Clients: 1x Mac mini, 1 x MacPro 5,1, 1 x 15 MBP, 1 x13" MB, 2 x 27" iMac
Mobile Clients: 2 x iPhone 5, 1 x iPhone 4, 2 x iPad Air

Airplay Targets: 1 x Denon AVR-4311 


#7 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 25 December 2012 - 11:31 AM

Hi,

hi ja mit SMB probier ich nochmal.

- Ja die Laufwerke sind im Autostart drin. Das funktioniert auch.
- Der PMS scannt alle 6 Stunden automatisch. Und alle Datein sind verfügbar.

Das Problem ist, das das NAS halt nicht geweckt wird. Normalerweise hör ich wenn die Festplatten anlaufen. Wenn ich Plex neu starte oder das PMS scannen anwerfe, dann klappt das auch brav.
Ich mach das erst mal über SMB. Vielleicht hab ich dann ja mehr Glück:D

Gruß Simon

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC


#8 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 26 December 2012 - 11:52 PM

@massaguana

wie machst du das mit SMB?? Wenn ich im Finder über Server Verbinden gehe, dann verliert der Mini nach einer Gewissen Zeit im Ruhezustand seine Verbindung. Dann muss ich einmal den Server neu Verbinden, ansonsten wird keine Verbindung zu den Datein aufgebaut.

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC


#9 Massaguana

Massaguana

    Rock Star

  • Members
  • PipPipPipPipPip
  • 599 posts
  • Location: Äppelwoitown

Posted 27 December 2012 - 04:07 PM

Das geht recht einfach...

Du Verbindest dich zu dem Netzlaufwerk und erstellst von dem erscheinenden Laufwerk (Die Option muss allerdings im Finder an sein. "Zeige Verbundene Server") ein Alias. In diesem Alias ist dann alles drin was der Mac benötigt um sich mit dem Laufwerk zu Verbinden, also Login usw. Das kommt dann in den Autostart.

Wenn du den Plex Server komplett neu Startest legt der von den Verbundenen Laufwerken gleich ein Alias in den Autostart. Das ist die einfachste lösung...

Primary PMS: Thecus N10850, 16GB RAM, Intel Xeon Quad "E3-1225" 3,1 GHz

Media Storage: Thecus N10850 24TB Storage, Thecus N700ProV2 12TB Storage

Desktop Clients: 1x Mac mini, 1 x MacPro 5,1, 1 x 15 MBP, 1 x13" MB, 2 x 27" iMac
Mobile Clients: 2 x iPhone 5, 1 x iPhone 4, 2 x iPad Air

Airplay Targets: 1 x Denon AVR-4311 


#10 kolossboss

kolossboss

    Dedicated Member

  • Members
  • PipPipPip
  • 141 posts

Posted 27 December 2012 - 05:34 PM

Hey, ja hab ich ja so gemacht. Beim Reboot klappt das auch, allerdings beim Ruhestand, hat er den Server verloren. Und ich musste ihn dann von Hand wieder Verbinden, bzw die Alias noch mal anklicken.
Habt jetzt aber be Lösung die Recht gut klappt. Im MacAppStore gibs ne App die heißt "drive mounter". Die Mountet alle beliebigen Laufwerke immer. Auch nach dem Ruhezustand. Funktioniert bei AFP wirklich sehr zuverlässig. SMB hab noch nicht getestet. Bin aber auch zufrieden jetzt.

Edit:
Ich glaub ich weiß, was das Problem war. Ich hab immer im PMS das gemountete Laufwerk angegeben und nicht das Alias. Dann will er natürlich auf das Laufwerk zugreifen und findet nichts. Wenn ich da auch das Alias angebe, dann gehts auch.
Vielen Dank nochmal.

MacMini (late 2012) 16GB RAM -- PMS and PHT

1x Roku 2 XD

3x iPhone

1x iPad 3

1x HP Touchpad with android

1x MacBook Pro (early 2011)

1x Macbook (Unibody late 2010)

6x Windows PC with Plex/Web or PMC





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users