Jump to content


Photo

Plex/Web Chrome - Direct Play issue


  • Please log in to reply
8 replies to this topic

#1 delpr1

delpr1

    Member

  • Members
  • PipPip
  • 15 posts

Posted 29 December 2012 - 10:14 PM

Hi,
I've been using Plex for about 6 months now and love it. I've recently encountered an issue with Chrome that I can't solve. On my PMS, which is a Dell XPS 8500 w/ Windows 7, I cannot view some of my own videos in Chrome when Direct Play is turned on. I've confirmed, using MediaInfo, that the videos (Blu Ray rips from my own collection) are MP4 / H264 / AAC encoded. I don't receive any error and the Plex Logs do not show any errors either.

The Browser just shows the frame (black screen with a play button that cannot be pressed and the timer says 0:00) and it does not play. The same video works fine on IOS devices and my Roku. If I turn off Direct Play in the Plex/Web browser, it runs fine (but I assume it is transcoding it as there is a slight delay before the video starts).

Any ideas? I have another Dell PC in my daughter's room, and confirmed that the same issue happens in Chrome there as well.

Thanks!

#2 ericmatthys

ericmatthys

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 2397 posts
  • Location: Denver

Posted 30 December 2012 - 03:35 PM

Hi,
I've been using Plex for about 6 months now and love it. I've recently encountered an issue with Chrome that I can't solve. On my PMS, which is a Dell XPS 8500 w/ Windows 7, I cannot view some of my own videos in Chrome when Direct Play is turned on. I've confirmed, using MediaInfo, that the videos (Blu Ray rips from my own collection) are MP4 / H264 / AAC encoded. I don't receive any error and the Plex Logs do not show any errors either.

The Browser just shows the frame (black screen with a play button that cannot be pressed and the timer says 0:00) and it does not play. The same video works fine on IOS devices and my Roku. If I turn off Direct Play in the Plex/Web browser, it runs fine (but I assume it is transcoding it as there is a slight delay before the video starts).

Any ideas? I have another Dell PC in my daughter's room, and confirmed that the same issue happens in Chrome there as well.

Thanks!


Could you post the media info for one of the videos?

#3 delpr1

delpr1

    Member

  • Members
  • PipPip
  • 15 posts

Posted 30 December 2012 - 06:08 PM

Thanks for the response... Here is the Media Info for one of the files that does not direct play.

MEDIA
Duration 2:20:02
Bitrate 2166 kbps
Width 1280
Height 720
Aspect Ratio 1.78
Video Resolution 720p
Container MP4
Video Frame Rate 24p
Optimized For Streaming 0

FILE
Accessible Yes
Exists Yes
Duration 2:20:02
File I:\Video Library\Roku\Batman Begins (2005).mp4
Size 2.12 GB
Container MP4
Has 6 4bit Offsets 0
Optimized For Streaming 0

VIDEO
Codec H264
Bitrate 1969 kbps
Cabac 0
Duration 2:20:02
Frame Rate 23.976 fps
Height 720
Level 3.1
Profile baseline
Ref Frames 2
Width 1280

AUDIO
Codec AAC
Channels 5.1
Bitrate 192 kbps
Bitrate Mode VBR
Duration 2:20:02
Profile lc
Sampling Rate 48000 Hz

#4 ericmatthys

ericmatthys

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 2397 posts
  • Location: Denver

Posted 31 December 2012 - 12:50 AM

Thanks for the response... Here is the Media Info for one of the files that does not direct play.

MEDIA
Duration 2:20:02
Bitrate 2166 kbps
Width 1280
Height 720
Aspect Ratio 1.78
Video Resolution 720p
Container MP4
Video Frame Rate 24p
Optimized For Streaming 0

FILE
Accessible Yes
Exists Yes
Duration 2:20:02
File I:\Video Library\Roku\Batman Begins (2005).mp4
Size 2.12 GB
Container MP4
Has 6 4bit Offsets 0
Optimized For Streaming 0

VIDEO
Codec H264
Bitrate 1969 kbps
Cabac 0
Duration 2:20:02
Frame Rate 23.976 fps
Height 720
Level 3.1
Profile baseline
Ref Frames 2
Width 1280

AUDIO
Codec AAC
Channels 5.1
Bitrate 192 kbps
Bitrate Mode VBR
Duration 2:20:02
Profile lc
Sampling Rate 48000 Hz


I think Optimized for Streaming = 0 is the issue. I should probably be checking that before letting the video attempt to play directly.

#5 delpr1

delpr1

    Member

  • Members
  • PipPip
  • 15 posts

Posted 02 January 2013 - 09:33 PM

I re-encoded the video in Handbrake and this version worked with no issues. The optimized for streaming was still 0, but now it is working. There are a couple of parameters that are different (like Cabac = 1 now where it was 0 before). Can't say I know what that is.

Duration 2:20:03
Bitrate 2794 kbps
Width 1280
Height 528
Aspect Ratio 2.35
Video Resolution 720p
Container MP4
Video Frame Rate 24p
Optimized For Streaming 0

FILE
Accessible Yes
Exists Yes
Duration 2:20:03
File I:\Video Library\Movies\Batman Begins (2005).m4v
Size 2.73 GB
Container MP4
Has 6 4bit Offsets 1
Optimized For Streaming 0

VIDEO
Codec H264
Bitrate 1993 kbps
Cabac 1
Duration 2:20:03
Frame Rate 23.976 fps
Height 528
Level 3.1
Profile high
Ref Frames 4
Width 1280

AUDIO
Codec AAC
Channels Stereo
Bitrate 156 kbps
Bitrate Mode VBR
Duration 2:20:03
Profile lc
Sampling Rate 48000 Hz

AUDIO
Codec AC3
Channels 5.1
Bitrate 640 kbps
Bitrate Mode CBR
Dialog Norm -31 dB
Duration 2:20:02
Sampling Rate 48000 Hz

#6 delpr1

delpr1

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 January 2013 - 05:57 AM

Just adding an update to this... it looks like my server updated Plex/Web to 0.9.9.1 this afternoon and now this video (and others) will no longer play Direct Play (it transcodes in Chrome). Also, there is no sound via Plex/Web, only video for videos like this. Media info is displayed in previous post.

Updated: I think the issue is with the AAC stream that is in Stereo. It is not playing correctly in the new player in Plex/Web. When I exit out of the video and go back and resume it, I get an error message AAC Header: Error #2006 and it ultimately starts playing from the beginning (but without sound).

If I change the sound to AC3 (5.1) and play it, it works fine.

Prior to 9.9.1, the audio worked in on both, and I was not getting the error message.

#7 ericmatthys

ericmatthys

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 2397 posts
  • Location: Denver

Posted 03 January 2013 - 03:04 PM

Just adding an update to this... it looks like my server updated Plex/Web to 0.9.9.1 this afternoon and now this video (and others) will no longer play Direct Play (it transcodes in Chrome). Also, there is no sound via Plex/Web, only video for videos like this. Media info is displayed in previous post.

Updated: I think the issue is with the AAC stream that is in Stereo. It is not playing correctly in the new player in Plex/Web. When I exit out of the video and go back and resume it, I get an error message AAC Header: Error #2006 and it ultimately starts playing from the beginning (but without sound).

If I change the sound to AC3 (5.1) and play it, it works fine.

Prior to 9.9.1, the audio worked in on both, and I was not getting the error message.


I am requiring optimized for streaming to be 1 now because there were videos failing to be directly played without that flag. I'd rather a transcode happen then videos fail completely. However, it seems like you are having issues with the transcoder. Could you open up your Plex Media Server logs, clear them, and try to play the video? Paste the logs here so we can see if it tells us anything on why the transcoder doesn't seem to like the audio. Does the video player itself give you that error message about AAC? Have you tried playing the video in Safari / OSX?

#8 delpr1

delpr1

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 January 2013 - 10:04 PM

It looks like 9.9.2 of Plex / Web fixed the audio issue I was having. I am not getting the error message anymore and am now getting audio. It is still transcoding, but that must be because you are checking optimized for streaming to be 1.

Just for clarity... how is that set? Can you tell me if that is the "Web Optimized" option in Handbrake?

UPDATE: Issue is occurring again, but will open another thread since this is not Direct Play related anymore.

#9 ericmatthys

ericmatthys

    Plex Employee

  • Plex Employee
  • PipPipPipPipPipPip
  • 2397 posts
  • Location: Denver

Posted 04 January 2013 - 10:04 PM

It looks like 9.9.2 of Plex / Web fixed the audio issue I was having. I am not getting the error message anymore and am now getting audio. It is still transcoding, but that must be because you are checking optimized for streaming to be 1.

Just for clarity... how is that set? Can you tell me if that is the "Web Optimized" option in Handbrake?

UPDATE: Issue is occurring again, but will open another thread since this is not Direct Play related anymore.


I believe the Web Optimized setting in Handbrake correlates to that flag.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users