Jump to content


Photo

SECURE ACCESS TO PLEX CONSOLE


  • Please log in to reply
9 replies to this topic

#1 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 13 January 2013 - 12:26 PM

Hi, guys,
I installed via apt-get Plex Server in Ubuntu Server.

If I access the URL "http://192.168.1.100.../web/index.html # / dashboard" from other PC in subnet, I see the dashboard without authentication required.
Is there any way to force login and password for access to the dashboard?

Many thanks

#2 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 14 January 2013 - 04:40 AM

Hi, guys,
I installed via apt-get Plex Server in Ubuntu Server.

If I access the URL "http://192.168.1.100.../web/index.html # / dashboard" from other PC in subnet, I see the dashboard without authentication required.
Is there any way to force login and password for access to the dashboard?

Many thanks

Settings -> myPlex -> Show Advanced -> Require authentication on local networks.
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#3 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 January 2013 - 07:06 PM

Settings -> myPlex -> Show Advanced -> Require authentication on local networks.



Thanks for your fast reply.

I went to the url:
http://192.168.1.100.../web/index.html #! / settings
but I can not find "require authentication on local network"

I see only user text box for username and text box for password
and two buttons.

Greetings

#4 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 16 January 2013 - 07:11 PM

Thanks for your fast reply.

I went to the url:
http://192.168.1.100.../web/index.html #! / settings
but I can not find "require authentication on local network"

I see only user text box for username and text box for password
and two buttons.

Greetings

click on show advanced settings.
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#5 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 January 2013 - 07:51 PM

Hi,
I click on "show advanced settings" but I see a new item in menu ( network ).
If I se new network menu, I can not find "require authentication on local network"

I upload a png images.
Many thanks.

Attached Files



#6 Tobias Hieta

Tobias Hieta

    Plex Dev Team

  • Plex Employee
  • PipPipPipPipPipPip
  • 3642 posts
  • Location: Gävle, Sweden

Posted 16 January 2013 - 09:00 PM

Hi,
I click on "show advanced settings" but I see a new item in menu ( network ).
If I se new network menu, I can not find "require authentication on local network"

I upload a png images.
Many thanks.


Upgrade.

Follow me on twitter @tobiashieta or G+


#7 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 January 2013 - 09:45 PM

Upgrade.


Hi,
I upgrade to latest version with following command:

sudo nano /etc/apt/sources.list
then I add "deb http://www.plexapp.com/repo lucid main" to the file
sudo apt-get update
sudo apt-get install plexmediaserver

ubuntu install the latest version ( see second image attached ), but I have not solved the problem ( see first image attached ).

Do you have other ideas ?

Attached Files



#8 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 January 2013 - 09:49 PM

I add third Image after upgrade below.
Is there any way to force login/password from command line ?

Many thanks

Attached Files



#9 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 16 January 2013 - 09:58 PM

Hi,
I click on "show advanced settings" but I see a new item in menu ( network ).
If I se new network menu, I can not find "require authentication on local network"

I upload a png images.
Many thanks.

you need to actually log into myPlex, you wont get far using it to provide security without logging in.
Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#10 mvlucchi

mvlucchi

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 16 January 2013 - 10:24 PM

you need to actually log into myPlex, you wont get far using it to provide security without logging in.



Thank you,
now I understand.
I did not think to secure access to the dashboard from the same subnet the server had to publish to myplex.

Many thanks.

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users